


Quick Reference

    Right-click objects and in windows to see context menus.

See also: 

Working with footage items (Project window) 

Viewing windows (Composition, Layer, and Footage windows) 

Displaying windows and palettes (any window) 

Moving around (Time Layout window) 

Moving around (Composition, Time Layout, Footage, and Layer windows) 

Previewing (Time Layout window) 

Editing (Composition, Layer, and Footage windows) 

Working with layers (Composition and Time Layout windows) 

Spatial zooming (Composition, Layer, and Footage windows) 

Temporal zooming (Time Layout window) 

Viewing layer properties (Time Layout window) 

Modifying keyframes (Time Layout window) 

Setting the work area (Time Layout window) 

Nudging layers (Composition and Time Layout windows) 

Working with compositions (Composition window) 

Working with masks (Layer window) 

Working with masks (Composition and Time Layout windows) 

Working with effects    (Effect Controls window) 

Using markers (Composition and Time Layout windows) 

Rendering (Render Queue window) 

Using the Tools palette (Tools palette) 

Using other palettes (any    window) 



Quick Reference 

Working with footage items (Project window)
 Shift      

 Ctrl

New Project  + Alt + N

Open Project  + O

Save Project  + S

Select previous item Up Arrow

Select next item Down Arrow

Open selected footage item or composition Double-click 

Open movie in an After Effects footage window Alt-double-click 

Activate most recently activated composition \

Add selected item to most recently activated 
composition

 + /

Display settings for selected composition  + K

Add selected composition to Render Queue window  +  + /

Import a footage file  + i

Import multiple footage files  + Alt + i

Replace a selected layer’s source footage item or 
composition    

Alt-drag footage 
item from Project 
window into 
composition

Replace footage file  + H

Set Interpret Footage options  + F

Scan for changed footage  + Alt +  + L

Reload footage  + Alt + L

New folder  + Alt +  + N

Remember footage interpretation  + Alt + C

Apply footage interpretation  + Alt + V

Set proxy file  + Alt + P

Exit  + Q
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Viewing windows (Composition, Layer, and Footage windows)
 Shift      
 Ctrl

Cycle through open windows  + Tab

Display/hide title-safe and action-safe 
zones

' (apostrophe)

Display/hide grid  + ' (apostrophe)

Display/hide proportional grid Alt + ' (apostrophe)

Center active window  + Alt + \

Update window dynamically Alt-drag property control

Suspend window updates Caps Lock

Take snapshot Alt + Pause

Display snapshot in active window  + Pause

Display channel in color Alt-click channel icon

Display unmatted color channels Alt-click alpha channel icon
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Displaying windows and palettes (any window)
 Shift      
 Ctrl

Project window  + 0

Render Queue window  + Alt + 0

Tools palette  + 1

Info palette  + 2

Time Controls palette  + 3

Audio palette  + 4

Display/hide palettes Tab

General Preferences  +    Alt + ; (semicolon)

New Composition  + N

Close active tab/window  + W

Close active window (all tabs)  +  + W

Close all windows (except Project window)  + Alt + W



Quick Reference 

Moving around (Time Layout window)
 Shift      
 Ctrl

Go to beginning of work area  + Home

Go to end of work area  + End

Go to previous visible keyframe J

Go to next visible keyframe K

Go to previous visible layer-time marker or 
keyframe

Alt + J

Go to next visible layer-time marker or 
keyframe

Alt + K

Go to a composition-time marker 0-9 on main keypad

Scroll selected layer to top of Time Layout 
window

X

Scroll current time to center of window D

Go to time  + G
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Moving around (Composition, Time Layout, Footage, and Layer windows)
 Shift      
 Ctrl

Go to beginning Home or  + Alt + Left Arrow

Go to end End or  + Alt + Right Arrow

Step forward one frame Page Down or  + Right Arrow

Step forward ten frames  + Page Down or  +  + Right 
Arrow

Step backward one frame Page Up or  + Left Arrow

Step backward ten frames  + Page Up or  +  + Left Arrow

Go to layer In point i

Go to layer Out point o

Snap items such as keyframes, time 
markers, and In and Out points to 
each other on a time ruler

 -drag item



Quick Reference 

Previewing (Time Layout window)
 Shift      
 Ctrl

Start/pause playback Spacebar

Preview audio from the current time . (period) on numeric keypad 

RAM preview  0 on numeric keypad

RAM preview every other frame   + 0 on numeric keypad    

Scrub video Alt-drag current-time marker

Scrub audio -drag current-time marker

Wireframe preview    Alt + 0 on numeric keypad

Display rectangle instead of alpha 
outline during wireframe preview

 + Alt + 0 on numeric keypad 

Leave window contents during 
wireframe preview 

Alt +  + 0 on numeric keypad    

Note: If no layers are selected, commands are applied to all layers.

Note: Visual previews honor loop and audio toggles in Time Controls palette.
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Editing (Composition, Layer, and Footage windows)
 Shift      
 Ctrl

Copy  + C

Duplicate  + D

Cut  + X

Paste  + V

Undo  + Z

Redo  +  + Z

Select all  + A

Deselect  +  + A

Rename layer, composition, folder, 
effect 

Return

Edit item in original application 
(Footage window only) 

 + E
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Working with layers (Composition and Time Layout windows)
 Shift      
 Ctrl

Bring to front  +  + ] (right bracket) 

Bring forward one level  + ] (right bracket) 

Send backward one level  + [ (left bracket) 

Send to back  +  + [ (left bracket)

Select next layer back  + Down Arrow

Select next layer forward  + Up Arrow

Select a layer by its layer-outline 
number

1-9 on numeric keypad

Deselect all layers  +  + A

Lock selected layers  + L

Unlock all layers  +  + L

Split selected layer  +  + D

Activate Composition window with 
layer

\

Display selected layer in Layer 
window

Enter on numeric keypad

Show/hide video  + Alt +  + V

Hide other video  +  + V

Display Effect Controls window for 
selected layer 

 +  + T

Switch between Composition and 
Time Layout windows

\

Open source of a layer Alt-double-click a layer

Scale layer without dragging a -drag layer



handle in Composition window

Snap layer to edges and center of 
frame in Composition window

Alt + -drag layer

Snap layer to grid in Composition 
window

 +  + ‘ (apostrophe)

Snap layer to guides in Composition
window

 +  + ; (semicolon)

Stretch layer to fit Composition 
window

 + Alt + F

Reverse a layer’s playback  + Alt + R

Set In point [ (left bracket)

Set Out point ] (right bracket) 

Trim In point of a layer Alt + [ (left bracket)

Trim Out point of a layer Alt + ] (right bracket) 

Toggle time remapping for selected 
layer

 + Alt + T

Set quality to Best  + U

Set quality to Draft  +  + U

Set quality to Wireframe  + Alt +  + U

Create new solid  + Y

Display solid settings  +  + Y

Precompose a layer  +  + C

Set In point by time-stretching  +  + , (comma)

Set Out point by time-stretching  + Alt + , (comma)
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Spatial zooming (Composition, Layer, and Footage windows)
 Shift      
 Ctrl

Zoom in . (period) 

Zoom out , (comma) 

Zoom to 100% / (on main keypad) or double-click 
zoom tool 

Zoom in and resize window Alt + . (period) or  + =    on main 
keypad 

Zoom out and resize window Alt + , (comma) or  + - (hyphen) 
on main keypad 

Zoom to 100% and resize window Alt + / on main keypad

Zoom window  + \ 

Zoom window to fill monitor  +  + \ 

Center window  + Alt + \ 

Zoom window to fit  + Alt + / 

Zoom in art, not window  + Alt + = 

Zoom out art, not window  + Alt + - (hyphen) on main keypad 



Quick Reference 

Temporal zooming (Time Layout window)
 Shift      
 Ctrl

Zoom to or from frame view (in 
Time Layout window only)

; (semicolon)

Zoom in time = on main keypad 

Zoom out time - (hyphen) on main keypad 



Quick Reference 

Viewing layer properties (Time Layout window)
 Shift      
 Ctrl

Anchor Point A

Audio Levels L

Effects E

Mask Feather F

Mask Shape M

Opacity T

Position P

Rotation R

Scale S

Show all animating values U

Set layer property value in dialog 
box (except Anchor Point; see 
Working with Compositions)

 +  + property shortcut

Hide property or category Alt +  -click property or category 
name

Add/remove property  + property shortcut



Quick Reference 

Modifying keyframes (Time Layout window)
 Shift      
 Ctrl

Set keyframe velocity  +  + K 

Set keyframe interpolation  + Alt + K 

Add or remove keyframe (if 
stopwatch is turned on) or turn on 
time-vary stopwatch (if off)

Alt +  + property display shortcut

Toggle hold keyframe  + Alt + H or  + Alt-click keyframe

Select all keyframes for a property Click property name

Add all keyframes for an effect to 
current keyframe selection

-click effect name

Snap keyframe to significant times -drag keyframe

Nudge keyframe one frame forward Alt + Right Arrow

Nudge keyframe one frame 
backward

Alt + Left Arrow

Amplify nudging by ten  + shortcut

Select all visible keyframes in 
selected layer

 + Alt + A

Go to previous visible keyframe J

Go to next visible keyframe K

Switch interpolation between Linear
and Auto Bezier

-click keyframe



Quick Reference 

Setting the work area (Time Layout window)
 Shift      
 Ctrl

Set beginning of work area to 
current time

B 

Set end of work area to current time N 

Set work area to selected layers  + Alt + B 

Set work area to composition 
duration when no layers are 
selected

 + Alt + B 
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Nudging layers (Composition and Time Layout windows)
 Shift      
 Ctrl

Nudge layer 1 pixel in specific 
direction

Arrow key (nudges in direction of 
arrow) 

Nudge layer rotation    +1 degree + (plus) on numeric keypad

Nudge layer rotation    –1 degree – (minus) on numeric keypad

Nudge layer scaling      +1% Alt +    + (plus) on numeric keypad

Nudge layer scaling –1% Alt + – (minus) on numeric keypad

Amplify nudging, scaling, or rotation
by 10

 + shortcut

Note: Nudging counts pixels at the current magnification, not at actual size. For example, nudging 
an item one pixel at 50% magnification is the same as nudging the item two pixels at 100% 
magnification. 



Quick Reference 

Working with compositions (Composition window)
 Shift      
 Ctrl

Display/hide guides  + ; (semicolon)

Lock/unlock guides  + Alt +  + ; (semicolon)

Display/hide rulers  + R

Constrain rotation to 45-degree 
increments

-drag rotation tool

Constrain scaling to footage frame 
aspect ratio

-drag layer handle

Constrain movement along x or y 
axis

-drag layer 

Reset rotation angle to 0 degrees Double-click rotation tool

Reset scale to 100% Double-click selection tool

Change background color  +  + B

Set composition resolution to full  + J

Set composition resolution to half  +  + J

Set composition resolution to a 
quarter

 + Alt +  + J

Set composition resolution to 
custom

 + Alt + J

Open Anchor Point dialog box  + Alt +  + A



Quick Reference 

Working with masks (Layer window)
 Shift      
 Ctrl

Reset oval mask to fill window Double-click oval tool

Reset rectangle mask to fill window Double-click rectangle tool



Quick Reference 

Working with masks (Composition and Time Layout windows)
 Shift      
 Ctrl

Define mask shape  +  + M

Define mask feather  +  + F

Set mask to inverse  +  + i

New mask  +  + N



Quick Reference 

Working with effects    (Effect Controls window)
 Shift      
 Ctrl

Select next effect Up Arrow

Select previous effect Down Arrow

Expand/collapse effect controls ` (grave accent)

Remove all effects from layer  +  + E

Add keyframe for effect control Alt-click effect property name

Activate composition window 
containing layer

\



Quick Reference 

Using markers (Composition and Time Layout windows)
 Shift      
 Ctrl

Set layer-time marker * on numeric keypad 

Remove layer-time marker -click marker

Go to previous visible layer-time 
marker or keyframe

Alt + J

Go to next visible layer-time marker 
or keyframe

Alt + K

Go to a composition-time marker 0-9 on main keypad

Set and number a composition-time
marker at the current time

 + 0-9 on main keypad



Quick Reference 

Rendering (Render Queue window)
 Shift      
 Ctrl

Make movie  + M

Activate most recently activated 
composition

\

Add active composition to Render 
Queue window

 +  + /

Duplicate item in queue with no 
output filename

 + D

Duplicate item in queue with same 
output filename

 +  + D

Save frame as  + Alt + S



Quick Reference 

Using the Tools palette (Tools palette)
 Shift      
 Ctrl

Selection tool: Selects, moves, and 
resizes layers, masks, and controls 

V 

Rotation tool: Rotates layers in the 
Composition window 

W 

Rectangle tool: Draws a rectangular
mask in the Layer window. Double-
click to reset the mask. 

C 

Oval tool: Draws an elliptical mask 
in the Layer window. Double-click to
reset the mask. 

Q 

Pen tool: Edits Bezier masks, 
motion paths, and Value graphs 

G 

Pan Behind tool: Moves a layer 
behind a mask, or moves the 
anchor point without moving the 
layer 

Y 

Hand tool: Scrolls window to reveal 
areas beyond window edge 

H 

Zoom tool: Magnifies (or reduces 
using Alt) an area of a page 

Z



Quick Reference 

Using other palettes (any    window)
 Shift      
 Ctrl

Switch from selection tool to pen 
tool

Hold down 

Switch from pen tool to selection 
tool

Hold down 

Display filename in Info palette 
(selection tool must be outside 
composition)

 + Alt + E



Getting Started

Welcome to Adobe(R) After Effects(R) 4.0, the ultimate software tool for motion graphics and visual 
effects. After Effects is widely used for digital post-production of film, motion graphics, video, 
multimedia, and the Web.

After Effects combines high-resolution compositing controls for multi-layer compositions; 
sophisticated motion control for high-quality, two-dimensional animation; and advanced capabilities 
for time-varying visual effects. Footage you create in After Effects can be digitally output to film, 
videotape, CD-ROM, or the Web, and for playback on computers.

After Effects integrates features in other Adobe programs. For example, you can easily import 
layered files from Adobe Photoshop(R) and Adobe(R) Illustrator(R), and projects from Adobe 
Premiere(R). When you import these file types as compositions, After Effects preserves attributes 
from the original files, such as Photoshop adjustment layers and transfer modes, and Premiere 
project cuts and transition locations. Using a combination of Adobe products, you can seamlessly 
create a still image file for printed output in one application and then import it into After Effects and 
turn it into a fully-animated moving-image presentation. You can also use Premiere EDL files in After
Effects. 

See also: 

About this guide 

Learning Adobe After Effects 

Windows system requirements 

Mac OS system requirements 

The Adobe After Effects package contents 

Registration 

About Adobe products and services 

Adobe Systems training opportunities 

What’s new in Adobe After Effects 4.0 



Getting Started 

About this guide

The Adobe After Effects 4.0 User Guide provides detailed information about using Adobe After 
Effects features and commands, as well as a hands-on tutorial to give you some familiarity with 
After Effects features. The user guide is designed to be a reference tool in your everyday work with 
After Effects. This manual contains instructions for using After Effects on both the Microsoft(R) 
Windows(R) and Mac(R) OS platforms. Any differences in procedures and commands between 
platforms are noted in the text.

Before using this guide, you need to install the After Effects application. You can find installation 
instructions and system requirement information in this chapter. Before working with After Effects, 
you should have a working knowledge of your system and its operating conventions.



Getting Started 

Learning Adobe After Effects

After Effects 4.0 includes the following documentation, either online or printed. Check the Adobe 
Web site for updated information about new plug-ins, troubleshooting technical issues, and tips and 
techniques. You have many resources to help you learn After Effects. 

User Guide Contains a quick tour of After Effects and complete information on using all its 
commands and features. The user guide also describes new features and lists CD-ROM contents 
and system requirements.

Online Help Contains all the information in the Adobe After Effects 4.0 User Guide, plus detailed 
descriptions of effects and an index and search function. In addition, Help includes a complete list 
of shortcuts. See Using online Help.

Quick Reference Card Contains a handy list of After Effects keyboard shortcuts. 

Tour movie Provides an overview and instruction on using the essential After Effects features. 

In addition to the documentation included with the product, a Classroom in a Book(R) is available 
for After Effects. For more information on Classroom in a Book, see Adobe Systems training 
opportunities. For availability of the Classroom in a Book in other languages, contact your local 
book distributor. 
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Windows system requirements

The following hardware and software are required to run Adobe After Effects:
•      Intel(R) Pentium(R) processor.
•      Microsoft Windows 98 (or a later version) or Windows NT 4.0 (or a later version).
•      At least 32 megabytes (MB) of random-access memory (RAM) for Windows 98 and at least 64 
MB of RAM for Windows NT.
•      At least 80 MB of available hard disk space for installation. You’ll need additional space to work 
with large files.
•      16-bit (or greater) color display adapter. 
•      CD-ROM drive.

The following are recommended:
•      Pentium II or multi-processor system (Windows NT only).
•      Windows NT 4.0 (or a later version).
•      64 MB or more of RAM.
•      500 MB or larger hard disk or hard disk array.
•      Video capture card.
•      A 24-bit or greater color display adapter.
•      A sound card (if your video capture card does not contain on-board sound circuitry).
•      Apple QuickTime 3.0 (or a later version).



Getting Started 

Mac OS system requirements

The following hardware and software are required to run After Effects:
•      Apple(R) Power Macintosh(R) computer.
•      Mac OS version 7.6.1 (or a later version).
•      At least 32 megabytes (MB) of application random-access memory (RAM).
•      At least 80 MB of available hard disk space for installation. You’ll need additional space to work 
with large files.
•      16-bit (or greater) color display adapter. 
•      CD-ROM drive.

The following are recommended:
•      64 MB or more of application RAM.
•      500 MB or larger hard disk or hard disk array.
•      Apple QuickTime 3.0 (or a later version).
•      Video capture card.
•      24-bit color display adapter.
•      Two monitors with accelerated 24-bit video.
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The Adobe After Effects package contents

The After Effects package includes the following software and documentation:
•      The Adobe After Effects CD-ROM. The contents of this disc are described in the following 
section.
•      Adobe After Effects User Guide.
•      Adobe After Effects Quick Reference Card.
•      Registration card. (The card is not included in upgrades from previous versions.)
•      Details on Adobe technical support policies and ways you can obtain technical support.

See also: 

Contents of the After Effects CD-ROM 



The Adobe After Effects package contents 

Contents of the After Effects CD-ROM

The Adobe After Effects Application CD-ROM contains the following:

The installer program Installs the Adobe After Effects application, including all After Effects audio 
and visual effects and sample files. Other software applications and third-party plug-in effects 
included on the disc use their own installers.

QuickTime(R) software Installs the standard version of QuickTime for Windows and Mac OS. 
When QuickTime is installed, you can import, export, and view QuickTime movies within After 
Effects.

Non-Adobe software Includes software from other manufacturers such as visual effect plug-ins, 
import filters, and information on training materials. 

Adobe After Effects Software Developer’s Kit Supplies complete support for developers 
interested in writing plug-ins, effects, and other custom solutions for After Effects.

Tryout versions of other Adobe Systems applications Includes exciting Adobe products you can
explore at no additional cost. 

Tour movie Provides an additional guide to help you learn After Effects. The tour movie, which 
requires that you install the QuickTime 3.0 (or later) software, demonstrates the key benefits and 
new features of this version of After Effects.

Adobe Acrobat“ Reader software Displays online documentation and third-party reference 
material saved as PDF (Portable Document Format) files.
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Registration

When you register your copy of Adobe After Effects, we can offer you technical support and keep 
you informed about new After Effects software developments. Please register your copy by filling 
out and returning the registration card included with your software package. If you are upgrading 
from a previous version of After Effects, the original registration card with your serial number is still 
valid and you do not need to reregister the product.
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About Adobe products and services

For information about Adobe products and services in the United States, you can visit the Adobe 
Web site (http://www.adobe.com). This site also contains links to other country-specific Adobe sites.
You can also open the Adobe Web site from within After Effects (provided you are connected to the 
Internet) by choosing File > Adobe Online and clicking a link in the window that appears.

Note: Your After Effects package includes printed instructions for getting technical support.
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Adobe Systems training opportunities

Classroom in a Book is the official training series for Adobe graphics and publishing software 
developed by experts at Adobe and published by Adobe Press. For information on purchasing 
Adobe After Effects Classroom in a Book, contact Macmillan Computer Publishing in the U.S. at 
800-428-5331 or http://www.mcp.com, or contact your local book distributor. You can also purchase 
a Classroom in a Book on-line through Amazon.com at http://www.amazon.com or 
ComputerLiteracy.com at http://www.clbooks.com. Classroom in a Book may not be available in 
some countries. 

The Adobe Certification program offers users, instructors, and training centers the opportunity to 
demonstrate their product proficiency and promote their software skills as Adobe Certified Experts 
and Adobe Certified Training Providers. Visit the Adobe Web site at http://www.adobe.com to learn 
how you can become certified.
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What’s new in Adobe After Effects 4.0

Adobe After Effects 4.0 includes many new features that extend integration with Adobe products 
and other software, offer greater creative control, and enhance performance. Here is an overview of
what’s new:

See also: 

Adobe product integration 

Multiple masks and new mask features 

New visual effects 

Audio enhancements and effects 

Adjustment layers 

RAM-based previews 

Redesigned Time Layout window 

Grouped windows 

Tabbed palettes 

Enhanced performance 

Pen tool enhancements and changes 

Alignment, grids, rulers, and guides 

Align palette 

Colored labels for files and layers 

New Preferences 



What’s new in Adobe After Effects 4.0 

Adobe product integration

Improved integration with Illustrator, Photoshop, and Premiere provides new features and 
capabilities in After Effects. 

Adobe Illustrator Enhanced integration enables you to import Adobe Illustrator layers, and to copy 
and paste an Adobe Illustrator path as a layer mask. After Effects now converts font information to 
path information during import to provide smoother type animation. You can also import generic 
Encapsulated Postscript (EPS) files. See Importing an Adobe Illustrator or EPS file. 

Photoshop You can import layered files from Photoshop as a composition, and maintain all 
transparent areas, adjustment layers, and transfer modes. After Effects now converts Photoshop 
adjustment layers to After Effects adjustment layers. In addition, Photoshop masks can be copied 
and pasted into After Effects. See Importing an Adobe Photoshop file.

Premiere You can now import Premiere projects as compositions. The project imports as a 
composition containing each clip used in the Premiere project and as a folder of all clips. Within the 
composition, After Effects preserves the clip order from the Premiere Timeline, as well as all 
duration edits. Transitions and titles convert into solid layers in the After Effects composition, so you
can easily replace them or continue to use them as placeholders. See Importing Adobe Premiere 
projects. 

Keyboard shortcuts and commands To make After Effects more compatible and consistent with 
other Adobe products, some keyboard shortcuts and commands have been changed and new ones
added. These changes also allow for additional shortcuts to be added in the future. 



What’s new in Adobe After Effects 4.0 

Multiple masks and new mask features

You can now create multiple masks for each layer in your composition. These masks can be open 
or closed paths, and can even be copied using the clipboard directly from Adobe Illustrator. New 
modes are also included so that you can precisely determine how multiple masks in a layer interact 
with each other. A new mask feature called Free Transform Points lets you easily rotate or scale 
selected mask points. After Effects also changed the way it adds and deletes points on an 
interpolated mask, so animating masks is much smoother and easier than ever before. Also, mask 
edges can now be manipulated directly. Many After Effects effects, such as Stroke and Fill, can now
access mask data, so you can apply the effect directly to a mask. See Working with Masks and 
Transparency.



What’s new in Adobe After Effects 4.0 

New visual effects

The following new visual effects have been added: Channel Mixer, Curves, Hue/Saturation, 
Threshold, Smear, Transform, Audio Spectrum, Audio Waveform, Ellipse, Fill, Beam, Stroke, Motion
Tile, Path Text, and Iris Wipe. Many of the other effects have been enhanced. See Applying Effects.



What’s new in Adobe After Effects 4.0 

Audio enhancements and effects

After Effects now offers a variety of audio effects, so you can add an audio delay, adjust bass and 
treble, reverse the playback of audio layers, or loop audio playback. Audio quality and previewing 
have been improved, and new sample rates and rate control monitors in the Audio palette are 
included. You can also apply the Time Remapping feature to a layer containing audio. See About 
time-remapping. 



What’s new in Adobe After Effects 4.0 

Adjustment layers

After Effects adjustment layers, which are equivalent to Photoshop adjustment layers, let you apply 
effects to more that one layer at a time. Effects applied to adjustment layers modify all layers 
beneath them in the Time Layout window outline, enabling you to create complex effects without 
using nested compositions. You can create a new adjustment layer containing only a solid 
background, or you can convert a layer containing footage into an adjustment layer. Using the mask
or alpha channel from an adjustment layer, you can control how the effect blends with the other 
layers in the composition. See Creating an adjustment layer. 



What’s new in Adobe After Effects 4.0 

RAM-based previews

After Effects now includes an option to preview your animations faster. The RAM preview option 
loads the frames in your composition’s work area into RAM and then plays them back using the 
frames per second set for your composition. The number of frames that After Effects can play back 
at one time depends on the amount of RAM you have installed. See Setting preview options. 



What’s new in Adobe After Effects 4.0 

Redesigned Time Layout window 

Some of the property and layer switch names and locations have changed to better integrate After 
Effects features with those of other Adobe programs. For example, the Geometrics property is now 
called Transform; the layer effect switch now appears as an f icon, appearing beside the effect 
property and in the Switches panel in the Time Layout window, and beside the effect name in the 
Effect Controls window. You can click this icon anywhere to turn an effect on or off. The Time Layout
window is now customizable—you can move the panels around and show and hide different panels 
at any time. See Understanding the Time Layout window.



What’s new in Adobe After Effects 4.0 

Grouped windows

The After Effects windows are grouped together by type and use tabs to make available multiple 
windows of the same type, one at a time, in a single window space. Grouped windows are 
intelligently linked. For example, when you select a tab in a Composition window, After Effects 
automatically selects the associated Time Layout and Effect Controls window tabs. Tabs are 
created and deleted as you open and close windows. In windows containing a large number of tabs,
you can display hidden tabs using a scroll bar located below the tabs. See Using windows.



What’s new in Adobe After Effects 4.0 

Tabbed palettes

The After Effects palettes make use of tabs to better organize and present information and options. 
Palettes can be easily opened and closed, resized, moved, and docked together, just as they can 
with other Adobe applications. See Using palettes. 



What’s new in Adobe After Effects 4.0 

Enhanced performance

After Effects performance has been enhanced to speed up processing, operation, and rendering. 
Use of caching and more multiprocessor-aware operations improve overall performance.



What’s new in Adobe After Effects 4.0 

Pen tool enhancements and changes

Operation of the pen tools has been enhanced for ease of use and to make them behave more like 
the pen tools in Illustrator and Photoshop. You can now access special pen tools—Add Control 
Point, Delete Control Point, and Convert Control Point—from the toolbox. 



What’s new in Adobe After Effects 4.0 

Alignment, grids, rulers, and guides 

In addition to viewing title-safe and action-safe zones and an adjustable grid, you can now view or 
hide vertical and horizontal guide lines in the Composition, Layer, and Footage windows. Another 
new feature is the ability to display vertical and horizontal rulers around the image area in the 
Composition, Layer, and Footage windows. You can snap objects to guides and grids, as well as 
align objects using the axis and anchor points you specify. See Viewing safe zones and grids and 
Using rulers and guides. 



What’s new in Adobe After Effects 4.0 

Align palette

Using this new palette you can align two or more layers, or distribute three or more layers along a 
vertical or horizontal axis. See Aligning and distributing layers. 



What’s new in Adobe After Effects 4.0 

Colored labels for files and layers

All imported files now have colored labels to help you organize and select different types of files. By
default, all still image files use pink labels, while motion footage files use yellow labels. This label is 
used throughout the program and appears next to the filename in the Project, Layer, and Time 
Layout windows. The layer duration bar and window tab also display the same color. You can select
layers of the same color in the Time Layout window. You can customize the colors in the 
Preferences dialog box. 



What’s new in Adobe After Effects 4.0 

New Preferences 

After Effects improved the Preferences dialog box, making it easier to set preferences for multiple 
items in one dialog box. Several new preferences were also added, including color for labels, grids, 
and guides.



Working with Projects, Windows, and Palettes 

Adobe After Effects is a powerful tool for time-based compositing, two-dimensional animation, and 
visual effects. After Effects is designed for use in video, film, multimedia, and the World Wide Web. 
You can composite layers in a variety of ways, apply and combine sophisticated visual and audio 
effects, and animate both objects and effects.

In After Effects, every animation starts as a project—a collection of video footage, still images (such
as Adobe Illustrator or Adobe Photoshop files), and audio files, which you arrange in compositions 
within the project. 

See also: 

Working in a project 

Planning your project 

Time basics 

Setting up a project 

Setting preferences 

Using windows 

Project window 

Footage window 

Composition window 

Layer window 

Time Layout window 

Using context menus 

Using online Help 

Composition, Layer, and Footage window controls 

Using palettes 

Time Controls palette 

Toolbox 

Info palette 

Audio palette 

Align palette 
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Working in a project

An After Effects project is a single file that stores references to all the footage you use in that 
project. It also contains information about how you’ve arranged the footage in compositions, 
including the details of any effects or animation you applied. Inside a project, you create one or 
more compositions. After you have imported source footage into the project, you can add footage 
items into the compositions.

See also: 

Where you work 

How you start 



Working in a project 

Where you work

In a project, you work with footage items using primarily three windows: the Project window, which 
lists all the source footage items you import; the Composition window, which displays images as 
they relate in space; and the Time Layout window, which displays compositions and animation 
events in terms of time. You can add footage items to a composition by dragging them from the 
Project window into either the Composition window or the Time Layout window. For each 
Composition window, there is a corresponding Time Layout window. When you select a composition
in a Composition window, After Effects automatically displays the corresponding Time Layout 
window, and vice versa. 

In addition to these windows, palettes provide a variety of tools and information useful in working 
with your compositions. See Using palettes.

A. Source footage B. Project window C. Composition window D. Time Layout window

As you work with compositions, you will also use three other types of windows: Footage windows, 
Layer windows, and Effect Controls windows. Footage windows are useful for viewing and 
evaluating footage items in their original form (see Viewing imported footage). To view a 
composition’s layers, to trim footage, or to work with masks, you can open a Layer window (see 
Composition, Layer, and Footage window controls). As you work with effects, you will use the Effect 
Controls window to modify and animate the effects (see Working with effects).

When you render your compositions into a movie, you will work in the Render Queue window to 
select rendering options and queue compositions for rendering (see Using the Render Queue 
window). 



Working in a project 

How you start

Starting a project involves two tasks: (1) planning your project based on the format of the final 
output and (2) creating a project file. Once you have planned your project and learned how to 
perform some basic tasks related to working in After Effects, you’ll be ready to start importing 
footage, which is covered in Preparing and Importing Footage. You then create a composition and 
begin working with your source footage (see Building a Composition).
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Planning your project

Planning your project before you start importing footage will make your work easier. A large part of 
planning is simply determining the best settings for your source footage based on the media for 
which you will render your finished project. This step is essential to achieving optimal image quality. 
Rendering order and nesting (described in Managing Projects Effectively) may also be part of 
project planning. 

See also: 

Choosing the right media 

Considerations for cross-platform projects 
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Choosing the right media 

Before you start importing footage items into your project, decide which media you’ll use for your 
finished project. Then determine the best settings for your compositions and source material. For 
example, if you will be rendering your project to videotape, you should create footage at an image 
size, color bit-depth, and frame rate that will produce the best image quality on videotape. Likewise,
if your project is intended for streaming video on the World Wide Web, the image size, color bit-
depth, and frame rate may need to be reduced to work with the data-rate limits of streaming video 
on the Internet. However, any footage item that can be imported can be used in any composition.

If you will be rendering a project to more than one media format, always match the resolution 
setting for your composition to the highest resolution setting used for your output. Then you can set 
up the Render Queue window to render a separate version of the project for each format.

For film and video, it is generally a good idea to match import and composition settings with settings
in the output module used to render a movie. For example, to ensure smooth playback, the footage 
frame rate selected in the Interpret Footage dialog box should match the setting in the Composition 
Settings dialog box and the output module in the Render Queue window. Also, the composition-
frame size should be determined by the image size in the playback medium. See Preparing motion 
footage frame rate for final output, Understanding composition settings, and Changing output 
module settings.

If you will be mixing source footage with different pixel aspect ratios, correctly specify this ratio for 
each footage item in the Interpret Footage dialog box. See About D1, DV, and various pixel aspect 
ratio footage.

The suggestions that follow will help you select composition settings. However, the best way to 
ensure that your project is suitable for a specific medium is to make a test composition and view it 
using the same type of equipment your audience will use to view it. 

Film If you will be rendering for film, you should consider both the aspect ratio of the frame size you
select for your composition and the frame rate of your source footage. For footage that was 
transferred from film using the 3:2 pulldown telecine method, you will need to remove 3:2 pulldown 
before adding effects. See Removing 3:2 pulldown from video transferred from film.

CD-ROM When you create a movie that you plan to render for playback from a CD-ROM, you may 
need to specify import and composition settings that take into account the wide range of hardware 
that your audience may be using, possibly including older single- or double-speed CD-ROM drives.

To make your final output compatible with older CD-ROM drives, try to reduce the data-transfer rate
of your final output by specifying certain settings for footage items: 
•      Lower the frame rate as far as you can in the Composition Settings dialog box without making 
motion seem too jerky. Start at 15 frames per second. 
•      When rendering your final composition, choose a file type and compressor/decompressor, or 
codec, appropriate for the final media. For example, for a cross-platform CD-ROM, you might 
specify a QuickTime codec or a codec designed for low data rates, such as Indeo, Cinepak, or 
Sorenson Video. Regardless of which codec you select, however, it must be available on the 
system used by your intended audience to ensure successful playback. Also consider the key frame
rate of the codec you have selected. See QuickTime compressors for more information on codec 
key frame rates. 
•      When rendering your final composition, lower the color depth to 256 colors in the Output Module
Settings dialog box. In addition to lowering the data-transfer rate, this may improve picture quality 
on a system or in presentation software that can display only 256 colors (8-bit color). 

Videotape When your final output will be videotape, it is important to set up your composition with a
specific video format in mind, such as NTSC, PAL, or SECAM. Using broadcast-safe colors and 
maintaining frame size and compression ratios are also important considerations. These 



suggestions will help in setting up a composition intended for videotape:
•      Select a frame size in the Composition Settings dialog box that matches the frame size of the 
source footage.
•      Use only NTSC-safe colors when adding or changing color in a project. 
•      If you will be using an MJPEG codec, keep in mind that the frame sizes and resolutions 
available for rendering are determined by the specific MJPEG board you are using. Refer to the 
specifications for your MJPEG board. 

Animated GIF When you render an animated GIF, colors will be dithered to an 8-bit palette. Before 
rendering your final project, you should render a test composition so that you can adjust colors if the
results are not what you expected. If any source footage includes an alpha channel, be sure you 
know how it will affect your final project before you start rendering. 

Streaming video over the World Wide Web Streaming video resembles a conventional television 
signal in that video is sent to the viewer frame-by-frame, instead of by downloading a large file to 
the hard disk. Streaming video on the Web is constrained by the limited bandwidth (56 Kbps or 
less) of most consumer modems, which is even lower than those used for CD-ROM playback. Use 
the same techniques that are listed for CD-ROM playback, but adapt them for further reduction in 
file size and data-transfer rate. 

Downloading video over the World Wide Web If your final output will be downloaded as a file 
from the World Wide Web, the main concern is the size of the file, which directly affects how long it 
takes to download the file. QuickTime and Microsoft Video for Windows are formats often used 
when rendering final output that will be downloaded. When you render a QuickTime movie, After 
Effects automatically creates a movie that can play on both Windows and Mac OS without 
modification. 

Intranet playback An intranet is an in-house or private network that uses Internet network 
protocols. Intranets generally use higher quality communications lines than standard telephone 
lines, so they are usually much faster than the Internet. The data-transfer rate for playback can be 
100 KB per second or faster, depending on the speed of your intranet. 
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Considerations for cross-platform projects

After Effects project files are compatible with both the Mac OS and Windows platforms. There are 
several things you can do to ease the process of exchanging projects between platforms.

Project Hierarchy When you move a project to a different computer and open it, After Effects 
attempts to locate the project’s footage files. After Effects locates footage using several different 
methods. First, After Effects searches the folder in which the project file is located. If this fails, After 
Effects looks for the file using its original path or folder location. If this fails, After Effects searches 
the root of the directory where the project is located.

If you are building cross-platform projects, it is best if the full paths have the same names on Mac 
OS and Windows systems. For example, a Windows network path may appear as \\MYSERVER\
Footage\RockStar.mov, where MYSERVER is the server name and Footage is the volume name. 
You can then share this volume to Mac OS as a server called MYSERVER with the volume 
Footage; full paths will be properly retained. If the footage is on a different volume than the project, 
make sure that the appropriate volume is mounted before opening the project. Also make sure that 
network volume names are the same on both systems.

It helps to store footage in the same folder as the project file or in another folder within that folder. 
Here's a sample hierarchy:

c:\newproject\project_file.aep c:\newproject\source\footage1.psd c:\newproject\source\footage2.avi 

The newproject folder can then be copied in its entirety across platforms, and After Effects will 
properly locate all of the footage. 

File naming conventions When possible, name your footage and project files with Windows-
compatible filename extensions. For example, QuickTime movies should end in .mov, as in 
“Monkey.mov,” and After Effects projects in .aep, such as “Dancing.aep.” In addition, limit filenames 
to eight characters plus a three-character extension. Although Windows 98 and Windows NT can 
use long filenames, some network software may truncate filenames that go beyond this limit. If files 
will be used on the World Wide Web, be sure filenames adhere to the appropriate conventions for 
extensions and paths. 

Mac OS file types On Mac OS systems, footage files should have proper Mac OS file types. There 
are several ways to ensure this when sharing files across platforms. Using services for Macintosh in
NT Server, you can set up explicit extension-to-file-type mappings in the File Manager. The Mac OS
PC Exchange control panel has a similar feature for removable media. If footage files are not 
properly recognized on Mac OS systems, you can use the Import As command in After Effects to 
override the Mac OS file types. There is no equivalent to the Import As command for projects. In 
order to open a Windows project on a Mac OS system, it must have the correct .aep extension.

Resources Ensure that all resources are available on both systems. Resources can include fonts, 
effects, and compressors. 

Here are some common extensions and their associated file types:

Format Extension Mac Type Mac Creator (optional)

After Effects Project .aep EggP FXTC 

AE Render Settings .ars RSpr FXTC 

AE Output Settings .aom OMpr FXTC 

AE Tracker Settings .aet AEtr FXTC 



AE Stabilizer Settings .aes AEst FXTC 

QuickTime movie .mov MooV TVOD 

PICT image .pct or .pic PICT 8BIM 

TGA image .tga TPIC 8BIM 

TIFF image .tif TIFF 8BIM 

Photoshop file .psd 8BPS 8BIM 

Filmstrip .flm FILM PrMr 

Illustrator file .ai TEXT ART5 

Electric Image .img EIDI FXTC
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Time basics

Time is central to many operations in After Effects. You can view, specify, and manage time in 
various ways. Whichever way you handle time, there are several specific time concepts you should 
understand as you create a project.

See also: 

Time display 

Frame rate 

NTSC (29.97) drop-frame timecode 

Duration 

Frames and fields 

Setting time-display preferences 



Time basics 

Time display

The way you view and specify time in After Effects depends on the display style, or unit of measure,
that you use to describe time. By default, After Effects displays time in Society of Motion Picture and
Television Engineers (SMPTE) timecode: hours, minutes, seconds, and frames. You can change to 
another system of time display, such as film frames, or feet and frames of 16mm or 35mm film. See 
Setting time-display preferences. 

Video-editing workstations use SMPTE timecode that is often striped (encoded) onto videotape for 
reference. If you are creating video that will be synchronized with video that uses SMPTE timecode,
you should use the default timecode display style.



Time basics 

Frame rate

Each composition you create can have its own frame rate. The frame rate is the number of frames 
the rendered composition will produce in every second when played back. The frame rate you use 
is generally determined by the type of output you will produce. For example, video for NTSC 
television plays at 29.97 frames per second (fps), and PAL plays at 25 fps.

When you set up changes over time, After Effects treats the changes as continuous throughout a 
composition timeline. Each frame is rendered as a slice out of the timeline at the frame rate you 
specify. Because After Effects treats time continuously, it is possible to change a composition’s 
frame rate at any time or override the frame rate of a composition when you render the final movie. 
See Setting frame rate.



Time basics 

NTSC (29.97) drop-frame timecode

When you work with a composition that is set to a frame rate of 29.97 fps, After Effects uses 
SMPTE 30 fps drop-frame timecode by default. Drop-frame timecode makes adjustments for the 
slight difference between 29.97 fps frame rate and 30 fps frame rate. Non-drop-frame timecode is 
also available. 

When you use drop-frame timecode, After Effects uses the SMPTE-standard method of 
renumbering the first two frame numbers of every minute, except at every tenth minute. For 
example, the frame after 59:29 is labeled 1:00:02. 

After Effects displays drop-frame timecode by using semicolons between the numbers and displays 
non-drop-frame timecode using colons between the numbers. You can open the Go To Time dialog 
box by clicking the underlined current time in the Time Layout or Composition window.

Drop-frame timecode display (left) and non-drop-frame timecode display (right).

In the Time Preferences dialog box, you can choose how 29.97-fps compositions and footage 
display their timecode (drop-frame or non-drop-frame). See Setting time-display preferences.



Time basics 

Duration

Each video footage item, layer, and composition in a project has its own duration, which describes 
how long the item plays. Duration determines the beginning and ending times of the timelines in the
Footage, Layer, and Time Layout windows. It is important to notice which duration you are viewing 
while you edit in multiple windows. See Understanding trimming and Positioning a layer in time. 
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Frames and fields

Each frame in an interlaced video source is made up of fields. It’s important not to confuse frames 
with fields. For video, every frame contains two interlaced fields. If you want to use interlaced video 
as source footage, you’ll usually want After Effects to separate the interlaced fields. Separating 
fields ensures maximum image quality when you apply animations and effects to video that was 
originally interlaced. If you’re producing a movie for videotape, you can render the composition to 
fields in a process known as field-rendering. See Interlaced and non-interlaced footage and Field 
rendering.



Time basics 

Setting time-display preferences

After Effects supports several methods of measuring and displaying time. You can display time as 
timecode, frames, or feet and frames. The method you choose applies to all time displays in After 
Effects; time preferences are saved with the After Effects application preferences and not with 
individual projects. A time preference does not alter the frame rate of footage or a composition—it 
changes only how frames are numbered. You can choose from three time-display options:
•      Timecode, which counts frames in frames per second.
•      Frames, which counts frames of footage without reference to time.
•      Feet and Frames, which counts feet of 16mm or 35mm motion-picture film, and counts fractions
of feet in frames; 35mm film has 16 frames per foot, and 16mm film has 40 frames per foot.

A. Timecode B. Frames C. Feet and Frames

When working with footage digitized from NTSC video, you will usually use the 30-fps, drop-frame 
timecode base. This counts NTSC-created frames using standard drop-frame timecode for 
maximum device compatibility. For frames, or feet and frames, timecode, you can also change the 
starting frame number to match the time-counting method of another editing system you may be 
using.

To change the time display:

1    Choose File > Preferences > Time.

2    Select a time preference:
•      To use timecode, click Timecode Base, and then select a frame rate from the Timecode pop-up 
menu.
•      To use drop-frame time code for footage and compositions with a frame rate of 29.97 fps, click 
Timecode Base, and then select 30 fps from the Timecode Base pop-up menu.
•      To use non-drop-frame timecode for footage and compositions with a frame rate of 29.97 fps, 
click Timecode Base and then select 30 fps from the Timecode Base pop-up menu and Non-Drop 
Frame from the NTSC menu.
•      To use frames, click Frames.
•      To use feet and frames, click Feet + Frames, and then choose a film type from the Feet + 
Frames pop-up menu.

3    If you want, enter a value in the Start Numbering Frames At option. This value applies only when
you have chosen Frames or Feet + Frames.

4    Click OK.
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Setting up a project

To set up a project in After Effects, you first create a new project. Then you import footage into the 
project and set project preferences. 

See also: 

Creating a new project 

Importing footage items 

Opening and closing a project 

Saving a project 



Setting up a project 

Creating a new project

By default, After Effects opens a new Project window when you start the application. When you 
know the media for your final project, you are ready to create a project by importing your footage 
items into a new Project window. You can also open a new Project window at any time from the File 
menu. See Project window.

To create a new project after closing the current project in After Effects:

Choose File > New > New Project.



Setting up a project 

Importing footage items

When you import a footage item, After Effects creates only a reference to the file and does not copy
or move the file itself. These references to your source files are displayed in the Project window. 

To import source footage items into an After Effects project:

1    Choose File > Import > Footage File or Footage Files.

2    Locate and select footage files and click Open.

For complete details, see Preparing and Importing Footage.



Setting up a project 

Opening and closing a project

You can have only one project open at a time. If you try to open another project, After Effects 
prompts you to save changes in the first project, and then closes the first project. Closing the 
Project window closes any associated windows, but palettes remain open. 

To open a project:

Choose File > Open Project, locate the project, and then click OK.

To close a project:

Click the Project window title bar to make it active and choose File > Close.



Setting up a project 

Saving a project

Save your work frequently as you develop a project. You can discard changes by reverting to the 
last saved version of the project. 

Note: When you revert to the last saved version, all editing and footage imported since you last saved are lost.
You cannot undo this action.

To save a project:

Choose File > Save, or press Control + S (Windows) or Command + S (Mac OS).

To save a project using a different name or location:

Choose File > Save As. Specify a filename and location and click Save (Windows) or OK (Mac OS).

The project currently open takes the new name and location; the original file remains as it was.

To save a copy of the project using a different name or location:

Choose File > Save a Copy. Specify a filename and location and click Save (Windows) or OK (Mac 
OS).

The project currently open retains its original name and location, and a copy is created but not 
opened.

To revert to the last saved version:

Choose File > Revert.
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Setting preferences

When you start After Effects for the first time, the default settings are used. You may want to change
some of these default settings so that each time After Effects is opened, it uses your selections 
instead of the standard defaults. After changing settings, you can easily restore the default settings 
at any time. All After Effects default settings are stored in a single file. 

After Effects saves the location and type of each open window with the project. Palette positions are
saved in the After Effects Preferences file, which applies to all projects.

See also: 

To open a preferences dialog box 

To restore all preferences to their default settings 

To start After Effects with default palette, window, and dialog box positions 



Setting preferences 

To open a preferences dialog box:

1    Choose the preferences command you want from the File > Preferences submenu.

2    To switch to another dialog box, do any of the following:
•      Choose an option from the menu at the top of the dialog box.
•      Click Next to display the next dialog box in the menu list; click Previous to display the previous 
dialog box.

For information on a specific option, see the index. 

See also: 

To restore all preferences to their default settings 

To start After Effects with default palette, window, and dialog box positions 



Setting preferences 

To restore all preferences to their default settings:

1    Make sure that After Effects is not running. If it is, choose File > Exit (Windows) or File > Quit 
(Mac OS). 

2    Do one of the following:
•      (Windows) Use Windows Explorer to locate the AEPrefs4.txt file inside the Prefs folder in the 
After Effects 4.0 folder and delete it or move it to another folder. When you start After Effects again, 
it creates a new preferences file. 
•      (Mac OS) Use the Finder to locate the After Effects 4.0 Prefs file in the Preferences folder in 
your System folder and delete it or move it to another folder. When you start After Effects again, it 
creates a new preferences file. 

See also: 

To open a preferences dialog box 

To start After Effects with default palette, window, and dialog box positions 



Setting preferences 

To start After Effects with default palette, window, and dialog box positions:

Hold down Shift when starting After Effects.

See also: 

To open a preferences dialog box 

To restore all preferences to their default settings 
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Using windows

Many After Effects windows are organized in groups by default. Each window group is identified by 
a different icon. You can customize and display these windows in certain ways depending on the 
type of window:

Composition window The title of a Composition window appears as a tab under the group 
window’s title bar. By default, Composition windows are grouped into one window. You can group 
Composition windows with Layer and Footage windows.

Layer and Footage windows As with Composition windows, the title of a Layer or Footage window
appears as a tab under the group window’s title bar. By default, Layer and Footage windows are 
grouped into one window. Each window group is identified by a different icon, and can be combined
with Composition windows and other Layer and Footage windows.

 
A. Composition tab icon B. Footage tab icon C. Layer tab icon

Time Layout windows Each composition name appears as a tab in the Time Layout window. You 
can combine Time Layout windows only with other Time Layout windows.

Effect Controls windows By default, the options for effects you apply to layers are grouped in one 
Effect Controls window. You can combine Effect Controls windows only with other Effect Controls 
windows.

Project window You cannot group Project windows with any other windows. 

See also: 

Reorganizing windows 



Using windows 

Reorganizing windows

Use the following techniques to reorganize windows:
•      To change the default from grouped windows to ungrouped windows, choose File > Preferences
> General, deselect Tabbed Windows, and click OK. 
•      To make a window appear at the front of its group, click its tab.
•      To move an entire window group, drag its title bar. 
•      To rearrange or separate a window group, drag the tab for a window. 

•      To move a window to another group window, drag its tab to that group. 

•      To display a window menu, click the triangle in the upper right corner of the palette or window 
(not available for all windows or palettes). 
•      To resize a window, drag its lower right corner. 
•      If a window contains more grouped windows than After Effects can display at once, drag the 
slider bar that appears below the tabs.

•      To close the frontmost window in a group, be sure the group window is active, and then click the
close box on the right side of the tab, or choose File > Close.
•      To open a Time Layout window from its Composition window (and vice versa) select the tab for 
the window and then click the Comp Family button above the vertical scroll bar. 



•      To close a group window and all included windows, click the close box in the upper right corner 
of the group window.
•      To display a window that is obscured by other windows, select it from the Window menu.
•      If both the Composition and Time Layout windows are closed, double-click the composition’s 
icon in the Project window to open both windows again.
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Project window

The Project window acts as a storage area for compositions and references to footage items. In the 
Project window you import, identify, replace, remove, and interpret footage items and compositions. 
You organize footage and compositions in the Project window using folders. The folders you create 
in the Project window exist only in the Project window. You can expand a folder to reveal its 
contents. You can also put folders inside other folders, and open a folder in its own window. 

See also: 

To remove footage from a project 

To organize footage items using folders 

To customize the Project window 

To create a new composition from the Project window 

To manage footage items in the Project window 



Project window 

To remove footage from a project: 

Do any of the following:
•      To eliminate an item from a project, select the item and press Delete, or click the delete icon ( )
at the bottom of the Project window.

•      To remove all unused footage items from a project, choose File > Remove Unused Footage. 
•      To remove all duplicate footage items from a project, Choose File > Consolidate All Footage. 

See also: 

To organize footage items using folders 

To customize the Project window 

To create a new composition from the Project window 

To manage footage items in the Project window 



Project window 

To organize footage items using folders:

Do any of the following:
•      To create a folder in the Project window, choose File > New > New Folder, or click the create 
folder icon ( ) at the bottom of the Project window.

•      To move a file or folder into a Project folder, drag the file or folder from the Project window list into a 
folder.
•      To move a file or folder from a folder to the top level of the Project window, drag the file or folder to the
gray information area at the top of the window.
•      To show or hide the contents of a folder, click the triangle to the left of the folder icon.

See also: 

To remove footage from a project 

To customize the Project window 

To create a new composition from the Project window 

To manage footage items in the Project window 



Project window 

To customize the Project window:

•      To resize a panel, drag the bar on the right side of the panel’s heading. Drag left to make the 
panel smaller, or right to make it larger.
•      To hide a panel, right-click (Windows) or Control-click (Mac OS) any panel heading and choose 
Hide This.
•      To show a panel, right click (Windows) or Control-click (Mac OS) any panel heading and choose
Panels > <panel heading>.

See also: 

To remove footage from a project 

To organize footage items using folders 

To create a new composition from the Project window 

To manage footage items in the Project window 



Project window 

To create a new composition from the Project window:

Click the create new composition icon at the bottom of the Project window.

See also: 

To remove footage from a project 

To organize footage items using folders 

To customize the Project window 

To manage footage items in the Project window 



Project window 

To manage footage items in the Project window:

Do any of the following:
•      To display information about a footage item or composition, select the footage or composition. 
Information is displayed at the top of the Project window next to the thumbnail image.

•      To sort footage items by name or type, click Name or Type in the Project window.

Note: The Project window contains references to source files that are stored elsewhere. Renaming items in 
the Project window changes only the item name that appears there; the source file itself is not affected. 
•      To rename a composition or folder, select the footage item, composition, or folder, press Enter 
(Windows) or Return (Mac OS), type the new name, and then press Enter or Return again.

See also: 

To remove footage from a project 

To organize footage items using folders 

To customize the Project window 

To create a new composition from the Project window 
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Footage window

The Footage window displays a footage item as it exists in the Project window, independent of any 
compositions. By default, After Effects opens a QuickTime footage item in a QuickTime Footage 
window and opens a Video for Windows footage item in a Video for Windows Footage window. You 
can also open any footage item in an After Effects Footage window and make use of the standard 
After Effects viewing controls found in the Composition and Layer windows. 

To open a footage item in an After Effects Footage window: 

Press and hold down Alt (Windows) or Option (Mac OS) and double-click the footage item in the 
Project window. 
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Composition window

The Composition window displays the footage items you have added to the composition, each item 
in its own layer. See Composition, Layer, and Footage window controls and Building a Composition.
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Layer window

The Layer window displays a layer as it exists in the Composition window, outside any 
compositions. You can use this window to trim footage, draw a mask, and move the point from 
which the layer rotates and scales. Modifying the layer in this window affects the layer only in the 
composition from which you opened it. 

To open a layer in a Layer window:

Do any of the following:
•      Double-click the layer item in the Composition window. 
•      Double-click the layer duration bar in the Time Layout window.
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Time Layout window

The Time Layout window represents a composition’s layers on a timeline so you can add effects 
and animate the layers. See Understanding the Time Layout window.
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Using context menus

In addition to the menus at the top of your screen, context menus display commands relevant to the
active tool or selected item.

To display context menus:

1    Position the pointer over the footage or over a label in a palette or window (for example, a button
in the Time Controls palette).

2    Click the right mouse button (Windows) or press Control and hold down the mouse button (Mac 
OS).
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Using online Help

Adobe After Effects includes complete documentation in online Help, including all of the information 
in this user guide plus a description of new features, keyboard shortcuts, and more.

To get online Help in Windows:

Do one of the following:
•      Press F1 to display the Help Topics menu.
•      Press F1 when a dialog box is displayed to get help on that dialog box. 
•      Choose Help > Help Topics, or choose another topic from the Help menu.

To get online help in Mac OS:

Choose Help > Help Topics.
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Composition, Layer, and Footage window controls

The Composition, Layer, and Footage windows let you preview and edit different parts of a project. 
These windows share a set of controls you can use to view safe zones (the visible areas of a 
television screen), view RGB and alpha channels, and change the magnification. You use these 
controls in the same way in all three windows.

See also: 

Displaying After Effects viewing controls in the Footage window 

Changing magnification in the Composition, Layer, or Footage windows 

Viewing safe zones and grids 

Changing safe-zone margins and grid spacing 

Using rulers and guides 

Viewing color and alpha channels 

Taking and viewing a window snapshot 

Viewing a specific frame 

Stopping window updates 



Composition, Layer, and Footage window controls 

Displaying After Effects viewing controls in the Footage window

By default, the Footage window displays movie controls for movie footage rather than the After 
Effects viewing controls found in the Layer and Composition windows. QuickTime and Video for 
Windows controls are fast and familiar tools for playing movie footage, and they play audio if it’s 
included in the footage. However, for the preview options discussed in this section, you must 
display footage using the After Effects viewing controls.

Note: After Effects always uses its own viewing controls for displaying still footage.

To display a footage item in the Footage window:

Double-click a footage item in the Project window.

To display .mov or .avi movies in the After Effects Footage window:

Press Alt (Windows) or Option (Mac OS) as you double-click a footage item in the Project window.
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Changing magnification in the Composition, Layer, or Footage windows

The lower left corner of a Composition, Layer, or Footage window shows the current magnification. 
When you change magnification, you change the appearance of the pixels in the window, not the 
actual resolution of the composition.

To zoom in or out:

Do one of the following:
•      Using the zoom tool, click inside the window you want to magnify.
•      Using the zoom tool, press Alt (Windows) or Option (Mac OS) as you click inside the window 
you want to reduce.
•      Double-click the zoom tool in the toolbox to view at actual size.
•      Choose a magnification from the menu in the lower left corner of a Footage, Layer, or 
Composition window. 



Composition, Layer, and Footage window controls 

Viewing safe zones and grids

In Footage, Layer, or Composition windows, you can display safe zones for titles and action, as well
as grids used for aligning layers. 

Television sets enlarge a video image and allow some portion of its outer edges to be cut off by the 
edge of the screen. This is known as overscan. The amount of overscan is not consistent across 
television sets, so you should keep important parts of a video image, such as action or titles, within 
margins known as safe zones. You can view safe zones in a Footage, Layer, or Composition 
window. When you arrange layers in a composition, do the following:
•      Keep important scene elements, graphics, and actors within the action-safe zone.
•      Keep titles and other text within the title-safe zone.

After Effects also provides grids you can use to help arrange and align layers. You can set the grid 
spacing using the Grids & Guides Preferences dialog box. 

A. Grid B. Title-safe zone C. Action-safe zone D. Overscan

See also: 

To view safe zones 

To view a standard grid 

To view a proportional grid 

To snap a layer to a grid 



Viewing safe zones and grids 

To view safe zones:

In a Footage, Layer, or Composition window, click the safe-zones icon to show or hide the safe 
zones.

See also: 

To view a standard grid 

To view a proportional grid 

To snap a layer to a grid 



Viewing safe zones and grids 

To view a standard grid:

Do one of the following:
•      With a Footage, Layer, or Composition window active, choose View > Show Grid or Hide Grid.
•      Press and hold down Alt (Windows) or Option (Mac OS) and click the safe-zones icon.
•      Press and hold down Control (Windows) or Command (Mac OS) and press ’(apostrophe).

See also: 

To view safe zones 

To view a proportional grid 

To snap a layer to a grid 



Viewing safe zones and grids 

To view a proportional grid:

Do one of the following:
•      Press and hold down Alt (Windows) or Option (Mac OS) and click the safe zones icon.
•      Press and hold down Alt (Windows) or Option (Mac OS) and press ’ (apostrophe).

See also: 

To view safe zones 

To view a standard grid 

To snap a layer to a grid 



Viewing safe zones and grids 

To snap a layer to a grid:

With a Footage, Layer, or Composition window active and the grid shown, choose View > Snap To 
Grid, then drag a layer until it snaps to the desired grid lines.

See also: 

To view safe zones 

To view a standard grid 

To view a proportional grid 
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Changing safe-zone margins and grid spacing

You can change the percentage of window area marked as title-safe or action-safe, and you can 
change the number of grid cells. Safe-zone margins represent the percentage of image area not 
included in the safe area.

To change safe-zone margins:

Choose File > Preferences > Display, enter values for Action-Safe Margin and Title-Safe Margin, 
and click OK.

To change grid spacing:

Choose File > Preferences > Grids & Guides, enter a value for Gridline Every, enter a value for 
Subdivisions, and click OK.
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Using rulers and guides

You can display rulers along the sides of the Composition, Layer, and Footage windows to provide a
visual guide for positioning and editing your footage. Using the cross hair in the upper left corner of 
the rulers, you can change the origin, or zero point, in both rulers. Changing the zero point makes it 
easy to measure from a specific point in the image. By default, rulers are hidden. 

For added precision in positioning objects, you can create guide lines. You can also lock guidelines 
to prevent them from being repositioned. 

Note: Rulers and guides are only a reference in the Composition, Layer, and Footage windows. They do not 
appear in your rendered movie. 

A. Cross hair B. Zero point C. Ruler D. Guide lines

See also: 

To display or hide rulers 

To set the zero point in rulers 

To create, reposition, lock, hide, or remove a guide 



Using rulers and guides 

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

See also: 

To set the zero point in rulers 

To create, reposition, lock, hide, or remove a guide 



Using rulers and guides 

To set the zero point in rulers:

Drag the cross hair from the intersection of the two rulers (in the upper left corner) into the image 
area. 

See also: 

To display or hide rulers 

To create, reposition, lock, hide, or remove a guide 



Using rulers and guides 

To create, reposition, lock, hide, or remove a guide:

Do any of the following:
•      Position the pointer inside either ruler and drag where you want to create a guide line. 

•      In the image area, drag a guide to reposition it. 
•      To lock or unlock guides, choose View > Lock Guides.
•      In the image area, drag a guide into a ruler to remove it. 
•      To display or hide all guides, choose View > Show Guides or Hide Guides.
•      To remove all guides, choose View > Clear Guides.

See also: 

To display or hide rulers 

To set the zero point in rulers 
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Viewing color and alpha channels

You can preview the red, green, blue, and alpha channels of a still image or movie in a Footage 
window, Layer window, or Composition window. When you view a color channel, areas with that 
color are displayed according to the color value of each pixel. For example, if you view the red 
channel, areas with high red values are displayed as white.

To see the color values in a color channel displayed in the channel’s own color instead of white, hold 
down Alt (Windows) or Option (Mac OS) and click the desired color channel icon. 

When you preview the alpha channel, After Effects displays opaque and transparent areas as black 
and white to make identification easier. Degrees of opacity appear as shades of gray.

To view a color channel or alpha channel:

1    Open the Composition, Layer, or Footage window to view a channel for a composition, layer, or 
footage item, respectively. 

2    At the bottom of the window, click the icon that corresponds to the channel you want to display.

A. Red channel B. Green channel C. Blue channel D. Alpha channel
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Taking and viewing a window snapshot

When you want to compare one view to another in the Composition, Layer, or Footage window, you 
can take a snapshot of one view and temporarily replace the window image with the snapshot. For 
example, you might want to compare two frames in different locations in a movie. You can instantly 
show and hide the snapshot to easily identify differences between the views. If you have a sound 
card installed and audio is included in the composition, you will hear a sound when you take a 
snapshot.

When working with snapshots, here are some tips to keep in mind:
•      Snapshots taken in one kind of window can be displayed in another kind. For example, you can 
take a snapshot of a Layer window and display the snapshot in the Composition or Footage 
window. 
•      Displaying a snapshot does not replace the content of the window.
•      You can take only one snapshot at a time; each snapshot you take replaces the previous one. 
•      If the snapshot has a different size or aspect ratio than the window in which you display it, the 
snapshot is resized to fit the window. 
•      The most recent snapshot you take is available as long as the display-snapshot icon is active. 
However, After Effects may discard the most recent snapshot if it needs to use the memory 
occupied by the snapshot.
•      Snapshots are for reference only and do not become part of the layer, composition, or rendered 
movie. 

To take a snapshot:

Click the take-snapshot icon at the bottom of the window.

A. Take-snapshot icon B. Display-snapshot icon

To view a snapshot:

Click and hold the display-snapshot icon at the bottom of the window.
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Viewing a specific frame

The duration of a composition, a layer, or a footage file is represented visually by the time ruler. On 
the time ruler, the current-time marker indicates the frame you are viewing or editing, and the frame 
appears in the corresponding window. You can view a different frame by entering a number or by 
dragging the current-time marker.

In a Layer or Footage window, the time ruler appears near the bottom of the window. In a 
Composition window, the time ruler appears in the corresponding Time Layout window. Keep in 
mind that the time rulers in different windows represent different durations. The time ruler in Layer 
and Footage windows represent the duration of the contents of that window, in contrast to the time 
ruler in the Time Layout window, which represents the duration of the entire composition. 

Current-time marker in the Time Layout window (left) and in the Layer window (right) 

To view a specific frame by dragging:

In the time ruler, drag the current-time marker to a new point in time.

To view a specific frame numerically:

1    Do one of the following:
•      Choose View > Go To Time, or press Control + G (Windows) or Command + G (Mac OS). 
•      Click the current-time display in a Footage, Layer, Composition, or Time Layout window.

2    Enter a new time and click OK.



Composition, Layer, and Footage window controls 

Stopping window updates

Press the Caps Lock key to prevent After Effects from updating Footage, Layer, or Composition 
windows. This is useful for a Layer or Composition window that takes a long time to update. When 
Caps Lock is active, all open Footage, Layer, or Composition windows display the last update you 
made before pressing Caps Lock, regardless of the changes you make. As soon as you make a 
change that would appear in a window, After Effects adds a red outline to any affected windows, 
and the windows are not updated. After Effects continues to update window controls such as motion
paths, anchor points, and mask outlines as you move them. To resume window updates and display
all changes made while Caps Lock was active, press Caps Lock again to deactivate it.
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Using palettes

Palettes float above windows and display information about the active composition or the selected 
layers. Like After Effects windows, palettes can be tabbed and grouped. You can customize palettes
in a variety of ways. After Effects includes four standard palettes: Audio, Info, Tools, and Time 
Controls. After Effects also includes two additional plug-in palettes: Align, which is used exclusively 
with layers, and Motion Sketch, which is used to draw Position keyframes (see Using Motion Sketch
to draw a motion path). 

See also: 

Changing palette display 



Using palettes 

Changing palette display

Use the following techniques to reorganize palettes:
•      To make a palette appear at the front of its group, click its tab.
•      To move an entire palette group or the toolbox, drag its title bar. 
•      To rearrange or separate a palette group, drag the tab for a palette. 
•      To move a tabbed palette to another group palette, drag its tab to that group. (You can move a 
tabbed palette only when the group palette contains more than one palette.) 
•      To show or hide a palette (except the Align palette), choose Show <palette name> in the 
Window menu. To show or hide the Align palette, choose Window > Plug-in Palettes > Align & 
Distribute. To show or hide the toolbox, choose Show Tools in the Window menu.
•      To show or hide tabs in windows, choose File > Preferences > General, select Tabbed 
Windows, and click OK.
•      To collapse a palette group to tabs only, click the appropriate box in the upper right corner or 
double-click a tab or the area alongside. Clicking a button or double-clicking the tab area restores 
the group. 

If you resized the Audio palette, double-clicking the tab area cycles through its new size, the default size, and the 
collapsed state. 
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Time Controls palette 

The Time Controls palette provides a variety of options for playing back your footage and moving 
forward and backward in time in a Composition, Time Layout, Layer, or Footage window. For details
on previewing animations, see Setting preview options.
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Toolbox

Use the tools in the toolbox to select, edit, and view layers. You can edit layer properties, masks, 
and motion paths graphically, and you can change the view of a Footage, Layer, or Composition 
window. The small triangle to the right of the pen tool indicates that there are hidden tools available.
Procedures for using these tools are included throughout this book. See the tool name in the index.

To select a tool:

Click the tool’s icon in the toolbox.

To select a pen tool:

Do one of the following:
•      If the tool is visible, click its icon.

A. Selection B. Rectangle C. Pen D. Add Control Point E. Delete Control Point F. Convert Control Point G. 
Hand H. Rotation I. Oval J. Pan Behind K. Zoom
•      If the tool is not visible, position the pointer on the pen tool and drag to highlight the tool you 
want.

To select a tool quickly, press its shortcut key on the keyboard. These keys are listed in the After Effects Quick 
Reference Card. To cycle through a set of hidden tools, press Alt (Windows) or Option (Mac OS) and click the pen 
tool; or press Shift while pressing the pen tool’s shortcut key.
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Info palette

The Info palette describes the area under the mouse pointer as you drag across a footage frame in 
the Composition, Layer, or Footage window. This palette displays values for the pixel color (R,G,B), 
alpha channel (A), and X and Y coordinates of the current position. When you modify a layer 
property graphically, the bottom portion of this palette displays precise values that relate to the layer
instead of the pointer. For example, when you drag a layer, the Info palette displays the X and Y 
coordinates of the layer’s center point and the offset from its last position. This makes it easy to 
move a layer by a specific number of pixels in either axis. During other operations, the Info palette 
provides context-sensitive information, such as the progress of rendering a window preview.

The X coordinate represents position in the horizontal axis, and the Y coordinate represents 
position in the vertical axis. Values for these coordinates are in pixels. The X and Y coordinates are 
relative to the origin (0,0), which is fixed at the upper left corner of the image area. The upper right 
portion of the Info palette displays the X and Y coordinates of the pointer. As you drag a layer, the 
lower portion of the Info palette displays the X and Y coordinates of the layer’s anchor point.

Note: The origin of the image area is different than the origin, or zero point, of the rulers. You can set the 
ruler’s zero point to match the origin of the image area, but you cannot change the origin of the image area. 

X and Y coordinates of the pointer are relative to the image area’s origin.

X and Y coordinates of a layer’s anchor point while the layer is being dragged, and the changes from the last 
position coordinates
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Audio palette

The Audio palette displays audio volume levels during playback and lets you adjust the left and right
audio level of a selected layer. You can set keyframes for audio levels using the Time Layout 
window and the Audio palette.

You can change the display of decibels to percentages and increase or decrease the decibel slider 
range in the Audio Options dialog box. See Using audio layers.
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Align palette

The Align palette lets you align selected layers along the axis you specify. You can align layers 
along the vertical axis, using the rightmost, center, or leftmost layer handles of the selected objects. 
You can also align layers along the horizontal axis, using the topmost, center, and bottommost 
selection handles of the selected layers.

You can also distribute layers evenly along either the horizontal or vertical axis.

See Aligning and distributing layers.



Preparing and Importing Footage

A footage item is the basic unit in an After Effects project. Before you begin animating, you need to 
import footage into After Effects. You can import moving image files, still image files, still image 
sequences, audio files, layered files from Adobe Photoshop and Adobe Illustrator, and other After 
Effects projects and projects created in Adobe Premiere. As you build a project, you can import 
footage items at any time.

See also: 

How After Effects works with imported files 

Working with file formats 

Preparing a still image file for import into After Effects 

Importing files into a project 

Importing a sequence of still image files 

Importing footage containing an alpha channel 

Importing an Adobe Photoshop file 

Importing an Adobe Illustrator or EPS file 

Importing an After Effects project 

Importing After Effects projects from different platforms 

Importing Adobe Premiere projects 

Importing an audio file 

Importing Cineon files 

Preparing motion footage for importing to After Effects 

Using interlaced video in After Effects 

Interpreting field order 

About 3:2 pulldown 

Removing 3:2 pulldown from video transferred from film 

About D1, DV, and various pixel aspect ratio footage 

Setting pixel aspect ratio 

Importing DDR-based footage 

Setting up frames and fields for DDR-based footage 
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How After Effects works with imported files

When you import files, After Effects does not copy the footage item (file, sequence, composition, or 
project) itself into your project. Instead, it creates a reference link in the Project window to the 
externally stored footage item. This process saves disk space by not duplicating source files each 
time you import them. If you delete or rename source files after you import them, you will break the 
reference link to each file. Moving footage files to a different disk or folder can also break the 
reference link. 

If the link to a footage item is broken, the reference displays in italics in the Project window and the 
File Path column lists it as missing. If the footage item is available, you can reestablish the link. See
Replacing and substituting footage.

If you use another application to modify footage that is used in a project, you will see the changes in
After Effects the next time you open the project. See Opening footage in its original application.

When you add a footage item to a composition in After Effects, you create a new layer, and the 
footage item becomes the source for the new layer. You can replace the source of a layer without 
affecting any of the edits you’ve made to the layer properties. See Building a Composition.
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Working with file formats

You can import and export the following file formats in After Effects 4.0. Included are formats you 
can import by using Adobe Photoshop’s File Format plug-ins. Additional file formats may be 
supported through QuickTime 3.0. For more information and an extensive listing of QuickTime’s 
supported formats, see the Apple Web site. You can also check the Adobe Web site for updates. 

File formats supported by After Effects: QuickTime, Video for Windows (Windows only), WAV 
(Windows only), Adobe Photoshop, JPEG, SGI, Targa, TIFF, PICT, Cineon, Electric Image, 
Filmstrip, FLC/FLI, EPS (import only), Adobe Illustrator (import only), Adobe Premiere (import only), 
GIF89a (export only).

File formats supported using Adobe Photoshop plug-ins: Amiga IFF, BMP, PCX, Pixar, PNG, GIF 
(import only). 

Notable formats supported by QuickTime: AIFF, AU, WAV (Mac OS only), Mac Sound (Mac OS 
only).
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Preparing a still image file for import into After Effects

Before you import a still footage item into After Effects, prepare the file as completely as possible. It 
is generally easier and faster to prepare a file in its original application; this also reduces rendering 
time in After Effects. You can use an image-editing application, such as Adobe Photoshop, to 
prepare the footage, and then use After Effects to manipulate only the image attributes you want to 
change over time. Before you import still image files into After Effects, consider doing the following:
•      Set the pixel dimensions of the still image to the resolution at which you will use it in After 
Effects. If you plan to output to DV or D1, you can set the pixel dimensions to a smaller size; see 
Using square-pixel footage for output to D1 or DV NTSC. If you plan to scale the image over time, 
set image dimensions that provide enough detail at the image’s largest size in the project. The 
maximum resolution you can use in After Effects is 4000-by-4000 pixels.
•      Set the resolution to even numbers if working in a composition that uses even-numbered 
resolution. Likewise, set the resolution to odd numbers if working in a composition that uses odd-
numbered resolution. This process prevents additional softening of images.
•      Crop the parts of the image that you do not want to be visible in After Effects.
•      Correct the contrast and color balance to ensure they are set correctly for broadcast video, if 
necessary.
•      Create an alpha channel if you want to designate areas as transparent.
•      If final output will be broadcast video, avoid the use of thin lines, for example, 1-pixel lines, for 
images or text because they may appear to flicker. If you must use thin lines, add a slight blur so 
the line or text displays on both fields instead of flickering between them. 
•      Save the file using the correct naming convention. For example, if you plan to import the file to 
After Effects on a Windows system, save the file using a three-character extension. If you plan to 
import the file to a Mac OS, save the file with a name containing a maximum of 31 characters.
•      Make sure the file format is supported on the operating system you plan to use.

See also: 

Changing the default duration of still images 
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Changing the default duration of still images

When you add a still image file to a composition, by default its duration is the duration of the 
composition. You can trim the duration of a still image manually, and you can change the default 
duration of still footage in the Import Preferences dialog box. See Understanding trimming.

To change the default duration of still footage:

1    Choose File > Preferences > Import.

2    In the Still Footage section, select a default duration and click OK:
•      Use Length of Composition to set the duration to the length of the composition into which it is 
added.
•      Use the time option to enter a custom duration.
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Importing files into a project

To save time and minimize the size and complexity of a project, you can import a footage item once 
and use it multiple times in a composition. It is occasionally useful, however, to import a footage 
item more than once; for example, when you want to use it at two different frame rates.

After Effects supports 24- and 32-bit files using 8-bits per channel (including alpha channel) and the
RGB, Grayscale, and Black and White color modes. For a list of supported file formats, see online 
Help.

After Effects can import Adobe Illustrator CMYK files. However, to maintain accurate color, convert 
your CMYK images to RGB images in Illustrator. When you import Adobe Illustrator CMYK images, After 
Effects remaps the CMYK colors to RGB, and may subtly shift colors. 

See also: 

To import footage into a Project window 

To import multiple items 

To import several items at once by dragging 

To import a folder by dragging 

Searching for footage when importing (Mac OS only) 

Importing an unrecognized file 



Importing files into a project 

To import footage into a Project window:

1    Open a project or choose File > New > New Project.

2    With the Project window open, choose File > Import > Footage File.

3    To see files of only one type, select a file type.

4    Locate and select the footage you want to import.

5    Click Open. The imported footage appears in the Project window. 

Note: If the Interpret Footage dialog box appears instead, the imported footage item contains an unlabeled 
alpha channel, and you’ll need to select a type or click Guess to let After Effects determine the type. See 
Interpreting alpha channels as straight or premultiplied.

See also: 

To import multiple items 

To import several items at once by dragging 

To import a folder by dragging 

Searching for footage when importing (Mac OS only) 

Importing an unrecognized file 



Importing files into a project 

To import multiple items:

1    Choose File > Import > Footage Files.

2    Select a file type, locate and select an item, and then click Open.

3    Repeat the previous step for each item, and then click Done. The imported footage appears in 
the Project window.

See also: 

To import footage into a Project window 

To import several items at once by dragging 

To import a folder by dragging 

Searching for footage when importing (Mac OS only) 

Importing an unrecognized file 



Importing files into a project 

To import several items at once by dragging:

1    In After Effects, open a project or choose File > New > New Project.

2    From the desktop or a folder, drag the files you want to import onto the After Effects application 
icon or into the Project window.

See also: 

To import footage into a Project window 

To import multiple items 

To import a folder by dragging 

Searching for footage when importing (Mac OS only) 

Importing an unrecognized file 



Importing files into a project 

To import a folder by dragging:

1    In After Effects, open a project or choose File > New > New Project.

2    Press Alt (Windows) or Option (Mac OS) as you drag the folder into the Project window.

Note: When you drag a folder to the Project window without pressing Alt or Option, After Effects imports the 
files in the folder as a sequence instead of as individual files.

See also: 

To import footage into a Project window 

To import multiple items 

To import several items at once by dragging 

Searching for footage when importing (Mac OS only) 

Importing an unrecognized file 
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Searching for footage when importing (Mac OS only)

When importing footage into After Effects, you can use the Find feature to locate a particular file or 
folder by specifying its name. After Effects searches the system’s local hard disks, but does not 
search any mounted volumes on a network.

To search for a file or folder:

1    Choose File > Import > Footage File.

2    Select a file type.

3    Click Find, type the name of a file or folder, and click OK. After Effects finds the first file or folder 
that matches the text. After Effects searches only for files of the specified file type. To continue the 
search, click the Find Again button.
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Importing an unrecognized file

If you want to import footage that After Effects supports, but the footage does not appear in its 
folder in the Import Footage dialog box, you can display all files in the folder and then specify the 
file format After Effects should use to read the file. This is useful when you want to open a 
compatible file that was transferred from another platform, such as a Silicon Graphics workstation.

To import a file by specifying its format manually:

1    Choose File > Import > Footage As.

2    Select a file type.

3    Locate and select the footage item you want to import.

4    Click Open. The imported footage appears in the Project window.
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Importing a sequence of still image files

After Effects can import a sequence of numbered still images with the same filename pattern, and 
automatically combine them into a single sequence file, where each numbered file represents one 
frame. After Effects changes all the images to the dimensions and bit depth of the first image in the 
sequence. It then imports, in numeric order, all still images in the folder that have the same filename
pattern and file type as the one you selected.

A sequence of still image files (left) becomes one image sequence when imported into After Effects (right).

When you import a sequence of still images, they assume the frame rate entered in the Import 
Preferences dialog box. The default rate is 30 frames per second (fps). You can change the default 
frame rate for the sequence before or after importing it.

See also: 

To import a sequence of still images 

To import a folder of still images as a sequence by dragging 

To change the default frame rate for a sequence before importing 

To assign a frame rate to a sequence of still images you’ve already imported 



Importing a sequence of still image files 

To import a sequence of still images:

1    Do one of the following:
•      In Windows, make sure that each filename has the correct file extension and that all filenames 
in the sequence contain an equal number of digits at the end of the filename, but before the 
extension. For example, File000.bmp, File001.bmp, File002.bmp, and so on.
•      In Mac OS, make sure all filenames in the sequence contain an equal number of digits at the 
end of the filename. For example, File000, File001, File002, and so on.

2    Move all the files in the sequence to the same folder.

3    In After Effects, choose File > Import > Footage File.

4    Locate and select the first file in the sequence.

5    Select <file format name> Sequence, and then click Open.

See also: 

To import a folder of still images as a sequence by dragging 

To change the default frame rate for a sequence before importing 

To assign a frame rate to a sequence of still images you’ve already imported 



Importing a sequence of still image files 

To import a folder of still images as a sequence by dragging:

1    In After Effects, open a project or choose File > New > New Project.

2    Drag the folder into the Project window. 

After Effects imports the first sequence that is listed in the folder, based on the filename.

See also: 

To import a sequence of still images 

To change the default frame rate for a sequence before importing 

To assign a frame rate to a sequence of still images you’ve already imported 



Importing a sequence of still image files 

To change the default frame rate for a sequence before importing:

1    Choose File > Preferences > Import.

2    In the Sequence Footage section, enter a default frame rate, and then click OK.

See also: 

To import a sequence of still images 

To import a folder of still images as a sequence by dragging 

To assign a frame rate to a sequence of still images you’ve already imported 



Importing a sequence of still image files 

To assign a frame rate to a sequence of still images you’ve already imported:

1    In the Project window, select the still image sequence.

2    Choose File > Interpret Footage > Main.

3    Select Assume This Frame Rate and enter the desired frame rate.

See also: 

To import a sequence of still images 

To import a folder of still images as a sequence by dragging 

To change the default frame rate for a sequence before importing 
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Importing footage containing an alpha channel

The color information in a typical footage item is contained in three channels: red, green, and blue. 
In addition, a footage item can include a fourth channel, called an alpha channel, that contains 
transparency information for the parts of the image that are partially or completely transparent. An 
alpha channel is often used as a matte for creating effects. When used in After Effects, a matte 
defines the transparent areas for its own or another layer. White areas define what is opaque, and 
black areas define what is transparent. See Using a footage item with an alpha channel.

A. Original footage file B. Footage file’s alpha channel C. Footage file in After Effects composition

Many file formats can include an alpha channel, including Adobe Photoshop, ElectricImage IMAGE,
TGA, TIFF, QuickTime (saved at a bit depth of Millions of Colors+), and Adobe Illustrator. For Adobe
Illustrator files, After Effects automatically converts empty areas to an alpha channel.

See also: 

Using straight or premultiplied alpha channels 

Interpreting alpha channels as straight or premultiplied 

Choosing an interpretation method 



Importing footage containing an alpha channel 

Using straight or premultiplied alpha channels

Footage files with alpha channels fall into two categories: straight or premultiplied. Although, the 
alpha channels are the same, the color channels differ.

With a straight alpha channel, a footage item keeps the transparency information in a separate 
channel (the alpha channel only), not in any of the visible color channels. This kind of alpha channel
is also known as unmatted alpha. With a straight alpha channel, the effects of transparency are not 
visible until the image is displayed in an application that supports straight alpha.

A. RGB image in original application B. Alpha channel in original application C. Image correctly displayed as 
straight alpha in After Effects 

With a premultiplied alpha channel, a footage item keeps the transparency information in the alpha 
channel, and also keeps the same information in the visible RGB channels, which are modified, or 
multiplied, with a background color. A premultiplied alpha channel is known as matted alpha with a 
background color. The colors of semitransparent areas, such as feathered edges, are shifted 
toward the background color in proportion to their degree of transparency.

Some software lets you specify the background color with which the alpha channel is premultiplied; 
otherwise, the background color is usually black or white.

A. RGB image as it appears in original application B. Alpha channel in original application C. Image correctly 
displayed as premultiplied with white in After Effects 

Straight alpha channels can produce better results when used in movies that require the highest 
level of color precision. Premultiplied alpha channels are compatible with a wider range of 
programs, such as Apple Movie Player. After Effects recognizes both types, so for most projects, 
either type will produce satisfactory results.
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Interpreting alpha channels as straight or premultiplied

When you import a footage file containing an alpha channel, After Effects determines if it is straight 
or premultiplied. If the alpha channel is unlabeled, After Effects displays the Interpret Footage dialog
box and prompts you to select Ignore, Straight, Premultiplied, or Guess. When you select Guess, 
After Effects determines the interpretation method. Use the Guess option if you are unsure. Choose
the Ignore option if you don’t want to use the alpha channel at all.

Correctly identifying the type of alpha channel when you import a file can prevent problems such as 
undesirable colors at the edge of an image or a loss of image quality at the edges of the alpha 
channel. If a color inaccuracy, such as a halo, appears along the edges of an alpha channel in a 
composition, try changing the interpretation method. 

Alpha channel premultiplied with black A. Original B. Correctly interpreted as premultiplied (matted with 
black) C. Interpreted as straight D. Interpreted as premultiplied (matted with white)

If a footage item doesn’t have an alpha channel or transparency information, you can create an 
alpha channel in After Effects using a layer mask. See Working with Masks and Transparency.



Importing footage containing an alpha channel 

Choosing an interpretation method

You can change the interpretation method for a file after you import the file. You can also change 
the default alpha channel interpretation in the Import Preferences dialog box. This is especially 
useful if you’re importing footage from an application that consistently uses one type of unlabeled 
alpha channel. 

See also: 

To import a footage file containing an alpha channel 

To set the alpha channel interpretation method for a file 

To set the default alpha channel interpretation 



Choosing an interpretation method 

To import a footage file containing an alpha channel:

1    Choose File > Import. Locate and select the file and click Open.

2    In the Interpret Footage dialog box, select the alpha channel type that matches your footage and
then click OK:

Guess Attempts to determine the type of alpha channel. If it fails, After Effects beeps.

Ignore Disregards the transparency data in the alpha channel.

Treat As Straight (Unmatted) Interprets the alpha channel as straight alpha. If the application you 
used to create the footage does not premultiply the alpha channel, select this option.

Treat As Premultiplied (Matted with color) Interprets the alpha channel as premultiplied alpha. 
This option is often used for images created in applications that specify white as transparent and 
black as opaque. Click the color swatch or the eyedropper tool to choose a color. 

See also: 

To set the alpha channel interpretation method for a file 

To set the default alpha channel interpretation 



Choosing an interpretation method 

To set the alpha channel interpretation method for a file:

1    In the Project window, select a footage item that includes an alpha channel.

2    Choose File > Interpret Footage > Main.

3    In the Alpha section, select an interpretation method.

4    Select Inverted to switch the opaque and transparent areas of the image. Then click OK.

See also: 

To import a footage file containing an alpha channel 

To set the default alpha channel interpretation 



Choosing an interpretation method 

To set the default alpha channel interpretation:

1    Choose File > Preferences > Import.

2    For Interpret Alpha As, select one of the following interpretation methods, and then click OK: 

Ask User Displays a dialog box containing interpretation options each time you import an unlabeled
alpha channel.

Guess Attempts to determine the type of alpha channel used in the image. If After Effects cannot 
guess confidently, it beeps.

Ignore Disregards all transparency data in the file.

Straight (Unmatted) Interprets the alpha channel as straight alpha. If the application you used to 
create the footage does not premultiply the alpha channel, select this option.

Premultiplied (Matted With Black) Interprets the alpha channel as premultiplied with black. 

Premultiplied (Matted With White) Interprets the alpha channel as premultiplied with white. 

See also: 

To import a footage file containing an alpha channel 

To set the alpha channel interpretation method for a file 
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Importing an Adobe Photoshop file

You can import an Adobe Photoshop file directly into an After Effects project with the option of 
preserving individual layers and layer masks from Adobe Photoshop. Importing layers makes it easy
to prepare still images for animation using the image-editing tools in Adobe Photoshop.

See also: 

Preparing layered Adobe Photoshop files 

Importing layered Photoshop files 

Using transparent areas and layer masks from Adobe Photoshop 

Using adjustment layers from Adobe Photoshop 

Using layer effects from Photoshop 5.0 



Importing an Adobe Photoshop file 

Preparing layered Adobe Photoshop files

Importing layers into After Effects makes it possible to prearrange a composition in Adobe 
Photoshop using layers, and preserve those layers in After Effects so they are ready for animation. 
Preserving layers is also useful if you want to use a single Adobe Photoshop file as a source for 
both print and dynamic media.

Before you import a layered Photoshop file, make sure you have prepared it thoroughly to reduce 
preview and rendering time. You can avoid problems importing and updating Adobe Photoshop 
layers by naming them properly. Before you import them into After Effects, do the following:
•      Organize and name layers. If you change a layer name or delete a layer in an Adobe Photoshop
file after you have imported it into After Effects, After Effects is unable to find the original layer 
name, and the Project window lists that layer as Missing.
•      Make sure each layer has a unique name, because After Effects manages layers by their 
names. Duplicate layer names can cause problems when you update footage.
•      If you want to import a composited version of a layered Photoshop 5.0 file along with a layered 
version, select the Include Composited Image With Layered Files option in Photoshop’s Saving 
Files Preferences dialog box.



Importing an Adobe Photoshop file 

Importing layered Photoshop files

After Effects imports attributes that were applied in Adobe Photoshop, including position, transfer 
modes, opacity, visibility, transparency (alpha channel), layer masks, adjustment layers, layer 
effects, and clipping groups. 

Adobe Photoshop 5.0 Layers palette displays layer names, stacking order, opacity, and transfer mode (left). 
After Effects Time Layout window displays layers from Photoshop file imported as a composition (right).

You can import a multilayered Adobe Photoshop file in the following ways:
•      As a new composition, with each layer in the Adobe Photoshop file becoming a separate layer in
the composition. 
•      As a single still footage item imported from any one layer in the Adobe Photoshop file.
•      As a single still footage item imported from all the Adobe Photoshop layers merged together. 

When you import a layered Adobe Photoshop file as a composition, all the layers contained in the 
composition retain their original positions as set in Adobe Photoshop. You can open the composition
in After Effects and animate the layers.

See also: 

To import a layered Adobe Photoshop file as a new composition 

To import an Adobe Photoshop file or one of its layers as a single footage item 



Importing layered Photoshop files 

To import a layered Adobe Photoshop file as a new composition:

1    Choose File > Import > Photoshop as Comp.

2    Locate and select an Adobe Photoshop file, and click Open. The Adobe Photoshop file appears 
in the Project window as a composition and as a folder containing all the layers as separate footage
items.

Note: If you click the Source Name heading in the Time Layout window, each layer displays the layer name 
followed by the Adobe Photoshop filename.

See also: 

To import an Adobe Photoshop file or one of its layers as a single footage item 



Importing layered Photoshop files 

To import an Adobe Photoshop file or one of its layers as a single footage 
item:

1    Choose File > Import > Footage File.

2    Locate and select an Adobe Photoshop file, and click Open.

3    In the Import Adobe Photoshop dialog box, select a layer to import from the file, or choose 
Merged Layers to import all layers in the file as a single layer in After Effects. Then click OK.

Note: When you import one Adobe Photoshop layer as a single footage item, its name in the Project window 
consists of the layer name followed by the Adobe Photoshop filename. When you import all layers as one file, 
its name in the Project window is “Merged” followed by the Adobe Photoshop filename.

See also: 

To import a layered Adobe Photoshop file as a new composition 



Importing an Adobe Photoshop file 

Using transparent areas and layer masks from Adobe Photoshop 

Adobe Photoshop supports a transparent area and one optional layer mask (alpha channel) for 
each layer in a file. Layer masks in Photoshop let you specify how different areas within a layer are 
hidden or revealed. When you import one layer of a layered Photoshop file, After Effects combines 
the layer mask (if present) with the transparent area for each layer and imports it as a straight alpha
channel.

If you import a layered Photoshop file as one single merged layer, After Effects merges the 
transparent areas and layer masks of all the layers into one alpha channel that is premultiplied with 
white. See Importing layered Photoshop files.

A. Layer palette in Adobe Photoshop B. Layer’s alpha channel and layer mask C. Merged alpha channel and 
layer mask in an After Effects Footage window

If a layered Adobe Photoshop file contains clipping groups, After Effects imports each clipping group
as a composition nested within the main composition for the Adobe Photoshop file. After Effects 
automatically applies its Preserve Underlying Transparency option to each layer in the clipping-
group composition so transparency settings are maintained. 

After Effects also supports any blending modes applied to the file. For more information on the 
Preserve Underlying Transparency option, see Preserving underlying transparency during 
compositing.
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Using adjustment layers from Adobe Photoshop 

Photoshop adjustment layers in Adobe Photoshop versions 4.0 and later change the color and tonal
qualities of an image without permanently modifying the original image. Photoshop adjustment 
layers affect the appearance of all layers below them. When you import an Adobe Photoshop file 
containing one or more adjustment layers, After Effects directly converts the Photoshop adjustment 
layers to After Effects adjustment layers, modifying all layers below them in the Time Layout 
window. You can turn off the Adjustment Layer switch in After Effects to remove the effect and 
display the layer as a white solid. To remove the effect and the white solid, you can either delete the
adjustment layer or turn off the Video switch for the layer. See Creating an adjustment layer and 
Using Feature switches in the Time Layout window.

An adjustment layer in Adobe Photoshop 5.0 (left) is imported as an After Effects adjustment layer (right).



Importing an Adobe Photoshop file 

Using layer effects from Photoshop 5.0

In Adobe Photoshop 5.0, you can use a layer effect to modify the layer to which it is applied. When 
you import an Adobe Photoshop file as a composition and one or more of the layers contain layer 
effects, After Effect includes the effect and the layer as two separate layers in the Time Layout 
window. 

A layer effect in Adobe Photoshop 5.0 (left) is imported into After Effects along with the layer and appears as 
an effect in the Time Layout window (right).

You can edit or remove a layer effect by opening the Effect property outline for the effect layer in the
Time Layout window or the Effect Controls window. You can even animate these Adobe Photoshop 
layer effects over time. For information on using the Effect Controls window, see Applying Effects.

To edit an Adobe Photoshop layer effect in After Effects:

1    Open the composition containing the layer effect.

2    In the Time Layout window, select the layer containing the effect and press E to display the 
effect properties.

3    Click the underlined value you want to change and enter a new value.
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Importing an Adobe Illustrator or EPS file

You can import Adobe Illustrator and EPS files directly into After Effects. When you import an Adobe
Illustrator file, After Effects converts all text information to paths, eliminating the need to create 
outlines in Adobe Illustrator before importing. If you import a file without creating outlines, make 
sure all fonts used in the file are available to After Effects when you import. 

When you import an Adobe Illustrator file, After Effects automatically makes all empty areas 
transparent by converting them into an alpha channel. Areas that are white are imported as objects.

For best results, always convert the elements in your Adobe Illustrator CMYK files to RGB before 
importing into After Effects. 

See also: 

About rasterizing 

Continuously rasterizing an Adobe Illustrator file 

Importing layers from Adobe Illustrator 7.0 and later 

Importing Adobe Illustrator paths as masks 



Importing an Adobe Illustrator or EPS file 

About rasterizing

When you import an Illustrator or EPS file, After Effects converts the path-based art into pixel-based
art using a process called rasterization. After Effects can rasterize the file two ways: it can rasterize 
the file once at the time you import it (the default method), and it can rasterize the file continuously 
as you change its geometric properties (for example, size).

When you rasterize the file only when importing, After Effects rasterizes it once at its actual size (as 
viewed in Adobe Illustrator). Then the file is treated like any other still image in a project. This is the 
faster method when you want to use the art at actual size or smaller.

When you rasterize the file continuously, After Effects recalculates the file’s resolution inside the 
project whenever you preview or render, so it displays at full resolution regardless of size.

Adobe Illustrator file imported and rasterized in After Effects A. Original B. Enlarged without Continuous 
Rasterization applied C. Enlarged with Continuous Rasterization applied

When a layer is scaled above 100%, continuously rasterizing generally produces higher quality 
results, but may slow down preview and render time. The difference in performance depends on the
complexity of the Adobe Illustrator file. When you use continuous rasterization, you can maximize 
editing performance by selecting continuous rasterization only when you need to fine-tune your 
edits or when you’re ready to render the composition. See Using Layer Switches.
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Continuously rasterizing an Adobe Illustrator file

You can continuously rasterize an Illustrator file at any time while designing your project. Whether 
you choose to continuously rasterize or not, if you view and render a composition using Best 
Quality, After Effects anti-aliases, or smoothes, the edges of the art. 

To continuously rasterize an Adobe Illustrator file:

1    Select the layer containing the Adobe Illustrator file in the Time Layout window.

2    Click the Continuously Rasterize column ( ) next to the layer name.
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Importing layers from Adobe Illustrator 7.0 and later

You can import layers from an Adobe Illustrator 7.0 or later file into After Effects.

The layer names, positions, and stacking order of an Adobe Illustrator file (left) are preserved in After Effects 
(right).

You can import a multilayered Adobe Illustrator file in the following ways:
•      As a new composition, with each layer in the Adobe Illustrator file becoming a separate layer in 
the composition.
•      As a single still image imported from any one layer in the Adobe Illustrator file.
•      As a single still image imported from all the Adobe Illustrator layers merged together. 

To import a layered Adobe Illustrator file as a layered composition:

1    Choose File > Import > Illustrator as Comp.

2    Locate and select an Adobe Illustrator file, and click Open. The Adobe Illustrator file appears in 
the Project window as a composition and as a folder containing all the layers as separate footage 
items.

To import an Adobe Illustrator file or one of its layers as a single footage item:

1    Choose File > Import > Footage File.

2    Locate and select an Adobe Illustrator file, and click Open.

3    In the Import Adobe Illustrator dialog box, select a layer to import from the file, or choose 
Merged Layers to import all layers in the file as a single layer in After Effects. Then click OK.
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Importing Adobe Illustrator paths as masks

You can use an Adobe Illustrator path as a mask in an After Effects layer composition by copying 
the path in Adobe Illustrator and pasting it directly into the Layer window in After Effects. After 
Effects will create a mask for each closed path copied from Illustrator. For more information on 
using masks, see Working with Masks and Transparency.

You can copy a shape drawn in Adobe Illustrator (left) and paste it as a mask in After Effects (right).

To import an Adobe Illustrator path as a mask:

1    In Adobe Illustrator, create your path, select all of the points along the path, and then choose 
Edit > Copy.

2    In After Effects, open the Layer window for the layer into which you want to import the path.

3    Choose Edit > Paste.
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Importing an After Effects project

You can import one After Effects project into another. Everything from the imported project, 
including footage files, compositions, and folders, appears inside a new folder in the current Project 
window. When you want to repeat a complicated mask, effect, or animation in a different project, 
you can import the project containing the effect and simply replace the source footage, keeping all 
the effect, composition, and layer settings intact.

To import an After Effects project:

1    Choose File > Import > Project.

2    Locate and select an After Effects project, and then click Open.
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Importing After Effects projects from different platforms

You can open and import an After Effects project from a different operating system as long as you 
maintain the filenames, folder names, and relative paths (folder locations) for all files in the project. 
To maintain relative paths, the network volumes for Windows and Mac OS must use the same 
names.

If a file format is not supported on the operating system you are using, if the file is missing, or if the 
reference link is broken, After Effects substitutes a placeholder file containing color bars. You can 
double-click the placeholder to relink the file, or select the file in the Project window and choose File
> Replace Footage > File As to select a file format that is supported. For more information on 
substituting footage, see Replacing and substituting footage.

To create projects for both Windows and Mac OS, see Considerations for cross-platform projects.
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Importing Adobe Premiere projects

The ability to import Premiere projects eliminates the need to render the project before applying 
visual effects and animations in After Effects. When you import an Adobe Premiere 5.0 project, After
Effects imports the project into the Project window as both a new composition containing each 
Adobe Premiere clip as a layer, and as a folder containing each clip as an individual footage item. If 
your Premiere project contains bins, After Effects converts them to folders within the Premiere 
project folder. 

After Effects preserves the order of clips in the Timeline, the footage duration (including all trimmed 
In and Out points), and the marker and transition locations. The arrangement of layers in the Time 
Layout window is based on the arrangement of clips in the Premiere Timeline. After Effects adds 
Premiere clips to the Time Layout window as layers in the order they appeared—from the bottom up
and from left to right—in Premiere Timeline. 

Clips from an Adobe Premiere Timeline (top), are converted to layers in an After Effects composition (bottom) 
and position, stacking order, and duration are retained.

Transitions and titles included in your Premiere project appear in the After Effects composition as 
solid layers, maintaining their original location and duration. After Effects discards all transparency, 
motion, and filter settings. 

To import an Adobe Premiere project:

1    Choose File > Import > Premiere as Comp.

2    Locate and select an Adobe Premiere Project file, and click Open.
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Importing an audio file

You can import a variety of audio file formats directly into After Effects. When you add audio-only 
files to a composition, they appear as layers in the Time Layout window. You can adjust the audio 
preview settings, such as sample rate, in the General Preferences dialog box. These settings 
change the quality of audio playback when you preview the composition, not when you render it. 
For more information, see Using audio layers.



Preparing and Importing Footage 

Importing Cineon files

You can import Cineon 4.5 or Digital Picture Exchange (DPX) files directly into an After Effects 
project as individual frames or as a sequence of numbered stills. Once you have imported a Cineon
file, you can use it in a composition and then render the composition as a Cineon sequence. See 
Importing a sequence of still image files.

Cineon files are commonly used to transfer motion-picture film to a digital format. To preserve the 
full dynamic range of motion-picture film, Cineon files are stored using 10 bits per channel. 
However, After Effects and QuickTime recognize only 8 bits per channel. After you import a 10-bit 
Cineon file, you apply the Cineon Converter effect to specify precisely the most important eight bits 
to use in After Effects. You can adjust the 10-bit to 8-bit conversion at any time; the results appear 
immediately. If you are working with a film sequence where exposure conditions vary over time, you
can vary the conversion over time by setting keyframes. For information on using the Cineon 
converter, see Cineon tools.

To import a Cineon sequence:

1    Choose File > Import > Footage File.

2    For the file type, select Cineon AE Format and then select Cineon AE Format Sequence.

3    Locate and select the first numbered Cineon sequence file and click Open.

4    When the Interpret Footage dialog box appears, select Treat as Straight (Unmatted), and click 
OK.

The Cineon file or sequence appears in the Project window. When you select it, the thumbnail 
preview appears garbled. This is normal because the Cineon file is still a 10-bit per channel image, 
which After Effects cannot display.
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Preparing motion footage for importing to After Effects

After Effects performs all its compositing and motion-graphics operations digitally. Some of the 
source footage you use may also have been created digitally (for example, in Adobe Photoshop or 
Adobe Premiere), but other footage may need to be transferred to the computer from analog 
sources such as film and videotape. When working with After Effects, understanding some of the 
differences among media can help you decide how to handle footage as you transfer it between 
digital and analog devices.

See also: 

Analog video 

Analog film 

Digital video 

Interlaced and non-interlaced footage 

Preparing a movie for import when final output is NTSC interlaced video 

Preparing motion footage frame rate for final output 
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Analog video

Analog video carries picture and sound information by creating variations in an electromagnetic 
signal. Before you can import analog video into After Effects, you need to digitize it. Digitizing 
converts the electromagnetic signal to a binary signal, which can be read by a computer. 
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Analog film

Analog film, such as a still transparency or common motion-picture film, carries picture information 
by creating variations in colored dyes on a strip of acetate. 

To apply digital effects to motion-picture film using After Effects, you must first transfer the film to a 
digital format. You can transfer film in two ways: 
•      Use a film scanner to transfer each analog film frame directly to a digital movie frame. This 
method best preserves the image quality. Using a film scanner is preferable, because you scan the 
footage directly to the computer as non-interlaced, full-resolution, 24-fps footage; in other words, it 
is ready to use in After Effects. See Importing Cineon files.
•      Transfer the analog film to analog videotape, and then digitize the videotape. This process is 
called telecine transfer. It converts 24-fps film footage to 30-fps videotape using 3:2 pulldown. 
Transferring using the 3:2 pulldown method introduces two issues: you must resolve the different 
frame rates of videotape and motion-picture film, and you must separate the fields of the interlaced 
video. After Effects can automatically resolve both of these issues while preserving image quality. 
See About 3:2 pulldown.

Note: To use an After Effects movie in an analog motion-picture film, you must transfer the movie back to the 
analog film medium. This transfer process is generally done at a post-production facility.
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Digital video

Digital video carries picture information by representing each pixel of a video frame as a discrete 
color value, and transmitting and storing the pixel values in the binary data format used by 
computers. Sound is also carried as binary data.

Digital video is not one format, but a medium within which many file formats exist. Even if your 
source footage was created digitally, you still have to make sure it is stored in a file format After 
Effects can import.

If you plan to distribute the movie digitally, for example on CD-ROM, you must render it in a file 
format appropriate for your distribution method. For more information, see Rendering a Movie.

Note: DV video format is a form of digital video that can be downloaded directly to your hard disk for editing in 
applications such as Adobe After Effects and Adobe Premiere. Many DV decks can connect directly to a 
computer using an IEEE-1394 (Firewire) interface. See About D1, DV, and various pixel aspect ratio footage.
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Interlaced and non-interlaced footage

Another way to classify analog or digital footage is as interlaced or non-interlaced. Currently, most 
broadcast video is interlaced, where each frame consists of two fields displayed in turn. The 
computer operating system and After Effects display non-interlaced video, also known as 
progressive scan, where each frame is displayed completely from top to bottom. When you finish 
creating a movie for display on a television, After Effects can render it back to fields, maintaining 
high quality for broadcast display.

Interlaced video consists of two fields, known either as Field 1 and Field 2, even and odd, or as 
After Effects refers to them, upper and lower. When these fields are presented sequentially on an 
NTSC or PAL video monitor they create a smooth, unified picture. See Frames and fields.

In interlaced video, a frame is divided into two fields. Each field contains every other horizontal line 
in the frame. A TV displays the first field of alternating lines over the entire screen, and then 
displays the second field to fill in the alternating gaps left by the first field. One NTSC video frame, 
displayed for approximately 1/30 of a second, contains two interlaced fields, displayed for 
approximately 1/60 of a second each.

Interlaced video describes a frame with two passes of alternating scan lines.

In non-interlaced video, scan lines are drawn in order from top to bottom, in one pass. Computer 
video and computer movie formats are generally non-interlaced. Motion-picture film is similar to 
non-interlaced video because it also displays an entire frame in one pass.

Interlacing is a factor in image quality only for certain effects, such as rotating a frame or 
compositing video with digital effects. It is a characteristic of footage capture and display, not a 
structural component of file formats or media. You can easily play back a digitized NTSC or PAL 
movie (interlaced) on a computer display (non-interlaced), or display a 35mm photograph (non-
interlaced) on an NTSC or PAL video monitor (interlaced). 

If you use interlaced video in a composition or want to use an After Effects movie in an interlaced-



video medium such as NTSC, you will have to separate fields as you import and field-render the 
composition to a finished movie file. For more information, see Using interlaced video in After 
Effects and Testing the field rendering order.
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Preparing a movie for import when final output is NTSC interlaced video

You can edit and prepare video footage in other applications, such as Adobe Premiere, before 
importing it into After Effects. If you want to render the footage from After Effects as NTSC 
interlaced video, do not field-render or create interlaced frames when you render the movie from the
other application. Make sure you keep track of the original field order so you can render it in After 
Effects correctly. See Field rendering.

As long as the footage is on a computer, it should remain non-interlaced. Keeping the footage in 
non-interlaced format preserves more image quality and saves you the extra step of separating 
fields in After Effects.

When you render the movie from the other application, render it at 60 fps of frame-rendered (non-
interlaced) video. After you integrate it into a composition, After Effects can render it to high-quality 
field-rendered (interlaced) frames at 30 fps for videotape.
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Preparing motion footage frame rate for final output

When you import motion footage into After Effects, the file’s frame rate does not change. If you plan 
to output your footage to a different frame rate, you can conform it to the new frame rate in After 
Effects. Conforming ensures that frames disperse evenly over the new output frame rate. 

Conforming footage does not alter the original footage, only the reference that is used by After 
Effects. When you conform, After Effects changes the internal duration of frames, and does not 
change the frame content. If you conform by a large amount the footage will play back at a different 
speed. For example, if you change the frame rate from 15 fps to 30 fps, the footage will play back 
faster. 

It’s best to make the frame rate the same as the final output frame rate for your project. This way, 
After Effects renders each frame, and the final output does not omit or duplicate frames. However, 
in order to not drastically change the speed of your motion footage, it may be beneficial to conform 
only by a small amount, making the new frame rate divisible by the output rate. For example, if your
original footage has a frame rate of 29.97 fps and you want to output it for playback on CD-ROM at 
10 fps, you can conform to 30 fps. At 30 fps, the frames are divisible by 10, so After Effects can 
evenly render every third frame.

Note: If you want to output original NTSC footage as PAL or vice versa, contact a post production facility that 
specializes in video transfer or duplication. Converting between the different frequencies used by these two 
formats requires specialized equipment. 

To change the frame rate of a motion footage file:

1    Select the footage file in the Project window.

2    Choose File > Interpret Footage > Main.

3    Select Conform to Frame Rate, and enter a new frame rate in the Frames Per Second text box. 
Then click OK.
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Using interlaced video in After Effects

If you want to use interlaced or field-rendered footage (such as from NTSC video) in an After Effects
project, you will get the best results if you separate the video fields when you import the footage. 
After Effects separates video fields by creating a full frame from each field, preserving all of the 
image data from the original footage. 

When importing interlaced video that was originally transferred from film, you may want to remove 
the 3:2 pulldown that was applied during the transfer from film to video as you separate fields so 
effects you apply in After Effects don’t appear distorted. See Removing 3:2 pulldown from video 
transferred from film.

See also: 

Separating fields 
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Separating fields

Separating fields is critical if you plan to make significant changes to the footage. When you scale, 
rotate, or apply effects to interlaced video, unwanted artifacts, such as crossed fields, are often 
introduced. By separating fields, After Effects accurately converts the two interlaced frames in the 
video to non-interlaced frames, while preserving the maximum amount of image quality. Using non-
interlaced frames allows After Effects to apply edits and effects consistently and at the highest 
quality. 

After Effects creates field-separated footage from a single formerly interlaced field by splitting fields 
into two independent frames. Each new frame has only half the information of the original frame, so 
some frames may appear to have a lower resolution than others when viewed at Draft quality. 
When you render the final composition, After Effects reproduces high-quality interlaced frames for 
videotape. When you render a movie using the Best Quality setting, After Effects interpolates 
between the scan lines of a field to produce maximum image quality.

Note: After Effects automatically separates fields for D1 and DV video footage files. You can manually 
separate fields for all other types of video footage in the Interpret Footage dialog box.

To separate video fields in imported footage:

1    Select the footage item in the Project window.

2    Choose File > Interpret Footage > Main.

3    Select an option from the Separate Fields pop-up menu.

4    Click Motion Detect to increase image quality in non-moving areas when the image is rendered 
at Best Quality. Then click OK.
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Interpreting field order

Interlaced video has a field order defining the order in which the two video fields (upper and lower) 
are displayed. A system that draws the upper lines before the lower lines is called upper field 
ordered; one that draws the lower lines before the upper lines is called lower field ordered. The 
order in which the fields are displayed is important, especially when the fields contain motion. 
Unfortunately, the field order varies among broadcast and video-editing systems; some video 
systems are upper field ordered, and others are lower field ordered. If you separate video fields 
using the wrong field order, motion will not appear smooth.

In After Effects, you can match the original field order of your footage. If you are not sure which field
order was used to interlace a footage item, use the procedure below to find out. 

To determine the original field order:

1    Select the item in the Project window.

2    Choose File > Interpret Footage > Main.

3    In the Interpret Footage dialog box, select Upper Field First from the Separate Fields pop-up 
menu, and then click OK.

4    In the Project window, press Alt (Windows) or Option (Mac OS) as you double-click the footage 
to open it in a Footage window.

5    If the Time Controls palette is not visible, choose Window > Show Time Controls.

6    In the Footage window, find a segment that contains one or more moving areas.

7    Using the Frame Advance button ( ) on the Time Controls palette, step forward at least five 
frames in the Footage window. Moving areas should move consistently in one direction. If the 
moving areas move backward every other frame, the wrong field-separation option has been 
applied to the footage.

See also: 

Field rendering 
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Field rendering

When you render a composition containing separated footage, you’ll need to set the Field 
Rendering option to the same field order of your video equipment. If you don’t field-render the 
composition or if you field-render with the incorrect settings, the final movie may appear too soft, 
jerky, or distorted. See Testing the field rendering order.
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About 3:2 pulldown

When you transfer 24-fps film to 29.97-fps (NTSC) video, you use a process called 3:2 pulldown, in 
which the film frames are distributed across video fields in a repeating 3:2 pattern. The first frame of
film is copied to fields 1 and 2 of the first frame of video, and also to field 1 of second video frame. 
The second frame of film is then spread across the next two fields of video—field 2 of the second 
video frame and field 1 of the third frame of video. This 3:2 pattern is repeated until four frames of 
film are spread over five frames of video, and is then repeated. 

When you apply 3:2 pulldown to footage, one frame of film (A) is separated into two or three interlaced 
video fields (B), which are grouped into video frames containing two fields each.

The 3:2 pulldown process results in whole frames (represented by a W) and split-field frames 
(represented by an S). The three whole video frames contain two fields from the same film frame. 
The remaining two split-field frames contain a video frame from two different film frames. The two 
split-field frames are always adjacent to each other. The phase of 3:2 pulldown refers to the point at
which the two split-field frames fall within the first five frames of the footage.

Phase occurs as a result of two conversions that happen during 3:2 pulldown: 24-fps film is 
redistributed through 30-fps video, so each of four frames of 24-fps film is spread out over five 
frames of 30(29.97)-fps video. First the film is slowed down 0.1% to match the speed difference 
between 29.97 fps and 30 fps. Next, each film frame is repeated in a special pattern and mated to 
fields of video. 

It’s important to remove 3:2 pulldown from video footage that was originally film, so that effects you 
add in After Effects synchronize perfectly with the original frame rate of film. Removing 3:2 pulldown
reduces the frame rate from 30-fps to 24-fps, which also reduces the number of frames you have to 
change. To remove 3:2 pulldown, you must also indicate the phase of the 3:2 pulldown. 
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Removing 3:2 pulldown from video transferred from film

Before you remove 3:2 pulldown, you need to separate the fields as either upper field first or lower 
field first. Once the fields are separated, After Effects can analyze the footage and determine the 
correct 3:2 pulldown phase and field order. If you already know the phase and field order, you can 
choose them. 

Note: If your footage file contains frames from different sources, the phase may not be consistent. If this is the 
case, import the footage once for each phase. Then, add the footage to your composition as many times as 
there are phases and trim each layer to use only the appropriate frames for each phase. 

To remove 3:2 pulldown from video transferred from film:

1    In the Project window, select the footage from which you want to remove 3:2 pulldown.

2    Choose File > Interpret Footage > Main.

3    In the Fields and Pulldown section, select Upper Field First or Lower Field First from the 
Separate Fields pop-up menu.

4    Do one of the following and click OK:
•      To have After Effects determine the correct settings, click Guess 3:2 Pulldown.

•      If you know the phase of the 3:2 pulldown, choose it from the Remove Pulldown pop-up menu.
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About D1, DV, and various pixel aspect ratio footage

Pixel aspect ratio specifies the ratio of width to height of one pixel in an image. Frame aspect ratio 
describes the ratio of width to height in the frame dimensions of an image. For example, D1 NTSC 
has a pixel aspect ratio of 0.9 (or 0.9 width by 1.0 height). It also has a frame aspect ratio of 4:3 (or 
4.0 width by 3.0 height). 

A 4:3 frame aspect ratio (left), and a wider 16:9 frame aspect ratio (right)

Some video formats output the same frame aspect ratio, but use a different pixel aspect ratio. For 
example, some NTSC digitizers produce a 4:3 frame aspect ratio, with square pixels (1.0 pixel 
aspect ratio), and a resolution of 640-by-480. D1 NTSC produces the same 4:3 frame aspect ratio, 
but uses rectangular pixels (0.9 pixel aspect ratio), and a resolution of 720-by-486. D1 pixels, which
are always rectangular, are vertically oriented in systems producing NTSC video and horizontally 
oriented in systems producing PAL video.

If you display rectangular pixels on a square-pixel monitor without alteration, images and motion 
appear distorted; for example, circles distort into ovals. However, when displayed on a broadcast 
monitor, the images will be correct. 

A. Square pixels and 4:3 frame aspect ratio B. Non-square pixels and 4:3 frame aspect ratio C. Non-square 
pixels displayed on a square-pixel monitor

When you import D1 NTSC or DV source footage into After Effects, the image looks slightly wider 
than it does on a D1 or DV system. (D1 PAL footage looks slightly narrower.) The opposite effect 
occurs when you import anamorphic footage using D1/DV NTSC Widescreen or D1/DV PAL 
Widescreen. Widescreen video formats have a frame aspect ratio of 16:9.

If a file uses rectangular pixels, After Effects displays the pixel aspect ratio next to the file’s image 
thumbnail in the Project window. You can change the pixel aspect ratio interpretation for individual 
files in the Interpret Footage dialog box. By ensuring that all footage files are interpreted correctly, 
you can combine footage with different ratios in the same project or composition and generate 
output that plays correctly. 

When you import footage with either the D1 resolution of 720-by-486, or the DV resolution of 720-
by-480, After Effects automatically sets the pixel aspect ratio for that file to D1/DV NTSC. When you
import footage with the D1 or DV resolution of 720-by-576, After Effects automatically sets the pixel 
aspect ratio for that file to D1/DV PAL. However, it is always a good idea to make sure all files are 



interpreted correctly by looking in the Project window or the Interpret Footage dialog box. 

Note: Make sure to reset the pixel aspect ratio to Square Pixels when you import a square-pixel file that 
happens to have a D1 or DV resolution, for example, an Adobe Photoshop image with a resolution of 720-by-
480.
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Setting pixel aspect ratio

It is important to set the pixel aspect ratio for a footage file at its original ratio, not the ratio of the 
final output. You can set pixel aspect ratios for footage and compositions with these approximate 
values: 

Square Pixels Uses a 1.0 pixel aspect ratio. Use this setting if your footage has a 640-by-480 or 
648-by-486 frame size.

D1/DV NTSC Uses a 0.9 pixel aspect ratio. Use this setting if your footage has a 720-by-480 or 
720-by-486 frame size, and your desired result is a 4:3 frame aspect ratio.

D1/DV NTSC Widescreen Uses a 1.2 pixel aspect ratio. Use this setting if your footage has a 720-
by-480 or 720-by-486 frame size, and your desired result is a 16:9 frame aspect ratio.

D1/DV PAL Uses a 1.0666 pixel aspect ratio. Use this setting if your footage has a 720-by-576 
frame size, and your desired result is a 4:3 frame aspect ratio.

D1/DV PAL Widescreen Uses a 1.4222 pixel aspect ratio. Use this setting if your footage has a 
720-by-576 frame size, and your desired result is a 16:9 frame aspect ratio.

Anamorphic 2:1    Uses a 2.0 pixel aspect ratio. Use this setting if your footage was shot using an 
anamorphic film lens.

D4/D16 Standard    Uses a 0.9481481 pixel aspect ratio. Use this setting if your footage has a 
1440-by-1024 or 2880-by-2048 frame size, and your desired result is a 4:3 frame aspect ratio.

D4/D16 Anamorphic    Uses a 1.8962962 pixel aspect ratio. Use this setting if your footage has a 
1440-by-1024 or 2880-by-2048 frame size, and your desired result is an 8:3 frame aspect ratio.

See also: 

To set the pixel aspect ratio for imported footage 

To set the pixel aspect ratio for a composition 

Using square-pixel footage for output to D1 or DV NTSC 



Setting pixel aspect ratio 

To set the pixel aspect ratio for imported footage:

1    Select the footage in the Project window.

2    Choose File > Interpret Footage > Main.

3    Select a ratio from the Pixel Aspect Ratio pop-up menu and click OK.

If you are planning to render to the same pixel aspect ratio as your footage, you also need to set the
pixel aspect ratio for the composition.

See also: 

To set the pixel aspect ratio for a composition 

Using square-pixel footage for output to D1 or DV NTSC 
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To set the pixel aspect ratio for a composition:

1    Open the composition.

2    Choose Composition > Composition Settings.

3    Select a ratio from the Pixel Aspect Ratio pop-up menu and click OK.

See also: 

To set the pixel aspect ratio for imported footage 

Using square-pixel footage for output to D1 or DV NTSC 
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Using square-pixel footage for output to D1 or DV NTSC

You can use square-pixel footage in a D1/DV NTSC composition and generate output that does not 
appear distorted. Note that the pixel aspect ratio is identical between D1 and DV, but there is a 
slight difference in composition frame size. The steps that follow contain information about issues 
discussed in detail later in this user guide. For more information on any of the topics mentioned, see
the index.

To use square-pixel footage when outputting to D1 or DV NTSC:

1    Prepare square-pixel footage that fills the entire frame using one of the following methods:
•      If your final output is DV, create and save it at a 720-by-534 frame size. 
•      If your final output is D1, create and save it at a 720-by-540 frame size.

2    Import the file into After Effects. 

Note: If your square-pixel footage was created and saved at 720-by-486 or 720-by-480, select it and choose 
File > Interpret Footage > Main. Then choose Square Pixels from the Pixel Aspect Ratio pop-up menu and 
click OK.

3    Choose Composition > New Composition, and then select one of the following:
•      If your final output is DV, choose NTSC DV, 720 x 480 for Frame Size, and D1/DV NTSC for 
Pixel Aspect Ratio. 
•      If your final output is D1, choose NTSC D1, 720 x 486 for Frame Size, and D1/DV NTSC for 
Pixel Aspect Ratio.

4    Select your other Composition settings as desired, and then click OK. 

5    Add your footage to the new composition.

Note: If your footage was created and saved at a frame size other than those noted in step 1, skip step 6.

6    Select the layer containing the square-pixel footage and apply the Shrink to Fit command: press 
Control + Alt + F (Windows) or Command + Option + F (Mac OS). 
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Importing DDR-based footage

You can easily integrate your digital disk recorder (DDR) with After Effects using DDR supplied 
plug-ins. After Effects includes plug-ins for the Accom WSD/XL and WSD/Xtreme DDRs. To find out 
if After Effects plug-ins are available for your DDR, contact your DDR manufacturer. 

You can bring DDR-based footage into an After Effects project in two ways. First, you can work with 
the footage while it remains on the DDR, essentially treating the DDR as a remote hard disk. Or, 
you can transfer the footage to your hard disk and import it into an After Effects project as you 
would any other file.

For information on using your DDR with After Effects, refer to your DDR plug-in documentation. You
can find documentation for the Accom DDR on the After Effects 4.0 CD-ROM.
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Setting up frames and fields for DDR-based footage

When working with DDR-based footage in After Effects, make sure your Composition Settings, 
Render Settings, and the Interpret Footage dialog boxes for the footage files are all set to the fps 
used by your DDR. If the frame rate in the Interpret Footage dialog box is 29.97 and the 
Composition Settings frame rate is 30 fps, the footage will appear with duplicate frames. 

It is also important to separate fields when importing DDR-based footage. Make sure the field 
settings in the Interpret Footage and Render Settings dialog boxes are the same; otherwise, the 
footage will preview and render with the wrong field order, causing the footage to play back with a 
jerky appearance. See Using interlaced video in After Effects.



Building a Composition

To create a movie with the footage items in your project, you must set up a composition. A 
composition includes one or more footage items—video, audio, both video and audio, or a still 
image—arranged in a Composition window and in the Time Layout window. Simple projects may 
include only one composition, while elaborate projects may include several compositions to 
organize large amounts of footage or intricate effects sequences. For more information on working 
with multiple compositions, see Managing Projects Effectively.

A composition includes at least one layer, which is the building block of a composition. When you 
add a footage item to a composition, the footage becomes the source for a new layer. A 
composition can have any number of layers, and you can also include a composition as a layer in 
another composition, which is called nesting.

A composition is the work space in which you create all animation, layering, and effects. Like other 
graphic program work spaces, a composition has specific spatial dimensions. 

In addition to these spatial dimensions, compositions also have a temporal dimension called 
duration. Each composition has an overall duration, or length in time. The duration of a composition 
limits the length of the layers in the composition. For example, if a layer’s duration is 45 seconds, 
and it is placed in a composition with a duration of 30 seconds, only 30 seconds of the layer’s 45-
second duration are used. You can change a layer’s duration or the portion of the layer that is used.

Before creating a composition, you may want to work with the footage items you have imported. 

See also: 

Working with imported footage 

Creating a composition 

Understanding composition settings 

Comparing composition settings and Interpret Footage settings 

About adding footage items to a composition 

Adding footage items to a composition 

Nesting a composition 

Working in the Composition and Time Layout windows 

Understanding the Composition window 

Using the Composition window 

Understanding the Time Layout window 

Replacing and substituting footage 
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Working with imported footage

After you have imported footage (see Preparing and Importing Footage), you are ready to begin 
working with the footage. You can view, edit, and change settings for your imported footage without 
using a Composition window.

See also: 

Viewing imported footage 

Opening footage in its original application 

Setting the frame rate for footage 

Looping footage 

Copying Interpret Footage settings 
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Viewing imported footage

You can view any movie or graphic item listed in a Project window at full size by opening it in a 
Footage window. You can also view the footage at different magnifications and examine individual 
frames. The Footage window is used only for viewing—you cannot work on an item in this window. 

When you double-click a movie in the Project window, it opens by default in the appropriate 
Footage window: QuickTime (.mov) files open in the QuickTime Footage window; Video for 
Windows (.avi) files open in the Video for Windows Footage window. Still images always appear in 
an After Effects Footage window. 

The QuickTime and Video for Windows Footage windows do not display the effect of settings made 
in the Interpret Footage dialog box, such as the alpha channel interpretation. However, for any 
footage item that includes audio, the QuickTime and Video for Windows Footage windows play the 
audio, while the After Effects Footage window does not. If you want to view the footage with more 
controls and information but without audio, view it in an After Effects Footage window. For more 
information about playing back, magnifying or reducing, or viewing the alpha channel of a footage 
item, see Composition, Layer, and Footage window controls. 

To open a movie in the default Footage window:

Double-click a movie in the Project window.

To open a movie in an After Effects Footage window:

Press Alt (Windows) or Option (Mac OS) as you double-click a movie in the Project window.

A. Current-time marker B. Magnification pop-up menu C. Safe zone icon D. View alpha channel icon
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Opening footage in its original application

You can open and edit a footage item in the application in which it was created, directly from an 
After Effects project. The original application must be installed on the computer you are using, and 
there must be enough unused RAM for it to run. When you edit and save changes to the footage in 
the original application, the changes are applied to all instances of the footage in the After Effects 
project the next time you open the project. 

When you edit a still-image sequence selected in the Time Layout or Composition windows, After 
Effects opens the individual image that is currently displayed. When you edit a still-image sequence
selected in the Project window, the first image in the sequence opens.

To open a footage item in the original application:

1    In the Project window, Composition window, or Time Layout window, select the footage or a 
layer containing the footage. If you selected a still-image sequence from the Composition or Time 
Layout window, move the current-time marker to the frame displaying the still image you want to 
edit.

2    Choose Edit > Edit Original or press Control+E (Windows) or Command+E (Mac OS).

3    Edit the footage in its original application, and save the changes.

Note: If you’re editing footage that has an alpha channel, make sure you’re viewing and editing all the 
channels, including the alpha channel, in the other application. Otherwise, changes you make might not be 
applied to the alpha channel, and it may become misaligned with the color channels.

If your project is open when you make a change to a footage file, After Effects can reload the new 
version of the file while the project is open.

To reload an edited file:

1    In After Effects, click the Project window title bar to make it active. 

2    Press Control + Alt + L (Windows) or Command + Option + L (Mac OS).



Working with imported footage 

Setting the frame rate for footage

You can change the frame rate for any movie or sequence of still images. For example, you can 
import a sequence of ten still images and specify a frame rate of five frames per second. 

To set the frame rate for footage:

1    Select an item in the Project window.

2    Choose File > Interpret Footage > Main.

3    In the Frame Rate section of the Interpret Footage dialog box, specify a frame rate for Conform 
to Frame Rate.

Note: If you remove 3:2 pulldown from interlaced video footage, After Effects automatically sets the frame rate 
of the resulting footage to four-fifths of the original frame rate. When removing 3:2 pulldown from NTSC video, 
the resulting frame rate is 24 fps. See About 3:2 pulldown. 



Working with imported footage 

Looping footage

If you intend to loop visual footage continuously in your project, you need to create only one cycle of
the footage in After Effects.

To loop footage:

1    In the Project window, select the footage you want to loop.

2    Choose File > Interpret Footage > Main.

3    Enter an integer value for Looping and click OK.



Working with imported footage 

Copying Interpret Footage settings

If you want to ensure that different footage items use the same Interpret Footage settings, you can 
copy settings from one item and apply them to others. 

To apply Interpret Footage settings to several footage items:

1    In the Project window, select the item whose footage interpretations you want to apply.

2    Choose File > Interpret Footage > Remember Interpretation.

3    Select one or more footage items.

4    Choose File > Interpret Footage > Apply Interpretation. After Effects applies the footage 
interpretation options to the selected items.
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Creating a composition

When you first create a new project, you will need to create a composition before you can start 
working with your footage items. When you create a composition without changing settings in the 
Composition Settings dialog box, the new composition uses the same settings as the previous 
composition. For information on changing composition settings, see Understanding composition 
settings. 

Once you have created a composition, you can change its settings at any time. Remember, 
however, that changing frame size or pixel aspect ratio can affect your final movie, so set these as 
early in the project as possible. 

Note: When you set up a new composition, the settings you use become the default settings that will appear 
the next time you create a composition.

See also: 

To create a composition with the last-used settings 

To create a composition with new settings 

To change a composition’s settings 



Creating a composition 

To create a composition with the last-used settings:

Do one of the following:
•      Choose Composition > New Composition and click OK.
•      Click the New Composition button ( ) at the bottom of the Project window.

•      Press Control + N (Windows) or Command + N (Mac OS). 

See also: 

To create a composition with new settings 

To change a composition’s settings 



Creating a composition 

To create a composition with new settings:

1    Choose Composition > New Composition or click the New Composition button ( ) at the bottom
of the Project window.

2    Specify settings as follows and click OK. For detailed descriptions of settings, see Understanding 
composition settings. 

•      Type a Composition Name.
•      Choose a Frame Size from the menu, or enter one. As a general rule, frame size and aspect 
ratio should match your source footage and intended output media. See Comparing composition 
settings and Interpret Footage settings. 
•      Select Lock Aspect Ratio if you want to enter a width or height not included in the menu and you
want After Effects to ensure that the composition dimensions conform to the aspect ratio for the 
current values.
•      Choose a Pixel Aspect Ratio from the pop-up menu. This is set automatically if you choose a 
digital format (D1, D4, D16, or DV) for Frame Size. See Setting pixel aspect ratio. 
•      Choose a Resolution from the pop-up menu.
•      Enter a Frame Rate in frames per second.
•      Enter a Duration for your composition.

See also: 

To create a composition with the last-used settings 

To change a composition’s settings 



Creating a composition 

To change a composition’s settings:

1    Choose Composition > Composition Settings, or choose Composition Settings from the window 
menu.

2    Adjust settings as explained in the next section and click OK.

Note: You cannot undo changes that were made prior to changing the composition settings.

See also: 

To create a composition with the last-used settings 

To create a composition with new settings 
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Understanding composition settings

When you create a new composition, it appears as a new item in the Project window. Before you 
set up a new composition, determine the specifications of the final output. These specifications 
influence the composition settings you choose for frame size, duration, frame rate, and pixel aspect 
ratio. Three factors determine composition settings:
•      The type of movie you are producing.
•      The requirements of any systems that will process the movie that After Effects renders.
•      The final delivery medium of the movie.

For best results, specify the composition settings at the beginning of your design process. After 
Effects bases certain calculations on the composition settings, so changing settings such as frame 
size and pixel aspect ratio late in the project can affect your final movie. (However, you can override
some composition settings when creating a movie. For example, you might change the 
composition-frame size to a smaller image size when rendering.

See also: 

Naming your composition 

Setting frame size 

Setting pixel aspect ratio 

Setting resolution 

Adjusting the appearance of low-resolution compositions 

Setting frame rate 

Setting duration 



Understanding composition settings 

Naming your composition

Give each composition a descriptive name so you will know what the composition contains just by 
looking at its tab. If your project will run on Windows and Mac OS systems, make composition 
names compatible with both platforms. 
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Setting frame size

The Composition window in After Effects contains the viewing frame and includes an area outside 
the frame you can use to move layers into and out of the frame. The frame size you specify can be 
up to 4000-by-4000 pixels. The viewing frame occupies the center of this 4000-by-4000-pixel area, 
which is centered in a larger work area. You can position items outside the frame if, for example, 
you want a layer to enter the frame from one side, cross the screen, and leave the frame on the 
other side.

You can move layers into and out of the frame. 

Because After Effects can position footage items outside the frame, specify a frame size no larger 
than the actual size of the final viewing screen. After Effects previews and renders only the footage 
items within the frame.

When you change the frame size, set the anchor point for the layer by clicking the arrow button in 
the Anchor diagram (in the Composition Settings dialog box) that corresponds to the edge or corner
to which you want to anchor the layer. 

The larger the frame size, the more processing power and application RAM is required to preview 
and render your movie. If you specify an unnecessarily large frame size, screen redraw will be 
slower than it need be.

For your convenience, After Effects includes a variety of preset frame sizes. You can also create a 
custom size for your movie.
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Setting pixel aspect ratio

Most computer monitors use square pixels, while ITU-R 601 (D1) video uses rectangular pixels. 
The Pixel Aspect Ratio option compensates for the rectangular pixels of D1 video format. Set the 
pixel aspect ratio that corresponds to your final output format. If you intend to create a movie for the
D1 output format, choose either D1 NTSC or D1 PAL. For more information about D1 format, see 
About D1, DV, and various pixel aspect ratio footage. 

Note: The correct pixel aspect ratio for D1 NTSC or D1 PAL is chosen automatically when you choose the 
corresponding size from the Frame Size pop-up menu. For example, if you drop a footage item that is 100-by-
100 pixels square into a D1 NTSC composition, the image is changed to 110-by-100 pixels.



Understanding composition settings 

Setting resolution

Resolution determines the dimensions of the image in pixels, which affects the image quality of the 
rendered composition. Setting a low resolution significantly increases frame-rendering speed and 
decreases the amount of memory required to render. You can use a low-resolution setting when 
animating or previewing a movie, and then increase the resolution before rendering your final 
movie.

Choose from the following resolution settings in the Composition Settings dialog box:

Full Resolution    Renders each pixel in a composition. This setting gives you the best image 
quality, but takes the longest to render.

Half Resolution    Renders one-quarter of the pixels contained in the full-resolution image—half the
columns and half the rows. This results in a rendering time approximately one-fourth of the time 
required to render the entire image at full resolution.

Third Resolution Renders one-ninth of the pixels contained in the full-resolution image. This 
results in a rendering time approximately one-ninth of the time required to render the entire image 
at full resolution.

Quarter Resolution    Renders one-sixteenth of the pixels contained in the full-resolution image. 
This results in a rendering time approximately one-sixteenth of the time required to render the entire
image at full resolution.

Custom Resolution    Renders the image at the resolution you specify.
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Adjusting the appearance of low-resolution compositions

When setting resolution, you can determine the size and appearance of the composition. When you
lower the resolution of a composition, you can maintain image clarity by reducing the composition’s 
size. Or, you can maintain its size but reduce image clarity, with the layers appearing blockier and 
more pixelated. The smaller on-screen image will update faster than the original-size image with a 
lower resolution.

A. Original composition resolution B. Half resolution with the same clarity but with a reduction in screen size C.
Half resolution with the same screen size but with a reduction in clarity

To determine the appearance of lower-resolution compositions:

1    Choose File > Preferences > Display.

2    Select Auto-Zoom When Resolution Changes to reduce the size of the composition while 
maintaining image clarity. Deselect this option to maintain the composition size in the Composition 
window but display layers with less clarity.

3    Click OK.
You can also set the 

magnification using the pop-up menu in the Composition window.



Understanding composition settings 

Setting frame rate

The composition frame rate determines the number of frames displayed per second. Frame rate is 
usually determined by the type of output you produce. NTSC video for television has a frame rate of
29.97 frames per second (fps) and PAL video has a frame rate of 25 fps, while motion picture film 
has a frame rate of 24 fps. Video intended for CD-ROM or the World Wide Web is often 10 to 15 
fps. 

Each motion-footage item in a composition can also have a frame rate, and the relationship 
between the footage-item frame rate and the composition frame rate determines how smoothly the 
layer plays. For example, if the footage-item frame rate is 30 fps and the composition frame rate is 
30 fps, whenever the layer advances one frame, the next composition frame is displayed. If the 
footage-item frame rate is 15 fps and the composition frame rate is 30 fps, then two composition 
frames are displayed before the current layer advances one frame, unless frame blending is 
enabled. See Using frame blending. When you use footage that was shot or rendered at the NTSC-
standard rate of 29.97 fps and the composition frame rate is 30 fps, After Effects uses drop-frame 
timecode, the SMPTE-standard method of compensating for the difference between these two 
frame rates. See NTSC (29.97) drop-frame timecode and Setting time-display preferences.



Understanding composition settings 

Setting duration

The duration is the overall length of the composition. You can set duration by entering values in the 
Duration field in the Composition Settings dialog box.

When you preview or render a movie, you can choose to preview or render only a portion of the 
total duration. See Setting up a work area.
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Comparing composition settings and Interpret Footage settings

You may encounter problems in playback if settings in the Composition Settings and Interpret 
Footage dialog boxes are different. These problems usually appear as moiré patterns or lines in 
playback. The frame rate and the pixel aspect ratio may be set to separate values in the 
Composition Settings and Interpret Footage dialog boxes. To avoid problems, be sure that the 
frame rate and the pixel aspect ratio settings in the Interpret Footage dialog box match the settings 
in the Composition Settings dialog box for any composition in which the footage item is used. 

There are some situations in which you may need to mismatch settings in the Composition Settings 
and Interpret Footage dialog boxes. For example, when you are converting from one frame rate to 
another, or if you want to achieve an effect such as simulating the slow frame rate of video 
conferencing. 
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About adding footage items to a composition

Once you have created a new composition and imported footage into the project (see Preparing 
and Importing Footage), you can add footage items or another composition to it. To do this, drag 
footage items or folders from the Project window to a Time Layout window, a Composition window, 
or a composition name or icon in the Project window. You can use individual items in the Project 
window any number of times in one or more compositions. 

Note: Although you cannot directly add a composition to itself, you can duplicate a composition and add the 
copy to the original.

When you add to a composition, each new footage item creates a new layer on top of all existing 
layers. If you drag a footage item into the Composition window, the layer appears where you drop it.
If you drag a footage item to the Time Layout window or onto a composition in the Project window, 
the layer snaps to the center of the Composition window. After you add a layer, you can move it to 
any position within the Composition window. When adding multiple footage items, they appear in 
the composition in the order used to sort the contents of the Project window. For example, if the 
Project window is sorted by name (alphabetically), the new layers containing the footage items 
appear in alphabetical order.

Items added to a composition begin at the time indicated on the current-time marker in the Time 
Layout window. For example, if the current time box displays 0:00:04:00 (4 seconds), when you 
place the item in the Composition window, the item begins its first frame at 4 seconds. By changing 
the location of the current-time marker (Time Layout window) or the time displayed in the Current 
Time button (Composition window), you can add a layer at any point in the composition. 

In the Composition window, layers are visible only if they are active at the time currently displayed. 
For example, if you have three layers in a composition, with two of the layers starting at the 
beginning of the composition and one layer starting at 6 seconds, only two of the layers appear in 
the Composition window when the current-time marker is set to the beginning of the composition. 

Layers that are not active at the current-time setting do not appear in the Composition window.

For more information on adjusting the duration or speed of a layer, see Understanding trimming and
Time-stretching a layer. For more information on setting and adjusting the current time, see Viewing
and setting the current time. 
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Adding footage items to a composition

You can add one or more footage items to a composition simply by dragging. 

See also: 

To add a footage item to a composition 

To add several footage items to a composition at the same time 



Adding footage items to a composition 

To add a footage item to a composition:

1    Activate the Time Layout window for the composition to which you want to add an item.

2    Do one of the following:
•      Click the current-time display, specify a new time, and then click OK.
•      Drag the current-time marker to the desired location on the time graph. See Viewing and setting
the current time.

New footage items are added at the current-time marker.

3    Drag the name of the footage item, the footage-item thumbnail, or a folder from the Project 
window to one of three places:
•      The Composition window.
•      The Time Layout window.
•      The composition name or icon in the Project window.

Adding a footage item to a composition
You can also add a 

footage item to a composition and center it by selecting the name of the footage item in the Project window and 
pressing Control + / (Windows) or Command + / (Mac OS). The footage item is centered in the current Composition 
window.

See also: 

To add several footage items to a composition at the same time 



Adding footage items to a composition 

To add several footage items to a composition at the same time:

1    Select multiple footage items by doing any of the following:
•      To select a contiguous range of items, press Shift as you click the footage items in the Project 
window, or select a group of items by dragging a marquee, or dotted selection rectangle, over them.
•      To select a discontiguous set of items, press Control (Windows) or Command (Mac OS) as you 
select the footage item names in the Project window.
•      Move multiple footage items into a folder in the Project window. For information on creating 
folders, see Project window.

2    Drag the names of the footage items or the folder from the Project window onto a composition 
name in the Project window, into the Composition window, or into the Time Layout window.

See also: 

To add a footage item to a composition 
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Nesting a composition

When creating an elaborate composition, you may find it easier to organize the layers that make up 
the composition by using a technique called nesting. With this technique, you put one or more 
compositions into another composition. You can create many levels of nesting, putting any number 
of compositions into another composition, which then goes into still another composition. Nesting 
creates a hierarchy of layers and compositions within the final composition. For further information, 
see Organizing a project using nesting.
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Working in the Composition and Time Layout windows

After adding footage items to the Composition window, use the Composition and Time Layout 
windows together to manipulate the layers in the composition as follows:
•      In the Composition window, you can preview the composition. You can animate the contents of 
a composition manually by making changes such as moving or scaling layers. Drag the layer or its 
handles in the Composition window.
•      In the Time Layout window, you can specify how layers change over time. You can also animate
the contents of a composition numerically by changing values for the layer, such as position or 
scale (relative size).

When you open a composition, a corresponding Time Layout window also opens. Each composition
displays its own tab at the top of the Composition and Time Layout windows. When you click a tab 
from either window, both windows display the corresponding composition.

You can quickly switch to another composition by clicking its tab in the Composition window (left), or the Time 
Layout window (right). 

If only the Composition window or the Time Layout window is open, you can open the other window 
by clicking the Comp Family button in each window, or by double-clicking a composition in the 
Project window. 

You can display a Time Layout window by clicking the Comp Family button at the right side of the Composition 
window. Likewise, you can display a Composition window by clicking the Comp Family button at the right side 
of the Time Layout window. 
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Understanding the Composition window

The Composition window contains a number of features and controls to help you work with footage 
items. 

A. Rulers Used to align layers in the composition window. The ruler scale is in pixels. See Using 
rulers and guides.

B. Magnification menu button Lets you choose a new magnification from the menu. See 
Changing magnification in the Composition, Layer, or Footage windows. Hold down Alt (Windows) 
or Option (Mac OS) as you press the mouse button to view composition information. 

C. Safe zones button Toggles between viewing the title-safe and action-safe zones and viewing 
just the image. To display the animator grid, hold down Alt/Opt and click this button. See Viewing 
safe zones and grids.

D. Current time button Displays the current time in the composition. Click to open the Go To Time 
dialog box, in which you change the current time. See Viewing and setting the current time.

E. Take- and display-snapshot icons Captures a screen image of the window. Snapshots are not 
saved to disk, and only the most recent snapshot can be viewed. Click and hold the Display 
snapshot icon to view the most recent snapshot instead of the active composition. See Taking and 
viewing a window snapshot.

F. Red, green, blue, and alpha channel icons Lets you click and hold one of the first three icons 
to view the composition’s red, green, or blue channel. Areas with high values of that channel’s color 
are displayed as white. Click and hold the fourth icon to view the composition’s alpha channel. 
Transparent and opaque areas are displayed as black and white, and degrees of opacity appear as 
shades of gray. See Viewing color and alpha channels.

G. Resolution button Lets you choose a resolution for the composition. You can select full, half, 
third, or quarter resolution, or choose Custom to set a custom resolution. See Setting resolution.

H. Composition window menu Displays the Composition Settings dialog box, enables frame 
blending and motion blur, and displays effect controls and layer controls, such as handles and 
paths. 

I. Comp family button Displays the active composition’s related windows. Click to display the Time
Layout window for the active composition. 
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Using the Composition window

In addition to viewing a composition, you can arrange layers in the Composition window. You can 
also change the background color of the composition. 

See also: 

Arranging a footage item in a composition by dragging 

Setting the background color of a composition 



Using the Composition window 

Arranging a footage item in a composition by dragging

You can change the spatial position of a footage item in a composition by selecting and dragging 
the layer in the Composition window. When you want to move a layer into or out of the frame, you 
can position it completely or partially outside the frame.

When you arrange a layer in the Composition window, you determine the position of the layer at the
current time, indicated by the current-time marker in the Time Layout window. If no keyframes are 
set for a layer, the position values you set will apply for the duration of the layer. The layer remains 
in position until you set up a change over time in the Time Layout window, as described in 
Animating Layers. For information about changing the order of layers, see Changing the layer 
stacking order. 

To arrange a layer in a composition by dragging:

1    Select the selection tool from the Tools palette.

2    Click a layer in the Composition window to select it, or, if the layer is obscured by another layer, 
select the layer name in the Time Layout window.

3    Position the pointer within the layer (but not on a handle) and drag the layer to a location within 
the Composition window.

After you start 
dragging a layer, hold down Shift to constrain the dragging to horizontal or vertical movements, or hold 
down Alt + Shift (Windows) or Option + Shift (Mac OS) to snap to the frame edges or center.
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Setting the background color of a composition

The default background color for the Composition window is black, but you can change the color at 
any time. The color stays with the composition if you render the movie with any color depth setting 
other than Millions of Colors+, which includes an alpha channel. If you render with a color depth of 
Millions of Colors+, the composition background becomes transparent.

When you add one composition to a second composition, a process called nesting, the second 
composition’s background color is preserved, and the first composition’s background becomes 
transparent. If you want to preserve the first composition’s solid background color, create a new, 
colored solid to use as a background layer in the first composition. See Creating a new solid layer. 
For more information on nesting, see Organizing a project using nesting.

A composition background color becomes transparent when the composition is placed inside another 
composition.

To set the background color of a composition:

1    Choose Composition > Background Color.

2    Click the color swatch to select a color, or click the eyedropper to sample a color from anywhere 
on the screen. Then click OK.
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Understanding the Time Layout window

Use the Time Layout window to set up changes over time, animate layer properties numerically, and
set In and Out points for a layer. The Time Layout window contains many controls, so these controls
are organized in panels of related functions. 

See also: 

Default controls and panels 

Optional panels 

Understanding the time graph 

Viewing and setting the current time 

Setting up a work area 
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Default controls and panels

By default, the Time Layout window contains a number of panels and controls. Optional panels are 
also available. See Optional panels. 

A. Composition tab Lets you close or move the window. Click a tab to display its composition in 
the current window. Drag a tab to move its composition to another existing window or to put it in a 
new window. 

B. Current time Displays the current time in the project. Click to open the Go To Time dialog box. 
See Viewing and setting the current time.

C. Audio/Video Features panel Contains switches for enabling and disabling audio and video. 
This panel also includes a lock switch for locking layers. See Using Audio/Video Feature switches.

D. Layer Outline Includes a label, a number (assigned by After Effects), and a source name for 
each layer. Clicking the triangle to the left of a layer lets you set properties for the masks, effects, 
and transform functions. See About layer properties. Use this part of the Time Layout window to 
sort layers in a composition. See Understanding layer numbers and colors. 

E. Switches panel button Displays or hides the Switches panel. 

F. Switches panel Contains options for controlling a number of display and performance features 
for a layer. With these switches, you can make layers shy; collapse transform properties or change 
the rasterization method; adjust image quality; display a layer’s effects; turn frame blending and 
motion blur on or off; turn adjustment layers on or off; or convert an existing footage layer into an 
adjustment layer. See Using Layer Switches. 

G. Time graph Visually represents the values of the In/Out panel (see Optional panels) and 
displays the positions of the keyframes and timeline for each layer. See Understanding the time 
graph.

H. Comp Family button Opens a tabbed composition in the window. Click again to display a Time 
Layout window.
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Optional panels

You can display or hide four optional panels in the Time Layout window. 

To display or hide optional panels:

Right-click (Windows) or press Control and click (Mac OS) a Time Layout window panel heading, 
and then choose the panel you want to display or hide in the Panels submenu. 

A. Comments panel Lets you type comments for the layer. 

B. In panel Lets you view or change the In point of a layer. See Understanding trimming. You can 
also display or hide this panel by clicking the ( ) button in the lower left corner of the time graph.

C. Out panel Lets you view or change the Out point of a layer. See Understanding trimming.
D. Duration panel Lets you view or change the duration of a layer. See Understanding trimming.
E. Stretch panel Lets you time-stretch a layer. See Understanding trimming.

F. Optional panel button Displays or hides the In, Out, Duration, and Stretch panels. 
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Understanding the time graph

The time graph portion of the Time Layout window contains a time ruler, markers to indicate specific
times and current work area, and duration bars for the layers in your composition. Use the time 
graph to adjust the range of time shown in the Time Layout window, and to specify a range of time 
to render when creating or previewing a movie. 

The time graph also contains controls for adjusting time for layers and controlling motion and 
changes over time. For more information on working with time for an individual layer, see 
Positioning a layer in time. For information on controlling motion and changes over time, see 
Animating Layers. 

A. Current time Shows the current time in the project. Click to open the Go To Time dialog box. 

B. Time graph    Lets you view layer durations, a time ruler, markers, and keyframes. 

C. Viewing-area markers Indicate the area displayed in detail in the time graph. These markers 
are part of the navigator view, described below. Drag to view a specific area. See Viewing and 
setting the current time.

D. Navigator view Uses smaller versions of the work-area markers and current-time marker 
(circled) to show their relationship to the entire composition. As you drag the viewing-area markers 
to change the view, the miniature markers in the navigator view show your view and the location of 
the current-time marker in the context of the full duration of the composition. 

E. Work-area markers Indicate an area of the composition for rendering or previewing. To render 
only part of the composition, drag the work-area marker to specify the part of the composition to 
render. You can also drag the bar defined by the markers. See Setting up a work area.

F. Current-time marker Indicates the point in time represented by the display in the Composition 
window. Drag the current-time marker to view a specific frame or to set or change keyframes. See 
Viewing and setting the current time.

G. Time ruler Indicates the part of the composition duration currently displayed in the time graph. 
For information on ways to display time on the time ruler, see Setting time-display preferences.

H. Window menu button Displays the Time Layout window menu, which includes functions 
affecting layers and keyframes, as well as providing access to the Composition Settings dialog box. 

I. Composition-time marker    Used to add markers to the time ruler. Drag the marker to a point on 
the time ruler. Drag it back to remove it. 

J. Comp Family button Click to open the active Time Layout window’s associated Composition 
window. 



K. Layer duration bar Indicates the duration of a layer in a composition.

L. Zoom slider Drag to magnify a portion of the time graph or to see more of the time graph. You 
can also use the zoom-in icon ( ) or the zoom-out icon (

). 
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Viewing and setting the current time

A composition’s current time is indicated by the current-time marker. For convenience, you can view
and move the current-time marker in both the navigator view and the time ruler. The navigator view 
shows the complete duration of a composition. When you view the duration of the entire 
composition, detailed work can be difficult. You can magnify a portion of the time graph so you can 
work on only the portion you need.

See also: 

To move the current-time marker by dragging 

To move the current-time marker numerically 

To magnify a portion of the time graph 

To see more of the time graph 



Viewing and setting the current time 

To move the current-time marker by dragging:

In the navigator view or on the time ruler, drag the current-time marker to a new location on the time
graph, or click a new setting on the time ruler.

Drag the current-time marker to change the current time.

See also: 

To move the current-time marker numerically 

To magnify a portion of the time graph 

To see more of the time graph 



Viewing and setting the current time 

To move the current-time marker numerically:

1    Do one of the following:
•      Click the current time in the Time Layout or Composition window.
•      Choose View > Go To Time.
•      Press Control + G (Windows) or Command + G (Mac OS).

2    Type a new time and click OK.

See also: 

To move the current-time marker by dragging 

To magnify a portion of the time graph 

To see more of the time graph 



Viewing and setting the current time 

To magnify a portion of the time graph:

Do one of the following:
•      In the Time Layout window, click the zoom-in icon ( ) or drag the zoom slider.

•      Press the = (equal sign) key on the main keyboard.
•      In the navigator view, drag the left, right, or both viewing-area markers until the time ruler displays the 
portion you want.

Drag the left, right, or both viewing-area markers to magnify or shrink the part of the time ruler displayed.

See also: 

To move the current-time marker by dragging 

To move the current-time marker numerically 

To see more of the time graph 



Viewing and setting the current time 

To see more of the time graph:

Do one of the following:
•      In the Time Layout window, click the zoom-out icon ( ).

•      Press the – (minus) key on the main keyboard.
•      In the navigator view, drag the left and right viewing-area markers until the time ruler displays the 
portion you want.

See also: 

To move the current-time marker by dragging 

To move the current-time marker numerically 

To magnify a portion of the time graph 



Understanding the Time Layout window 

Setting up a work area

When you work on a composition, you may want to preview or render only part of the composition. 
After Effects lets you do this by specifying a part of the composition time ruler as a work area. For 
more information on previewing, see Previewing animation. For more information on rendering the 
final movie, see Rendering a Movie. 

You can set the work 
area start and end points to the current time by pressing B (begin) or N (end) respectively.

To set up a work area:

In the time ruler, move the left and right work-area markers until they mark the beginning and end of
the part of the composition you want to use as a work area.

The work-area markers indicate the part of the composition displayed when previewing or rendering.



Building a Composition 

Replacing and substituting footage

After Effects offers a number of ways to replace and substitute footage in a composition. Using 
proxies or other items in place of original footage can be useful when the footage you want to use is
not available. Also, when you are working with large, high-resolution items, you may want to use 
low-resolution proxies to work more quickly and efficiently. 

See also: 

Replacing footage throughout a project 

Replacing footage for one layer only 

About placeholders and proxies 

Working with missing source footage 

Substituting a placeholder for footage 

Substituting a low-resolution proxy for footage 

Identifying proxy items in the Project window 



Replacing and substituting footage 

Replacing footage throughout a project

You can replace one footage item with another at any time while working on a project. This can be 
useful if you receive a new version of a source file used in your project, and you want to replace the
original footage with the new version. The new footage item replaces the existing one in layers and 
compositions throughout the project. When you replace footage, all values (property settings, effect 
settings, and so on) remain applied to the layer.

To replace footage throughout a project:

1    In the Project window, select the name of the footage item you want to replace.

2    Do one of the following:
•      To import a replacement file using its original file type, choose File > Replace Footage > File, 
select the file, and click Open.
•      To import a replacement file as a different file type, choose File > Replace Footage > File As, 
select the file, select the file type in Import As, and click Open.

Note: If the new footage item is a different size, it is not scaled to fit the original item’s size.



Replacing and substituting footage 

Replacing footage for one layer only

You can replace the original source footage of one layer without changing any settings applied to 
the original footage. Unlike replacing footage throughout a project, this technique affects only one 
layer. The new source footage takes the place of the old layer, but uses the existing keyframes.

To replace the source footage of one layer:

1    In a Time Layout window, select the layer to be replaced.

2    Hold down Alt (Windows) or Option (Mac OS) as you drag a footage item from the Project 
window to any of the following places containing the selected layer:
•      The Composition window. 
•      The Time Layout window. 
•      The Composition icon in the Project window. 



Replacing and substituting footage 

About placeholders and proxies

When you want to temporarily substitute footage, use one of two alternatives: a placeholder or a 
proxy.

Placeholder    A still image used to temporarily take the place of missing footage. Use a 
placeholder when you are building a composition and want to try out ideas for footage that is not yet
available. After Effects generates placeholders automatically, so you do not have to provide any 
placeholder footage.

Proxy    Most often a lower resolution or still version of existing footage used to replace the original 
to save processing time. Use a proxy when you have the actual footage but you want to speed up 
previewing or rendering of test movies. You must have a file available to use as a proxy. 

Using either method, any attributes and keyframes you apply to the placeholder or proxy are 
transferred to the actual footage. You can even set a proxy for a placeholder, so that you use a low-
resolution or still version of full-resolution footage that is not yet available. See Working with missing
source footage and Substituting a low-resolution proxy for footage.

If final footage is unavailable, and you simply want to substitute draft footage or a storyboard still 
image, you can import the draft footage and replace it with final footage later. 



Replacing and substituting footage 

Working with missing source footage

If After Effects cannot find footage when you open a project, it appears in the Project window 
labeled Missing, and the name of the missing footage appears in italics. Any composition using that 
item as a layer replaces it with placeholder color bars.

You can still work with the missing item in the project, and any effects you have already applied to 
the missing layer remain intact.

If you replace the placeholder with the actual footage, it returns to its correct place in all the 
compositions that use it. For a procedure, see Substituting a placeholder for footage.

Missing footage replaced by color bars



Replacing and substituting footage 

Substituting a placeholder for footage

A placeholder appears in After Effects as a still image of color bars. You can apply a mask, effects, 
and geometric properties to a placeholder. When the actual footage item becomes available, you 
can replace the placeholder with it, and the applied attributes and keyframes are transferred to the 
actual footage.

For best results, set the placeholder to exactly the same size and duration as the actual footage.

To use a placeholder:

1    Choose File > Import > Placeholder or File > Replace Footage > Placeholder. 

2    In the New Placeholder dialog box that appears, specify the placeholder’s name, size, and 
duration, and then click OK.

To replace a placeholder with the actual footage:

1    In the Project window, double-click the placeholder you want to replace.

2    Locate and select the actual footage, and then click OK, or choose File > Replace Footage > 
File to locate the file.



Replacing and substituting footage 

Substituting a low-resolution proxy for footage

Movies, images, and compositions used as layers can take up significant amounts of RAM and disk
space when used in compositions, and can slow down working and rendering in elaborate projects. 
Using low-resolution proxy items in place of actual items is a way to lighten the burden on your 
computer and speed your work. Effects, masks, and properties applied to the proxy are applied to 
the actual footage item when you replace the proxy with the actual footage.

Actual footage (left), and low-resolution proxy (right) 

When you use a proxy, After Effects replaces the actual footage with the proxy in all compositions 
that use the actual footage item. When you finish working, you can switch back to the actual 
footage item in the project list. After Effects then replaces the proxy with the actual footage item in 
any composition.

When you render your composition as a movie, you may choose to use either all the actual high-
resolution footage items or their proxies. You might want to use the proxies for a rendered movie if, 
for example, you simply want to test motion using a rough movie that renders quickly.

For best results, set a proxy so that it has the same aspect ratio as the actual footage item. For 
example, if the actual footage item is a 640-by-480-pixel movie, create and use a 160-by-120-pixel 
proxy. When a proxy item is imported, After Effects scales the item to the same size and duration as
the actual footage. If you create a proxy with an aspect ratio that is different from that of the actual 
footage item, scaling will take longer. 



Replacing and substituting footage 

Identifying proxy items in the Project window

In the Project window, After Effects marks the footage name to indicate whether the actual footage 
item or its proxy is currently in use:
•      A box containing a black square indicates that a proxy item is currently in use throughout the 
project; the name of the proxy appears bold in the project list.
•      An empty box indicates that the actual footage item is in use throughout the project.
•      No box indicates that no proxy is assigned to the footage item.

A. Proxy assigned and in use B. Proxy assigned, but original in use C. No proxy assigned D. Proxy name

See also: 

To locate and use a proxy 

To toggle between using the original footage and its proxy 

To stop using a proxy 



Identifying proxy items in the Project window 

To locate and use a proxy:

1    In the Project window, select a footage item.

2    Choose File > Set Proxy > File.

3    In the Open dialog box, locate and select the file you want to use as the proxy, and click OK.

See also: 

To toggle between using the original footage and its proxy 

To stop using a proxy 



Identifying proxy items in the Project window 

To toggle between using the original footage and its proxy:

In the Project window, click the proxy indicator to the left of the footage name.

See also: 

To locate and use a proxy 

To stop using a proxy 



Identifying proxy items in the Project window 

To stop using a proxy:

1    In the Project window, select the original footage item.

2    Choose File > Set Proxy > None.

See also: 

To locate and use a proxy 

To toggle between using the original footage and its proxy 



Managing Layers

Layers are the components you use to build a composition. Any item you add to a composition—
such as a still image, moving image file, audio file, or even another composition—becomes a new 
layer. Without layers, a composition consists only of an empty frame. 

Layers in the Time Layout window (left) and in the Composition window (right)

Layers are like transparent sheets of acetate stacked on top of each other. Using a layer’s masks or
alpha channel, you can see through to the layers below and to the background of the composition 
beneath all of the layers.

Transparent areas on a layer let you see through to the layers below.

Layers let you work with specific footage items in a composition without affecting any other footage.
For example, you can move, rotate, and draw masks for one layer without disturbing any other 
layers in the composition, or you can use the same footage in more than one layer and use it 
differently in each instance. Thus, you can experiment freely with different combinations of graphics,
type, visual effects, geometric transformations, and layer modes.

This chapter covers setting up and using layers. For more basic information about using the 
Composition window, see Building a Composition. For more information about creating a mask, see
Creating masks.

After Effects can import layers directly from Adobe Photoshop and Adobe Illustrator files, and it 
converts clips in Adobe Premiere files into layers. For more information, see Importing an Adobe 
Photoshop file, Importing an Adobe Illustrator or EPS file, or Importing Adobe Premiere projects.

See also: 

Adding layers to a composition 

Kinds of layers 



Creating a new layer from a footage item 

Creating a new layer from a composition 

Creating an adjustment layer 

Creating a new solid layer 

Changing the layer stacking order 

Understanding layer numbers and colors 

Changing a layer’s default color label 

Renaming a layer 

Viewing the source name of a layer 

Understanding trimming 

Trimming layer footage 

Duplicating a layer 

Splitting a layer 

Creating simple cuts and transitions between layers 

Aligning and distributing layers 

Positioning a layer in time 

Using markers 

Using Feature switches in the Time Layout window 

Using Audio/Video Feature switches 

Using Layer Switches 

About motion blur 

Using audio layers 



Managing Layers 

Adding layers to a composition

When you add an item to a composition, you create a new layer for that composition. You can 
duplicate layers within a composition or even copy and paste layers from one composition to 
another. Use as many layers as necessary to create your composition.

When you modify a layer, you do not affect the original source footage. When you view a 
composition or render it into a movie, After Effects reads footage from its original files on disk and 
combines your changes with it, generating new frames while leaving the original footage intact. For 
more information, see How After Effects works with imported files.



Managing Layers 

Kinds of layers

A layer can be any of the following:
•      Created from any footage item in the Project window list, including audio.
•      Created from another composition in the project.
•      Created from an existing layer using the Duplicate command or Copy and Paste commands.
•      An adjustment layer you create in an After Effects composition, which modifies all layers below 
it.
•      A solid area of color you create in an After Effects composition.

A. Solid layer B. Adjustment layer C. Composition layer D. Footage layer



Managing Layers 

Creating a new layer from a footage item

You can create a new layer from any footage item in your Project window by adding it to a 
composition. Once you make a footage item a layer in a composition, you can modify and animate 
it.

To create a layer from footage:

Display the Composition window or Time Layout window for the composition to which you want to 
add footage and do one of the following:
•      Drag a footage item from the Project window list to the target Composition window or Time 
Layout window.
•      In the Project window, drag the footage item to the target composition icon.
•      Select the footage item and press Control + / (Windows) or Command + / (Mac OS).



Managing Layers 

Creating a new layer from a composition

When you add a composition to another composition, the process is called nesting. The 
composition you add becomes a layer in the other composition. Nested compositions can change 
composition structure, memory usage, and rendering order. For more information, see Organizing a
project using nesting.

To create a layer from a composition:

1    Display the Composition window or Time Layout window for the composition to which you want 
to add footage.

2    Drag a composition from the Project window list to the target Composition window or Time 
Layout window.



Managing Layers 

Creating an adjustment layer

Applying an effect to a layer affects only that layer and no others (see Working with effects). 
However, you may want an effect to exist independently of any layer. You can do this using an 
adjustment layer. Unlike a normal layer, an adjustment layer does not display source footage, but 
exists only to apply an effect. Also, effects applied to an adjustment layer affect all layers below it in 
the composition’s stacking order. Otherwise, an adjustment layer behaves exactly like a normal 
layer; for example, you can use keyframes to adjust any adjustment layer property over time.

The Blur effect applied to a normal layer affects only that layer (left), whereas the same effect applied to an 
adjustment layer affects all layers below (right).

Adjustment layers are useful for applying an effect to many layers at once. For example, if you have
a composition where you want to blur all layers representing objects in the background of the 
picture, you would normally have to apply a blur effect to each of those layers separately, or 
precompose all of those layers before applying the blur effect. With an adjustment layer, you simply 
create the layer, apply a blur effect to it, and position it in the stacking order above all the layers you
want to blur. You can also change an existing layer into an adjustment layer; see Using the 
Adjustment Layer switch.

To create a new adjustment layer:

1    Display the Composition or Time Layout window to which you want to add an adjustment layer.

2    Choose Layer > New Adjustment Layer. A new adjustment layer appears at the top of the Time 
Layout window. You can move the layer to any location in the Time Layout window outline.

If you want to apply an
effect to just part of an image, draw a mask (see Working with masks) on an adjustment layer. The mask 
will restrict the area to which the effect applies. You can animate the mask to follow a moving subject.



Managing Layers 

Creating a new solid layer 

You can create solid images of any size or color using After Effects. After Effects treats solids as it 
does any other footage item, letting you modify the solid’s mask, transform properties, and apply 
effects. Using solids, you can add color to a background or create simple graphic images using 
masks and layer properties.

Original solid layer (left), and masked solid layer (right)

To create a solid-color layer:

1    Open the Composition window or Time Layout window for the composition into which you want 
to add footage.

2    Choose Layer > New Solid. The Solid Settings dialog box appears.

3    Type a name for the layer.

4    Enter a size for the solid. You can choose a unit of measure from the Units menu. To constrain 
the aspect ratio of the layer, select Lock Aspect Ratio.

5    Set the color of the layer in one of two ways:
•      To specify a color, click the color swatch, specify a color, and then click OK.
•      To specify a color that appears on the screen, click the eyedropper, and then click the color on 
the screen. In Windows, you must click within the After Effects program window, not on the desktop 
or in another application.



Managing Layers 

Changing the layer stacking order

When you add a new layer to a composition, it appears at the top of the layer stack by default. The 
top layer is also the frontmost layer in the Composition window. As you add more layers, they 
appear at the top of the stack by default. Changing the order of footage layers modifies the 
appearance of your composition by repositioning footage in front of or behind other footage. 
Changing the position of an adjustment layer in the stacking order changes which layers are 
affected by it (because it affects all layer below it). An adjustment layer at the bottom of the stacking
order affects no layers and has no visible effect. For more information, see Creating an adjustment 
layer.

The Time Layout window displays the layer stacking order. The top layer is listed at the top of the 
layer outline, the second layer second from the top, and so on. You can change the layering order in
the Composition window or in the Time Layout window.

Changing the stacking order of layers in the Time Layout window changes the order in the Composition 
window.

See also: 

To arrange layers in any order 

To move a layer one level 

To move a layer to the front 

To move a layer to the back 



Changing the layer stacking order 

To arrange layers in any order:

1    In the Time Layout window, drag a layer name up or down.

2    Observe the horizontal line that appears between layer names as you drag, and release the 
layer at the desired position.

See also: 

To move a layer one level 

To move a layer to the front 

To move a layer to the back 



Changing the layer stacking order 

To move a layer one level:

In the Composition or Time Layout window, select the layer and do one of the following:
•      Choose Layer > Bring Forward, or press Control + ] (Windows) or Command + ].
•      Layer > Send Backward, or press Control + [ (Windows) or Command + [. 

See also: 

To arrange layers in any order 

To move a layer to the front 

To move a layer to the back 



Changing the layer stacking order 

To move a layer to the front:

1    In the Composition or Time Layout window, select the layer.

2    Choose Layer > Bring to Front, or press Control + Shift + ] (Windows) or Command + Shift + ] 
(Mac OS).

See also: 

To arrange layers in any order 

To move a layer one level 

To move a layer to the back 



Changing the layer stacking order 

To move a layer to the back: 

1    In the Composition or Time Layout window, select the layer.

2    Choose Layer > Send to Back, or press Control + Shift + [ (Windows) or Command + Shift + 
[ (Mac OS).

See also: 

To arrange layers in any order 

To move a layer one level 

To move a layer to the front 



Managing Layers 

Understanding layer numbers and colors

After Effects automatically numbers all layers in a composition. A layer’s number is based on its 
position in the stacking order. Each time you add a new layer, the new layer becomes layer 1 and 
all other layers in the composition change to the next highest number. For example, the previous 
layer 1 becomes layer 2, the previous layer 2 becomes layer 3, and so forth. You can select a layer 
by its number.

After Effects also assigns different colors for compositions and source footage to help you 
distinguish between them in the Time Layout window. You can change the layer name or color at 
any time; however, the layer number always depends on the position of the layer in the stacking 
order, so After Effects will change the layer numbers if you change the layer stacking order (see 
Changing the layer stacking order).

A. Color heading B. Number heading C. Name heading

To select a layer by its number:

With the Time Layout, Composition, or Effect Controls window active, press the layer number on the
numeric keypad. You can select layers 1 through 9 using this method.

To select several layers of one color:

1    In the Time Layout window, select one layer from the color group you want to select.

2    Choose Edit > Label > Select Label Group.



Managing Layers 

Changing a layer’s default color label

Layer colors are associated with the layer’s source file-type class, such as video, still, audio, and so
on. You can change the color for one layer’s source file, or you can change the color for all source 
files of that same type.

To change a color label for an individual layer:

1    In the Time Layout window, select the layer.

2    Choose Edit > Label > <color name>.

To change the default color label for a layer’s source type:

1    Choose File > Preferences > Labels.

2    Under Default Labeling, choose a color from a source type menu. For example, from the Video 
menu, choose Red to change all labels of video source files in all compositions to red.

To change the default color options:

1    Choose File > Preferences > Labels.

2    In the Preferences dialog box, do one of the following:
•      Click a color swatch and select a color from the color picker, and then click OK.
•      Click an eyedropper icon and click to select a color from anywhere on your desktop.

3    Type a new name for the color in the name box, and then click OK.



Managing Layers 

Renaming a layer

By default, the layer outline in the Time Layout window lists layers by the name of their source 
footage. You can rename any layer at any time. Giving each layer in a composition a unique name 
can help identify layers when you use the same source footage for more than one layer, for 
example, when you duplicate a layer. You can switch between displaying the original filename and 
the layer name you’ve specified; see Viewing the source name of a layer.

Original layer name (left), and renamed layer (right)

After you rename a layer, all other layers in the composition display with brackets around the 
names. Renamed layers display without brackets.

To rename a layer:

1    In the Time Layout window’s layer outline, select the layer you want to rename.

2    Press Enter on main keyboard (Windows) or Return (Mac OS) and type a new name.

3    Press Enter on main keyboard (Windows) or Return (Mac OS) again to apply the new name.



Managing Layers 

Viewing the source name of a layer

The Time Layout window can list a layer by the name of its source footage or by a name you give 
the layer in After Effects (see Renaming a layer). You can instantly switch between viewing source 
names and layer names. After Effects can also display the source file name in the Info palette, 
which is useful when a layer’s source footage is a still-frame sequence (because each still image 
has a different filename).

To switch between a layer’s source name and layer name:

In the layer outline in the Time Layout window, click the Source Name or Layer Name heading. 

To see a layer’s source name using the Info palette:

1    If the Info palette is not open, choose Window > Show Info.

2    In a Composition or Time Layout window, select the layer for which you want to see the source 
name.

3    Press Control + Alt + Shift + I (Windows) or Command + Option + Shift + I (Mac OS). The name 
of the source footage appears in the Info palette.



Managing Layers 

Understanding trimming

You can trim, or edit out, footage at the beginning or end of a layer. When you trim a layer, you 
change which frames are first or last in the composition. The first frame is known as the In point and
the last frame is known as the Out point. When you use one footage item as a source for different 
layers, you can trim it differently in each layer.

The process of trimming an audio or video layer merely suppresses frames at the beginning or end 
of layer footage. The original source video or audio is always available and can easily be restored. 
Trimming a still image layer simply changes the length of time the image displays in the 
composition; it does not affect what portion of the image displays.

A. Original In point B. Original Out point C. Out point after trimming D. Suppressed footage E. Original Out 
point reference

An In point refers to the same frame in the Layer window and the Time Layout window; this is also 
true for an Out point. However, be aware that an In or Out point often has a different time location in
each window. In the Layer window, the In and Out points are relative to the duration of the source 
footage for the layer, while in the Time Layout window, the In and Out points are relative to the 
duration of the composition containing the layer. For example, if you have untrimmed footage that’s 
two seconds long and you start it one second into a composition, the layer’s Out point in the Layer 
window is 00:00:02:00, but its Out point in the Time Layout window is 00:00:03:00. When you trim 
the In point of a layer in the Time Layout window, the layer’s starting time also changes. If you want 
to trim the beginning of the layer without changing its start time in the composition, trim it in the 
Layer window.

A. In point in the Layer window, relative to source footage duration B. Out point in the Layer window, relative to
source footage duration C. In point in the Time Layout window, relative to composition duration D. Out point in 
the Time Layout window, relative to composition duration
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Trimming layer footage

You can trim in the Layer window or the Time Layout window, depending on what you want to 
change (see Understanding trimming).

See also: 

To trim or restore layer footage by dragging 

To trim or restore layer footage using the current-time marker 

To trim layer footage in the Layer window 

To restore trimmed layer footage in the Layer window 



Trimming layer footage 

To trim or restore layer footage by dragging:

In the Time Layout window, drag the end of the layer duration bar you want to trim. If the entire layer
duration bar moves, you’ve accidentally grabbed the layer itself; choose Edit > Undo Layer Time 
Change and try again.

See also: 

To trim or restore layer footage using the current-time marker 

To trim layer footage in the Layer window 

To restore trimmed layer footage in the Layer window 



Trimming layer footage 

To trim or restore layer footage using the current-time marker:

1    In the Time Layout window, select the layer you want to trim.

2    Move the current-time marker to the frame at which you want to trim the footage.

3    Do one of the following:
•      To trim the In point of the layer, press Alt + [ (Windows) or Option + [ (Mac OS).
•      To trim the Out point of the layer, press Alt + ] (Windows) or Option + ] (Mac OS).

See also: 

To trim or restore layer footage by dragging 

To trim layer footage in the Layer window 

To restore trimmed layer footage in the Layer window 



Trimming layer footage 

To trim layer footage in the Layer window:

1    In a Composition window or Time Layout window, select the layer you want to trim and double-
click it or choose Layer > Open Layer Window.

2    On the time ruler, move the current-time marker to the frame at which you want to trim the 
footage.

3    Do one of the following:
•      To trim the beginning of the layer, click the In button ( ).

•      To trim the end of the layer, click the Out button ( ).

After trimming in the Layer window, trimmed frames appear as dimmed outlines in the Time Layout 
window before the first frame and after the last frame of the layer.

See also: 

To trim or restore layer footage by dragging 

To trim or restore layer footage using the current-time marker 

To restore trimmed layer footage in the Layer window 



Trimming layer footage 

To restore trimmed layer footage in the Layer window:

Use the same procedure you use for trimming footage, but with the following differences:
•      To restore footage at the beginning of a layer, move the current-time marker to the beginning of 
the layer time ruler, and then click the In button.
•      To restore footage at the end of a layer, position the current-time marker to the end of the layer 
time ruler, and then click the Out button.

See also: 

To trim or restore layer footage by dragging 

To trim or restore layer footage using the current-time marker 

To trim layer footage in the Layer window 
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Duplicating a layer

When you duplicate a layer, After Effects copies all property keyframes, masks, and effects to the 
duplicate. The duplicate is added above the original layer and automatically selected. If you want to 
duplicate a layer without duplicating its keyframes, masks, or effects, add the original source 
footage file to the composition again.

To duplicate a layer:

In a Composition or Time Layout window, select a layer, and choose Edit > Duplicate, or press 
Control + D (Windows) or Command + D (Mac OS). 
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Splitting a layer

You can split a layer at any point along its timeline. When you split a layer you create two separate 
layers from one layer. Splitting a layer has the same result as duplicating a layer, trimming the Out 
point of the original layer, and then trimming the In point of the new layer to one frame later than the
original layer’s Out point. Splitting is useful when you want a layer to change places in the stacking 
order in the middle of a composition. For example, you might split a layer if you want footage of a 
moon to orbit in front of and then behind footage of a planet.

When you split a layer, both resulting layers contain all the keyframes that were in the original layer,
in their original positions; see Understanding keyframes.

To split a layer:

1    In the Time Layout or Composition window, select a layer.

2    In the Time Layout window, move the current-time marker to the time where you want to split the
layer.

3    Choose Edit > Split Layer, or press Control + Shift + D (Windows) or Command + Shift + D (Mac
OS).
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Creating simple cuts and transitions between layers

A simple cut from one layer to another is easy to create in the Time Layout window. If you want to 
create other kinds of transitions, such as fading or dissolving one layer into another, you need to 
know about setting opacity, In and Out points, and keyframes. For more information, see Setting 
and animating opacity, Understanding trimming, and Understanding keyframes. Also, some 
transitions exist as plug-in effects, so you don’t have to build them from scratch; see Applying 
Effects. 

To cut from one layer to another:

1    Display the Time Layout window containing the two layers for which you want to create the 
transition.

2    Set the In point of the second layer at one frame later than the Out point of the first layer. For 
more information, see Understanding trimming.
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Aligning and distributing layers

The Align palette can line up or evenly space selected layers. You can align or distribute layers 
along the vertical or horizontal axes of selected objects.

Layers in original position (left) and aligned to horizontal center and vertical center (right)

Layers in original position (left) and distributed horizontally by each layer’s center (right) 

When you align and distribute selected layers, keep the following in mind:
•      An alignment option aligns selected layers to the object that most closely represents the new 
alignment. For example, if you apply right-edge alignment, all selected layers align to the right edge 
of the selected object furthest to the right. 
•      A distribution option evenly spaces selected layers between the two most extreme layers. For 
example, if you apply a vertical distribution option, selected layers are distributed between the top 
and bottom layers in the selection.
•      When you distribute layers of different sizes, the space between layers may not be uniform. For 
example, distributing layers by their centers will create equal space between the centers—but 
different-sized layers will extend by different amounts into the space between layers.
•      Locked layers are not moved by alignment or distribution options.
•      Text alignment is not affected by options in the Align palette. If you created the text using the 
Basic Text effect, change the text alignment there. For more information, see Basic Text.

To align or distribute layers:

1    Select the layers you want to align or distribute.

Note: To align, you must select two or more layers; to distribute, you must select three or more layers. 

2    Choose Window > Plug-in Palettes > Align & Distribute.



3    Click the icon representing the type of alignment or distribution you want.
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Positioning a layer in time

You move a layer in time by changing its In or Out point in the Time Layout window. You can specify
a new In or Out point either numerically or by dragging the layer duration bar. After Effects provides 
two ways to view and change the In and Out points of a layer in the Time Layout window:
•      The In and Out panels represent the layer duration numerically.
•      The duration bar represents the layer duration visually.

See also: 

To display the In and Out panels 

To move a layer in time by dragging 

To move a layer in time by moving its In point 

To move a layer in time by moving its Out point 

To change the In and Out points of a layer numerically 



Positioning a layer in time 

To display the In and Out panels:

Do one of the following: 
•      In the Time Layout window, right-click (Windows) or Control-click (Mac OS) any panel heading, 
and then choose Panels > In. Repeat to open the Out panel.
•      Click the Expansion button at the lower left corner of the time graph.

Time Layout window before displaying In, Out, Duration, and Stretch panels

See also: 

To move a layer in time by dragging 

To move a layer in time by moving its In point 

To move a layer in time by moving its Out point 

To change the In and Out points of a layer numerically 



Positioning a layer in time 

To move a layer in time by dragging:

In the Time Layout window, drag the layer duration bar to the left or right. To snap the layer duration
bar to significant points in time, such as markers or the start or end of the composition, press Shift 
as you drag.

Before and after moving the duration bar

See also: 

To display the In and Out panels 

To move a layer in time by moving its In point 

To move a layer in time by moving its Out point 

To change the In and Out points of a layer numerically 
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To move a layer in time by moving its In point:

1    Display the Time Layout window for the composition containing the layer you want to move.

2    In the Time Layout window, drag the current-time marker to the time when you want the layer to 
begin playing. To determine the exact time as you drag, use the current-time display at the upper 
left corner of the Time Layout window.

3    If the In panel is not visible in the Time Layout window, right-click (Windows) or Control click 
(Mac OS) any panel heading, and then choose Panels > In.

4    In the In panel, press Alt (Windows) or Option (Mac OS) as you click the In option for the layer 
you are changing.

See also: 

To display the In and Out panels 

To move a layer in time by dragging 

To move a layer in time by moving its Out point 

To change the In and Out points of a layer numerically 
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To move a layer in time by moving its Out point:

Use the procedure for changing the In point, but with the following differences:
•      Move the current-time marker to the Out point you want.
•      Press Alt (Windows) or Option (Mac OS) as you click the Out option for the layer you are 
changing.

See also: 

To display the In and Out panels 

To move a layer in time by dragging 

To move a layer in time by moving its In point 

To change the In and Out points of a layer numerically 
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To change the In and Out points of a layer numerically:

1    Display the Time Layout window for the composition containing the layer you want to change.

2    If the In and Out panels are not visible in the Time Layout window, right-click (Windows) or 
Control-click (Mac OS) any panel heading, and then choose Panels > In. Repeat for the Out panel.

3    In the In or Out panel, click the In or Out option for the layer you want to change.

4    Enter a new time, and then click OK.

Note: Do not adjust the In and Out points in the Time Layout window in this manner if you are trying to trim, 
speed up, slow down, or distort time within layer footage. For more information, see Understanding trimming 
and About time-remapping.

See also: 

To display the In and Out panels 

To move a layer in time by dragging 

To move a layer in time by moving its In point 

To move a layer in time by moving its Out point 
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Using markers

You can use composition-time and layer-time markers to mark important points in a composition or 
in a specific layer. Composition-time markers are numbered, while layer-time markers use specified 
text labels. 

Markers also make it easier to align layers or the current-time marker with specific points in time, 
because items you drag in the Time Layout window can snap to markers. 

See also: 

Composition-time markers 

Layer-time markers 

Nesting compositions containing layer-time markers 

Adding markers synchronized to audio 



Using markers 

Composition-time markers

Composition-time markers appear on the time ruler and are numbered in the order you add them. 
You can have up to ten composition-time markers within a composition, numbered from 0 (zero) to 
9.

To add a composition-time marker by dragging:

Drag a composition-time marker from the Time-marker button to the desired point in the 
composition.

To add a composition-time marker at the current time:

Press Shift as you press a number key on the main keypad. The number you press appears on the 
marker as its label.

To move a composition-time marker to a new time:

Drag the composition-time marker.

To move the current-time marker to an existing composition-time marker:

Press the marker’s number key on the main keyboard.

To snap the current-time marker or layer duration bars to markers:

Press Shift as you drag the current-time marker or a layer duration bar.

To remove a composition-time marker:

Drag a composition-time marker to the right until the time-marker button is highlighted and the 
marker slides off the time ruler, and then release the mouse.
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Layer-time markers

Layer-time markers appear as rounded white triangles on a layer-duration bar. You can have any 
number of layer-time markers per layer and name them.

Layer-time markers

To add a layer-time marker:

1    Select the layer to which you want to add a layer-time marker.

2    Move the current-time marker to the frame where you want the marker.

3    Choose Layer > Add Marker, or press the asterisk key (*) on the numeric keypad.

To name a layer-time marker:

1    Double-click the layer-time marker. (When renaming, be sure to double-click the marker icon, 
rather than its name; otherwise the Layer window instead of the Choose Name dialog box will 
open.)

2    Type a name, and then click OK.

To move a layer-time marker to a new time:

Drag the layer-time marker.

To remove a layer-time marker:

Press Control (Windows) or Command (Mac OS) as you click the layer-time marker.
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Nesting compositions containing layer-time markers

If you add one composition to another, After Effects includes the composition as a layer, and 
converts all composition-time markers to layer-time markers. The markers are not linked, however; 
changing markers in the composition that was added does not change markers in the new layer. 
For more information, see Organizing a project using nesting.
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Adding markers synchronized to audio

After Effects provides a quick way to add and label markers for significant points in a layer’s audio 
track, such as a rhythmic beat in music or spoken words in dialogue. Once created, you can use the
markers to synchronize video or other effects.

To synchronize markers to dialogue:

1    Press the decimal point key (.) on the numeric keypad to preview audio.

2    Whenever you hear audio where you want to add a marker, press the asterisk key (*) on the 
numeric keypad to create a layer marker at that time.

3    When previewing is complete, double-click a marker you just created, type a descriptive label 
(such as a word being spoken at that time), and click OK. Repeat for any other markers you added.
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Using Feature switches in the Time Layout window

The Time Layout window contains two switches panels: Audio/Video Features and Layer Switches. 
These panels appear on the left and right side of each layer name and are customizable, so you 
can hide them or move them to different locations in the Time Layout window. 

A. Audio/Video Features B. Layer Features

Using the switches in these panels, you can control aspects of a layer’s display and rendering 
performance, as well as layer settings that don’t change over time, such as video quality, showing 
or hiding a layer, and turning an adjustment layer on or off. By selecting the switches, you adjust the
balance between display performance and display quality during your work session. All switches are
also available as commands in the Layer menu.

See also: 

To use layer switches 

To adjust switches using menus 



Using Feature switches in the Time Layout window 

To use layer switches:

Do any of the following:
•      To hide a switches panel, right-click (Windows) or press Control (Mac OS) as you click a panel 
heading, and choose Hide This.

•      To display a switches panel, right-click (Windows) or press Control (Mac OS) as you click a 
panel heading, choose Panels, and then choose the panel you want to display.

•      To rearrange switches panels, drag the panel heading to a different location along the Time 
Layout window. When the panel outline appears where you want the panel to appear, release the 
mouse.

A gray outline appears when you drag a panel (left). When you release, panels are rearranged (right).

Note: All layer switches move together—you can move the entire switch panel to a different position between 
other panels, but you can’t rearrange the switches within the panel.
•      To change the width of a panel, drag the raised vertical bar left or right to set the new width. If 
the panel does not have a raised vertical bar at its right edge, it cannot be resized.



See also: 

To adjust switches using menus 



Using Feature switches in the Time Layout window 

To adjust switches using menus:

1    In the Time Layout window, select the layer you want to modify.

2    Choose Layer > Switches and select or deselect a layer switch command.

See also: 

To use layer switches 
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Using Audio/Video Feature switches

The Audio/Video (A/V) Features panel in the Time Layout window lets you lock layers, control which
layers display in the Composition window, and control which layers appear in a preview and a 
rendered version. 

A. Video B. Audio C. Lock

See also: 

Hiding layers in the Composition window 

Including and excluding a layer’s audio track 

Locking and unlocking a layer 
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Hiding layers in the Composition window

You can use the Video switch to exclude or include layers from appearing in the Composition 
window. The Video switch is on by default, so the layer displays in the Composition window. When 
you want to speed up redraw or exclude a layer from appearing in both the preview and the 
rendered version, turn off the Video switch.

A. Video on B. Video on and transfer mode applied C. Video off

To show or hide a layer in the Composition window:

Do any of the following:
•      To show or hide a layer, click the Video switch next to a layer in the Time Layout window.
•      Select a layer, choose Layer > Switches, and make sure the Video command is selected (to 
display the layer) or deselected (to hide the layer).

Layer visible in Composition window (left) or hidden (right)

To hide all layers that are not selected in the Composition window:

Choose Layer > Switches > Hide Other Video.

To show all layers in the Composition window:

Choose Layer > Switches > Show All Video.
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Including and excluding a layer’s audio track

The Audio switch includes or excludes a layer’s audio track in the composition preview or rendered 
version. This switch is available only if the layer contains an audio track. 

To include or exclude a layer’s audio track from a composition:

Do one of the following:
•      In the Time Layout window, click the Audio switch next to a layer.

Audio layer included (left) and excluded (right) from a layer
•      Choose Layer > Switches and make sure the Audio command is selected (to include audio) or 
deselected (to exclude audio).
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Locking and unlocking a layer

The Lock switch prevents accidental selection of layers you do not want to alter. When the Lock 
switch is on for a layer, you cannot select the layer in the Composition window or the Time Layout 
window. If you try to select or modify a locked layer, the layer flashes in the Time Layout window.

To lock or unlock a layer:

Do one of the following:
•      In the Time Layout window, click the Lock switch next to a layer.

Layer unlocked (left) and locked (right)
•      Select a layer, choose Layer > Switches, and make sure the Lock command is selected (to lock 
the layer) or deselected (to unlock a layer).

To unlock all layers:

Choose Layer > Switches > Unlock All Layers.
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Using Layer Switches

You can use the switches in the Layer Switches panel in the Time Layout window to control a 
variety of display and performance features. The features represented by these switches are also 
accessible from the Layers menu.

A. Shy B. Collapse Transformations/Continuously Rasterize C. Quality D. Effects E. Frame Blending F. Motion 
Blur G. Adjustment Layer

The Layer Switches panel shares space in the Time Layout window with the Transfer Modes panel 
(see Using layer modes), so it won’t be visible if the Transfer Modes panel is visible. You can 
change instantly between the Layer Switches panel and the Transfer Modes panel.

To toggle between the Layer Switches panel and the Transfer Modes panel:

Click the Switches/Modes button in the Time Layout window.

Clicking the Switches/Modes button toggles between the Layer Switches panel (left) and the Transfer Mode 
panel (right).

See also: 

Showing and hiding layers in the Time Layout window 

Collapsing the transformation properties or continuously rasterizing a layer 

Changing a layer’s image quality 

Showing and hiding applied effects 

Enhancing time-altered motion by blending frames 

Using frame blending 
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Showing and hiding layers in the Time Layout window

You can mark a layer as shy, so that it can be hidden in the Time Layout window and yet still display
in the Composition window. Making layers shy is useful when you want to make room in the Time 
Layout window to show the layers and layer properties you want to adjust. Once layers are marked 
as shy, the Hide Shy Layers button hides or displays all shy layers. Making layers shy determines 
which layers are listed in the Time Layout window; if you want to hide or show layers in the 
Composition window, use the eye icon (see Hiding layers in the Composition window).

To mark a layer as shy or not shy:

Do one of the following:
•      In the Time Layout window menu, click the Shy switch for a layer.

Layer marked as not shy (left) and shy (right)
•      Select a layer, choose Layer > Switches, and make sure the Shy command is selected (to mark 
as shy) or deselected (to mark as not shy).

To hide all shy layers:

Do one of the following:
•      Click the Hide Shy Layers button at the top of the Time Layout window so that it is selected.

Note which layers are marked as shy and click the Hide Shy Layers button (left). Note that Shy layers are now 
hidden (right).
•      Select Hide Shy Layers from the Time Layout window menu.



To show all shy layers:

Click the Hide Shy Layers button at the top of the Time Layout window so that it is deselected, or 
deselect Hide Shy Layers from the Time Layout window menu.
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Collapsing the transformation properties or continuously rasterizing a layer

The Collapse Transformations/Continuously Rasterize switch affects a nested composition or an 
Adobe Illustrator file. However, it affects these layers differently. When a layer’s source is a 
composition, this switch becomes the Collapse Transformations switch. Selecting it may improve 
image quality and decrease viewing and rendering time. You cannot select this switch if a mask or 
effect is applied to the layer. When a layer’s source is an Adobe Illustrator file, this switch becomes 
the Continuously Rasterize switch. Selecting this switch causes After Effects to re-rasterize the 
Illustrator file for each frame, which improves image quality but also increases previewing and 
rendering time.

You may not be able to apply masks and some effects if this switch is on. If you want to apply an 
effect to a layer that uses this switch, you can either apply an adjustment layer higher up in the 
stacking order (see Creating an adjustment layer), or nest or precompose the layer with the switch 
applied and then apply the effect or mask. See Importing an Adobe Illustrator or EPS file.

To collapse transformations or change the rasterization method for a layer:

Do one of the following:
•      In the Time Layout window, click the Collapse Transformations/Continuously Rasterize switch.

Collapse Transformations/Continuously Rasterize switch off (left) and on (right)
•      Select a layer, choose Layer > Switches, and make sure the Collapse command is selected (to 
turn it on), or deselected (to turn it off).
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Changing a layer’s image quality

You can select three levels of quality for the layer image: Best, Draft, and Wireframe. A higher 
quality setting shows more detail at higher resolution, but at the expense of redraw and rendering 
speed. The three levels of quality are as follows:
•      Best quality displays and renders a layer using subpixel positioning, anti-aliasing, and complete 
calculation of any applied plug-in effects. Best provides the slowest display and rendering time.
•      Draft quality displays a layer so that you can see it, but only at rough quality. Draft quality 
displays and renders a layer without anti-aliasing and subpixel positioning, and some effects are not
precisely calculated. Draft quality is often the most useful setting for general work.
•      Wireframe quality represents a layer as a box with an X across it. Layer wireframes display and 
render faster than other settings. However, layer contents or masks are not visible—only position 
and size. Because of this limitation, wireframe quality is only available from the Layer menu.

To change a layer’s image quality:

Do one of the following:
•      In the Time Layout window, click the Quality switch icon next to a layer to toggle between Draft 
and Best quality.

Quality set to Draft (left) and Best (right) in the Time Layout window
•      Select a layer, choose Layer > Quality, and choose Best, Draft, or Wireframe.
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Showing and hiding applied effects

Using the Effect switch, you can control whether a layer’s effects appear in both previews and 
rendered versions. When you deselect this switch, the layer is displayed and rendered without its 
effects, saving previewing and rendering time. This switch is available only if a layer has effects 
applied to it.

To show or hide all effects applied to one layer:

Do one of the following:
•      In the Time Layout window, click the Effect switch icon for a layer to toggle between showing 
and hiding effects.

Effect switch set to display (left) and hide (right) effects
•      Select a layer, choose Layer > Switches, and make sure the Effect command is selected (to 
show effects) or deselected (to hide effects).

You can temporarily turn on or off an individual effect applied to a layer. For more information, see 
Applying and controlling effects.
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Enhancing time-altered motion by blending frames

When you time-stretch (see Time-stretching a layer) or time-remap (see About time-remapping) 
footage to a slower frame rate or to a rate lower than that of its composition, movement can appear 
jerky. This jerky appearance results because the layer now has fewer frames per second than the 
composition. By default, After Effects fills in the missing frames in slow-motion footage by repeating 
the last frame shown. After Effects can create a more gradual transition between frames by 
interpolating new frames between existing ones.

When you time-stretch or time-remap footage to a frame rate that is faster than the original or 
higher than that of its composition, After Effects skips many of the original frames to achieve the 
new rate and, consequently, movement can appear jerky. Frame blending combines the remaining 
original frames to create smoother fast motion.

Without frame blending, frames played at a lower- or higher-than-normal frame rate appear jerky.

Frame blending interpolates intermediate frames to create a more gradual change between frames.
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Using frame blending

Use the Frame Blending switch when motion already exists in the source footage for a layer, such 
as people moving in live-action video. You can apply frame blending to a sequence of still images, 
but not to a single still image. If you are animating a layer—for example, moving a layer of type 
across the screen— use the motion blur switch. For more information, see About motion blur. 

Frame blending slows previewing and rendering, so you might want to apply frame blending without
displaying it. By selecting the Enable Frame Blending button at the top of the Time Layout window, 
you can control whether layers that use frame blending affect redraw and rendering. The Quality 
setting you choose also affects frame blending. When the layer is set to Best Quality, frame 
blending results in smoother motion, but may take longer to render than when set to Draft Quality. 
You can also enable frame blending for all compositions when you render a movie. For more 
information, see Changing render settings.

See also: 

To apply frame blending to a layer 

To preview and render frame blending for the layers in which the Frame Blending switch is on 



Using frame blending 

To apply frame blending to a layer:

Do one of the following:
•      In the Time Layout window, click the Frame Blending switch for a layer.

Frame blending not applied (left) and applied (right) to a layer
•      Select a layer, choose Layer > Switches, and make sure Frame Blending is selected (to turn it 
on) or deselected (to turn it off).

See also: 

To preview and render frame blending for the layers in which the Frame Blending switch is on 



Using frame blending 

To preview and render frame blending for the layers in which the Frame 
Blending switch is on:

Do one of the following:
•      Click the Enable Frame Blending button at the top of the Time Layout window.

Frame blending for preview and render disabled (left) and enabled (right)
•      Select Enable Frame Blending from the Time Layout window menu.

See also: 

To apply frame blending to a layer 
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About motion blur

When you view one frame of motion-picture film or video containing a moving object, the image is 
often blurred. This is because a frame represents a sample of time (in film, a sample 1/24 of a 
second long), and in that time a moving object occupies more than one position as it travels across 
the frame, so it cannot be shown as a sharp, still object. The faster the object moves, the more it 
blurs; a camera’s shutter angle also affects the appearance of the blur. In contrast, in a single frame
of a computer-generated animation you may not be able to tell which objects are moving because 
all moving objects may appear as sharp and clear as nonmoving objects. Without motion blur, layer 
animation produces a strobe-like effect of distinct steps instead of an appearance of continuous 
change. Adding motion blur to layers you animate in After Effects makes layer motion appear 
smoother and more natural.

Original rotating layer

Rotating layer with motion blur applied

You can use motion blur when you are animating a layer—for example, moving a layer of text 
across the screen. You cannot add motion blur to motion that already exists within a layer, such as 
live-action video of a running person. If you want to smooth live-action video where you assigned a 
frame rate much lower or higher than the original, use frame blending. See Enhancing time-altered 
motion by blending frames and Using frame blending.

See also: 

Using motion blur 

Adjusting the shutter angle for motion blur 

Using the Adjustment Layer switch 

Applying layer switches to nested compositions 
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Using motion blur

Use the Motion Blur switch to apply motion blur to a layer. The Motion Blur switch is different from 
the Motion Blur and Radial Blur effects. The Motion Blur switch creates a true motion blur based on 
a layer’s movement in a composition and a shutter angle you specify (see Adjusting the shutter 
angle for motion blur). The Motion Blur and Radial Blur effects synthesize a blur based on arbitrary 
values you specify in the Effect Controls window, which may not account for actual layer movement.
For more information, see Effects included with After Effects.

Motion blur slows previewing and rendering, so you might want to apply motion blur without 
displaying it in the Composition window. The Enable Motion Blur button lets you control whether 
layers that use motion blur affect redraw and rendering. You can also enable motion blur for all 
compositions when you render a movie. For more information, see Changing render settings.

See also: 

To apply motion blur to a layer 

To preview and render motion blur for all layers in a composition 



Using motion blur 

To apply motion blur to a layer:

Do one of the following:
•      In the Time Layout window, click the Motion Blur switch for a layer.

Motion blur switch off (left) and on (right)
•      Select a layer, choose Layer > Switches, and make sure Motion Blur is selected (to turn it on) or
deselected (to turn it off).

See also: 

To preview and render motion blur for all layers in a composition 



Using motion blur 

To preview and render motion blur for all layers in a composition:

Do one of the following:
•      Click the Enable Motion Blur button at the top of the Time Layout window.

Motion blur disabled (left) and enabled (right)
•      Select Enable Motion Blur from the Time Layout window menu.

See also: 

To apply motion blur to a layer 
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Adjusting the shutter angle for motion blur

You can adjust the intensity of motion blur by setting the shutter angle preference. The shutter angle
is measured in degrees, simulating the exposure allowed by a rotating shutter. If you are not 
applying motion blur, shutter angle has no effect.

The shutter angle uses the footage frame rate to determine the simulated exposure. For example, 
entering 90 degrees (25% of 360 degrees) for 24-fps footage creates an effective exposure of 1/96 
of a second (25% of 1/24 of a second). Entering 1 degree applies almost no motion blur, and 
entering 360 degrees applies the maximum amount of blur. By default, the shutter angle is set to 
180 degrees.

To set the shutter angle for motion blur:

1    Choose File > Preferences > General.

2    Enter a value for Shutter Angle, and then click OK.

Note: You can also change the shutter angle for a composition in the Render Queue window. See Changing 
render settings.
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Using the Adjustment Layer switch

You can use the Adjustment Layer switch to turn adjustment layers on or off or to convert an 
existing footage layer into an adjustment layer. When you convert a layer into an adjustment layer, 
the footage disappears from the Composition window, and the layer’s alpha channel and applied 
effects modify the layers below in the Time Layout window outline. The effects modify other layers 
only where the other layers intersect with the adjustment layer’s alpha channel or mask. See 
Creating an adjustment layer.

When you disable the Adjustment Layer switch for a new adjustment layer, the layer displays as a 
white solid. When you disable the Adjustment Layer switch for a footage layer, the original footage 
displays and the layer’s effects alter only that layer.

To turn the Adjustment Layer switch on or off:

In the Time Layout window, click the Adjustment Layer switch for a layer.

Adjustment Layer switch off (left) and on (right)



About motion blur 

Applying layer switches to nested compositions

By default, changing the setting of some layer switches affects the composition that contains the 
switch and all of the compositions nested within it. The switches in this group are the Quality, 
Collapse Transformations/Continuously Rasterize, Enable Motion Blur, and Enable Frame Blending 
switches, as well as the Resolution setting for the composition (see Setting resolution). You can 
change this preference so the switches affect only the composition that contains the switch. 

To disable switches in nested compositions: 

1    Choose File > Preferences > General.

2    Deselect Recursive Switches, and then click OK.



Managing Layers 

Using audio layers

In After Effects, you can change volume levels of audio layers, preview them at a specified quality, 
and identify and mark locations. An audio layer contains different properties than a footage layer, 
but you modify them the same way. You can apply special audio effects to audio layers, and adjust 
the waveform values. 

See also: 

Previewing audio 

Scrubbing composition audio 

Changing volume levels of an audio layer 



Using audio layers 

Previewing audio

When you preview audio, you have control over the quality and length of the preview. The audio 
preview preferences you set do not affect rendering; the quality or audio in rendered video is 
determined by the output module setting; see Changing output module settings.

While previewing audio, After Effects displays clipping signals that indicate when the audio is 
clipping. Clipping is a distortion that occurs when the audio signal exceeds the maximum level of 
the audio processing equipment. 

After Effects also displays a Volume Unit (VU) meter that actively displays audio levels during 
playback. To view the VU meter and levels controls in more detail, increase the height of the Audio 
palette.

A. Audio clipping warning icons B. VU meter C. Level controls D. Level units E. Audio Options menu F. Level 
values

You can also preview audio synchronized with layer motion. For more information, see Previewing 
animation.

See also: 

To set display options for the Audio palette 

To set preferences for audio preview 

To preview audio 

To preview audio and rendered images 



Previewing audio 

To set display options for the Audio palette:

1    In the Audio palette, click the triangle in the upper right corner and choose Options.

2    In the Audio Options dialog box, select one of the following:
•      Decibels to display audio levels as decibels.
•      Percentage to display audio levels as a percentage, where 100% equals 0 dB.

3    From the Slider Minimum menu, select the minimum decibel level you want to display in the 
Audio palette, and then click OK.

See also: 

To set preferences for audio preview 

To preview audio 

To preview audio and rendered images 



Previewing audio 

To set preferences for audio preview:

1    Choose File > Preferences > General.

2    In the Audio Preview section, choose an audio sample rate from the first menu.

3    Choose an audio sample size from the second menu.

4    Choose Stereo or Mono playback from the third menu.

5    Type a duration for the audio preview. An audio preview begins at the current-time marker and 
continues for the duration you specify here. This option is useful when you are checking short 
passages of a composition, although you can interrupt an audio preview at any time.

6    Click OK.
 CD quality sound is 

44.1 KHz, 16-bit stereo. However, to reduce the time and memory required to preview, you may want to 
choose a lower bit depth and sample rate.

See also: 

To set display options for the Audio palette 

To preview audio 

To preview audio and rendered images 



Previewing audio 

To preview audio:

1    In the Composition window or Time Layout window, move the current-time marker to the time 
where you want the preview to begin.

2    Choose Composition > Preview > Audio (Here Forward), or press the period key (.) on the 
numeric keypad.

See also: 

To set display options for the Audio palette 

To set preferences for audio preview 

To preview audio and rendered images 



Previewing audio 

To preview audio and rendered images:

1    In the Composition window or Time Layout window, move the current-time marker to the time 
where you want the preview to begin.

2    Set the work area for the area you want to preview. For more information, see Setting up a work 
area.

3    Click the Audio button on the Time Controls palette, and then click the Real-time Preview button,
or press 0 (zero) on the numeric keypad.

4    Click the Loop button to loop the audio preview.

See also: 

To set display options for the Audio palette 

To set preferences for audio preview 

To preview audio 



Using audio layers 

Scrubbing composition audio

You can also preview audio by scrubbing the audio in a composition. Scrubbing lets you easily 
identify and mark a location to synchronize audio and visual effects. Instead of using the audio 
wave form, you can identify a location in the layer by moving the current-time marker in the Time 
Layout window and listening to audio playback. 

To scrub composition audio:

In the Time Layout window, move the current-time marker while pressing the Control key (Windows)
or the Command key (Mac OS). After Effects plays segments of the audio as you move across time.
You can play the audio forwards or backwards. If you stop moving the current-time marker while 
keeping the mouse depressed, a short section of audio will loop.



Using audio layers 

Changing volume levels of an audio layer

When you use footage containing audio, the audio level in the footage plays at 0 decibels in After 
Effects, meaning that the level is unadjusted in After Effects. Setting a positive decibel level 
increases volume, and setting a negative decibel level decreases volume.

The VU meter in the Audio palette displays the volume range for the audio as it plays. The red 
blocks at the top of the meter represent the limit of what your system can handle. When the audio 
volume extends past the top of the meter, After Effects makes the speaker icons red as a warning 
that audio is clipping. If you don’t lower the level, the audio playback may be distorted when 
rendered. You can reset the warning signal to black by clicking the red speaker icon.

You can adjust the audio level and set level keyframes by dragging the level sliders as you preview 
an audio layer.

To set the volume level of an audio layer in the Audio palette:

1    Select the layer in the Composition window or Time Layout window.

2    If the Audio palette is not visible, choose Window > Show Audio. For greater precision in setting 
levels, drag the resize icon in the lower right corner of the Audio palette to increase its size.

3    In the Audio palette, adjust volume as follows:
•      To set the level of the left and right channels together, drag the center slider up or down.
•      To set the level of the left channel, drag the left slider up or down, or enter a new value in the 
levels box at the bottom of the left slider.
•      To set the level of the right channel, drag the right slider up or down, or enter a new value in the 
levels box at the bottom of the right slider.



Animating Layers

The ability to animate layers is one of the most powerful features of After Effects. Animation is the 
creation of change over time, and creating change over time in After Effects is simple. At one point 
in time, you set a value for a layer property; and then at another point in time, you change that 
value. After Effects interpolates (calculates) the values for all frames in between, animating the 
change.

You can animate different layer properties, such as position, rotation, masks, and effects, with 
endless possibilities for creativity. Each change can occur independently of, and yet simultaneously 
with, other changes. For example, you can make a layer move in any direction around the screen, 
changing its opacity, rotation, size, color balance, and effect intensity. 

See also: 

About layer properties 

Understanding keyframes 

Setting keyframes 

Moving and copying keyframes 

Determining where to set and modify keyframes 

Setting and animating position 

Subpixel positioning 

Modifying a motion path 

Changing the number of visible motion-path keyframes 

Using Motion Sketch to draw a motion path 

Setting and animating size 

Flipping a layer using Scale property keyframes 

Setting and animating opacity 

Setting and animating rotation 

Rotating a layer along a motion path 

Setting and animating an anchor point 

Setting and animating mask shapes and feathers 

Setting and animating effects 

Setting preview options 

Previewing animation 



Animating Layers 

About layer properties

Each layer can contain several sets of properties. Layers that contain video or still images have 
mask and transform properties, such as mask shape or layer rotation. A layer can also include other
properties, such as time remapping, video effects, and audio effects. 

After Effects provides two ways to animate layer properties. You can animate a layer graphically in 
a Composition or Layer window, or by entering numbers into a dialog box. You use each method in 
a slightly different way:
•      When you animate a layer graphically, you change a value relative to the previous value. For 
example, you move a layer by selecting it at its existing position and then dragging it ten pixels to 
the left.
•      When you animate a layer numerically, you change a value by specifying an absolute number. 
For example, you move a layer by entering new coordinate values for the Position property. You can
open a layer property dialog box by clicking the underlined value in the Time Layout window or by 
choosing the property from the Layer menu.

See also: 

Viewing layer properties in the Time Layout window 



About layer properties 

Viewing layer properties in the Time Layout window

As you add layers to a composition, they are added to the top of the layer outline in the Time Layout
window. You can expand the layer outline to display layer properties and change property values. 

Keyboard shortcuts can help you quickly display a layer property and save space in the Time 
Layout window. Using shortcuts displays only the property you are modifying, hiding all others. For 
more information, see the After Effects Quick Reference Card.

See also: 

To expand a layer outline heading 

To collapse a layer outline heading 

To expand or collapse all layer outline headings 



Viewing layer properties in the Time Layout window 

To expand a layer outline heading:

1    Click the triangle to the left of the layer name so that it points downward.

2    Click the triangle to left of Masks, Effects, or Transform to further expand the outline.

See also: 

To collapse a layer outline heading 

To expand or collapse all layer outline headings 



Viewing layer properties in the Time Layout window 

To collapse a layer outline heading:

Click the triangle to the left of the layer name so that it points to the right.

See also: 

To expand a layer outline heading 

To expand or collapse all layer outline headings 



Viewing layer properties in the Time Layout window 

To expand or collapse all layer outline headings:

Select the layer and then press the grave accent (`) key. The first level of outline headings expands 
or collapses. When outline headings expand, subheadings return to the state they were in the last 
time headings were expanded.

See also: 

To expand a layer outline heading 

To collapse a layer outline heading 



Animating Layers 

Understanding keyframes

After Effects uses keyframes to create and control animation. A keyframe marks the point in time in 
a composition where you specify a value for a layer property. Animation of any kind requires at least
two keyframes. Change begins at the first keyframe and continues until it reaches the second 
keyframe. After Effects creates animation between keyframes by interpolating transition frames 
between each keyframe using intermediate values based on the changing property values from one
keyframe to the next. 

Two Position keyframes and the interpolated frames in between create a motion path.

You can modify layer properties with or without setting keyframes. If you do not set keyframes, or if 
you set only one keyframe, changes you make to the property value remain in effect for the duration
of the layer. 

A keyframe contains the following information:
•      When the change occurs.
•      Which layer property is changing.
•      The value of a layer property at that keyframe’s point in time.
•      The type of change (for example, smooth or abrupt) between the values at the previous, 
selected, and next keyframe.
•      How fast change occurs between keyframes.

See also: 

Time-vary stopwatch 

Keyframe navigator 

Keyframe icons 



Understanding keyframes 

Time-vary stopwatch

Each layer property has a time-vary stopwatch icon ( ) that you must click to begin the animation 
process. Once the stopwatch is active for a specific property, After Effects automatically sets new 
keyframes whenever you change the current time and the property value. When the stopwatch is 
deselected, no keyframes are present. If you enter a value for a layer property while the stopwatch 
is deselected, the value remains in effect for the duration of the layer.

A. Selected stopwatch B. Deselected stopwatch



Understanding keyframes 

Keyframe navigator

After you set the initial keyframe for a property, After Effects displays the keyframe navigator, which 
you can use to move from keyframe to keyframe or to set or remove keyframes. When the 
keyframe navigator box is selected, the current-time marker lies precisely at a keyframe for that 
layer property. When it is deselected, the current-time marker lies between keyframes. When there 
is no keyframe navigator, no keyframes exist for that property on that layer. When arrows appear on
each side of the keyframe navigator box, other keyframes for that property exist on both sides of the
current time. You can click the arrows to move to the previous or next keyframe. 

A. Keyframe at current time B. No keyframe at current time C. No keyframes for layer property



Understanding keyframes 

Keyframe icons

The appearance of a keyframe icon depends on the interpolation method you chose for the interval 
between keyframes. When half of the icon is gray, the gray half indicates that there is no keyframe 
adjacent to that side, or that its interpolation is overridden by the Hold interpolation applied to the 
preceding keyframe. See Comparing interpolation methods.

Keyframe icons A. First keyframe for layer property B. Keyframe following a Hold keyframe C. Last keyframe 
for layer property

You can change the keyframe icons to numbers by choosing Use Keyframe Indices in the Time 
Layout window menu, located on the right side of the window.

Keyframes as icons

Keyframes as indices (numbers)



Animating Layers 

Setting keyframes

You can set keyframes for any type of layer and any combination of layer properties at any point in 
time. At any time, you can move, delete, or change the value or interpolation method of a keyframe.

This section provides an overview of setting keyframes. For details on changing and animating 
individual layer properties, see the specific sections for each property, for example Setting and 
animating position.

See also: 

To set the first keyframe for a layer property 

To add additional keyframes for a layer property 

To add a keyframe without changing a value 

Selecting keyframes 

Deleting keyframes 



Setting keyframes 

To set the first keyframe for a layer property:

1    In the Time Layout window, select the layer you want to animate, and then display the layer 
property you want to animate.

2    Move the current-time marker to a point in time where you want to add a keyframe.

3    Set the layer property to the value you want at that point in time; for example, move the layer to 
a new position. For information on setting each layer property, see the specific property section in 
this chapter; for example, see Setting and animating position.

4    Click the stopwatch icon ( ) next to the property name to activate it. After Effects creates a 
keyframe at the current time for that property value.

See also: 

To add additional keyframes for a layer property 

To add a keyframe without changing a value 

Selecting keyframes 

Deleting keyframes 



Setting keyframes 

To add additional keyframes for a layer property:

1    In the Time Layout window, select the layer you want to animate

2    Display the layer property for which you want to add a keyframe. It must already contain at least 
one keyframe, and the stopwatch must be activated.

3    Move the current-time marker to the point in time where you want to add a new keyframe.

4    Change the value for the layer property you are animating. After Effects adds a keyframe 
automatically.

Once you set an initial property keyframe (left), After Effects adds keyframes automatically as you change the 
property values at other points in time (right).

See also: 

To set the first keyframe for a layer property 

To add a keyframe without changing a value 

Selecting keyframes 

Deleting keyframes 



Setting keyframes 

To add a keyframe without changing a value:

1    Display the Time Layout window for the composition containing the layer you want to animate.

2    Display the layer property for which you want to add a keyframe. The property must already 
contain at least one keyframe, and the stopwatch must be activated.

3    Move the current-time marker to the point in time where you want to add a new keyframe.

4    Click the keyframe navigator option for the layer property. If the current-time marker is after the 
last keyframe for that layer property, the new keyframe will have the same value as the preceding 
keyframe. Otherwise, the new keyframe’s value will be an interpolated value based on the previous 
and next keyframe values.

See also: 

To set the first keyframe for a layer property 

To add additional keyframes for a layer property 

Selecting keyframes 

Deleting keyframes 



Setting keyframes 

Selecting keyframes

If you want to modify or copy a keyframe, you must first select it. After Effects provides many 
methods for selecting one or more keyframes.

See also: 

To select a keyframe 

To select multiple keyframes 

To select all keyframes for a layer property 

To move the current-time marker to the previous or next keyframe 

To snap the current-time marker to a keyframe 



Selecting keyframes 

To select a keyframe:

Do one of the following:
•      Click the keyframe icon in the Time Layout window’s time graph.
•      Using the selection tool, click the keyframe icon on the motion path in the Composition or Layer 
window.

See also: 

To select multiple keyframes 

To select all keyframes for a layer property 

To move the current-time marker to the previous or next keyframe 

To snap the current-time marker to a keyframe 



Selecting keyframes 

To select multiple keyframes:

Do one of the following:
•      Press Shift as you click to select multiple keyframes in any window.
•      Drag a selection marquee around the keyframes you want to select in the Time Layout window.

See also: 

To select a keyframe 

To select all keyframes for a layer property 

To move the current-time marker to the previous or next keyframe 

To snap the current-time marker to a keyframe 



Selecting keyframes 

To select all keyframes for a layer property:

In the layer outline, click the layer property name. For example, click the word Position to select all 
the Position keyframes for a layer.

See also: 

To select a keyframe 

To select multiple keyframes 

To move the current-time marker to the previous or next keyframe 

To snap the current-time marker to a keyframe 



Selecting keyframes 

To move the current-time marker to the previous or next keyframe:

Click a keyframe navigator arrow. The arrow to the left moves the current-time marker to the 
previous keyframe. The arrow to the right moves the current-time marker to the next keyframe.

See also: 

To select a keyframe 

To select multiple keyframes 

To select all keyframes for a layer property 

To snap the current-time marker to a keyframe 



Selecting keyframes 

To snap the current-time marker to a keyframe:

Hold down Shift as you drag the current-time marker to a keyframe.

See also: 

To select a keyframe 

To select multiple keyframes 

To select all keyframes for a layer property 

To move the current-time marker to the previous or next keyframe 



Setting keyframes 

Deleting keyframes

If you make a mistake while setting keyframes, or if you decide a keyframe is no longer needed, 
you can easily delete one or more keyframes from a layer.

To delete a keyframe:

1    Select a keyframe. See Selecting keyframes.

2    Do one of the following:
•      Press Delete on your keyboard.
•      Choose Edit > Clear.
•      Deselect the keyframe navigator box.

When you delete a keyframe, change for that interval starts at the previous keyframe, and if there is
a subsequent keyframe, continues to that keyframe.

To delete all keyframes of one layer property:

Do one of the following:
•      Click the stopwatch icon to the left of the name of the layer property to deactivate it.

•      Click the property name in the layer outline to select all keyframes, and then press the Delete 
key.

Note: When you deselect the stopwatch icon, keyframes for that property are permanently removed and the 
value of that property becomes the value at the current time. You cannot restore deleted keyframes by 
reselecting the stopwatch. If you accidentally delete keyframes, choose Edit > Undo.



Animating Layers 

Moving and copying keyframes

You can easily move keyframes to different points in time or copy them to different layers. Moving 
keyframes makes it easy to change when animations occur. Copying keyframes lets you easily use 
the same property setting in different layers. You can also copy a property value from a layer that 
contains no keyframes. For more information, see Copying a value from a layer without keyframes.

Note: To copy an entire layer, including the source footage and keyframes, see Duplicating a layer.

See also: 

Moving keyframes 

Copying and pasting keyframes 

Moving a layer duration bar independently of its keyframes 

Copying a value from a layer without keyframes 

Changing several keyframe values at once 



Moving and copying keyframes 

Moving keyframes

You can move any keyframe to a different point in time. When you move keyframes, you move the 
values and settings they contain. 

See also: 

To move a keyframe to another time 

To move multiple keyframes to another time 

To move a keyframe precisely to a different time 



Moving keyframes 

To move a keyframe to another time:

Drag one keyframe icon to the desired time.

See also: 

To move multiple keyframes to another time 

To move a keyframe precisely to a different time 



Moving keyframes 

To move multiple keyframes to another time:

1    Select the keyframes you want to move. See Selecting keyframes.

2    Drag any selected keyframe icon to the desired time. All of the other selected keyframes 
maintain their relative distance from the keyframe you drag.

See also: 

To move a keyframe to another time 

To move a keyframe precisely to a different time 



Moving keyframes 

To move a keyframe precisely to a different time:

1    Move the current-time marker to the desired time.

2    Hold down Shift after you begin to drag a keyframe icon to the current-time marker. When you 
drag over the current-time marker, the keyframe snaps to the current-time marker, and the 
keyframe navigator box for that property is selected to indicate that the keyframe is at the current 
time.

See also: 

To move a keyframe to another time 

To move multiple keyframes to another time 



Moving and copying keyframes 

Copying and pasting keyframes

When you want to use the same keyframe values at another point in time or in another layer, copy 
and paste keyframes. You can copy and paste keyframes between layers for the same property, 
such as Position, or you can copy and paste keyframes between different properties that use the 
same type of data. Properties between which you can copy and paste keyframes include:
•      Position, Effect Point, and Anchor Point properties. 
•      Rotation, Effect angle control, and Effect slider control properties.
•      Effect color properties.

You can copy keyframes from only one layer at a time and paste them into one layer at a time. 
When you paste keyframes into another layer, they appear in the corresponding property in the 
destination layer. The earliest keyframe appears at the current time, and the other keyframes follow 
in relative order. The keyframes remain selected after pasting, so you can immediately move them 
in the destination layer. 

Note: When copying and pasting between the same properties, you can copy from more than one property 
and paste to more than one property at a time. However, when copying and pasting to different properties, you 
can copy only from one property and paste to one property at one time.

To copy and paste keyframes:

1    In the Time Layout window, display the layer property containing the keyframes you want to 
copy. 

2    Select one or more keyframes. See Selecting keyframes.

3    Choose Edit > Copy.

4    In the Time Layout window containing the destination layer, move the current-time marker to the 
point in time where you want the keyframes to appear.

5    Select the destination layer and choose Edit > Paste. 



Moving and copying keyframes 

Moving a layer duration bar independently of its keyframes

Once you set keyframes, they maintain their position relative to their layer’s duration bar. If you 
move the duration bar earlier or later in the composition, its keyframes move with it. You can 
prevent this by cutting and pasting keyframes. 

If you want to move keyframes without moving the layer duration bar, select the keyframes and drag
them. See Moving keyframes.

To move a layer duration bar but not its keyframes:

1    Make a note of the time at which the first keyframe appears.

2    In the layer outline, click the name of one or more layer properties containing the keyframes you 
want to keep at the same times. To select more than one property, press Shift as you click the 
property name.

3    Choose Edit > Cut.

4    Move or stretch the layer duration bar to its new In and Out points.

5    Move the current-time marker to the time at which the first keyframe appeared before you cut 
the keyframes.

6    Choose Edit > Paste.

Before and after moving the duration bar without moving the keyframes.



Moving and copying keyframes 

Copying a value from a layer without keyframes

You can copy the current value of a layer property to another layer, even when the original layer 
contains no keyframes. This can save you the time of having to set up a property the same way on 
various layers.

To copy a value from a layer without keyframes:

1    In the Time Layout window, display the layer property containing the value you want to copy.

2    Click the I-beam icon for the layer property to select it.

3    Choose Edit > Copy.

4    Select the layer into which you want to paste the value.

5    If the target layer contains keyframes, move the current-time marker to the time where you want 
to paste the value. If the target layer does not contain keyframes, the new value will apply to the 
entire duration of the layer.

6    Choose Edit > Paste.



Moving and copying keyframes 

Changing several keyframe values at once

You can change the values of multiple keyframes on multiple layers at one time; however, all the 
selected keyframes must belong to the same layer property. When you change more than one 
keyframe value at once, the way the values change depends on how you make the change:
•      If you change a value numerically, all selected keyframes use the new value exactly. In other 
words, you make an absolute change. For example, if you select several Position keyframes on a 
motion path and numerically specify a Position value for one of them, all selected keyframes move 
to the same position.
•      If you change a value graphically in the Composition or Layer window, all selected keyframes 
change using the difference between the old and new values, not the values themselves. In other 
words, you make a relative change. For example, if you select several Position keyframes on a 
motion path and then drag one of them ten pixels to the left, they all move ten pixels to the left of 
their original positions.

To set multiple keyframes to the same value:

1    Select the keyframes you want to change. See Selecting keyframes. All keyframes you select 
must be for the same property.

2    Change the value of any selected keyframe.



Animating Layers 

Determining where to set and modify keyframes

You can freely change any keyframe attribute. Because After Effects provides more than one view 
of a keyframe, where you modify it depends on what you want to do as well as the type of keyframe
and layer property. All layer properties are temporal—they can change the layer over time. Some 
layer properties, such as Position, are also spatial—they can move the layer across composition 
space. You modify some attributes of a spatial layer property in different windows than temporal 
properties. See Comparing interpolation methods.

When modifying a keyframe, consider the following guidelines:
•      Use the Composition window to move, scale, or rotate a layer by dragging the layer directly. You
can also use this window to change motion path shapes, adjust spatial interpolation, and move 
anchor points.
•      Use the Time Layout window to animate non-spatial property values such as opacity, velocity, 
motion-path speed, and temporal interpolation. You can also use this window to enter numerical 
values for any property.
•      Use the Layer window to modify anchor point values, control point values of an effect, and mask
shape values.
•      Use the Effect Controls window to set and change effect values.

Before you make any changes to a keyframe, make sure the current-time marker is positioned at an
existing keyframe. If you change a property value when the current-time marker is not at an existing
keyframe, After Effects will add a new keyframe. However, if you double-click a keyframe to modify 
it, the current-time marker location is not relevant, nor is it relevant when you change a keyframe’s 
interpolation method. See Comparing interpolation methods.

Note: You can also copy and paste keyframes into a tab-delimited spreadsheet application, such as Microsoft 
Excel, and modify the values. This method works for Time Remap, Mask Feather, Anchor Point, Position, 
Scale, Rotation, and Opacity keyframes. 
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Setting and animating position

Every layer appears at a specific position in the Composition window. You determine the initial 
position when you add a layer to a composition. You can move the layer in the Composition window,
in the Time Layout window, or by using keys on your keyboard. For information on layer 
coordinates, see Info palette.

When you animate position values, After Effects displays the movement as a motion path in the 
Composition or Layer window. A motion path appears as a sequence of dots, where each dot marks
the position of the layer at each frame. An X in the path marks the position of a keyframe. The 
density of dots between the Xs indicate the layer’s relative speed. Dots close together indicate a 
slower speed; dots farther apart indicate a greater speed.

Faster (left) and slower speed (right)

See also: 

To quickly access the Position property for a layer 

To move a layer numerically 

To move a layer by dragging in the Composition window 

To precisely move a layer 

To animate the Position property (create a motion path) 



Setting and animating position 

To quickly access the Position property for a layer:

In the Time Layout window, select the layer you want to modify and press P on your keyboard.

See also: 

To move a layer numerically 

To move a layer by dragging in the Composition window 

To precisely move a layer 

To animate the Position property (create a motion path) 



Setting and animating position 

To move a layer numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the outline to display the Position property for the layer (under Transform) or press P on 
your keyboard.

3    Click the underlined Position values.

4    Enter new values, and then click OK. 

Note: The X and Y coordinates represent the distance in pixels of a layer’s anchor point from the top left 
corner of the composition. The X coordinate represents the distance from the left edge of the composition, 
while the Y coordinate represents the distance from the top edge of the composition. For information on layer 
coordinates, see Info palette. 

See also: 

To quickly access the Position property for a layer 

To move a layer by dragging in the Composition window 

To precisely move a layer 

To animate the Position property (create a motion path) 



Setting and animating position 

To move a layer by dragging in the Composition window:

In the Composition window, drag the layer to a new location. 
If you have difficulty 

selecting a layer in the Composition window, first select it in the Time Layout window, and then drag it in 
the Composition window. Make sure you do not drag the layer by its anchor point or a layer handle.

See also: 

To quickly access the Position property for a layer 

To move a layer numerically 

To precisely move a layer 

To animate the Position property (create a motion path) 



Setting and animating position 

To precisely move a layer:

To move a layer by a specific amount, do one of the following:
•      To nudge a layer by one pixel at the current magnification, press the Left, Right, Up, or Down 
arrow key.
•      To nudge a layer by ten pixels at the current magnification, press Shift as you press the Left, 
Right, Up, or Down arrow key.
•      To constrain horizontal and vertical movement while dragging a layer, press Shift after you start 
dragging the layer in the Composition window.
•      To snap the edge of the layer to the edge of the Composition window frame, press Alt + Shift 
(Windows) or Option + Shift (Mac OS) after you start dragging the layer in the Composition window.

See also: 

To quickly access the Position property for a layer 

To move a layer numerically 

To move a layer by dragging in the Composition window 

To animate the Position property (create a motion path) 



Setting and animating position 

To animate the Position property (create a motion path):

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to animate.

3    Press P to display the Position property.

4    Move the layer to the position where you want it to begin by either dragging it in the Composition
window or clicking the underlined Position values in the Time Layout window to change them.

5    Click the stopwatch icon to the left of the Position property to select it.

6    Move the current-time marker to the time where you want to add the second keyframe.

7    Change the position values of the layer; for example, in the Composition window, drag it to a 
new position. A second keyframe appears in the Time Layout window.

8    Repeat steps 6 and 7 as many times as you want to add keyframes.

Note: If a keyframe appears to be added out of sequence, start over and make sure that you drag the layer 
and not an existing keyframe in the Composition window. Keyframe icons in the Composition window appear 
as an X. 

See also: 

To quickly access the Position property for a layer 

To move a layer numerically 



To move a layer by dragging in the Composition window 

To precisely move a layer 
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Subpixel positioning

After Effects computes all Position and Effect values to subpixel locations. While this is desirable for
smooth animation, you may notice additional softness on non-moving images if they are positioned 
at fractional pixel locations.

After Effects resamples and positions a layer at a subpixel location when you scale or rotate it, or 
when the difference between the Position value and the Anchor Point value is not a whole integer 
value. For example, if the X and Y Position coordinates of your layer are (320, 240) and its Anchor 
Point coordinates are (160, 120), the difference is (160, 120), so the image will not be resampled. 
Conversely, if your layer Position coordinates are (321, 240) and its Anchor Point coordinates are 
(160.5, 120), the difference is (160.5, 120), so the image will be resampled. To ensure optimal 
image quality when setting Position keyframes for a layer, use only integer values for Position 
coordinates.

Because the default anchor point for a layer is the center of an image, odd-sized images (for 
example, 640-by-475 or 325-by-65) have non-integer Anchor Point values and appear soft when 
placed at integer Position values.
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Modifying a motion path

You can modify a motion path by either changing an existing keyframe or adding a new keyframe. A
motion path is less complex and generally easier to modify when you use fewer keyframes to 
describe the path. If you want to add a new keyframe to a motion path, make sure the current-time 
marker is positioned at the time you want the new keyframe to occur. If you want to change an 
existing keyframe, make sure the current-time marker is positioned at the existing keyframe; 
otherwise, After Effects will add a new keyframe. For information on controlling speed on a motion 
path, see Controlling speed along a motion path.

The motion-path controls you see in the Composition window depend on the options selected in the
Composition window menu. For maximum control over the shape of a motion path, use the pen 
tools and the spatial interpolation methods After Effects provides. See Controlling change through 
interpolation and Applying Bezier interpolation graphically.

A. Layer handle B. Layer keyframe C. Direction handle on direction line D. Composition window menu E. 
Layer path

See also: 

To move a position keyframe 

To add a position keyframe by moving the layer 

To add a keyframe using the pen tool 

To move all points on a motion path in unison 



Modifying a motion path 

To move a position keyframe:

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to modify.

3    Expand the outline to display the Position property for the layer (under Transform) or press P on 
your keyboard.

4    If you cannot see the keyframe you want to modify in the Composition window, move the 
current-time marker in the Time Layout window to the keyframe.

5    In the Composition window, use the pointer tool to drag a keyframe marker or its control handles
on the motion path to a new position.

Note: The current time marker does not need to be located on a keyframe before you drag it.

See also: 

To add a position keyframe by moving the layer 

To add a keyframe using the pen tool 

To move all points on a motion path in unison 



Modifying a motion path 

To add a position keyframe by moving the layer:

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to modify.

3    Press P to display the Position property.

4    In the Time Layout window, move the current-time marker to the time where you want to add a 
new keyframe.

5    Move the layer by dragging it in the Composition window or by changing its Position property 
value.

See also: 

To move a position keyframe 

To add a keyframe using the pen tool 

To move all points on a motion path in unison 



Modifying a motion path 

To add a keyframe using the pen tool:

1    Display the Time Layout and Composition windows for a composition.

2    Select the layer you want to modify.

3    Select the pen tool ( ) from the toolbox.
4    In the Composition window, move the pen tool over the motion path where you want to add the new 
keyframe and click to add the keyframe. 

A new keyframe appears at the frame you clicked, on the motion path and in the Time Layout 
window. If you want to move the keyframe, use the selection tool.

See also: 

To move a position keyframe 

To add a position keyframe by moving the layer 

To move all points on a motion path in unison 



Modifying a motion path 

To move all points on a motion path in unison:

1    Display the Composition and Time Layout windows for a composition.

2    In the Time Layout window, select the layer containing the motion path you want to move.

3    Press P to open the Position property.

4    Click the word “Position” to select all Position keyframes.

5    In the Composition window, click a keyframe and drag the path to a new position.

See also: 

To move a position keyframe 

To add a position keyframe by moving the layer 

To add a keyframe using the pen tool 
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Changing the number of visible motion-path keyframes

By default, After Effects displays motion path keyframes and dots in the Composition window that 
fall within a 15-second range from the current-time marker. However, you can change this default. 
For greater precision when extensively modifying a motion path, you can display more keyframes. If
you want to speed up screen updates, you can display fewer keyframes.

To change the number of visible motion-path keyframes:

1    Choose File > Preferences > Display.

2    In the Motion Path section of the Display Preferences dialog box, select one of the following 
options, and then click OK:
•      Click All Keyframes to display every keyframe in the window.
•      Click No More Than __ Keyframes to specify a maximum number of keyframes to display, 
centered on the current-time marker.
•      Click No More Than __ to specify a range of time within which keyframes display, centered on 
the current-time marker.
•      Click No Motion Path to prevent the display of a motion path and its keyframes.
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Using Motion Sketch to draw a motion path

You can draw a path for the motion of a selected layer using Motion Sketch, which records the 
position of the layer and the speed at which you draw. You can create a path anywhere within a 
composition; you can speed up, slow down, stop, and then start again. You can record speed in real
time, so that the motion will play back at the exact speed at which you draw, or you can specify that 
After Effects records the motion faster or slower than your drawing speed. As you create the path, 
After Effects generates a position keyframe at each frame, using the frame rate specified in the 
composition.

As you draw the motion path in the Composition window, After Effects generates position keyframes, recording
the speed at which you draw.

Motion Sketch does not affect keyframes you have set for other properties. For example, if you set 
rotation keyframes for an image of a ball, you can use Motion Sketch to generate position 
keyframes, so that the ball appears to roll along the path you created.

To sketch a motion path:

1    In the Composition or Time Layout window, select the layer for which you want to sketch a 
motion path.

2    In the Time Layout window, set the work area markers to the area in which you want to sketch 
motion.

3    Choose Window > Plug-in Palettes > Motion Sketch.

4    Select one of the following Motion Sketch options:
•      Show Wireframe displays a wireframe view of the layer as you sketch the motion path. A 
wireframe view is especially useful if you display the contents of the Composition window while 
sketching (see the next option). The wireframe view lets you see the boundaries of the moving layer
as you move it across the window. In addition, the wireframe view lets you see any rotation or 
scaling that you have applied to the layer.
•      Keep Background displays the contents of the Composition window while you sketch. Viewing 
the contents of the window is useful if you want to sketch motion relative to other images in your 
composition. Note that After Effects does not show the animation of other layers; while you sketch, 
After Effects displays only the first frame at the time you start sketching. If you do not select this 
option, After Effects displays the motion path as a series of white dots on a black background.

5    If the composition contains audio, choose Window > Show Time Controls and click the Audio 
button to play all audio in the composition as you sketch. Playing audio is useful if you are 
synchronizing motion with sound.

6    For Speed, set the capture speed of the motion by specifying a percentage for how fast the 
motion plays back in relation to how fast you draw the path. You set the playback speed in one of 
the following ways:



•      To set the playback speed to the exact speed at which you sketch, set the capture speed to 
100%. 
•      To set the playback speed faster than the sketching speed, set the capture speed greater than 
100%. If you set it to 200%, for example, After Effects would play back the motion twice as fast as 
your sketching speed. 
•      To set the playback speed slower than the sketching speed, set the capture speed less than 
100%. If you set the number to 50%, for example, After Effects would play back the motion half as 
fast as your sketching speed.

7    Click Start Capture, and then, in the Composition window, drag the layer to create the motion 
path. Release the mouse button to end the path. If you drag the mouse outside of the work area, 
After Effects automatically ends the path.
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Setting and animating size

By default, a layer appears at 100% of its original size in the Layer window. You can change the 
scale of a layer over time by dragging the layer’s handles in the Composition window or by 
changing the Scale property values in the Time Layout window. You can scale the layer partially or 
completely outside the frame. When you scale, the layer is scaled around its anchor point. For more
information, see Setting and animating an anchor point.

To quickly access the Scale property for a layer:

In the Time Layout window, select the layer you want to modify and press S on your keyboard.

See also: 

To scale a layer numerically 

To scale a layer by dragging 

To scale a layer by nudging it one percent 

To scale a layer by nudging it ten percent 

To animate a layer’s scale 



Setting and animating size 

To scale a layer numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Scale property (under Transform) or press S on your 
keyboard.

3    Click the underlined Scale value. 

4    Choose a unit of measure from the Units menu.

5    Click Preserve Frame Aspect Ratio if you want to maintain the existing aspect ratio of the layer.

6    Enter a value. If you did not select Preserve Frame Aspect Ratio, enter values for both Width 
and Height.

7    Click OK.

See also: 

To scale a layer by dragging 

To scale a layer by nudging it one percent 

To scale a layer by nudging it ten percent 

To animate a layer’s scale 



Setting and animating size 

To scale a layer by dragging:

In the Composition window, do one of the following:
•      To scale proportionally, hold down Shift as you drag any layer handle.
•      To scale freely, drag a corner layer handle.
•      To scale one dimension only, drag a side layer handle.

See also: 

To scale a layer numerically 

To scale a layer by nudging it one percent 

To scale a layer by nudging it ten percent 

To animate a layer’s scale 



Setting and animating size 

To scale a layer by nudging it one percent:

Select a layer and then press Alt (Windows) or Option (Mac OS) as you press + or – on the numeric
keypad. (Press + to enlarge the layer. Press – to shrink the layer.)

See also: 

To scale a layer numerically 

To scale a layer by dragging 

To scale a layer by nudging it ten percent 

To animate a layer’s scale 



Setting and animating size 

To scale a layer by nudging it ten percent:

Select a layer and then press Alt + Shift (Windows) or Option + Shift (Mac OS) as you press + or – 
on the numeric keypad. (Press + to enlarge the layer. Press – to shrink the layer.)

See also: 

To scale a layer numerically 

To scale a layer by dragging 

To scale a layer by nudging it one percent 

To animate a layer’s scale 



Setting and animating size 

To animate a layer’s scale:

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to animate.

3    Move the current-time marker to the time where you want to begin scaling.

4    Press S to display the Scale property.

5    Set the layer’s starting size by either dragging the layer handles in the Composition window or 
clicking the underlined Scale values in the Time Layout window and entering new values.

6    Click the Scale property stopwatch icon to set the initial keyframe.

7    Move the current-time marker to the time where you want to add the second keyframe.

8    Change the scale value for the layer; for example, drag the handles to decrease the size.

9    Repeat steps 7 and 8 as many times as you want to add more keyframes.

See also: 

To scale a layer numerically 

To scale a layer by dragging 

To scale a layer by nudging it one percent 

To scale a layer by nudging it ten percent 
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Flipping a layer using Scale property keyframes

You can flip a layer using the numerical Scale option. A layer flips around its anchor point, so if you 
move the anchor point away from the center of the layer, it may move when you flip it. For more 
information, see Setting and animating an anchor point.

See also: 

To flip a layer by dragging 

To flip a layer numerically 



Flipping a layer using Scale property keyframes 

To flip a layer by dragging:

In the Composition window, drag a layer handle over and past the layer’s anchor point.

See also: 

To flip a layer numerically 



Flipping a layer using Scale property keyframes 

To flip a layer numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Scale property (under Transform) or press S on your 
keyboard.

3    Click the underlined Scale value.

4    In the Scale dialog box, deselect Preserve Frame Aspect Ratio.

5    Do one of the following and then click OK:
•      To flip horizontally, enter a negative Width value.
•      To flip vertically, enter a negative Height value.

A. Width 100, Height 100 B. Width -100, Height 100 C. Width 100, Height -100 D. Width -100, Height -100

See also: 

To flip a layer by dragging 
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Setting and animating opacity

By default, a layer is displayed at full opacity except for areas excluded by a mask or alpha channel.
You can adjust the degree of transparency by setting an opacity value of less than 100%. When you
change a layer’s opacity, the changes you create are temporal. They do not involve a movement in 
space. You set and change opacity only in the Time Layout window. 

See also: 

To quickly access the Opacity property for a layer 

To set a layer’s opacity numerically 

To set a layer’s opacity by dragging 

To animate a layer’s opacity 



Setting and animating opacity 

To quickly access the Opacity property for a layer:

In the Time Layout window, select the layer you want to modify and press T (for transparency) on 
your keyboard.

See also: 

To set a layer’s opacity numerically 

To set a layer’s opacity by dragging 

To animate a layer’s opacity 



Setting and animating opacity 

To set a layer’s opacity numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Opacity property (under Transform) or press T on your 
keyboard.

3    Click the underlined Opacity value.

4    Enter a new value and then click OK.

See also: 

To quickly access the Opacity property for a layer 

To set a layer’s opacity by dragging 

To animate a layer’s opacity 



Setting and animating opacity 

To set a layer’s opacity by dragging:

1    In the Time Layout window, select a layer.

2    Press T to display the Opacity property.

3    Press Alt (Windows) or Option (Mac OS) as you click the Opacity property name, and then 
adjust the slider that appears. Drag up to increase opacity, or drag down to decrease opacity.

See also: 

To quickly access the Opacity property for a layer 

To set a layer’s opacity numerically 

To animate a layer’s opacity 



Setting and animating opacity 

To animate a layer’s opacity:

1    Display the Time Layout window for a composition.

2    In the Time Layout window, select the layer you want to animate.

3    Move the current-time marker to the time where you want the opacity changes to begin.

4    Press T to display the Opacity property.

5    Click the underlined Opacity value and enter the layer’s starting opacity. Click OK.

6    Click the Opacity property stopwatch icon to set the initial keyframe.

7    Move the current-time marker to the time where you want to add the second keyframe.

8    Click the underlined Opacity value and enter a new value for the layer. Click OK.

9    Repeat steps 7 and 8 as many times as you want to add more keyframes.

See also: 

To quickly access the Opacity property for a layer 

To set a layer’s opacity numerically 

To set a layer’s opacity by dragging 
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Setting and animating rotation

A layer can rotate any number of degrees in relation to its original orientation. You can rotate a layer
as many times as you want, which is useful when you want to spin an object continuously over time.
You can animate a layer’s rotation in the Composition window using the rotation tool, or in the Time 
Layout window by entering a revolution or degree value. You can rotate a layer partially or 
completely outside the frame

When you rotate, the layer rotates around its anchor point. For more information, see Setting and 
animating an anchor point.

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer numerically 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it one degree 

To rotate a selected layer by nudging it ten degrees 

To animate a layer’s rotation 



Setting and animating rotation 

To quickly access the Rotation property for a layer:

In the Time Layout window, select the layer you want to modify and press R on your keyboard.

See also: 

To change the angle of a layer numerically 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it one degree 

To rotate a selected layer by nudging it ten degrees 

To animate a layer’s rotation 



Setting and animating rotation 

To change the angle of a layer numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Rotation property (under Transform) or press R on your 
keyboard.

3    Click the underlined Rotation value.

4    Enter a new Degrees value, and then click OK.

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it one degree 

To rotate a selected layer by nudging it ten degrees 

To animate a layer’s rotation 



Setting and animating rotation 

To change the angle of a layer by dragging:

1    Select the rotation tool ( ) from the toolbox.
2    In the Composition window, click anywhere on the layer and drag in an arc around the layer. For finer 
control over rotation, drag in a wide arc away from the layer’s anchor point. To add multiple rotations, drag
the rotation tool around the layer continuously for the desired number of rotations. To constrain rotation to 
45-degree increments, hold down Shift as you drag.

Before and after rotating a layer

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer numerically 

To rotate a selected layer by nudging it one degree 

To rotate a selected layer by nudging it ten degrees 

To animate a layer’s rotation 



Setting and animating rotation 

To rotate a selected layer by nudging it one degree:

Press + or – on the numeric keypad.

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer numerically 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it ten degrees 

To animate a layer’s rotation 



Setting and animating rotation 

To rotate a selected layer by nudging it ten degrees:

Press Shift as you press + or – on the numeric keypad.

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer numerically 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it one degree 

To animate a layer’s rotation 



Setting and animating rotation 

To animate a layer’s rotation:

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to animate.

3    Move the current-time marker to the time where you want the rotation to begin.

4    Press R to display the Rotation property.

5    Set the layer’s starting angle by either dragging the layer with the rotation tool in the 
Composition window or clicking the underlined Rotation value in the Time Layout window and 
entering a new value.

6    Click the Rotation property stopwatch icon to set the initial keyframe.

7    Move the current-time marker to the time where you want to add the second keyframe.

8    Change the rotation value for the layer; for example, drag the handle in a partial circle.

9    Repeat steps 7 and 8 as many times as you want to add more keyframes.

See also: 

To quickly access the Rotation property for a layer 

To change the angle of a layer numerically 

To change the angle of a layer by dragging 

To rotate a selected layer by nudging it one degree 

To rotate a selected layer by nudging it ten degrees 
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Rotating a layer along a motion path

You can make a layer rotate automatically as it moves along a motion path. For example, if you 
animate a toy airplane careening through the sky, you can apply auto-orient rotation and make the 
plane turn and change direction.

Before applying auto-orient rotation (left) and after (right)

To use Auto-Orient Rotation:

1    Display the Time Layout and Composition windows for a composition.

2    In the Time Layout window, select the layer you want to modify.

3    Choose Layer > Transform > Auto-Orient Rotation.



Animating Layers 

Setting and animating an anchor point

After Effects rotates and scales from a layer’s anchor point. By default, the anchor point is at the 
center of a layer. You can move the anchor point to change rotation into revolution, making the layer
rotate from one end or the other. For example, if you want to animate a maraca so it appears to be 
shaking, you first need to move the anchor point from the center of the maraca to the end of the 
handle. 

With anchor point in center of layer(left), layer rotates around the center. With anchor point moved to end of 
handle (right), layer rotates from one end.

You move an anchor point in the Layer window. As you do so, the selected layer moves in the 
Composition window, so you can view its position in relation to other layers. You can also move the 
anchor point using the Pan Behind tool in the Composition window. See Moving a mask and 
panning a layer behind a mask. If you animate the anchor point over time, and more than one 
keyframe exists, the window displays a motion path to represent the movement. 

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point numerically 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it one pixel at the current magnification 

To move a layer anchor point by nudging it ten pixels at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To quickly access the Anchor Point property for a layer:

In the Time Layout window, select the layer you want to modify and press A on your keyboard.

See also: 

To move the anchor point numerically 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it one pixel at the current magnification 

To move a layer anchor point by nudging it ten pixels at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To move the anchor point numerically:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Anchor Point property (under Transform) or press A on 
your keyboard.

3    Click the underlined Anchor Point value.

4    Enter a new value, and then click OK.

Note: The anchor point’s coordinates are relative to the Layer window, not the Composition window. For 
information on layer coordinates, see Info palette.

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it one pixel at the current magnification 

To move a layer anchor point by nudging it ten pixels at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To move the anchor point by dragging in the Layer window:

1    In the Composition or Time Layout window, double-click the layer you want to modify or select 
the layer and choose Layer > Open Layer Window.

2    Choose Anchor Point Path from the Layer window menu at the top of the Layer window. The 
anchor point appears as a circle with an X through it.

3    Drag the anchor point to a new location.

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point numerically 

To move a layer anchor point by nudging it one pixel at the current magnification 

To move a layer anchor point by nudging it ten pixels at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To move a layer anchor point by nudging it one pixel at the current 
magnification:

1    In the Time Layout window, double-click the layer.

2    In the Layer window, select Anchor Point Path from the Layer window menu.

3    Press the Left, Right, Up, or Down arrow key.

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point numerically 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it ten pixels at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To move a layer anchor point by nudging it ten pixels at the current 
magnification:

1    In the Time Layout window, double-click the layer.

2    In the Layer window, select Anchor Point Path from the Layer window menu.

3    Press Shift as you press the Left, Right, Up, or Down arrow key.

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point numerically 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it one pixel at the current magnification 

To animate a layer’s anchor point 



Setting and animating an anchor point 

To animate a layer’s anchor point:

1    Display the Time Layout and Layer windows for a layer you want to animate.

2    In the Time Layout window, select the layer.

3    Move the current-time marker to the time where you want the animation to begin.

4    Press A to display the Anchor Point property.

5    Display the anchor point in the Layer window by selecting Anchor Point Path from the Layer 
window menu.

6    Set the starting position for the layer’s anchor point by dragging the anchor point in the Layer 
window or by clicking the underlined Anchor Point values in the Time Layout window and entering 
new values.

7    Click the Anchor Point property stopwatch icon to set the first keyframe.

8    Move the current-time marker to the time where you want to add the second keyframe.

9    Change the anchor point value for the layer. For example, move the anchor point to a new 
location in the Layer window.

10    Repeat steps 8 and 9 as many times as you want to add more keyframes.

See also: 

To quickly access the Anchor Point property for a layer 

To move the anchor point numerically 

To move the anchor point by dragging in the Layer window 

To move a layer anchor point by nudging it one pixel at the current magnification 

To move a layer anchor point by nudging it ten pixels at the current magnification 



Animating Layers 

Setting and animating mask shapes and feathers

Masks are paths that you draw or import into a Layer window to create transparent areas for a 
layer. In the Time Layout window, you can set mask shapes and mask feather properties and 
change these properties over time. You can also set interactions between different masks within a 
layer and set the type of interaction used between the mask and the layer itself. For information on 
changing mask properties and animating masks, see Working with Masks and Transparency.



Animating Layers 

Setting and animating effects

In the Time Layout window, you can set keyframes for effect properties if at least one effect is 
applied to the layer. You can also set multiple keyframes to animate effects. The properties 
available vary depending on the effect. For more information on changing and animating effect 
properties, see Applying Effects.

To set effects keyframes:

1    In the Time Layout window, select the layer you want to modify.

2    Expand the layer outline to display the Effects property or press E on your keyboard. An effect 
must be applied to the layer before you can set effects keyframes.

3    Click the underlined effect value you want to modify.

4    Enter a new value and click OK.

5    Click the Effect value stopwatch icon to set the initial keyframe.



Animating Layers 

Setting preview options

After Effects provides four options for previewing your animations: RAM preview, standard preview, 
manual preview, and wireframe preview. You can access RAM, standard, and manual previews 
using the Time Controls palette.

A. First Frame B. Frame Reverse C. Play D. Frame Advance E. Last Frame F. Audio G. Loop H. RAM Preview
I. Time indicator J. Jog control K. Shuttle control

The different preview options represent different balances between preview quality and speed:

RAM preview This option plays a preview of the frames (including audio) at the frame rate of your 
composition or as fast as your system allows. The number of frames previewed depends on the 
amount of available contiguous RAM allocated to the application. After Effects indicates the total 
number of frames requested for the preview and the number it can render. RAM Preview previews 
only the span of time you specify as the work area. Before you preview, check which frames are 
designated as the work area. See Setting up a work area.

Audio plays only for layers in which the Audio switch is on. When the Audio button ( ) is 
deselected in the Time Controls palette, no audio layers are included in the preview. To preview 
audio alone see Previewing audio.

Standard preview This option provides a preview of all frames in your composition. When you use this 
option, After Effects displays every frame as quickly as it can using the current settings of the layer 
switches, composition switches, and composition resolution. This preview generally plays slower than real
time; however, it may play faster than real time if the composition is very small and simple.

Manual preview Using the shuttle control, the jog control, and the time indicator, you can manually 
navigate through a composition, layer, or footage file. The time marker indicates the position of a 
frame relative to the beginning and end of a composition, layer, or footage file. Because the time 
marker travels only a fixed distance in the Time Controls palette, it is less precise with long 
compositions. 

Wireframe preview This option displays a preview of the frames for all layers in your active 
workspace. Each layer is represented by a rectangle, or, if a still-image layer has a mask or an 
alpha channel created in another program, by the outline of the mask or alpha channel. 

You can also use the Motion with Trails preview, which preserves the outline of each frame of each 
selected layer so that you can see an outline trail for every frame. This is useful for detailed analysis
of motion.



Wireframe preview (left). Motion with Trails preview (right).



Animating Layers 

Previewing animation

When you preview a composition in After Effects, the more detail and precision you want to see, the
more slowly the composition displays in standard preview and the more RAM is required for RAM 
preview. You can control the amount of detail shown in either the standard or RAM preview by 
changing the resolution, magnification, and preview quality of your composition. See Setting 
resolution and Changing a layer’s image quality.

You can also limit the number of layers previewed by turning off the video switch for certain layers, 
or limit the number of frames previewed by adjusting the composition’s work area. See Hiding 
layers in the Composition window or Setting up a work area. For information on all the previewing 
shortcuts available, see the After Effects Quick Reference card.

See also: 

To stop any preview before it is complete 

To use RAM preview 

To use standard preview 

To loop the preview so it plays continuously 

To use the manual preview options 

To use the wireframe preview 



Previewing animation 

To stop any preview before it is complete:

Press the spacebar.

See also: 

To use RAM preview 

To use standard preview 

To loop the preview so it plays continuously 

To use the manual preview options 

To use the wireframe preview 



Previewing animation 

To use RAM preview:

1    In the Time Layout window, make sure the video switch is selected for the layers you want to 
preview. 

2    Set the work-area to the time span you want to preview.

3    Click the Audio button ( ) on the Time Controls palette if you want to preview audio with video.
4    Do one of the following:

•      Press 0 (zero) on the numeric keypad.
•      Choose Composition > Preview > RAM Preview.
•      Choose Window > Show Time Controls, and then in the Time Controls palette, click the RAM 
Preview button.

Note: You can decrease the amount of RAM required and increase the duration of footage previewed by 
previewing every other frame. To do this, press and hold Shift, and then either press 0 on the numeric keypad, 
or click the RAM Preview button.

See also: 

To stop any preview before it is complete 

To use standard preview 

To loop the preview so it plays continuously 

To use the manual preview options 

To use the wireframe preview 



Previewing animation 

To use standard preview:

1    In the Time Layout window, make sure the video switch is selected for the layers you want to 
preview.

2    Move the work-area markers to set the time span you want to preview.

3    Do one of the following:
•      Choose Window > Show Time Controls, and then in the Time Controls palette, click the Play 
button ( ).

•      Press the spacebar to start; press again to stop.

See also: 

To stop any preview before it is complete 

To use RAM preview 

To loop the preview so it plays continuously 

To use the manual preview options 

To use the wireframe preview 



Previewing animation 

To loop the preview so it plays continuously:

Click the Loop button ( ), and then click the Play or RAM Preview button.

See also: 

To stop any preview before it is complete 

To use RAM preview 

To use standard preview 

To use the manual preview options 

To use the wireframe preview 



Previewing animation 

To use the manual preview options:

Do any of the following:
•      To go forward one frame, click the Frame Advance button (

).
•      To go forward ten frames, press Shift as you click the Frame Advance button.
•      To go backward one frame, click the Frame Reverse button ( ).
•      To go backward ten frames, press Shift as you click the Frame Reverse button.
•      To preview with finer precision, drag anywhere along the jog control or drag the time indicator or 
shuttle control ( ). Playback speed is relative to how far you drag the controller in either direction.

•      To go the beginning of the composition, layer, or footage, click the First Frame button ( ).
•      To go to the end of the composition, layer, or footage, click the Last Frame button ( ).

See also: 

To stop any preview before it is complete 

To use RAM preview 

To use standard preview 

To loop the preview so it plays continuously 

To use the wireframe preview 



Previewing animation 

To use the wireframe preview:

1    In the Time Layout window, select the layers you want to preview. To preview all layers make no 
selection.

2    Set the work area to the time span you want to preview.

3    Do one of the following:
•      Choose Composition > Preview > Wireframe Preview. To display a rectangular layer outline 
instead of an alpha channel outline, press Control (Windows) or Command (Mac OS) as you 
choose the preview method. 
•      Choose Composition > Preview > Motion with Trails. 

See also: 

To stop any preview before it is complete 

To use RAM preview 

To use standard preview 

To loop the preview so it plays continuously 

To use the manual preview options 



Fine-tuning Animation 

In After Effects, you control precisely how change occurs between keyframes. You can apply an 
interpolation method to any keyframe for any layer property. Some interpolation methods create 
abrupt changes or sharp angles in motion, while others provide a smooth transition and round 
curves. You can also control the speed of change between keyframes. 

Using different interpolation methods, you can determine exactly how the keyframes for each layer 
property interact with each other in a composition. For example, when creating a motion path, you 
can make a layer decelerate as it drifts from the first keyframe to the second, then make it quickly 
bounce off a third keyframe as it rounds a curve and speeds toward the final keyframe. 

You can create simple or complex motion paths. You can assign a constant linear speed (left) or control subtle 
changes to the speed on a Bezier curve (right).

See also: 

Controlling change through interpolation 

Comparing interpolation methods 

Changing the interpolation method 

Using the Value graph to change a layer property value 

Adding keyframes to a Value graph 

Factors affecting speed 

Controlling speed along a motion path 

Fine-tuning speed 

Time-stretching a layer 

Keeping keyframes intact when time-stretching a layer 

Using the Time-Reverse Keyframes keyframe assistant 

Reversing the playback direction of a layer 

About time-remapping 



Fine-tuning Animation 

Controlling change through interpolation

After Effects provides several interpolation methods that affect how change occurs through and 
between keyframes. For example, if you are setting up motion, you can choose to make a layer 
change direction abruptly or through a smooth curve. After Effects interpolates values for a change 
using the values at the keyframes on both ends of the change.

You can control temporal interpolation (the interpolation between keyframe values over time) for all 
layer properties. For layer properties that involve movement, such as Position, Anchor Point, and 
Effect Point, you can also control spatial interpolation (the interpolation between motion-path 
keyframes through space). For more information on editing motion paths, see Modifying a motion 
path.

When you make a layer property vary over time, After Effects records the resulting values of 
temporal interpolation in the Value graph in the Time Layout window. If the layer property includes 
spatial interpolation, the resulting values of spatial interpolation are displayed as a motion path in 
either the Composition or the Layer window, depending on the property. You can add or delete 
keyframes in the Value graph or motion path using the pen tool.

See also: 

Spatial interpolation and the motion path 

Temporal interpolation and the Value graph 



Controlling change through interpolation 

Spatial interpolation and the motion path

When you apply or change the spatial interpolation for a property such as Position, you adjust the 
motion path in the Composition window. The different keyframes on the motion path provide 
information about the type of interpolation at any point in time.

Motion path interpolation A. Linear B. Auto Bezier C. Continuous Bezier D. Bezier E. Hold



Controlling change through interpolation 

Temporal interpolation and the Value graph

Using the Value graph in the Time Layout window, you can make precise adjustments to the 
temporal property keyframes you’ve created for your animation. The Value graph provides complete
information about and control of the value at any point in time in a composition. The Time Layout 
window also provides information about the speed of changes between values (or speed along a 
motion path) in the Speed graph. See Using the Value graph to change a layer property value. 

The Value graph appears when a non-spatial layer property contains two or more keyframes.

A temporal interpolation method can appear as a specific kind of icon, so you can immediately see 
what kind of interpolation is applied to a keyframe. You can press Control (Windows) or Command 
(Mac OS) as you click a keyframe icon to switch between Linear and Auto Bezier interpolation. For 
information on each type of interpolation, see Comparing interpolation methods.

Timeline keyframe icons A. Linear B. Linear in, Hold out C. Auto Bezier D. Continuous Bezier or Bezier 



Fine-tuning Animation 

Comparing interpolation methods

All interpolation methods provided by After Effects are based on the Bezier interpolation method, 
which provides direction handles so that you can control exactly how keyframes transition from one 
to another. Interpolation methods that don’t use direction handles are constrained versions of Bezier
interpolation, and are convenient for certain tasks.

To learn more about how different temporal interpolation methods affect layer properties, 
experiment by setting up at least three keyframes with different values for a temporal property such 
as Opacity, and change the interpolation methods for all keyframes as you view the Value graph in 
the Time Layout window.

To learn more about how different spatial interpolation methods affect a motion path, experiment by 
setting up three keyframes with different values on a motion path, and change the interpolation 
methods as you view the motion path in the Composition window. For more information, see 
Determining where to set and modify keyframes and Adding keyframes to a Value graph.

In the following descriptions of interpolation methods, the effect of each method is described as if 
you had applied it to all the keyframes for a layer property. This is done to clarify the examples. In 
practice, you can apply any available interpolation method to any layer property keyframe.

See also: 

No interpolation 

Linear interpolation 

Auto Bezier interpolation 

Continuous Bezier interpolation 

Bezier temporal interpolation 

Hold interpolation 



Comparing interpolation methods 

No interpolation

No interpolation is the state in which there are no keyframes for a layer property—when the 
stopwatch is turned off and the I-beam icon ( ) displays in the Time Layout window under the 
current-time marker. By default, no interpolation is applied to a layer property. If any keyframes are 
present for a layer property, some kind of interpolation is in use. Removing all keyframes from a 
layer property also removes all interpolation methods from the layer property. No interpolation 
means that, when you set the value of a layer property, it maintains that value for the layer’s 
duration.



Comparing interpolation methods 

Linear interpolation

Linear interpolation creates a uniform rate of change between keyframes. After Effects interpolates 
the values to the next keyframe as directly as possible without accounting for the values of other 
keyframes. Linear value changes add a rhythmic or mechanical look to animations.

If you apply Linear temporal interpolation to all keyframes of a layer property, change begins 
instantly at the first keyframe and continues to the next keyframe at a constant speed. At the 
second keyframe, the rate of change switches immediately to the rate between it and the third 
keyframe. When the layer reaches the final keyframe value, change stops instantly. In the Value 
graph, the graph segment connecting two Linear keyframes appears as a straight line.

Linear temporal interpolation on a Value graph

If you apply Linear spatial interpolation to all keyframes of a motion path, After Effects creates a 
straight line between each keyframe. At each Linear keyframe, the motion path forms a corner. For 
example, you might use Linear spatial interpolation to create the path of a pinball. The speed of 
motion along the path is controlled by the temporal interpolation applied at each keyframe.

Linear spatial interpolation on a motion path



Comparing interpolation methods 

Auto Bezier interpolation

Auto Bezier interpolation creates a smooth rate of change through a keyframe. As you change an 
Auto Bezier keyframe value, After Effects changes the positions of Auto Bezier direction handles 
automatically to maintain a smooth transition between keyframes. This is done by keeping the 
positions of the direction handles parallel to an imaginary line connecting the previous and next 
keyframes. The automatic adjustments change the shape of the Value graph or motion path 
segments on either side of the keyframe. If the previous and next keyframes also use Auto Bezier 
interpolation, the shape of the segments on the far side of the previous or next keyframes also 
change. If you adjust an Auto Bezier direction handle manually, you convert it to a Continuous 
Bezier keyframe.

If you apply Auto Bezier temporal interpolation to all keyframes of a layer property, After Effects 
creates a smooth transition between the incoming and outgoing rates of change at each keyframe. 
After Effects maintains a smooth transition by moving the direction handles for each keyframe on 
the Value graph automatically as you change an Auto Bezier keyframe value.

Auto Bezier temporal interpolation on a Value graph

If you apply Auto Bezier spatial interpolation to all keyframes of a motion path, After Effects creates 
a smooth transition at each keyframe in a motion path. As with temporal properties, After Effects 
maintains the smooth transitions by automatically adjusting motion-path direction handles as you 
move an Auto Bezier keyframe on the motion path. The speed of motion along the path is controlled
by the temporal interpolation applied at each keyframe. You might use Auto Bezier spatial 
interpolation to create the path of a car turning on a curving road.

Auto Bezier temporal interpolation on a motion path

After Effects uses Auto Bezier as the default spatial interpolation. For information about changing 
the default, see Setting the default spatial interpolation to Linear.



Comparing interpolation methods 

Continuous Bezier interpolation

Like Auto Bezier interpolation, Continuous Bezier interpolation creates a smooth rate of change 
through a keyframe. Unlike Auto Bezier, you set the positions of Continuous Bezier direction 
handles manually; After Effects does not adjust the direction handle positions automatically. 
Adjustments you make change the shape of the Value graph or motion path segments on either 
side of the keyframe.

If you apply Continuous Bezier temporal interpolation to all keyframes of a layer property, After 
Effects creates smooth transitions between each keyframe by ensuring that incoming and outgoing 
rates of change are the same. After Effects maintains existing direction handle positions as you 
change a Continuous Bezier keyframe value.

Continuous Bezier temporal interpolation on a Value graph

If you apply Continuous Bezier spatial interpolation to all keyframes of a motion path, After Effects 
adjusts the motion path at each keyframe to create a smooth transition at each keyframe. As with 
temporal properties, After Effects maintains the smooth transitions as you move a Continuous 
Bezier keyframe on the motion path. The speed of motion along the path is controlled by the 
temporal interpolation applied at each keyframe.

Continuous Bezier spatial interpolation on a motion path



Comparing interpolation methods 

Bezier temporal interpolation

Bezier interpolation provides the most precise control because you manually adjust the shape of the
Value graph or motion path segments on either side of the keyframe. Unlike Auto Bezier or 
Continuous Bezier, the two direction handles on a Bezier keyframe operate independently in both 
the Value graph and motion path.

If you apply Bezier temporal interpolation to all keyframes of a layer property, by default After 
Effects creates a smooth transition between keyframes. The initial position of the direction handles 
is calculated using the same method used in Auto Bezier interpolation. After Effects maintains 
existing direction handle positions as you change a Bezier keyframe value.

Bezier temporal interpolation on a Value graph

Unlike other interpolation methods, you can create any combination of curves and straight lines 
along the motion path. Because the two Bezier direction handles operate independently, a curving 
motion path can suddenly turn into a corner at a Bezier keyframe. Bezier spatial interpolation is 
ideal for drawing a motion path that follows a complex shape, such as a map route or the outline of 
a logo.

Bezier spatial interpolation on a motion path

After Effects maintains existing direction handle positions as you move a motion-path keyframe. 
The speed of motion along the path is controlled by the temporal interpolation applied at each 
keyframe. For more information on controlling the speed, see Controlling speed along a motion 
path.



Comparing interpolation methods 

Hold interpolation

Hold interpolation is only available as a temporal interpolation method. You can use Hold 
interpolation to change the value of a layer property over time, but without a gradual transition. This 
interpolation method is useful for time-lapse or strobe effects, or when you want layers to appear or 
disappear suddenly.

If you apply Hold temporal interpolation to all keyframes of a layer property, the value of the first 
keyframe holds steady until the next keyframe. At the next keyframe, the coordinate values change 
immediately. In the Value graph, the graph segment following a Hold keyframe appears as a straight
line. Unlike Linear interpolation, the straight line is always horizontal.

Hold temporal interpolation on a Value graph

Even though Hold interpolation is only available as a temporal interpolation method, the effects are 
visible on a motion path. The keyframes on the motion path are visible, but are not connected by 
layer-position dots. For example, if you animate a layer’s Position property using Hold interpolation, 
the layer holds at the position value of the previous keyframe until the current-time marker reaches 
the next keyframe, at which point the layer disappears from the old position and appears at the new
position.

You can only use Hold interpolation for outgoing temporal interpolation (for the frames following a 
keyframe). However, if directly following a Hold keyframe, you create a new keyframe using the 
keyframe navigator option, the new keyframe will use incoming Hold interpolation. See Adjusting 
direction handles to create curves and corners.

Hold spatial interpolation on a motion path



Fine-tuning Animation 

Changing the interpolation method

You can apply and change the interpolation method for any property keyframe. Setting different 
interpolation methods for different keyframes in a layer can create a more realistic appearance and 
add variety to your animations.

You can change the interpolation method for a keyframe using the Keyframe Interpolation dialog 
box, or you can change it directly on a Value graph or motion path. Before you use the Value graph 
or motion path, note which kind of interpolation you want to change. Editing interpolation on a Value
graph affects only the temporal interpolation of a layer property. Editing interpolation on a motion 
path affects only the spatial interpolation of a layer property. For more information on using the 
Value graph, see Controlling change through interpolation.

See also: 

To change an interpolation method for a keyframe using the Keyframe Interpolation dialog box 

To change an interpolation method directly in a window 

Applying Bezier interpolation graphically 

Adjusting direction handles to create curves and corners 

Retracting and extending Bezier direction handles 

Mixing incoming and outgoing interpolation methods 

Setting the default spatial interpolation to Linear 



Changing the interpolation method 

To change an interpolation method for a keyframe using the Keyframe 
Interpolation dialog box:

1    In the Time Layout window, select the keyframes you want to change.

2    Choose Layer > Keyframe Interpolation.

3    For Temporal Interpolation, choose one of the following options:
•      Current Settings preserves the interpolation values already applied to the selected keyframes. 
Choose this option when multiple or manually adjusted keyframes are selected and you do not want
to change the existing settings.
•      Linear, Bezier, Continuous Bezier, Auto Bezier, and Hold apply a temporal interpolation method 
using default values.

4    If you selected keyframes of a spatial layer property, choose one of the following options for 
Spatial Interpolation (available only for Position, Anchor Point, and Effect Point keyframes):
•      Current Settings preserves the interpolation settings already applied to the selected keyframes.
•      Linear, Bezier, Continuous Bezier, and Auto Bezier apply a spatial interpolation method using 
default values.

5    If you selected keyframes of a spatial layer property, use the Roving menu to choose how a 
keyframe determines its position in time, and then click OK:
•      Current Settings preserves the currently applied method of positioning the selected keyframes 
in time.
•      Rove Across Time smoothes the rate of change through the selected keyframes by 
automatically varying their position in time, based on the positions of the keyframes immediately 
before and after the selection. See Creating smooth changes using roving keyframes.
•      Lock to Time keeps the selected keyframes at their current position in time. They stay in place 
unless you move them manually.

See also: 

To change an interpolation method directly in a window 

Applying Bezier interpolation graphically 

Adjusting direction handles to create curves and corners 

Retracting and extending Bezier direction handles 

Mixing incoming and outgoing interpolation methods 

Setting the default spatial interpolation to Linear 



Changing the interpolation method 

To change an interpolation method directly in a window:

1    Display the Value graph in the Time Layout window or the motion path in the Composition or 
Layer window.

2    Using the selection tool, press Control (Windows) or Command (Mac OS) as you click the 
keyframe marker you want to change. The interpolation method that the keyframe changes to 
depends on the current interpolation:
•      If the keyframe uses Linear interpolation, it changes to Auto Bezier.
•      If the keyframe uses Bezier, Continuous Bezier, or Auto Bezier, it changes to Linear.

A Linear keyframe (left) changes to Auto Bezier (right)

See also: 

To change an interpolation method for a keyframe using the Keyframe Interpolation dialog box 

Applying Bezier interpolation graphically 

Adjusting direction handles to create curves and corners 

Retracting and extending Bezier direction handles 

Mixing incoming and outgoing interpolation methods 

Setting the default spatial interpolation to Linear 



Changing the interpolation method 

Applying Bezier interpolation graphically

One way to apply Bezier interpolation is by using the Keyframe Interpolation dialog box. See 
Changing the interpolation method. However, when you are using the mouse intensively on a Value 
graph or motion path, you may prefer to apply Bezier interpolation graphically. 

To enable Bezier direction handles graphically:

1    Using the selection tool, do one of the following:
•      If the current keyframe interpolation is Linear, press Control (Windows) or Command (Mac OS) 
as you click the keyframe to change it to Auto Bezier.
•      If the current interpolation is Auto Bezier, drag one of the direction handles. Direction lines 
appear, visually connecting the direction handles to the keyframe and indicating that you have 
changed the interpolation to Continuous Bezier.

An Auto Bezier keyframe (left) changes to a Continuous Bezier keyframe (right)

2    Press Control (Windows) or Command (Mac OS) as you drag one of the direction handles. This 
changes the interpolation to Bezier. Each direction handle now moves independently.



Changing the interpolation method 

Adjusting direction handles to create curves and corners

By default, Bezier interpolation creates a curved transition at a keyframe. Clicking the keyframe with
the Convert Control Point tool creates a corner at the keyframe. On a Value graph, a corner results 
in an abrupt transition. On a motion path, the keyframe becomes a corner in the path.

You can also change a Bezier keyframe so that the two handles move together, forming a curve 
through the keyframe.

To change a Bezier keyframe from a curve to a corner:

1    Select the pen tool (
) from the 

toolbox.
2    In the Composition window, drag a keyframe’s direction handle in any direction.

Continuous Bezier direction handles (left) become two separate Bezier direction handles (right)



Changing the interpolation method 

Retracting and extending Bezier direction handles

You can retract or extend the direction handles that appear by default. When the direction handles 
are extended, the keyframe represents Continuous Bezier interpolation (see Continuous Bezier 
interpolation). When both direction handles are retracted, the interpolation method is Linear, which 
creates a corner point instead of a curve. See Linear interpolation.

To retract one direction handle:

Using the selection tool, on a Value graph in the Time Layout window or motion path in the 
Composition or Layer window, drag the direction handle to the center of its keyframe.

To retract both Bezier direction handles:

1    Select the Convert Control Point tool ( ) from the toolbox.
2    On a Value graph or motion path, click the keyframe.

To extend retracted Bezier direction handles:

1    Select the Convert Control Point tool ( ) from the toolbox.
2    On a Value graph or motion path, click the keyframe and drag outward from the keyframe.

To toggle between the selection tool and the pen tool:

Hold down Control (Windows) or Command (Mac OS).
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Mixing incoming and outgoing interpolation methods

By default, a keyframe icon uses one interpolation method, but you can apply two methods: the 
incoming method applies to the property value as the current time approaches a keyframe, and the 
outgoing method applies to the property value as the current time leaves a keyframe. When you set
different incoming and outgoing interpolation methods, the keyframe icon changes accordingly. It 
displays the left half of the incoming interpolation method icon and the right half of the outgoing 
interpolation icon.

Mixed keyframe icon A. Linear incoming interpolation B. Bezier outgoing interpolation

You can freely mix Linear and Bezier interpolation methods using the Speed or Velocity graph. See 
Fine-tuning speed. Because Auto Bezier interpolation automatically adjusts both incoming and 
outgoing direction handles, once you mix Auto Bezier with another method, the original half of the 
keyframe becomes Bezier.

See also: 

To mix Bezier and Linear interpolation methods 

To apply or remove Hold interpolation as outgoing interpolation 



Mixing incoming and outgoing interpolation methods 

To mix Bezier and Linear interpolation methods:

1    In the Time Layout window, select the Bezier or Linear keyframe you want to change.

2    Expand the layer outline to display the Speed or Velocity graph for the layer property containing 
the keyframe.

Note: Make sure you adjust the handles on the Speed or Velocity graph, not the Value graph. See Factors 
affecting speed.

3    Drag the incoming or outgoing handle to adjust the speed of the keyframe. 

See also: 

To apply or remove Hold interpolation as outgoing interpolation 



Mixing incoming and outgoing interpolation methods 

To apply or remove Hold interpolation as outgoing interpolation:

1    In the Time Layout window, select the keyframe you want to change.

2    Choose Layer > Toggle Hold Keyframe.

See also: 

To mix Bezier and Linear interpolation methods 
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Setting the default spatial interpolation to Linear

When you create spatial changes in a layer, After Effects uses Auto Bezier as the default spatial 
interpolation. You can change this default to Linear. 

To set the default spatial interpolation to Linear:

1    Choose File > Preferences > General.

2    Select the Default Spatial Interpolation to Linear option and click OK.
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Using the Value graph to change a layer property value

The Time Layout window displays the values for each keyframe and the interpolated values 
between keyframes. When the Value graph of a layer property is level, the value of a layer property 
is unchanging between keyframes. When the Value graph goes up or down, the value of a layer 
property is increasing or decreasing between keyframes.

A. A level value graph indicates unchanging values. B. A rising graph indicates increasing values. C. A falling 
graph indicates decreasing values.

You can change layer property values by moving the points on the Value graph up or down. For 
example, you can increase a Rotation keyframe’s value by dragging a point on the Rotation 
property’s Value graph higher up the graph. 

Note: Values for the Anchor Point, Mask Shape, Effect point controls, and Position properties are spatial, so 
they are graphically represented in the Layer and Composition windows, not in the Value graph in the Time 
Layout window.

To increase or decrease the value of a layer property:

1    In the Time Layout window, display the property for a layer that contains at least two keyframes.

2    Click the triangle next to the property name to display the Value graph.

3    Do one of the following:
•      To increase a keyframe value, drag a value marker up, or double-click the keyframe icon to 
enter a larger value.
•      To decrease a keyframe value, drag a value marker down, or double-click the keyframe icon to 
enter a smaller value.
•      To see the new value displayed next to the property name, position the current-time marker on 
the keyframe.
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Adding keyframes to a Value graph

The pen tools provide the most flexible way to change temporal properties in the Value graph or a 
motion path. Editing with a pen tool is similar to the way you modify a path in a drawing application 
such as Adobe Illustrator. For more information on using the pen tools, see Drawing a Bezier mask 
with the pen tool.

For best results with the pen tool, you should understand how Bezier interpolation affects the Value 
graph and the motion path. When you use Bezier interpolation on a graph or path, you can control 
the shapes of corners, making them into smooth curves or angled corners. See Bezier temporal 
interpolation.

To add a keyframe to a Value graph using the pen tool:

1    In the Time Layout window, display a layer property containing at least two keyframes.

2    Click the triangle to the left of the property name to display the Value graph.

3    Select the pen tool (
) from the 

toolbox.
4    In the Time Layout window, move the pen tool over the time on the Value graph where you want to add
the new keyframe, and then click to add a new keyframe.

Clicking the pen tool on the Value graph line adds a keyframe.
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Factors affecting speed

After you create your keyframes and motion paths, you may want to make more precise 
adjustments to the way the spatial coordinates or speed of a moving layer changes through 
keyframes.

You can fine-tune nearly all changes over time using the Speed graph or Velocity graph in the Time 
Layout window. The Speed graph provides complete information about and control of the value and 
rate of change for all spatial values, such as Position, at any frame in a composition. The Velocity 
graph provides complete information about and control of the value and rate of change for all non-
spatial values, such as Rotation, at any frame in a composition.

A. Speed at the current-time marker B. Minimum and maximum speed (not limits) C. Speed graph D. Speed 
control 

The change of value or speed over time is affected by the following factors:

Time difference The time difference between keyframes in the Time Layout window. The shorter 
the time interval between keyframes, the more quickly the layer has to change before reaching the 
next keyframe value. If the interval is longer, the layer changes more slowly, since it must make the 
change over a longer period of time. You can use distance to adjust speed by moving keyframes 
forward or backward along the timeline.

Shorter interval (left) creates faster change. Longer interval (right) creates slower change.

Value difference The difference between the values of adjacent keyframes. A large difference 
between keyframe values, such as the difference between 75% and 20% opacity, creates a faster 
rate of change than a smaller difference, such as the difference between 30% and 20% opacity. You
can use value differences to adjust the rate of change by increasing or decreasing the value of a 
layer property at a keyframe.



Larger difference (left) creates faster change. Smaller difference (right) creates slower change.

Interpolation type    The type of interpolation applied for a keyframe. For example, it is difficult to 
make a value change smoothly through a keyframe when the keyframe is set to Linear 
interpolation; but at any time, you can switch to Bezier interpolation, which supports a smooth 
change through a keyframe. If you use Bezier interpolation, you can adjust the rate of change even 
more precisely using ease handles. For more information, see Fine-tuning speed.

Linear interpolation (left) causes sharp changes. Bezier interpolation (right) creates smoother change.
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Controlling speed along a motion path

When you animate a spatial property, such as Position, Anchor Point, Effect Point, or Mask Shape, 
you can view and adjust the speed of the layer in the Speed graph in the Time Layout window or on
the motion path in the Composition or Layer window. As you adjust the speed in one window, you 
can view the changes in the other window. In the Time Layout window’s Speed graph, change in the
graph height indicate changes in speed. Level values indicate constant speed; higher values 
indicate increased speed. 

A higher Speed graph indicates faster layer motion.

In the Composition or Layer window, the spacing between dots in a motion path indicates speed. 
Each dot represents a composition frame, based on the frame rate of the composition. Even 
spacing indicates a constant speed and wider spacing indicates a higher speed. Keyframes using 
Hold interpolation display no dots because there is no intermediate transition between keyframe 
values; the layer simply appears at the next Position keyframe value.

A. Dots are close together indicating slower speed. B. Dots are far apart indicating faster speed. C. 
Inconsistent spacing of dots indicates changing speed. 

See also: 

To control speed between keyframes 



Controlling speed along a motion path 

To control speed between keyframes:

Use any combination of the following options:
•      In the Composition or Layer window, adjust the spatial distance between two keyframes on the 
motion path. Increase the speed by moving one keyframe position farther away from the other, or 
decrease the speed by moving one keyframe position closer to the other.

More spatial distance between keyframes increases layer speed.
•      In the Time Layout window, adjust the time difference between two keyframes. Decrease the 
speed by moving one keyframe farther away from the other, or increase the speed by moving one 
keyframe closer to the other.

Shorter temporal distance between keyframes increases layer speed.
•      Apply the Easy Ease keyframe assistant. Easy Ease automatically adjusts the speed of change 
as motion advances toward and retreats from a keyframe. See Automatically easing speed using 
the Easy Ease keyframe assistant.
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Fine-tuning speed

Using the Speed or Velocity graph, you can adjust motion or a value change so that it occurs more 
slowly just before or just after a keyframe, or so that a layer moves quickly over a certain distance 
and then slows down smoothly. By adjusting the rise and fall of the graph, you can control how fast 
or slow a value changes from keyframe to keyframe. Each temporal interpolation method affects 
acceleration and deceleration differently. If you don’t get the results you want, try a different 
temporal interpolation method.

The speed increases as the graph rises (A) and decreases as the graph falls (B).

When adjusting speed on a motion path, set the shape of a motion path first, and then use ease 
handles to fine-tune the speed relationships in the Speed graph. Ease handles provide the most 
direct control over acceleration and deceleration. You can control the values approaching or leaving
a keyframe together or separately. The incoming handle increases the influence of a keyframe 
value on the previous keyframe when you drag it left, and decreases the influence on the previous 
keyframe when you drag it right. It increases or decreases the speed when you drag it up or down. 
The outgoing handle influences the next keyframe in the same way.

A. Incoming ease handle B. Speed control C. Outgoing ease handle 

Note: If you want a handle to have influence over more than one keyframe, you can use roving keyframes. 
See Creating smooth changes using roving keyframes.

See also: 

To fine-tune speed between keyframes 

To fine-tune speed separately for incoming and outgoing frames 



To rejoin split ease handles 

Adjusting the Speed or Velocity graph border 

Creating a bounce or intense peak 

Starting or stopping change gradually 

Extending the influence of an ease handle 

Changing speed numerically 

Creating smooth changes using roving keyframes 

Automatically easing speed using the Easy Ease keyframe assistant 



Fine-tuning speed 

To fine-tune speed between keyframes:

1    In the Time Layout window, expand the outline for the keyframe you want to adjust. Then click 
the triangle to the left of the property to display the Speed graph or the Velocity graph.

2    At the keyframe you want to adjust, drag either ease handle up to accelerate or down to 
decelerate entering and leaving the keyframe.

See also: 

To fine-tune speed separately for incoming and outgoing frames 

To rejoin split ease handles 

Adjusting the Speed or Velocity graph border 

Creating a bounce or intense peak 

Starting or stopping change gradually 

Extending the influence of an ease handle 

Changing speed numerically 

Creating smooth changes using roving keyframes 

Automatically easing speed using the Easy Ease keyframe assistant 



Fine-tuning speed 

To fine-tune speed separately for incoming and outgoing frames:

1    In the Time Layout window, display the Speed or Velocity graph for the keyframe you want to 
adjust.

2    At the keyframe you want to adjust, press Control (Windows) or Command (Mac OS) as you 
drag either ease handle up or down.

See also: 

To fine-tune speed between keyframes 

To rejoin split ease handles 

Adjusting the Speed or Velocity graph border 

Creating a bounce or intense peak 

Starting or stopping change gradually 

Extending the influence of an ease handle 

Changing speed numerically 

Creating smooth changes using roving keyframes 

Automatically easing speed using the Easy Ease keyframe assistant 



Fine-tuning speed 

To rejoin split ease handles:

1    In the Time Layout window, display the Speed or Velocity graph for the keyframe you want to 
adjust.

2    At the keyframe you want to adjust, press Control (Windows) or Command (Mac OS) as you 
drag either split ease handle up or down until it meets the other handle.

See also: 

To fine-tune speed between keyframes 

To fine-tune speed separately for incoming and outgoing frames 

Adjusting the Speed or Velocity graph border 

Creating a bounce or intense peak 

Starting or stopping change gradually 

Extending the influence of an ease handle 

Changing speed numerically 

Creating smooth changes using roving keyframes 

Automatically easing speed using the Easy Ease keyframe assistant 
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Adjusting the Speed or Velocity graph border

When you drag an ease handle beyond the upper or lower graph border, After Effects calculates a 
new minimum or maximum value based on how far you dragged outside the graph, and redraws the
graph so that all the values you specified for that layer property are visible in the graph. You can 
manually adjust the size of the Speed or Velocity graph border when you want to make greater 
changes to the speed.

To adjust the Speed or Velocity graph border:

Position the pointer tool on the graph border and, when the pointer becomes a double-arrow cursor,
drag up or down.

Speed graph border at default location (left) and expanded for precision editing (right)
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Creating a bounce or intense peak

You can use ease handles to simulate the type of acceleration seen in a bouncing ball. When you 
create this type of effect, the Speed or Velocity graph appears to rise quickly and peak.

To create a bounce or peak:

1    In the Time Layout window, expand the outline for the keyframe you want to adjust. Then click 
the triangle to the left of the property to display the Speed graph or the Velocity graph.

2    At the desired keyframe, drag the ease handle up until it is near the top of the graph.
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Starting or stopping change gradually

Ease handles can also create gradual starts and stops, such as a boat slowing to a stop and then 
starting again. When you use this technique, the Speed or Velocity graph resembles a smooth U 
shape.

To start or stop change gradually:

1    In the Time Layout window, expand the outline for the keyframe you want to adjust. Then click 
the triangle to the left of the property to display the Speed graph or the Velocity graph.

2    At the desired keyframe, drag the ease handle down until it is near the bottom of the graph.
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Extending the influence of an ease handle

Along with controlling the level of acceleration and deceleration, you can also extend the influence 
of a keyframe outward or inward in relation to an adjacent keyframe. Influence determines how 
quickly the Speed graph reaches the speed you set at the keyframe, giving you an additional 
degree of control over the shape of the graph.

As you adjust an ease handle, the effects of the change are visible in the Speed graph and in the 
motion path in the Composition window.

To adjust the influence of an ease handle on the previous or next keyframe:

1    In the Time Layout window, expand the outline for the keyframe you want to adjust. Then click 
the triangle to the left of the property to display the Speed graph or the Velocity graph.

2    At the desired keyframe, drag the ease handle left or right.
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Changing speed numerically

You may want to specify speed more precisely than you can by dragging ease handles. In such 
cases, you can specify speed numerically in the Keyframe Velocity dialog box.

The exact options available in the dialog box vary depending on the layer property you are editing, 
and may also vary for plug-in effects:

Anchor Point and Position Speed is expressed as pixels per second.

Mask Shape Speed is expressed as units per second.

Mask Feather Speed is expressed as pixels per second for both the X (horizontal) and Y (vertical) 
dimensions.

Scale Speed is expressed as percent per second for both the X (horizontal) and Y (vertical) 
dimensions.

Rotation Speed is expressed as degrees per second.

Opacity Speed is expressed as percent per second.

To specify speed numerically:

1    Display the Speed graph for the keyframe you want to adjust.

2    Select the keyframe you want to edit.

3    Choose Layer > Keyframe Velocity.

4    Enter values for Incoming and Outgoing Velocity Speed.

5    Enter values for the following options, and then click OK:
•      Influence specifies the amount of influence toward the previous keyframe (for incoming 
interpolation) or the next keyframe (for outgoing interpolation).
•      Continuous creates a smooth transition by maintaining equal incoming and outgoing velocities.
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Creating smooth changes using roving keyframes

Using the Roving keyframes command in After Effects, you can easily create smooth movement 
across several keyframes at once. Roving keyframes are keyframes that you unlink from a specific 
time; their speed and timing are determined by adjacent keyframes. When you change the position 
of a keyframe adjacent to a roving keyframe in a motion path, the timing of the roving keyframe 
changes.

Roving keyframes are available only for spatial layer properties such as Position. In addition, a 
keyframe can rove only if it is not the first or last keyframe in a layer, because a roving keyframe 
must interpolate its speed from the previous and next keyframes.

The original motion path (left) indicates different velocities between keyframes. After the keyframes are set to 
rove (right), the motion path displays consistent speed over the range of keyframes.

See also: 

To smooth motion over several keyframes 

To change a roving keyframe back to a non-roving keyframe 



Creating smooth changes using roving keyframes 

To smooth motion over several keyframes:

1    In the Time Layout window, set up the keyframes for the motion you will smooth. See Setting 
and animating position.

2    Determine the beginning and ending keyframes for the range you want to smooth.

3    Do one of the following:
•      For every keyframe in the range (except the beginning and ending keyframes), deselect the 
roving-keyframe option directly below the keyframe. The intermediate keyframes will adjust their 
positions on the timeline to smooth the speed curve between the beginning and ending keyframes.

•      Select the keyframes you want to rove and choose Layer > Keyframe Interpolation. Then 
choose Rove Across Time from the Roving pop-up menu.

See also: 

To change a roving keyframe back to a non-roving keyframe 



Creating smooth changes using roving keyframes 

To change a roving keyframe back to a non-roving keyframe:

Do one of the following:
•      Select the roving-keyframe option, or drag the roving keyframe left or right.
•      Select the roving-keyframe and choose Layer > Keyframe Interpolation. Then choose Lock To 
Time from the Roving pop-up menu.

See also: 

To smooth motion over several keyframes 
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Automatically easing speed using the Easy Ease keyframe assistant

You can eliminate sudden changes in a property’s speed by using the Easy Ease keyframe 
assistant to automatically ease the speed coming into and out of a selected range of keyframes. 
Although you can manually adjust the speed of a keyframe by dragging ease handles, as described
on page 333, using Easy Ease automates the work.

After you apply Easy Ease, each keyframe has a speed of zero with an influence of 33.33 percent 
on either side. When you ease the speed of an object, for example, the object slows down as it 
approaches a keyframe, and gradually accelerates as it leaves. You can ease speed only when 
coming into or out of a keyframe, or both. 

Without Easy Ease, speed changes can be sudden coming into or out of a keyframe (left). With Easy Ease, 
speed gradually decreases and increases coming into and out of a keyframe (right). 

To ease speed:

1    In the Time Layout window, select a range of keyframes.

2    Do one of the following:
•      Choose Layer > Keyframe Assistant> Easy Ease to ease speed coming both into and out of 
selected keyframes.
•      Choose Layer > Keyframe Assistant > Easy Ease In to ease speed coming into selected 
keyframes.
•      Choose Layer > Keyframe Assistant > Easy Ease Out to ease speed coming out of selected 
keyframes.
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Time-stretching a layer

Using the Time Stretch command, you can easily change how fast or slow a layer containing either 
audio or video is played back. Speeding up or slowing down a layer is also known as time-
stretching. When you time-stretch a layer, the audio file or the original frames in the footage and all 
keyframes that belong to the layer are redistributed along the new duration. Use this command only
when you want the layer and all layer keyframes to change to the new duration.

Time-stretching redistributes keyframes along the new duration.

If you time-stretch a layer so that the resulting frame rate is significantly different from the original 
speed, the quality of motion within the layer may suffer. You can turn on frame blending to improve 
slow-motion or fast-motion effects. See Enhancing time-altered motion by blending frames.

Note: Although you can time-stretch a still-image layer, this may adversely affect keyframe precision and After 
Effects performance. Instead, set the duration by dragging the triangle at the end of the layer duration bar.

See also: 

To time-stretch a layer from a specific time 

To time-stretch a layer to a specific time 



Time-stretching a layer 

To time-stretch a layer from a specific time:

1    In the Time Layout or Composition window, select the layer.

2    Choose Layer > Time Stretch.

3    Enter a new duration for the layer, or enter a Stretch Factor.

4    Click one of the Hold in Place options to specify the point in time from which the layer will be 
time-stretched, and then click OK:
•      Layer In-point holds the layer’s current starting time, and time-stretches the layer by moving the 
Out point.
•      Current Frame holds the layer at the position of the current-time marker (also the frame 
displayed in the Composition window), and time-stretches the layer by moving the In and Out 
points.
•      Layer Out-point holds the layer’s current ending time and time-stretches the layer by moving the
In point.

See also: 

To time-stretch a layer to a specific time 



Time-stretching a layer 

To time-stretch a layer to a specific time:

1    In the Time Layout window, move the current-time marker to the frame where you want the layer
to begin or end.

2    Display the In and Out panels in the Time Layout window by right-clicking (Windows) or pressing
Control and clicking (Mac OS) the Switches panel heading, and choosing Panels > In and Panels > 
Out. 

3    Do one of the following:
•      To stretch the In point to the current time, press Control (Windows) or Command (Mac OS) as 
you click the In time for the layer in the In panel.
•      To stretch the Out point to the current time, press Control (Windows) or Command (Mac OS) as 
you click the Out time for the layer in the Out panel.

See also: 

To time-stretch a layer from a specific time 
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Keeping keyframes intact when time-stretching a layer

When you time-stretch a layer, the positions of its keyframes stretch with it by default. You can 
circumvent this behavior by cutting and pasting keyframes. 

To time-stretch a layer but not its keyframes:

1    Make a note of the time at which the first keyframe appears.

2    In the layer outline, click the name of one or more layer properties containing the keyframes you 
want to keep at the same times.

3    Choose Edit > Cut.

4    Move or stretch the layer to its new In and Out points.

5    Move the current-time marker to the time at which the first keyframe appeared before you cut 
the keyframes.

6    Choose Edit > Paste.
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Using the Time-Reverse Keyframes keyframe assistant

For any property in a layer, you can select a range of keyframes and reverse their order. For 
example, you can reverse keyframes in the Position property to reverse the motion of an object. 
You can select and reverse keyframes across multiple layers and properties, but each set of 
keyframes for a property is reversed only within its original time range, not that of any other 
selected property. Markers in the Time Layout window are not reversed, so you may need to move 
markers after reversing keyframes. 

Original property values

Scale property values reversed using the Time-Reverse Keyframes keyframe assistant

To reverse keyframes:

1    In the Time Layout window, select a range of keyframes you want to reverse.

2    Choose Layer > Keyframe Assistant > Time-Reverse Keyframes.

For information on reversing the direction in which a layer plays and changing the order of the 
keyframes, see Reversing the playback direction of a layer. For information on reversing the 
direction in which a layer plays without changing the order of the keyframes, see About time-
remapping.
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Reversing the playback direction of a layer

You can easily reverse a layer’s playback direction. When you do, all keyframes for all properties on
the selected layer also reverse position relative to the layer. The layer itself maintains its original In 
and Out points relative to the composition. This technique is what you use to play a movie in 
reverse.

Original property values

All property values reversed using the reverse playback command

Note: For best results, replace the layer with a composition having the same frame size as the layer, and 
reverse the layer inside the composition. This is the most accurate way to reverse footage.

To reverse a layer’s playback direction:

1    In a Time Layout window, select the layer you want to reverse.

2    Press Control + Alt + R (Windows) or Command + Option + R (Mac OS).

Note: You can also play a layer backward by entering a negative time-stretch value in the Time Stretch dialog 
box.

If you want to reverse the order of keyframes without reversing the layer’s playback direction, select
keyframes and choose Layer > Keyframe Assistant > Time-Reverse Keyframes (see Using the 
Time-Reverse Keyframes keyframe assistant). 

If you want to reverse a layer’s playback direction without reversing the order of its keyframes, use 
time-remapping to reverse the layer (see About time-remapping).
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About time-remapping 

In After Effects you can easily expand, compress, play backwards, or freeze a portion of a layer’s 
duration using a process known as time-remapping. For example, if you are using footage of a 
person tearing a movie ticket, you can play footage of the tearing, freeze the motion as the ticket is 
torn halfway, and then play a few frames backwards to make the ticket appear whole again. 

Footage is usually displayed at a constant speed in one direction.

Time-remapping distorts time for a range of frames within a layer.

You can also time-remap layers containing audio or both audio and video. When you apply time-
remap to a layer containing audio and video, the audio and video remain synchronized. You can 
remap audio files to gradually decrease or increase the pitch, play audio backwards, or create a 
warbled or scratchy sound. 

You can remap time in either the Layer window or the Time Layout window. Remapping video in 
one window displays the results in both windows. Each window provides a different view of the 
layer duration:
•      The Layer window provides a visual reference of the frames you change, as well as the frame 
number. The window displays the current-time marker and a remap-time marker, which you move to
select the frame you want to play at the current time. 



A. Current-time marker B. Remap-time marker C. Time-remap value D. Navigator bar
•      The Time Layout window provides a precise view of the changes you specify over time by 
marking your changes with keyframes and a graph similar to the one displayed for other layer 
properties. You must be familiar with using keyframes in order to remap time in the Time Layout 
window. For more information, see Animating Layers.

A. First frame B. Last frame C. Active frame D. Top speed E. Current speed F. Lowest speed

When remapping time in the Time Layout window, you can use the values represented in the Time 
Remap graph to determine and control which frame of the movie plays at which point in time:

Time Remap This value indicates which frame plays at the current time. As you drag a Value graph 
marker up or down, this value changes accordingly. You can click this value and enter a new one. 
The Time Remap value also appears in the Layer window next to the Out point value.



Value:Time Remap The top value represents the last frame in the layer and the bottom value 
represents the first frame. 

Velocity:Time Remap The top value indicates the layer’s fastest speed. The bottom value is 
always a negative of the top value. The middle value indicates how fast the video is playing at the 
current time. Normal speed is 100%, slow-motion is less than 100%, and fast-motion is greater than
100%.

When you remap time, After Effects adds a Time Remap keyframe at the start and end points of the
layer in the Time Layout window. By setting additional remap keyframes, you can create complex 
motion effects. Every time you add a Time Remap keyframe, a Value graph marker appears on the 
graph directly below the keyframe. As you move this marker up or down, the Time Remap value 
changes to the frame of the video set to play at the current time. After Effects then interpolates 
intermediate frames and plays the footage forward or backward from that point. 

The speed at which remapped video plays depends on the number of frames you are remapping 
and the amount of time allocated in the timeline for the changes. For example, if you freeze a frame
for one second and do not increase the duration of the layer by one second, the footage following 
the freeze frame must play faster than normal in order to play all frames in the limited time 
remaining.

A. Default start keyframe B. Added keyframe C. Value graph marker D. Default end keyframe

The original duration of the source footage may no longer be valid when remapping time, because 
parts of the layer no longer play at the original rate. If necessary, set the new duration of the layer 
before you remap time. See Understanding trimming.

Note: If the layer you’re remapping has been trimmed, create new keyframes at the trimmed In and Out points 
and delete the default keyframes. If you don’t create new keyframes, After Effects considers the entire 
untrimmed footage when calculating the time-remap values.

If you remap time and the resulting frame rate is significantly different from the original, the quality 
of motion within the layer may suffer. You can apply frame blending to improve slow- or fast-motion 
effects. See Using frame blending.

See also: 

Time-remapping parts of a motion footage or audio layer 

Time-remapping audio pitch 



About time-remapping 

Time-remapping parts of a motion footage or audio layer

There are limitless options for time-remapping in After Effects. For example, you can time-remap an
entire layer, making it play backwards. You can time-remap a few frames at the beginning or end of 
the layer, creating a freeze-frame effect. Or you can time-remap frames in the middle of the layer, 
creating a slow-motion effect. 

You can remap time for video footage only; still images cannot be remapped. For best results, do 
not remap video footage that has been time-stretched.

See also: 

To freeze the first frame without changing the speed 

To freeze the last frame without changing the speed 

To remap time in the Time Layout window 

To remap time in a Layer window 



Time-remapping parts of a motion footage or audio layer 

To freeze the first frame without changing the speed: 

1    In a Composition window or Time Layout window, select the layer you want to remap.

2    Choose Layer > Enable Time Remapping.

3    Click the triangle to the left of the layer name to expand the layer outline.

4    Click the triangle to the left of the Time Remap heading to display the time graph for time 
remapping.

5    Move the current-time marker to where you want the movie to begin.

6    Press Shift and select the keyframes at the layer’s start and end.

7    Drag the first keyframe to the current-time marker.

See also: 

To freeze the last frame without changing the speed 

To remap time in the Time Layout window 

To remap time in a Layer window 



Time-remapping parts of a motion footage or audio layer 

To freeze the last frame without changing the speed: 

1    In a Composition window or Time Layout window, select the layer you want to remap.

2    Choose Layer > Enable Time Remapping.

3    Click the triangle to the left of the layer name to expand the layer outline.

4    Click the triangle to the left of the Time Remap heading to display the time graph for time 
remapping.

5    Drag the triangle at the end of the layer duration bar to the time where you want the freeze 
frame to end.

See also: 

To freeze the first frame without changing the speed 

To remap time in the Time Layout window 

To remap time in a Layer window 



Time-remapping parts of a motion footage or audio layer 

To remap time in the Time Layout window:

1    In a Composition window or Time Layout window, select the layer you want to remap.

2    Choose Layer > Enable Time Remapping.

3    Click the triangle to the left of the layer name to expand the layer outline.

4    Click the triangle to the left of the Time Remap heading to display the time graph for time 
remapping.

5    Move the current-time marker to the frame where you want change to begin, and then click the 
keyframe navigator box.

6    On the Time Remap graph below the keyframe, drag the Value graph marker, watching the Time
Remap value as you drag. To prevent the graph from dropping below the dotted line, press Shift as 
you drag the graph marker.

•      To slow down the layer, drag the Value graph marker down. (If the layer is playing in reverse, 
drag up.)
•      To speed up the layer, drag the Value graph marker up. (If the layer is playing in reverse, drag 
down.)
•      To play frames backward, drag the Value graph marker down to a value below the previous 
keyframe value.
•      To play frames forward, drag the Value graph marker up to a value above the previous keyframe
value.
•      To freeze the previous keyframe, drag the Value graph marker up to a value equal to the 
previous keyframe value so that the graph line is flat. Another method is to select the keyframe and 
choose Layer > Toggle Hold Keyframe, and then add another keyframe where you want the motion 
to start again.



A. No change B. Fast motion C. Freeze frame D. Backward motion

See also: 

To freeze the first frame without changing the speed 

To freeze the last frame without changing the speed 

To remap time in a Layer window 



Time-remapping parts of a motion footage or audio layer 

To remap time in a Layer window:

1    Open the Layer window for the layer you want to remap.

2    Choose Layer > Enable Time Remapping. A second time ruler appears in the Layer window 
above the default time ruler and the navigator bar.

3    On the lower time ruler, move the current-time marker to the first frame where you want the 
change to occur.

4    On the upper time ruler, the remap-time marker indicates the frame currently mapped to the time
indicated on the lower time ruler. To display a different frame at the time indicated on the lower time 
ruler, move the remap-time marker accordingly.

5    Move the current-time marker on the lower time ruler to the last frame where you want change 
to occur.

6    Move the remap-time marker on the upper time ruler to the frame you want to display at the time
indicated on the lower time ruler:
•      To move the preceding portion of the layer forward, set the remap-time marker to a later time 
than the current-time marker.
•      To move the preceding portion of the layer backward, set the remap-time marker to an earlier 
time than the current-time marker.
•      To freeze a frame, set the remap-time marker to the frame you want frozen. Then, move the 
current-time marker (lower ruler) to the last point in time where the frame will appear frozen and 
move the remap-time marker again to the frame you want frozen.

See also: 

To freeze the first frame without changing the speed 

To freeze the last frame without changing the speed 

To remap time in the Time Layout window 



About time-remapping 

Time-remapping audio pitch

The Velocity graph in the Time-remap property directly relates to the pitch of an audio file. By 
making subtle changes to the Velocity graph, you can create a variety of interesting effects. To 
avoid screeching audio, you may want to keep the Velocity below 200%. When the velocity (speed) 
is too high, use the Levels controls, located under the Audio property, to control the volume.

You may hear clicks at the beginning and end of an audio or an audio and video layer after setting 
new In and Out points in the Time Remap graph. You can use the Levels controls to remove these 
clicks. See Using audio layers.

See also: 

To change the pitch of an audio layer 

To remove clicks from new In and Out points in the Time Remap graph 



Time-remapping audio pitch 

To change the pitch of an audio layer:

1    In a Composition window or Time Layout window, select the layer you want to remap.

2    Choose Layer > Enable Time Remapping.

3    Click the triangle to the left of the layer name to expand the layer outline.

4    Click the triangle to the left of the Time Remap heading to display the time graph for time-
remapping.

5    Move the current-time marker to the frame where you want change to begin, and then click the 
keyframe navigator box.

6    On the Velocity graph below the keyframe, drag a marker, watching the Velocity value as you 
drag.
•      To lower the pitch, drag the Velocity graph marker down. 
•      To increase the pitch, drag the Velocity graph marker up.

See also: 

To remove clicks from new In and Out points in the Time Remap graph 



Time-remapping audio pitch 

To remove clicks from new In and Out points in the Time Remap graph:

1    If necessary, choose Window > Show Audio.

2    In the Time Layout window, select the audio or audio and video layer to which you applied time-
remapping.

3    Expand the layer outline to display the Audio property and then the Levels property, or press L 
on your keyboard.

4    Move the current-time marker to the new In point and click the stopwatch icon next to Levels to 
set a keyframe.

5    In the Audio palette, change the decibel value to 0.0.

6    Press the Page Up key on your keyboard to move the current-time marker to the previous 
frame.

7    In the Audio palette, change the decibel level to -96.0.

8    Move the current time to the new Out point and set the decibel level to 0.

9    Press the Page Down key on your keyboard to move the current-time marker to the next frame.

10    In the Audio palette, change the decibel level to -96.0.
You can change the 

decibel slider Minimum value in the Audio Options dialog box, which is available from the Audio palette 
window menu. See Previewing audio.

See also: 

To change the pitch of an audio layer 



Working with Masks and Transparency

When part of a layer is transparent, that transparency information is stored in the layer’s alpha 
channel. When the alpha channel of a layer doesn’t meet your requirements, you can use any 
combination of masks, mattes, and keying to display or hide different parts of a layer. You can also 
combine layers to achieve visual effects, apply layer modes to control the intensity or transparency 
of colors or brightness values, and use a color channel in one layer to create an effect in another 
layer. With a combination of layers and layer masks, you can create an array of effects. 

In order to create effects by combining images, parts of each image must be transparent. The 
terminology of transparency varies by media and by software; After Effects refers to transparent 
areas using the following terms:

Alpha channel An invisible channel that defines transparent areas for the footage item or layer that
contains the channel. With imported items, an alpha channel provides a way to store both the 
footage and its transparency information in a single file without disturbing the footage item’s color 
channels. Each After Effects layer contains one alpha channel which can accommodate an alpha 
channel included with a footage item. See Importing footage containing an alpha channel.

Mask A path, or outline, that modifies a layer’s alpha channel. Use a mask when you want to draw 
areas of transparency in After Effects. A mask belongs to a specific layer, but each After Effects 
layer can contain multiple masks.

Matte A layer (or any of its channels) that defines the transparent areas of that layer or another 
layer. Use a matte when you have a channel or layer that defines the desired area of transparency 
better than the alpha channel (or in cases where footage does not include an alpha channel).

Keying Defining transparency by a particular color (color key) or brightness value (luminance key) 
in an image. Pixels matching the key color become transparent. Use keying to remove a 
background with a uniform color, such as a bluescreen.



Comparing methods for creating transparency A. Original footage with unwanted background B. Saving an
alpha channel in footage file C. Drawing a mask in After Effects D. Creating a matte as a separate file E. Using
a color key in footage background F. Resulting footage composited over a new background 

See also: 

Creating high-quality mattes and transparency 

Using a footage item with an alpha channel 

Working with masks 

Creating masks 

Drawing rectangular and oval masks 

About mask paths 

Drawing a Bezier mask with the pen tool 

Selecting masks and mask points 

Scaling and rotating selected masks or points 

Changing the shape of a mask 

Feathering mask edges 

Specifying which parts of a mask are inside and outside 



Moving a mask and panning a layer behind a mask 

Specifying one mask as the target for animation 

Animating a mask 

Importing masks from Adobe Illustrator and Adobe Photoshop 

Applying effects to a mask 

Creating visible lines and solid shapes from masks 

Controlling how masks in the same layer interact 

Using mask modes 

Reusing a mask 

Creating track mattes and traveling mattes 

Using layer modes 

Creating transparency using keying 



Working with Masks and Transparency 

Creating high-quality mattes and transparency

When you define transparent areas and composite layers, the quality of your results depends 
largely on the quality of the footage you’re using. Remember that your goal is to make the matte or 
color key as clean as possible. Use the following guidelines to help ensure professional results:
•      Use the cleanest, highest-quality footage you can. The noise and lack of color precision in 
lower-quality formats such as VHS can result in mattes with holes or poorly defined edges, making 
clean compositing difficult or impossible.
•      When digitizing a matte or footage containing a key color, apply lossless compression such as 
run-length encoding (RLE). An example of an RLE compressor is the QuickTime Animation 
compressor set to highest quality. Lossy compressors such as Cinepak do not maintain the large, 
flat areas of color that are critical for professional results. For example, some lossy compressors 
throw out precision in the color blue first. This is obviously unacceptable if you are working with 
bluescreen footage.
•      When shooting against a background for a color key, such as a bluescreen, light the 
background evenly so that the color is as uniform as possible in the resulting frame. Variations in 
color—such as a shadow falling across the bluescreen—make it difficult to isolate one color for 
keying.

In After Effects, areas can be partially transparent. An alpha channel can use an 8-bit range of 
values, providing 256 levels of transparency, so masks or mattes you create can also use this many
levels of transparency. When you define a key color or value, you can specify a tolerance so that 
colors or values close to the key color or value also become transparent. Partial transparency is 
most useful for smoothing the edges of transparent areas.

If you often work with difficult mattes or color key footage, the After Effects Production Bundle 
contains matte tools such as the Spill Suppressor that can help compensate for poorly shot footage.



Working with Masks and Transparency 

Using a footage item with an alpha channel

An alpha channel is a fourth 8-bit channel, included in addition to the three 8-bit red, green, and 
blue color channels of video footage or an RGB image. When a file contains an alpha channel, its 
image is defined using a total of 32 bits, or as using Millions of Colors+. An alpha channel has the 
same function as a key in analog video compositing or a matte in optical film compositing—it 
describes which areas of an image are transparent. See Importing footage containing an alpha 
channel.



Working with Masks and Transparency 

Working with masks

Each layer in an After Effects composition can contain up to 127 masks. You create and view masks
in the Layer window, and set interactions between mask properties in the Time Layout window. You 
can also animate the shape of the mask by animating individual control points on a mask path. For 
more information on creating keyframes, see Setting keyframes.

To view masks in the Layer window:

Select Masks from the Layer Window menu.

To specify a mask in the Layer window as the target for all new mask shapes:

Select the mask name from the Target pop-up menu. For more information on the Target menu, see
Specifying one mask as the target for animation.



Working with Masks and Transparency 

Creating masks

In After Effects, you can create one or more masks for each layer in a composition. Using multiple 
masks in one layer makes it easy to create intricate designs, such as a transparent ring in the 
center of an image. Masks appear in the Time Layout window in the order you create them. 

You can create a mask in After Effects using any of the following methods: 
•      Draw a path using the tools from the toolbox.

A. Selection B. Rectangle C. Pen D. Oval
•      Specify the dimensions of the mask shape in the Mask Shape dialog box.
•      Paste a path drawn in and copied from another layer or from Adobe Illustrator or Adobe 
Photoshop. For more information, see Importing masks from Adobe Illustrator and Adobe 
Photoshop.

See also: 

Working with multiple masks in one layer 

Types of masks 



Creating masks 

Working with multiple masks in one layer

After you create your first mask, you can continue to create additional masks for a layer using any 
of the methods listed. 

Mask names appear in the order you create them in both the Layer window’s Target pop-up menu 
and the Time Layout window outline. To organize and keep track of your masks, you can rename 
them the same way you rename layers (see Renaming a layer).

When creating additional masks for one layer, make sure the Target pop-up menu in the Layer 
window is set to None; otherwise, you will replace the targeted mask instead of creating a new 
mask. See Specifying one mask as the target for animation.



Creating masks 

Types of masks

You can draw three types of masks:

Rectangular A rectangular mask can also be square. This type of mask is previewed and rendered 
faster than any other kind of drawn mask.

Oval An oval mask can also be circular.

Bezier You can use the pen tool to draw a freeform Bezier path as a mask. This is the most flexible 
type of mask; you can create any shape with the pen tool.

A. Rectangular mask B. Oval mask C. Bezier mask

After you first create a mask, it can be resized or rotated as a whole (see Scaling and rotating 
selected masks or points) or you can change parts of it (see Changing the shape of a mask).



Working with Masks and Transparency 

Drawing rectangular and oval masks

You can use the rectangle and oval tools to create mask shapes or you can specify a mask shape 
numerically.

To create a rectangular or oval mask by dragging:

1    Display a layer in the Layer window.

2    Select the rectangle tool ( ) or the oval tool (
) in the toolbox.

3    Position the cursor in the Layer window at one corner of the mask you want to draw and drag to the 
opposite corner. 
4    You can use any of the following techniques to alter the mask as you draw:

•      Press Shift as you drag to create a square with the rectangle tool or a circle with the oval tool.
•      Press Alt (Windows) or Option (Mac OS) while dragging to create a mask that extends from its 
center.
•      Double-click the oval tool to create an oval mask tangent to the edges of the layer.

For more information about moving, scaling, and rotating masks, see Scaling and rotating selected 
masks or points.

To create a new mask by specifying a mask shape numerically:

1    Display a layer in the Layer window.

2    Choose Layer > Mask > New Mask. A new mask appears in the Layer window with its handles 
at the outer edges of the frame.

3    Choose Layer > Mask > Mask Shape.

4    Select Rectangle or Oval.

5    If desired, specify the size and location of the mask’s bounding box. For information on 
coordinates, see Info palette.

6    Click OK.



Working with Masks and Transparency 

About mask paths

A mask in After Effects is a drawn path consisting of path segments and control points. Segments 
are the lines or curves that connect two control points. Control points define where each segment of
a path starts and ends. 

On curved paths, each control point provides further control over the shape of a curve through one 
or two direction lines extending out of the control point. You adjust the lines by dragging the 
direction handles.

A. Corner control point B. Smooth control point C. Direction line and handle D. Straight segment E. Curved 
segment

In addition, the mask you create can be either an open or closed path. An open path has different 
beginning and ending points; for example, a straight line is an open path. A closed path is 
continuous and has no beginning or end, for example, a circle is a closed path. Closed path masks 
can create transparent areas for a layer. Open paths cannot create transparent areas for a layer, 
but are useful when used as a parameter for an effect; for example, creating a visible line or shape 
from the mask using the Stroke effect. For more information, see Applying effects to a mask.

Open path mask (left) and closed path mask (right)



Working with Masks and Transparency 

Drawing a Bezier mask with the pen tool

Using the pen tools, you can create a Bezier mask of any shape, including straight lines at any 
angle or smooth flowing curves. The pen tools require more practice than other tools, but provide 
the most precise control over straight lines and curves.

A Bezier mask can be any shape.

You can easily adjust the shape of the path by dragging the mask’s control points or the direction 
lines associated with a control point. You can also quickly add points to or delete points from a 
segment, or change a control point from one type to another.

See also: 

Drawing straight lines with the pen tool 

Drawing curves with the pen tool 

Tips for drawing curves 



Drawing a Bezier mask with the pen tool 

Drawing straight lines with the pen tool

With the pen tool, you draw straight lines by simply clicking the pen tool to create control points. 
Each time you click the tool in a new location, After Effects draws a straight path segment from the 
previous point to the new point.

To draw straight lines with the pen tool:

1    Display a layer in its Layer window.

2    Select the pen tool (
) from the 

toolbox.
3    In the Layer window, position the cursor where you want the mask to begin and click to make the first 
control point.
4    Move the cursor to where you want the line to end and click to make the second point.
5    Continue clicking to create additional straight lines.
6    To end the path, do one of the following:

•      To leave the path open, stop drawing.
•      To close the path, position the cursor directly over the first control point, and when you see a 
closed circle icon ( ) next to the cursor, click. Or, choose Layer > Mask > Closed.



Drawing a Bezier mask with the pen tool 

Drawing curves with the pen tool

You can create a curved mask by dragging the pen tool in the direction you want the curve to go. 
Before you draw and modify curved lines with the pen tool, it is important to understand direction 
lines and curves. As with straight segments, control points mark a change in direction, but instead 
of creating a corner, control points on curves create smooth changes in direction. On curved 
segments, each selected control point displays one or two direction lines, ending in direction 
handles. The shape of a curved segment depends on the direction line at either end of the 
segment. As a path exits one control point, that point’s direction line shapes the curve. As the path 
approaches the next control point, its shape is less influenced by the previous point and more 
influenced by the direction line at the next control point. Moving these elements reshapes the 
curves in a path.

The direction lines are always touching the curve at the control points. The angle and length of a 
direction line determines the shape of the curve as it exits that control point.

Moving a direction line changes the slope of the curve

Continuous curved paths—that is, paths along a continuous wave shape—are connected by control
points called smooth points. Noncontinuous curved paths are connected by corner points. 

Smooth point (left) and corner point (right)

When you move a direction line on a smooth point, the curves on both sides of the point adjust 
simultaneously. By contrast, when you move a direction line on a corner point, only the curve on the
same side of the point as the direction line is adjusted.



Adjusting smooth point (left) and corner point (right)

To draw a curved Bezier mask:

1    Display a layer in its Layer window.

2    Select the pen tool (
) in the toolbox.

3    Position the pen tool in the Layer window where you want to draw the mask’s first control point. 
4    Click to make a control point. Hold down the mouse and drag in the direction you want the curve 
segment to be drawn. As you drag, the pointer pulls one of two direction handles.

The length and slope of the direction line determine the shape of the curve. You can adjust one or 
both sides of the direction line later. 

Drag in the outgoing direction of the curve to set the first control point (left). Then drag in opposite direction to 
complete the curve (right).

5    Click again in the location you want the curve to end and drag in the opposite direction of the 
first control point.

6    Repeat step 5 until you’ve drawn every segment.

7    Complete the shape by clicking the first control point or by double-clicking the last point.

A small circle appears when the pen tool is positioned directly over the first control point, making it easy to 



close a path.



Drawing a Bezier mask with the pen tool 

Tips for drawing curves

The following guidelines may help you draw curves quickly and easily.

Always drag the first direction handle in the direction of the bump of the curve, and drag the second 
direction handle in the opposite direction to create a single curve. Dragging both direction handles 
in the same direction creates an S curve.

Drag in the opposite direction to create a smooth curve (left). Drag in the same direction to create an S curve 
(right).

When drawing a series of continuous curves, draw one curve at a time, placing control points at the 
beginning and end of each curve, not at the top of the curve. Use as few control points as possible, 
placing them as far apart as possible along the path. This minimizes the number of points you have 
to manipulate when you want to make an adjustment, and helps prevent unwanted bumps from 
appearing on the path.

Fewer points create more efficient curves.



Working with Masks and Transparency 

Selecting masks and mask points

Before you can modify or animate masks, you must know how to select them, especially when 
you’ve created more than one mask on a layer. Also, unlike layers, masks can have more than one 
level of selection. You can select a mask as a whole path, which is appropriate when you want to 
move or resize a mask. However, if you want to change the shape of a mask, you select one or 
more points on a mask. Selected points appear solid, and unselected points appear hollow.

Whole mask selected (left) and one point selected on a mask (right)

See also: 

To select all or part of one or more masks in the Layer window 

To select masks in the Time Layout window 

To add masks or mask points to the selection 

To remove masks or mask points from the selection 



Selecting masks and mask points 

To select all or part of one or more masks in the Layer window:

1    Click the selection tool ( ).
2    Do one of the following:

•      To select a point on a mask, click it.
•      To select an entire mask by clicking, press Alt (Windows) or Option (Mac OS) as you click a 
mask. To select more masks, hold down Alt+Shift or Option+Shift as you click other masks.
•      To select masks by dragging, drag a dotted selection rectangle, called a marquee, completely 
around the points or masks you want to select.

To use the selection 
tool when using any other tool, hold down Control (Windows) or Command (Mac OS).

See also: 

To select masks in the Time Layout window 

To add masks or mask points to the selection 

To remove masks or mask points from the selection 



Selecting masks and mask points 

To select masks in the Time Layout window:

1    Click the right-facing arrow next to a layer name to expand it.

2    Click the right-facing arrow next to the Masks heading to expand it, revealing all masks on that 
layer.

3    Do any of the following:
•      To select one mask, click its name.
•      To select a contiguous range of masks, hold down Shift as you click the names of the first and 
last masks in the range.
•      To select several discontiguous masks together, hold down Control (Windows) or Command 
(Mac OS) as you click the names of any masks you want to include.

Note: You can only select whole masks in the Time Layout window. To select individual points on a mask, use 
the Layer window.

See also: 

To select all or part of one or more masks in the Layer window 

To add masks or mask points to the selection 

To remove masks or mask points from the selection 



Selecting masks and mask points 

To add masks or mask points to the selection:

Do one of the following:
•      With the selection tool ( ), drag a marquee to enclose all points on all desired masks.

•      With a mask selected, press Shift as you drag a marquee over other unselected masks.
•      With the selection tool, select a mask and press Shift as you click other unselected masks.

See also: 

To select all or part of one or more masks in the Layer window 

To select masks in the Time Layout window 

To remove masks or mask points from the selection 



Selecting masks and mask points 

To remove masks or mask points from the selection:

Do one of the following:
•      With the selection tool ( ), drag a marquee to enclose all points on all desired masks.

•      With a mask selected, press Shift as you drag a marquee over other selected masks.
•      With the selection tool, select a mask and press Shift as you click other selected masks.

To select all masks on a layer:

Choose Edit > Select All.

See also: 

To select all or part of one or more masks in the Layer window 

To select masks in the Time Layout window 

To add masks or mask points to the selection 



Working with Masks and Transparency 

Scaling and rotating selected masks or points

In one step, you can scale and rotate an entire mask or selected points in one or more masks by 
using the Free Transform Points command. When you use Free Transform Points, a bounding box 
surrounds the selected points and an anchor point displays in the center of the bounding box to 
mark the effect point for the current transformation. You can scale and rotate the selected mask 
points by dragging the bounding box or its handles. You can also change the point from which the 
mask rotates or scales by moving the bounding box anchor point.

It’s important to remember that the Free Transform Points bounding box handles and anchor point 
exist independently of the handles and anchor point for the layer. The layer’s handles and anchor 
point persist throughout a composition and correspond to the Position and Anchor Point layer 
properties. The Free Transform Points handles and anchor point exist only for the current 
transformation and are discarded after you’re finished modifying the mask.

Note: Animating a mask using Free Transform Points animates the overall shape of a mask, not the free-
transform movements, so results may be different than you expect.

A. Free Transform Points bounding box B. Bounding box handle C. Bounding box anchor point D. Layer 
anchor point

See also: 

To move, scale, or rotate a mask or mask points 



Scaling and rotating selected masks or points 

To move, scale, or rotate a mask or mask points:

1    Display the Layer window for the layer containing the mask or masks you want to transform.

2    With the selection tool, select the mask or mask points you want to transform.

3    Choose Layer > Mask > Free Transform Points.

4    If you want to move the bounding box’s anchor point, position the selection tool over the 
bounding box anchor point ( ) until the selection tool changes to a move anchor point icon (

). Drag to position the anchor point.

5    Do any combination of the following:
•      To move the mask or selected points, position the pointer inside the bounding box and drag.

Moving by dragging within a bounding box
•      To scale the mask or selected points, position the pointer on a bounding box handle, and when 
the pointer changes to a straight, double-sided arrow ( ), drag to a new size.

Scaling by dragging a Free Transform Points handle
•      To rotate the mask or selected points, position the pointer just outside the Free Transform 



bounding box and when the pointer changes to a curved double-sided arrow ( ), drag to rotate.

Rotating by dragging just outside the Free Transform Points bounding box



Working with Masks and Transparency 

Changing the shape of a mask

In the Layer window, you can freely change the shape of a mask. Changes to the masked area 
appear in the Composition window. You can move, delete, or add control points to reshape a mask 
and create a flexible outline to accommodate any shape. You can even change a mask shape over 
time.

Some changes require the use of tools grouped with the pen tool in the toolbox. To reveal these 
tools, click and hold the pen tool in the toolbox. When modifying a mask, make sure you click only 
existing control points or segments; otherwise, you may create a new mask instead.

Note: To view the changes in the Composition as you modify the mask, position the Layer and Composition 
windows so that you can see both.

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To change a mask shape numerically:

Choose Layer > Mask > Mask Shape, specify the changes, and then click OK.

See also: 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To replace one mask shape with another:

1    In the Layer window, select the mask from the Target pop-up menu.

2    Draw a new mask shape.

Note: After you create the new mask shape, select None from the Target pop-up menu; otherwise all 
subsequent masks you create will replace the targeted mask. See Specifying one mask as the target for 
animation.

See also: 

To change a mask shape numerically 

To delete a mask 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To delete a mask:

Select the mask in the Time Layout window, and then press Delete.

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To move a control point:

Using the selection tool ( ), drag the control point.

You can change the shape of the curve segment by dragging or repositioning the control points.
You can temporarily 

switch from the pen tool to the selection tool by pressing Control (Windows) or Command (Mac OS).

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To add a control point to a mask:

Using the Add Control Point tool ( ), click the line between two existing control points.

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To delete a control point from a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To delete a control point from a mask:

Do one of the following:
•      Using the Delete Control Point tool ( ), click a point.

•      Using the selection tool, select the control point and press Delete, or choose Edit > Clear.

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To add a control point to a mask 

To adjust the shape of a curve segment 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To adjust the shape of a curve segment:

Do one of the following:
•      Using the selection tool, drag a control point.

Dragging a control point
•      Using the selection tool, drag the direction lines extending from an adjoining smooth point.

Dragging a direction line
•      Using the selection tool, drag a curved segment.

Dragging a segment 

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To change a control point from a corner to a smooth point or vice versa 



Changing the shape of a mask 

To change a control point from a corner to a smooth point or vice versa:

Do one of the following:
•      Using the Convert Control Point tool (

), click the 
control point. 

•      Using the selection tool, press Control (Windows) or Control (Mac OS) as you click the control point.
•      Using the pen tool, click the control point.

See also: 

To change a mask shape numerically 

To replace one mask shape with another 

To delete a mask 

To move a control point 

To add a control point to a mask 

To delete a control point from a mask 

To adjust the shape of a curve segment 



Working with Masks and Transparency 

Feathering mask edges

Using the Mask Feather property, you can make mask edges hard-edged or soft-edged (feathered).
The feather width straddles the mask edge, half inside and half outside. For example, if you set the 
feather width to 25, the feathering extends 12.5 pixels inside the mask edge and 12.5 pixels outside
it.

A. No feather B. 2-pixel feather C. 40-pixel feather

Mask feathering takes place only within the dimensions of the layer frame area. Therefore, a 
feathered mask shape should always be slightly smaller than the layer area. If a mask feather 
extends beyond the layer area, the feathered edge will end abruptly.

Mask feather extends past layer boundary, ending abruptly (left). Mask feather remains inside layer boundary 
and all edges appear soft (right).

You can adjust the feathering of a layer’s mask by specifying precise values or by using a slider.

See also: 

To adjust feathering by specifying precise values 

To adjust feathering by dragging a slider 



Feathering mask edges 

To adjust feathering by specifying precise values:

1    Choose Layer > Mask > Mask Feather.

2    Specify amounts for horizontal and vertical feathering, and then click OK.

See also: 

To adjust feathering by dragging a slider 



Feathering mask edges 

To adjust feathering by dragging a slider:

1    Display the Time Layout window and expand the desired layer and its Mask property.

2    Press Control (Windows) or Command (Mac OS) as you click Mask Feather. A slider appears.

3    Drag the slider up to soften the mask edge or down to create a harder edge. The feather value is
displayed in the Info palette.

See also: 

To adjust feathering by specifying precise values 



Working with Masks and Transparency 

Specifying which parts of a mask are inside and outside

The image area inside the mask outline appears in the Composition window, and the area outside 
the mask outline is transparent. If you want to create the appearance of a hole in a video layer to 
reveal a layer underneath, switch the inside and outside areas by inverting the mask. You cannot 
change the mask state using keyframes; a mask is either inverted or not inverted for the entire 
duration of a composition.

Default behavior for a drawn mask (left); same mask inverted (right)

To invert a drawn mask:

Select the mask you want to invert and then do one of the following:
•      In the Time Layout window, select the Inverted option next to the mask name.

•      Choose Layer > Mask > Inverse.

When you have multiple masks in one layer, you can apply mask modes to create complex 
transparent shapes or varying levels of transparency. For more information, see Controlling how 
masks in the same layer interact.



Working with Masks and Transparency 

Moving a mask and panning a layer behind a mask

You can adjust the area that displays through a mask by either moving the mask in the Layer 
window or panning (moving) the layer behind the mask in the Composition window. When you move
a mask, the mask layer’s Position values remain constant, and the mask moves in relation to other 
objects in the Composition window. 

When you move a mask in the Layer window, the mask position changes, but its layer’s position remains the 
same. The mask moves in the Layer window (top), revealing different areas of its layer in the Composition 
window (bottom).

When you use the Pan Behind tool to pan a layer behind a mask, the mask’s position remains 
constant in the Composition window, but in the Layer window, its position changes. The masked 
layer’s Position values change in relation to the composition. As you pan past the edges of the 
layer’s frame, the layer’s Mask Shape values also change. Using the Pan Behind tool saves steps; 
without it, you would have to change the masked layer’s Position and Mask Shape properties 
manually. You can animate a layer panning behind another layer by setting keyframes for the 
masked layer’s Position and Mask Shape properties (see Setting keyframes).



When you use the Pan Behind tool in the Composition window, After Effects automatically makes two 
adjustments for you. In the Layer window, the mask is moved in relation to its layer (top), while in the 
Composition window, the layer is moved in relation to the composition (bottom).

You can also use the Pan Behind tool to move a layer’s anchor point without moving the layer’s 
relative position in the Composition window. When you select a layer in either the Composition or 
Time Layout window and then select the Pan Behind tool, that layer’s anchor point becomes active 
and adjustable. Again the Pan Behind tool saves you steps, because moving the layer’s anchor 
point with the selection tool would shift its resulting position in the Composition window; using the 
Pan Behind tool changes the layer’s position in order to compensate for your anchor point 
adjustment. As a result, you can move the anchor point without disturbing the Composition window.

When you use the Pan Behind tool to move the anchor point in the Composition window (left), After Effects 
automatically compensates for the move so that the layer maintains its position relative to the Composition 
window (right).

Note: Because a layer’s Anchor Point and Position properties are changed when you drag the anchor point 
using the Pan Behind tool, using the Pan Behind tool to change the anchor point of a moving layer alters the 
motion path. If your layer contains a motion path, move the anchor point in the Layer window (see Setting and 
animating an anchor point), and then select the motion path and adjust it accordingly.

See also: 



To move a mask 

To pan a layer behind its mask 

To move a layer’s anchor point using the Pan Behind tool 



Moving a mask and panning a layer behind a mask 

To move a mask:

1    In the Layer window, use the selection tool to select all of the mask’s control points. 

2    Click one point and drag to a new location. To constrain the movement of the mask to horizontal 
or vertical, press Shift after you start dragging.

See also: 

To pan a layer behind its mask 

To move a layer’s anchor point using the Pan Behind tool 



Moving a mask and panning a layer behind a mask 

To pan a layer behind its mask:

1    Select the Pan Behind tool in the toolbox ( ).
2    Click inside the mask area in the Composition window and drag the layer to a new position.

See also: 

To move a mask 

To move a layer’s anchor point using the Pan Behind tool 



Moving a mask and panning a layer behind a mask 

To move a layer’s anchor point using the Pan Behind tool:

1    Select a layer in either the Composition or Time Layout window.

2    Select the Pan Behind tool.

3    In the Composition window, use the Pan Behind tool to drag the anchor point to a new location. 
Notice that the Position and Anchor point values change for that layer.

Note: When using the Pan Behind tool to move an anchor point, make sure you drag the anchor point; 
otherwise, you will pan the masked layer.

See also: 

To move a mask 

To pan a layer behind its mask 



Working with Masks and Transparency 

Specifying one mask as the target for animation

As soon as you draw the first point on your first mask for a layer, the Layer window displays a 
Target pop-up menu, which you use to specify a mask as the target for all new mask shapes. 

When you create a new mask shape while a mask is selected in the Target pop-up menu, the 
targeted mask is replaced by the new shape. Targeting masks makes it easy to animate a mask 
from one shape to another. You can change this behavior by selecting None from the pop-up menu 
so any new mask shape you create in the Layer window creates a new mask instead of replacing 
an existing mask. 

To specify a mask as the target of all new shapes:

In the Layer window, select the mask name from the Target pop-up menu.

To specify no mask as a target for changes:

In the Layer window, select None from the Target pop-up menu.



Working with Masks and Transparency 

Animating a mask

You can change a layer’s Mask Shape and Mask Feather values over time by using keyframes (see
Understanding keyframes). When you animate a mask shape, After Effects follows the location of 
the mask’s control points from keyframe to keyframe. Animating a mask shape using the Free 
Transform Points command may create unexpected results.

When animating control points, plan ahead for efficient and predictable animation. Start with the 
minimum number of points and add more as you animate. This may require starting at the end of 
the animation. For example, if you start at 00:00 with a complex mask shape and end at 05:00 with 
a simple triangle mask shape, start animating your mask at 05:00 and work backwards in time.

Note: When you add a control point to a mask, the new point appears on the mask at all points in time, but 
only reshapes the mask at the point where it was added. When you delete a control point from a mask at a 
specific point in time, the point is deleted from the mask at all points in time. Check your work often, at various 
points along the timeline.

See also: 

To animate a mask shape 

To animate mask feathering 



Animating a mask 

To animate a mask shape:

1    Display the Layer window for a layer and select the mask name from the Target pop-up menu.

2    In the Time Layout window, select the mask you want to animate. 

3    Expand the layer outline to display the Mask property.

4    Make sure the current-time marker is where you want the animation to begin, and then click the 
Mask Shape stopwatch icon to set the initial keyframe.

5    Move the current-time marker to a point in time where you want to add a keyframe.

6    In the Layer window, move or change the mask, or create a new mask shape. After Effects 
automatically creates a new keyframe at the current time.

7    Repeat steps 5 and 6 as many times as necessary.

Individual control points animated over time

See also: 

To animate mask feathering 



Animating a mask 

To animate mask feathering:

1    In the Time Layout window, select the layer you want to animate. 

2    Expand the layer outline to display the Mask property.

3    Make sure the current-time marker is where you want the animation to begin, and then click the 
underlined Mask Feather value and enter any value you want.

4    Click the Mask Feather stopwatch icon to set the initial keyframe.

5    Move the current-time marker to the point in time where you want to add the next keyframe.

6    Click the underlined Mask Feather value and enter a new value. After Effects automatically 
creates a new keyframe at the current time.

7    Repeat steps 5 and 6 as many times as you want. 

See also: 

To animate a mask shape 



Working with Masks and Transparency 

Importing masks from Adobe Illustrator and Adobe Photoshop

You can import paths from Adobe Illustrator or Adobe Photoshop and use them in your After Effects 
layers. Using the special path editing tools available in these applications, you can create a wider 
variety of shapes for your After Effects masks.

Path in Adobe Illustrator (left), and that same path imported into an After Effects Layer window as a mask 
(right)

To import a path from Adobe Illustrator or Adobe Photoshop:

1    Open Adobe Illustrator or Adobe Photoshop and create a path. For more information about 
creating a path in Adobe Illustrator or Adobe Photoshop, see the user guide for the application.

2    Select all of the control points on the path that you want to copy to After Effects.

3    Choose Edit > Copy.

4    Open After Effects.

5    Open the Layer window into which you want to paste the path, and choose Edit > Paste.

Note: Each path from Adobe Illustrator or Adobe Photoshop will be imported into After Effects as one mask.



Working with Masks and Transparency 

Applying effects to a mask

You can apply the following effects to a mask shape: Path Text, Audio Waveform, Audio Spectrum, 
Stroke, Fill, Reshape (After Effects Production Bundle only), and Smear.

You may also be able to apply masks to effects from other manufacturers. To find out where to get 
more information on the effects listed, see the index.



Working with Masks and Transparency 

Creating visible lines and solid shapes from masks

You can create visible lines and solid shapes by drawing a mask with the pen tool and rendering it 
with a stroke (outline), fill, or both, using any color for each. Each mask in a layer can have different
fill and stoke settings. You can stroke an open or closed mask path, but if you want to fill a mask, it 
must be a closed path. Stroke and fill are available as effects you apply to a mask (see Working 
with effects).

A stroke is applied to a mask with its brush size (stroke weight) centered on the mask path. If you 
want to add both a stroke and a fill to a closed path, the order in which you apply the stroke and fill 
effects determines the visible width of the stroke. If the fill is applied before the stroke, the full stroke
brush size is visible. If the stroke is applied before the fill, the fill will appear on top of the stroke, 
obscuring the half of the stroke that falls inside the path. You can change the order of the effects in 
the Effect Controls window.

A. Original closed mask (top) and open mask (bottom) B. Stroked closed mask (top) and stroked open mask 
(bottom) C. Filled closed mask D. Filled and Stroked closed mask

See also: 

To apply a stroke to a mask outline 

To apply a fill to a closed mask path 



Creating visible lines and solid shapes from masks 

To apply a stroke to a mask outline:

1    In the Time Layout or Composition window, select the layer containing the mask you want to 
stroke. 

2    Choose Effect > Render > Stroke.

3    In the Effect Controls window, choose the mask you want to stroke from the Path menu.

4    Specify the following options as necessary:

Brush Size The width of the stroke at 100% Brush Hardness.

Brush Hardness Pressure applied by the brush, represented by the fuzziness of the edge. 100% 
equals full pressure. Lowering the value can simulate easing up on the brush, especially if you 
lower and raise the value over time using keyframes.

Opacity Transparency of the stroke. 0% opacity equals full transparency.

Spacing Frequency at which the brush lays down the stroke. 0% spacing creates a continuous 
stroke. Higher values create a dotted-line effect, especially when brush size and hardness are 
reduced.

See also: 

To apply a fill to a closed mask path 



Creating visible lines and solid shapes from masks 

To apply a fill to a closed mask path:

1    In the Time Layout or Composition window, select the layer containing the mask you want to fill.

2    Choose Effect > Render > Fill.

3    In the Effect Controls window, choose the mask you want to fill from the Fill Mask menu.

4    Select the fill settings you want. The effect appears in the Composition window as you enter new
settings.

See also: 

To apply a stroke to a mask outline 



Working with Masks and Transparency 

Controlling how masks in the same layer interact

After Effects provides transfer modes for masks, which control how different masks within a layer 
interact with one another. By default, all masks are set to Add, which combines the transparency 
values of any masks that overlap on the same layer. You can apply one mode to each mask, and 
you cannot change a mask’s mode over time. 

The first mask you create interacts with the layer’s alpha channel or, if doesn’t have an alpha 
channel, it interacts with the layer frame. Each additional mask you create interacts with masks 
located above it in the Time Layout window outline. The results of mask modes vary depending on 
the modes set for the masks higher up in the outline. You can use mask modes only between 
masks in the same layer.



Working with Masks and Transparency 

Using mask modes

Using mask modes, you can create complex mask shapes with multiple transparent areas. For 
example, you can set a mask mode that combines two masks and sets the opaque area to the 
areas where the two masks intersect.

Mask shapes that result when different modes are applied to circle mask A. Original masks B. None C. 
Add D. Subtract E. Intersect F. Difference 

The following mask mode descriptions are based on interactions between two layer masks— the 
top set to Add, the other set to the mask mode described:

None After Effects treats the mask as if it does not exist. The mask has no impact on the layer or 
composition. This option is useful when you want to use the mask’s path for an effect such as 
Stroke or Fill, but do not want it to create transparent areas in the layer. For more information, see 
Applying effects to a mask.

Add Adds the selected mask area to the other masks for that layer, displaying all mask contents in 
the Composition window. Where multiple masks intersect, the opacity of all intersecting masks is 
added together.

Subtract Subtracts the mask from the mask located above it in the Time Layout window. The 
contents of the subtracted mask area do not display in the Composition window. This option is 
useful when you want to create the appearance of a hole in the center of another mask.

Intersect Adds the mask to all masks above it, but displays in the Composition window only the 
area where the selected mask and any of the others intersect. Where multiple masks intersect, the 
opacity of all intersecting masks is added together.

Lighten Adds the mask to all the masks above it, displaying contents of all masked areas in the 
Composition. Where multiple masks intersect, the highest opacity value is used, so opacity doesn’t 
build up.

Darken Adds the mask to all masks above it, but displays in the Composition window only the area 
where the selected mask and any of the others intersect. Where multiple masks intersect, the 



highest transparency value is used, so transparency doesn’t build up.

Difference Adds the selected mask to the masks above it, and displays in the Composition window 
the mask contents of all masked areas except those areas where the masks intersect.

A. Original frame with the default Add mode B. Detail of feathered edge using Add mode C. Detail of edges 
made more distinct by applying Lighten mode.

To apply a mask mode: 

1    In the Time Layout window, select the layer containing the mask to which you want to apply a 
mode.

2    Press M, or click the triangle next to the layer name and then click the triangle next to Masks to 
expand the Mask outline.

3    Click the menu next to the mask name and choose a mask mode.



Working with Masks and Transparency 

Reusing a mask

You can reuse masks in other layers and compositions. It is particularly useful to store Bezier 
masks you’ve spent a long time perfecting. You can even create a project with compositions that 
exist just to store complex layer masks. Mask shapes are stored inside a composition, not as an 
external file on your hard disk. When you want to use a mask from another project, import that 
project into your current project.

See also: 

To save a mask 

To reuse the mask 



Reusing a mask 

To save a mask:

1    Open the Time Layout window for the composition containing the layer and mask, and then 
expand the layer and its mask properties.

2    Do one of the following:
•      To save an animated mask, select the mask keyframes you want to save. For more information, 
see Setting keyframes.
•      To save a non-animated mask, select the I-beam for the mask, or open the Layer window and 
select the mask path.

3    Choose Edit > Copy.

4    Create a new layer to use as a placeholder for the mask. The new layer can be a simple solid.

5    Select the new layer in the Time Layout window.

6    Choose Edit > Paste.

See also: 

To reuse the mask 



Reusing a mask 

To reuse the mask:

1    Open the Time Layout window for the composition containing the layer and mask, and then 
expand the layer and its mask properties.

2    Open the Layer window and select the mask path.

3    Choose Edit > Copy.

4    Select the layer in the Time Layout window in which you want to use the mask.

5    Choose Edit > Paste.

See also: 

To save a mask 



Working with Masks and Transparency 

Creating track mattes and traveling mattes

When you want one layer to show through a hole in another layer, set up a track matte. You’ll need 
two layers—one to act as a matte, and another to fill the hole in the matte.

You can animate either the track matte layer or the fill layer. When you animate the track matte 
layer, you create a traveling matte. If you want to animate the track matte and fill layers using 
identical settings, consider precomposing them (see Understanding precomposing).

A. Original footage (fill layer) B. Traveling matte C. Resulting image 

See also: 

Using alpha channel or luminance values for a track matte 

To create a track matte 

Preserving underlying transparency during compositing 



Creating track mattes and traveling mattes 

Using alpha channel or luminance values for a track matte

After Effects lets you define transparency in a track matte using values from either its alpha channel
or the luminance of its pixels. Using luminance is useful when you want to create a track matte 
using a layer without an alpha channel or a layer imported from a program that can’t create an 
alpha channel. In both alpha channel mattes and luminance mattes, pixels with higher values are 
more transparent. In most cases, you use a high-contrast matte so that areas are either completely 
transparent or completely opaque. Intermediate shades should appear only where you want partial 
or gradual transparency, such as along a soft edge.

A. Original footage B. Track matte using varying luminance values for hard and soft edges C. Result



Creating track mattes and traveling mattes 

To create a track matte:

1    Click the Switches/Modes button at the bottom of the Time Layout window. The Transfer Modes 
panel appears in place of the Layer Features panel. 

2    Arrange two layers in the Time Layout window. Make sure the designated matte layer is directly 
above the designated fill layer.

3    From the TrkMat menu for the fill layer, define transparency in the next layer above by choosing 
one of the following:

No Track Matte No transparency created; next layer above acts as a normal layer.

Alpha Matte Opaque when alpha channel pixel value is 100%.

Alpha Inverted Matte Opaque when alpha channel pixel value is 0%.

Luma Matte Opaque when a pixel’s luminance value is 100%.

Luma Inverted Matte Opaque when a pixel’s luminance value is 0%.

After Effects converts the next layer above into a track matte, turns off the video of the track matte 
layer, and adds a dotted line border between the matte layer and the fill layer in the Time Layout 
window. The Composition window displays the fill layer viewed through the alpha channel of the 
matte layer.

Note: Although the video is turned off for the matte layer, you can still select the layer to reposition, scale, or 
rotate it. Select the layer in the Time Layout window, then drag the center (indicated by a circle with an X) of 
the layer in the Composition window.

See also: 

Using alpha channel or luminance values for a track matte 

Preserving underlying transparency during compositing 



Creating track mattes and traveling mattes 

Preserving underlying transparency during compositing

The Preserve Underlying Transparency option specifies that the opaque areas of a layer display 
only when positioned over opaque areas in underlying layers. With this option, you can make a 
layer display only when it is positioned over the layer below it. It’s useful for creating effects such as
glints or light reflecting off a polished surface.

To preserve underlying transparency:

Select the T option in the Layer Switches column for the appropriate layer.
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Using layer modes

Layer modes control how each layer blends with or reacts to layers beneath it. The stencil and 
silhouette layer modes affect the alpha channels of layers beneath them. Other layer modes affect 
how colors appear when blended with the colors from other layers. Layer modes in After Effects are
very similar to layer modes in Adobe Photoshop.

Layer modes cannot be animated using keyframes. If you want a layer mode to change at a certain 
time, split the layer at that time and apply the new layer mode to the part of the layer that continues.
You can also use the Compound Arithmetic effects, which are similar to layer modes but can 
change over time. For more information on splitting layers, see Splitting a layer. For more 
information on Compound Arithmetic effects, see Compound Arithmetic.

When using layer modes, it is helpful to think of the effects in the following terms:
•      The underlying colors are the colors of the layers located below the layer to which you want to 
apply the mode.
•      The layer colors are the original colors in the layer where you set the layer mode.
•      The resulting colors are the final colors displayed.

Layer modes change the appearance of certain colors in a layer. The layer mode you select 
determines how the layer’s colors appear, based on how the two layers’ color values combine 
mathematically.

See also: 

Specifying a layer mode 

Using stencil and silhouette layer modes 



Using layer modes 

Specifying a layer mode

You can apply one of the following layer modes to a layer:
Normal 
Dissolve 
Multiply 
Screen 
Overlay 
Soft Light 
Hard Light 
Color Dodge 
Color Burn 
Darken 
Lighten 
Difference 
Exclusion 
Hue 
Saturation 
Color 
Luminosity 

Normal    Composites the layer on top of underlying layers.

Dissolve    Randomly replaces layer colors with colors from underlying layers, based on layer 
transparency.

Dancing Dissolve    Functions the same as the Dissolve option, except that the placement of 
random color changes varies over time.

Add    Combines the color values of the layer and underlying colors. The resulting color is lighter 
than the original. This is a good way to combine non-overlapping images in two layers. Pure black 
in a layer does not change the underlying color. Pure white in the underlying color is never 
changed.

Multiply    Multiplies the color values in the layers and divides the result by 255. The resulting color 
is never brighter than the original.

Screen    Multiplies the inverse brightness values of the colors in all layers. The resulting color is 
never darker than the original. Using the Screen option is similar to the traditional technique of 
superimposing two different film negatives and printing the result.

Overlay    Mixes colors between layers, preserving highlights and shadows to reflect the light and 
dark areas of the layer colors.

Soft Light    Darkens or lightens resulting colors, depending on the layer color. The effect is similar 
to shining a diffused spotlight on the layer. If the underlying color is lighter than 50% gray, the layer 
lightens. If the underlying color is darker than 50% gray, the layer darkens. A layer with pure black 
or white becomes markedly darker or lighter, but does not result in pure black or white.

Hard Light    Multiplies or screens the resulting color depending on the original layer color. The 
effect is similar to shining a harsh spotlight on the layer. If the underlying color is lighter than 50% 
gray, the layer lightens as if it were screened. If the underlying color is darker than 50% gray, the 
layer darkens as if it were multiplied. This option is useful for creating the appearance of shadows 
on a layer.



Darken    Compares the channel values of the underlying and layer colors and displays the darker 
of the two. Specifying this option can cause color shifts in layers with color.

Lighten    Compares the channel values of the underlying and layer colors and displays the lighter 
of the two. Specifying this option can cause color shifts in layers with color.

Difference    Subtracts the channel values of the layer and underlying colors and displays the 
absolute value of the result.

Hue    Creates resulting colors with the luminance and saturation of the underlying colors and the 
hue of the layer colors.

Saturation    Creates resulting colors with the luminance and hue of the underlying colors and the 
saturation of the layer colors. If you use this option with a layer having no saturation (gray), there is 
no change.

Color    Creates resulting colors with the luminance of the underlying colors and the hue and 
saturation of the layer colors. This preserves the gray levels in the image.

Luminosity    Creates resulting colors with the hue and saturation of the underlying colors and the 
luminance of the layer colors. This option is the inverse of the Color option.

Alpha Add Composites layers normally, but adds complementary alpha channels together to create
a seamless area of transparency. Useful for removing visible edges from two alpha channels that 
are inverted relative to each other, or from the alpha channel edges of two touching layers that are 
being animated.

Luminescent Premul Prevents clipping of color values that exceed the alpha channel value after 
compositing by adding them to the composition. Useful for compositing rendered lens or light 
effects (such as lens flare) from footage with premultiplied alpha channels. May also improve 
results when compositing footage from other manufacturers’ matting software. When applying this 
mode, you may get the best results by changing After Effects’ interpretation of the premultiplied-
alpha source footage to straight alpha (see Interpreting alpha channels as straight or premultiplied).

To apply a layer mode:

1    If the Mode menu is not visible in the Time Layout window, click the Switches/Mode button at the
bottom of the Time Layout window.

2    From the layer’s Mode menu, choose a mode.



Using layer modes 

Using stencil and silhouette layer modes

The stencil and silhouette layer modes use either a layer’s alpha channel or its luminance (luma) 
values to affect the alpha channel of all layers beneath the layer. This differs from the track matte, 
which affects only one layer. 

Stencil mode Cuts through all layers, so you can show multiple layers through the frame of the 
stencil layer’s alpha channel.

Silhouette mode Blocks out all layers below it, so you can cut a hole through several layers at 
once.

Note: The stencil and silhouette layer modes affect all layers below the layer to which they are applied. To 
keep the silhouette and stencil layer modes from cutting through or blocking all layers underneath, nest the 
layer in a composition. For more information on nesting, see Creating animations by nesting compositions.

When using Stencil Luma, the lighter pixels of the layer are more opaque than the darker pixels. 
When using Silhouette Luma, the lighter pixels of the layer are more transparent than the darker 
pixels.

Stencil cuts through to show all layers below. Silhouette cuts through all layers below.

To use the stencil or silhouette modes on a layer:

1    Choose Transfer Controls from the pop-up menu at the bottom of the Time Layout window.

2    From the Mode pop-up menu for the layer you want to use as a stencil or silhouette, choose one
of the following:
•      Stencil Alpha creates a stencil using the layer’s alpha channel.
•      Stencil Luma creates a stencil using the layer’s luma values.
•      Silhouette Alpha creates a silhouette using the layer’s alpha channel.
•      Silhouette Luma creates a silhouette using the layer’s luma values.
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Creating transparency using keying

You can make parts of a footage file transparent by keying out a color or luminance value. Keying 
makes it easy to key objects moving across a consistent background color or objects too complex 
to easily mask. When you key out a value, all pixels that have similar colors or luminance values 
become transparent. This technique is often called bluescreening, although you do not have to use 
blue; you can use any solid color for a background.

Note: To get more powerful keying capabilities, use the advanced keying effects available in the Adobe After 
Effects Production Bundle.

See also: 

Keying out a color value 

Keying out a luminance value 



Creating transparency using keying 

Keying out a color value

When you key out a color value in a layer, that color or range of colors becomes transparent for the 
entire layer. You can control the range of transparent colors by adjusting the tolerance level. You 
can also feather the edges of the transparent area to create a smooth transition between the 
transparent and opaque areas.

Footage shot against a bluescreen (left); blue color keyed out to reveal layer behind (right)

To key out a single color:

1    Select the layer.

2    Choose Effect > Keying > Color Key.

3    In the Effect Controls window, specify a key color in one of two ways:
•      Click the Key Color swatch to open the Color dialog box and specify a color.
•      Click the eyedropper, and then click a color on the screen.

4    Drag the Color Tolerance slider to specify the range of color to key out. Lower values key out a 
smaller range of colors near the key color. Higher values key out a wider range of color.

5    Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values enlarge 
the mask, increasing the transparent area. Negative values shrink the mask, decreasing the 
transparent area.

6    Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer 
edge but take longer to render.



Creating transparency using keying 

Keying out a luminance value

When the object you want to matte has a markedly different luminance value than its background, 
you can make the background value transparent by keying it out.

For example, if you want to create a matte for musical notes on a white background, you can key 
out the brighter values; the dark musical notes become the only opaque area.

Original footage with a light background (left); light background keyed out and replaced with a color (right)

To key out a luminance value:

1    Select the layer.

2    Choose Effect > Keying > Luma Key.

3    Choose from the Key Type pop-up menu to specify the range to be keyed out:

Key Out Brighter    Keys out values greater than the threshold value.

Key Out Darker    Keys out values less than the threshold value.

Key Out Similar    Keys out values within the tolerance value of the threshold value.

Key Out Dissimilar    Keys out values outside the tolerance value of the threshold value.

4    Drag the Threshold slider on the Effect Controls window to set the luminance value on which 
you want the matte to be based.

5    Drag the Tolerance slider to specify the range of values to be keyed out. Lower values key out a 
smaller range of values near the threshold. Higher values key out a wider range of values.

6    Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values grow 
the mask, increasing the transparent area. Negative values shrink the mask.

7    Drag the Edge Feather slider to specify the softness of the edge. Higher values create a softer 
edge but take longer to render.



Applying Effects

The power of After Effects lies in its ability to employ and change effects over time. After Effects 
includes a variety of effects that you can apply to any layer. An effect can add a special visual or 
audio characteristic or provide an unusual feature. For example, effects can alter the exposure or 
color of footage, manipulate sound, distort images, add artistic or lighting effects, animate credits 
and titles, or create an unusual transition. You can also convert Cineon frames for use in an After 
Effects project. 

All effects are stored in the Plug-ins folder inside the After Effects folder. You can use third-party 
effects that are not provided by Adobe. You can add a single new effect or an entire folder of new 
effects to the Plug-ins folder. Whenever you launch After Effects, it searches this folder for all 
installed effects and adds them to the Effect menu.

Note: The Adobe After Effects 4.0 Production Bundle provides additional effects and advanced controls. For 
more information on the After Effects Production Bundle, contact your Adobe retailer or visit the Adobe Web 
site. 

You can add any effect to a layer at any time. If you don’t like an effect, you can easily delete it. You
can even apply a single effect to one layer several times. The intensity and position of an effect is 
determined by values that you control. You change these values in a variety of ways, depending on 
the effect. For example, you can change a percentage or size by entering a new value, or adjust an 
angle by clicking in an angle control. These controls provide infinite levels of precision and subtly.

You can change all values for all effects in the Effect Controls window. In addition, you can change 
some values directly from the Time Layout window. A few effects have additional controls in the 
Composition and Layer windows.

By default, when you apply an effect to a layer, the effect is active for the duration of the layer. 
However, you can make an effect start and stop at specific times, or make the effect more or less 
intense over time, by using keyframes. 

For a description of each effect, see Effects included with After Effects. For detailed information 
about an effect’s controls, as well as for specific procedures on certain effects, see the online Help. 
You can print any Help topic at any time.

See also: 

Working with effects 

Changing the values of an effect’s properties 

Placing an effect using effect points 

Changing effects over time 

Applying multiple effects 

Positioning effects on layers 

Applying an effect to several layers with an adjustment layer 

Changing rendering order 

Using audio effects 

Using Adobe Photoshop layer effects in After Effects 

Effects included with After Effects 

Adjust effects 

Audio effects 

Blur and Sharpen effects 



Channel effects 

Cineon tools 

Distort effects 

Image Control effects 

Keying effects 

Perspective effects 

Render effects 

Stylize effects 

Text effects 

Time effects 

Transitions effects 

Video effects 



Applying Effects 

Working with effects

When you apply an effect to a layer, the Effect Controls window opens, in which the effect is listed. 
Each layer to which you apply effects appears on its own tab in the Effect Controls window. The 
effect is also listed in the Effects section under the layer name in the Time Layout window. If you 
apply additional effects to the layer, they are listed under the first effect in the Time Layout window. 
Effects are rendered in order from top to bottom in this list. You change the order in which effects 
are rendered by dragging the effect name to a new position in the list. 

The Effect Controls window contains a variety of controls you use to modify the properties of an 
effect. Controls include sliders, options, color swatches, effect points, angles, and other controls 
that adjust values. 

See also: 

Applying and controlling effects 
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Applying and controlling effects

You can apply or remove an effect at any time. Once you’ve applied effects to a layer, you can 
temporarily turn off one or all the effects in the layer to concentrate on another aspect of your 
composition. Effects that are turned off do not appear in the Composition window and typically are 
not included when the layer is previewed or rendered. (However, in the Render Queue window, you 
can specify that the composition is rendered with all effects on, regardless of which effects you are 
displaying in the Composition window.) Turning off an effect does not delete the keyframes created 
for any of the effect properties; all keyframes remain until the effect is deleted from the layer. 

For some effects, after applying the effect you can quickly adjust its controls by clicking Options in 
the Effect Controls dialog box. 

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 
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To apply an effect to a layer:

1    In the Time Layout or Composition window, select a layer.

2    Choose a category from the Effect menu, and then choose an effect from the submenu.
Using this procedure, 

you can apply multiple instances of a single effect to a layer.

See also: 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 



Applying and controlling effects 

To open the Effect Controls window:

In the Time Layout window, double-click an effect name, or choose Layer > Open Effect Controls. 

See also: 

To apply an effect to a layer 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 
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To select a layer in the Effect Controls window:

Click the tab below the Effect Controls title bar for the layer you want to select. 

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 
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To open the Options dialog box for an effect:

In the Effect Controls window, click Options to the right of the effect name.

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 



Applying and controlling effects 

To copy effects in a layer and paste them into other layers:

1    In the Effect Controls window, select one or more effect, and then choose Edit > Copy.

2    In the Time Layout window, select one or more layers, and then choose Edit > Paste.

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 



Applying and controlling effects 

To temporarily turn off an effect:

In the Effect Controls or Time Layout window, select the layer, and then click the Effect option to the
left of the effect name.

A. The Effect option in the Effect Controls window controls a specific effect. B. The Effect option in the Time 
Layout window also controls a specific effect. C. The Effect switch in the Switches panel of the Time Layout 
window controls all effects in a layer.

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 

To remove an effect 



Applying and controlling effects 

To temporarily turn off all effects in a layer:

In the Time Layout window, click the Effect switch in the Switches panel for the desired layer. 

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To set a keyframe for an effect 

To remove an effect 
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To set a keyframe for an effect:

In the Effect Controls window, press and hold down Alt (Windows) or Option (Mac OS) and click the 
effect property for which you want to set a keyframe.

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To remove an effect 
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To remove an effect:

In the Effect Controls window, select an effect name and press Delete, or choose Edit > Clear.

See also: 

To apply an effect to a layer 

To open the Effect Controls window 

To select a layer in the Effect Controls window 

To open the Options dialog box for an effect 

To copy effects in a layer and paste them into other layers 

To temporarily turn off an effect 

To temporarily turn off all effects in a layer 

To set a keyframe for an effect 
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Changing the values of an effect’s properties

The Effect Controls window shows all the controls used to change the property values for an effect. 
These controls can include underlined values, sliders, effect point icons, angle controls, menus, 
color swatches, eyedroppers, and graphs. 

You can also change the property values for an effect in the Time Layout window, although using 
the Effect Controls window is often quicker and easier. 

Sliders in the Effect Controls window cover only the most common range of values. To enter a 
higher or lower value, or to get more precise control over a value, click the underlined value and 
enter a number in the dialog box that appears. The dialog box displays the minimum and maximum 
values you can use.

See also: 

To change the value of an effect property 

To set an angle 

To set a tint value for an effect 

To display a version number and description for an effect 



Changing the values of an effect’s properties 

To change the value of an effect property:

1    In the Effect Controls window, click the effect name to select it.

2    If the effect’s controls are not visible, click the triangle to the left of the effect name. 

3    Change the value using one of the following methods:
•      Drag the slider left or right. 
•      Click the underlined value, type a new value in the dialog box, and click OK.
•      To select default values, click Reset.

A. Click to expand or collapse an effect’s controls. B. Drag left to decrease or right to increase a value. C. 
Click to return to the default values. D. Click to enter a new value.

To see effect 
properties change interactively in the Composition window, press and hold down Alt (Windows) or Option 
(Mac OS) and then change the property. 

See also: 

To set an angle 

To set a tint value for an effect 

To display a version number and description for an effect 



Changing the values of an effect’s properties 

To set an angle:

Set the angle using one of the following methods:
•      Click a point inside the angle control.
•      Click and drag the angle line. 

Note: Once you have clicked inside the angle control, you can drag outside of it for more precision. 
•      Click the underlined value above the angle control, type a new value, and click OK.

Note: You can set an angle of more than 360 degrees by dragging the angle line around the circle more than 
once or by entering a new angle value. 

See also: 

To change the value of an effect property 

To set a tint value for an effect 

To display a version number and description for an effect 



Changing the values of an effect’s properties 

To set a tint value for an effect:

Set the tint value using one of the following methods:
•      In the Effect Controls window, click the color swatch, select a color in the Color dialog box, and 
click OK.
•      Click the eyedropper, position it on the desired color anywhere on the screen, and click to select
the color. 

See also: 

To change the value of an effect property 

To set an angle 

To display a version number and description for an effect 



Changing the values of an effect’s properties 

To display a version number and description for an effect:

Click About to the right of the effect name in the Effect Controls window. 

See also: 

To change the value of an effect property 

To set an angle 

To set a tint value for an effect 
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Placing an effect using effect points

Some effects require that you identify specific positions on a layer to determine how the effect will 
be applied. Often, these effect points enable After Effects to properly position the effect on the layer.
A given effect may require as few as one or as many as four or more effect points. 

Note: The positions of these effect points are based on the coordinate system for the layer, not for the 
composition. For example, the coordinates for the center of a 40x40 square are always 20, 20, no matter what 
size you specify for the composition. The coordinates shown in the Info palette are composition coordinates 
when you’re working in the Composition window and layer coordinates when you’re working in the Layer 
window.

You can specify the location of an effect point by using the effect point icon in the Effect Controls 
window, or by dragging the effect point in the Composition or Layer window. If you move the effect 
point over time by creating position keyframes, you can view the path of its movement in the Layer 
window. To view the effect point in the Layer window, select the effect name in the Layer window 
menu.

Note: A layer’s anchor point does not influence the position of an effect. 

See also: 

To set an effect point by dragging 

To set an effect point using the effect point icon 

To set an effect point using position coordinates 



Placing an effect using effect points 

To set an effect point by dragging:

Click the effect point ( ) in the Composition window and drag. 
The coordinates in the Effect Controls window change as you drag. 

See also: 

To set an effect point using the effect point icon 

To set an effect point using position coordinates 



Placing an effect using effect points 

To set an effect point using the effect point icon:

1    Click the effect point icon in the Effect Controls window.

2    In the Composition or Layer window, position the cursor at the place where you want the effect 
point, and click. 

See also: 

To set an effect point by dragging 

To set an effect point using position coordinates 



Placing an effect using effect points 

To set an effect point using position coordinates:

1    Click the position coordinates to the right of the effect point icon in the Effect Controls window.

2    In the Point Control dialog box, select units, type values for the x-axis and y-axis, and click OK.

See also: 

To set an effect point by dragging 

To set an effect point using the effect point icon 
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Changing effects over time

By default, when you apply an effect to a layer, the controls you specify do not change for the 
duration of a layer. However, you can make an effect change over time. For example, you can 
simulate a layer snapping into focus by applying the Gaussian Blur effect, setting a high value at the
beginning of the effect, and then decreasing it to zero.

You change an effect over time the same way you change other layer or composition settings over 
time—by assigning a keyframe to one of the effect’s properties in the Time Layout window at the 
time you want a change to happen, and then changing the effect controls at that keyframe. For 
more information about setting keyframes and creating changes over time, see Animating Layers.



Applying Effects 

Applying multiple effects

You can add multiple effects to a layer or to a group of selected layers.

A. Original image B. with Color Key applied C. with Color Key and Brush Strokes D. with Color Key, Brush 
Strokes, and Drop Shadow 

The controls for all effects applied to a layer are shown in the Effect Controls window, which 
manages multiple effects in much the same way as the Time Layout window manages multiple 
layers.

To apply multiple effects to one or more layers:

1    In the Time Layout window, select a layer or group of layers.

2    Choose a category from the Effect menu, and then choose an effect from the submenu.

3    Repeat step 2. 

Each effect is added to the list on the layer’s tab in the Effect Controls window.

To remove all effects applied to a layer:

1    In the Time Layout or Composition window, select the layer or layers from which you want to 
remove all effects. 

2    Choose Effect > Remove All. 

Note: This command eliminates all keyframes for the deleted effects. If you choose Remove All accidentally, 
immediately choose Edit > Undo to restore the effects and keyframes.
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Positioning effects on layers

After Effects renders all effects using subpixel positioning, a highly accurate interpolation that 
calculates a layer’s position to thousandths of a pixel. Effects are calculated to a level of precision 
higher than the resolution displayed on-screen, which results in smooth, high-quality effects and 
animations. Positioning with subpixel accuracy may soften pixels when used with blending or 
smoothing effects. 

Note: A layer must be set to Best quality to take advantage of subpixel accuracy. However, for faster editing 
you can keep layers at Draft quality until you render a finished movie.

To position an effect exactly where you want it, you can zoom in on the layer in the Composition 
window. The more you zoom in, the more accurate you can be. Effect points for effects are 
interpolated throughout the area of the image. A point that starts at the upper left and ends at the 
lower right is interpolated between the two locations with intermediate points. Intermediate points 
are calculated with subpixel accuracy (regardless of how you placed the points at the keyframe 
times), so the motion of an effect point can appear extremely smooth over time.

Note: Effect points are visible only when Effect Controls is selected in the Composition window menu. 
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Applying an effect to several layers with an adjustment layer

You apply and edit effects to an adjustment layer just as you do to any other layer. The major 
difference between adjustment layers and all other layers is that when you apply an effect to an 
adjustment layer, the effect is applied to all layers below it in the Time Layout window. For more 
information, see Creating an adjustment layer.
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Changing rendering order 

When you apply more than one effect to a layer, the final result may depend on the order in which 
those effects are applied. You change the order in which effects are applied by dragging the effect 
name to a new position in the Effect Controls window or the Time Layout window.

Another factor that may affect the final result of an applied effect is the order in which After Effects 
renders masks, effects, and transform properties. This is called the rendering order, and it is not 
related to the order in which individual effects are applied to a layer. To achieve certain effects, you 
will need to change the default rendering order so that a transform property is rendered before an 
effect in a layer, instead of after the effect. For information on changing the rendering order, see 
Understanding default rendering order. 
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Using audio effects

Some audio effects, such as Bass & Treble, enhance or correct audio characteristics. Other effects 
add depth and tone color, or delay or reverse audio footage. Any audio effect can be customized to 
radically change the sound of the original. For more impact, you can duplicate a layer that contains 
audio effects, add additional audio effects to the duplicate layer, and then turn off the original layer’s
effects to hear only the processed audio.
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Using Adobe Photoshop layer effects in After Effects

After Effects supports most of the layer effects from Adobe Photoshop. Photoshop layer effects 
supported include Drop Shadow, Inner Shadow, Inner Glow, and Outer Glow. If you apply layer 
effects in Photoshop and then import the file into After Effects, the effects are also imported, and 
you can edit them in the Effect Controls window. 
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Effects included with After Effects 

After Effects includes an array of visual effects and audio effects. Its plug-in technology enables you
to use additional effects from other Adobe plug-in-compatible filters, such as Photoshop. 

The effects described in this chapter are categorized by the order in which they appear on the Effect
menu. Other effects from Adobe or third-party vendors also appear on the submenu. The prefix PS 
appears before any Photoshop filter names.

Since you can add new effects and delete unused ones at any time, your menu and submenu 
selections may be different from the ones listed here. Check the Read Me file included with After 
Effects for the latest available effects.



Applying Effects 

Adjust effects 

Use these effects to adjust color in a layer. 

See also: 

Brightness & Contrast 

Channel Mixer 

Color Balance 

Curves 

Hue/Saturation 

Levels 

Posterize 

Threshold 



Adjust effects 

Brightness & Contrast

The Brightness & Contrast effect adjusts the brightness and contrast of the entire layer. The center 
point of each slider is neutral and indicates no effect. The layer’s quality setting does not affect 
Brightness & Contrast.

Using the Brightness & Contrast effect is the easiest way to make simple adjustments to the tonal 
range of the image. Unlike the Curves and Levels effects, this effect adjusts all pixel values in the 
image at once—highlights, shadows, and midtones. Brightness & Contrast does not work on 
individual channels. 



Adjust effects 

Channel Mixer

With the Channel Mixer effect, you can modify a color channel using a mix of the current color 
channels. You can use this effect to make creative color adjustments not easily done with the other 
color adjustment tools; create high-quality grayscale images by choosing the percentage 
contribution from each color channel; create high-quality sepia-tone or other tinted images; and 
swap or duplicate channels.

Red, Green, Blue Specify the contribution of the individual source channel to the output channel. 

Constant Specifies the base amount of the input channel to be added to the output channel. 

To mix channels in an image:

1    Choose Effect > Adjust > Channel Mixer.

2    Drag any existing (or source) channel’s slider to the left to decrease the channel’s contribution to
the output channel and to the right to increase it. Or, click an underlined value and enter a value 
between –200% and +200% in the value box and click OK. Using a negative value inverts the 
source channel before adding it to the output channel. 

3    If desired, drag the slider or enter a value for the channel’s constant value. This value adds a 
base amount of a channel to the output channel.

4    If desired, select Monochrome to apply the same settings to all the output channels, creating a 
color image that contains only gray values. 

Monochrome is useful for images you plan to convert to grayscale. If you select and then deselect 
this option, you can modify the blend of each channel separately, creating a hand-tinted 
appearance.



Adjust effects 

Color Balance

The Color Balance effect changes the amount of red, green, and blue color in a layer. The center 
point of each slider is neutral and indicates no effect. A setting of –100 removes all of the color; a 
setting of +100 intensifies the color. The layer’s quality setting does not affect Color Balance.

Shadow/Midtone/Hilight (Channel) Balance Specify the amount of a channel’s color in the darker,
middle, and lighter color intensity ranges of a layer. 

Preserve Luminosity Preserves the average brightness of the image while changing the color. 
This option maintains the tonal balance in the image. 



Adjust effects 

Curves

You can use Curves to adjust the tonal range of an image. You can also use Levels to do this, but 
Curves gives you more control in the process when you need it. Instead of making the adjustments 
using just three variables (highlights, shadows, and midtones) as Levels does, you can use Curves 
to adjust any point along the 0–255 scale while keeping up to 15 other values constant.

When you apply the Curves effect, After Effects displays a graph in the Effect Controls window that 
you use to specify a curve. 

A. Shadows B. Midtones C. Highlights

The horizontal axis of the graph represents the original brightness values of the pixels (Input levels);
the vertical axis represents the new brightness values (output levels). In the default diagonal line, 
no pixels have been mapped to new values, so all pixels have identical input and output values. 

Note: Curves displays brightness values from 0 to 255, with shadows (0) on the left. 

The gamma of any curve is its slope, expressed as the ratio of the logs of the output to input values.
For example, a gamma value of 1.0 equals an output-to-input ratio of 1:1. Moving the midpoint of 
the curve up (in an RGB readout) lowers the gamma value; moving the midpoint down raises the 
gamma value. Gamma specifies contrast that affects the midtones in a range. 

You can also use the Arbitrary Map option to draw a tonal curve by dragging. This feature helps you
create a variety of interesting tonal and color effects. In addition, you can import curves and 
arbitrary maps from Photoshop. Curves supports .amp files (Windows) and Photoshop lookup files 
(Mac OS) created by using the pencil tool, and .acv files (Windows) and Photoshop spline files 
(Mac OS) created by using the graph tool. 

Channel Specifies the color channel or alpha channel to be modified. 

See also: 

To use the Curves effect 

To use the Arbitrary Map option in the Curves effect 





Curves 

To use the Curves effect:

1    Choose Effect > Adjust > Curves. 

2    If the image has more than one color channel, choose the channel you want to adjust from the 
Channel menu. RGB alters all channels using a single curve. 

3    Select Bezier ( ). 
4    Click the part of the curve you want to adjust.
5    Click any points on the curve that you want to remain fixed. For example, if you want to adjust the 
midtones while minimizing the effect on the highlights and shadows, click the quarter and three-quarter 
points on the curve. You can add up to 14 points to the curve, locking those values. 

6    To remove a fixed point, drag it off the graph.

7    Adjust the curve by dragging it. 

See also: 

To use the Arbitrary Map option in the Curves effect 



Curves 

To use the Arbitrary Map option in the Curves effect:

1    Click the pencil tool to the right of the Curves graph. 

2    Drag to draw the curve you want in the Curves graph.

3    If desired, click Smooth ( ) to smooth the curve.

See also: 

To use the Curves effect 



Adjust effects 

Hue/Saturation

Using the Hue/Saturation effect, you can adjust the hue, saturation, and lightness of individual color
components in an image. Like the Color Balance effect, this effect is based on the color wheel. 
Adjusting the hue, or color, represents a move around the color wheel. Adjusting the saturation, or 
purity of the color, represents a move across its radius. 

Channel Control Specifies the color channel you want to adjust. Choose Master to adjust all colors
at once.

Channel Range Specifies the definition of the color channel selected in the Channel Control menu. 
Two color bars represent the colors in their order on the color wheel. The upper color bar shows the
color before the adjustment; the lower bar shows how the adjustment affects all of the hues at full 
saturation. Use the adjustment slider to edit any range of hues. 

Master Hue Specifies the overall hue of the channel selected in the Channel Control menu. Use the
dial, which represents the color wheel, to change the overall hue. The underlined value displayed 
above the dial reflects the number of degrees of rotation around the wheel from the pixel’s original 
color. A positive value indicates clockwise rotation; a negative value indicates counterclockwise 
rotation. Values range from –180 to +180.

Master Saturation and Master Lightness Specify the overall saturation and lightness of the 
channel selected in the Channel Control menu. Values range from –100 to +100. 

Colorize Adds color to a grayscale image converted to RGB, or adds color to an RGB image—for 
example, to make it look like a duotone image by reducing its color values to one hue. See the 
procedure on page 377.

Colorize Hue, Saturation, and Lightness Specify the hue, saturation, and lightness of the color 
range you selected in the Channel menu. After Effects displays only the sliders for the Channel 
menu selection. 

See also: 

To adjust an image using Hue/Saturation 

To modify the range of an adjustment slider 

To colorize an image or create a monotone effect 



Hue/Saturation 

To adjust an image using Hue/Saturation: 

1    Choose Effect > Adjust > Hue/Saturation.

2    From the Channel menu, choose which colors to adjust:
•      Choose Master to adjust all colors at once. 
•      Choose a preset color range for the color you want to adjust, then use the sliders for that color 
range. 

3    For Hue, enter a value or drag the slider.

4    For Saturation, enter a value or drag the slider. The color shifts away from or toward the center 
of the color wheel, relative to the beginning color values of the selected pixels. Values range from –
100 to +100.

5    For Lightness, enter a value or drag the slider. Values range from –100 to +100.

See also: 

To modify the range of an adjustment slider 

To colorize an image or create a monotone effect 



Hue/Saturation 

To modify the range of an adjustment slider:

1    From the Edit menu, choose an individual color.

2    Do any of the following:
•      Drag one or both of the white triangles to adjust the amount of feather without affecting the 
range. 
•      Drag one or both of the vertical white bars to adjust the range. Increasing the range decreases 
the fall off, and vice versa.

A. Adjusts feather without affecting range B. Adjusts range of color 

Note: By default, the range of color selected when you choose a color component is 30° wide, with 30° of fall 
off on either side. Setting the fall off too low can produce dithering in the image.

See also: 

To adjust an image using Hue/Saturation 

To colorize an image or create a monotone effect 



Hue/Saturation 

To colorize an image or create a monotone effect: 

1    Choose Effect > Adjust > Hue/Saturation.

2    Select Colorize. The image is converted to the hue of the current foreground color. The lightness
value of each pixel does not change.

3    Drag the Colorize Hue slider to select a new color if desired. 

4    Drag the Colorize Saturation and Colorize Lightness sliders. 

See also: 

To adjust an image using Hue/Saturation 

To modify the range of an adjustment slider 



Adjust effects 

Levels

The Levels effect remaps the range of input color levels onto a new range of output color levels, 
and changes the gamma correction curve at the same time. The Levels effect is useful for basic 
image quality adjustment. This effect functions the same as the Levels adjustment in Photoshop 5.0
and will display in the same way, provided that monitor calibration is off. 

You can adjust the brightness, contrast, and gamma in an image. Use Levels to adjust the gamma 
to change the brightness values of the middle range of gray tones without dramatically altering the 
shadows and highlights. 

A. Channel Specifies the color channel to be modified.

B. Histogram The histogram shows how the pixel values are distributed in an image. The 
horizontal axis of the histogram represents the brightness value. The vertical axis represents the 
number of pixels at each brightness level. There can be no pixel darker than the output black level, 
and no pixel brighter than the output white level. 

C. Input Black Specifies the threshold of the black value for the input image. Pixels below the input
black level are mapped as black on the input image. The input black value is represented by the 
upper left triangle below the histogram.

D. Output Black Specifies the limit of the black value for the output image. The output black value 
is represented by the lower left triangle below the histogram. 

E. Gamma Specifies the gamma value, which is represented by the middle triangle below the 
histogram. 

F. Output White Specifies the limit of the white value for the output image. The output white value 
is represented by the lower right triangle below the histogram.

G. Input White Specifies the threshold of the white value for the input image. Pixels below the input
white level are mapped as white on the input image. The input white value is represented by the 
upper right triangle below the histogram.



Adjust effects 

Posterize

Using the Posterize effect, you can specify the number of tonal levels (or brightness values) for 
each channel in an image. Posterize then maps pixels to the closest matching level. For example, 
choosing two tonal levels in an RGB image gives you two tones for red, two tones for green, and 
two tones for blue. Values range from 2 to 255. Although the results of this effect are most evident 
when you reduce the number of gray levels in a grayscale image, Posterize also produces 
interesting effects in color images.

Use Level to adjust the number of tonal levels for each channel to which Posterize will map existing 
colors. 

A. Original image B. Posterize applied with five levels of color C. Threshold applied



Adjust effects 

Threshold 

Use the Threshold effect to convert grayscale or color images to high-contrast, black-and-white 
images. You specify a certain level as a threshold; all pixels lighter than the threshold are converted
to white and all pixels darker to black.



Applying Effects 

Audio effects

Use these effects to add ambiance, adjust equalization, and play audio backward. 

See also: 

Backwards 

Bass & Treble 

Delay 

Stereo Mixer 



Audio effects 

Backwards

The Backwards effect reverses an audio footage item by playing it from the last frame or keyframe 
to the first frame or keyframe. The frames remain in their original order when viewed in the Time 
Layout window. 



Audio effects 

Bass & Treble

You can make basic adjustments to the audio tone of an audio layer using the Bass and Treble 
effect. If you need greater control in working with audio tone, use the Parametric Equalization effect 
in the After Effects Production Bundle. 

Bass/Treble Specify the amount of boost or cut applied to the low frequencies of the audio layer. 



Audio effects 

Delay

The Delay effect repeats the sounds in the audio footage after a specified amount of time. This 
simulates sound bouncing off a surface, such as a wall some distance away. 

Note: To simulate the acoustic ambience of a room, use the Reverb effect in the After Effects Production 
Bundle.

Delay Time Specifies the interval of time between the original sound and its echo, in milliseconds. 
Drag the slider to the right to increase the time between the original sound and its echo.

Delay Amount Specifies the level of the first delayed audio. Drag the slider to the right to increase 
the amount of the original sound that is sent as echo.

Feedback Specifies the amount of the echo that is fed back into the delay line to create subsequent
echoes. Drag the slider to the right to increase the amount of echo signal fed back into the delay 
line.

Dry Out, Wet Out Specify the balance of the original (Dry) sound to the delayed (Wet) sound in the 
final output. Values of 50% are commonly used.



Audio effects 

Stereo Mixer

Using the Stereo Mixer effect, you can mix the left and right channels of an audio layer and pan the 
entire signal from one channel to the other. 

Left level, Right level Specifies the level of the left or right audio channel of an audio layer. A value
of 2.00 is full level. 

Left pan, Right pan Shifts the mixed stereo signal from one audio channel to the other. Values of –
1.00 for Left pan and +1.00 for Right pan produce an even balance. 

Invert Phase Inverts the phase of both channels of the stereo signal. Use this to prevent two 
sounds at the same frequency from cancelling each other out. 



Applying Effects 

Blur and Sharpen effects

Use these effects to soften or sharpen an image.

See also: 

Channel Blur 

Compound Blur 

Fast Blur 

Gaussian Blur 

Motion Blur (directional blur) 

Radial Blur 

Sharpen 

Unsharp Mask 



Blur and Sharpen effects 

Channel Blur

The Channel Blur effect blurs a layer’s red, green, blue, or alpha channels individually. You can 
specify that the blur is horizontal, vertical, or both. At Best quality, the blur is smooth. Use this effect 
for glow effects or if you want a blur that does not become transparent near the edges of the layer. 

Edge Behavior    Describes how to treat the edges of the blurred image. If deselected, pixels 
outside of the image are transparent, which makes the edges of the blurred image semi-
transparent. The Repeat Edge Pixels option repeats the pixels around the edges, preventing the 
edges from darkening and becoming more transparent.



Blur and Sharpen effects 

Compound Blur 

The Compound Blur effect blurs pixels in the selected layer based on the luminance values of a blur
layer, or blurring map. The blur layer, which can be any layer that contains pixels of different 
luminance values, is essentially overlaid on top of the selected layer and the pixels of both layers 
are matched, one to one. Where the blur layer is black, no blurring occurs in the same location in 
the selected layer. Note that the blur layer is used only as a map; it is not visible in the composition.

This effect is useful for simulating changes in visibility due to atmospheric conditions such as smoke
or heat, especially with animated blurring layers. It is also useful for simulating smudges and 
fingerprints. Compound Blur is especially effective in combination with other effects, such as 
Displacement Map. See Chapter 4 in the After Effects 4.0 Production Bundle Guide. 

Blur Layer Specifies which layer in the composition to use as the blurring map. Bright values in the 
blur layer correspond to more blurring of the affected layer, while dark values correspond to less 
blurring.

Maximum Blur Specifies the maximum amount, in pixels, that any part of the affected layer can be 
blurred. For example, if this value is set to 30, no region of the image will be blurred greater than 30
pixels no matter what the values of the blurring layer.

Stretch Map to Fit Stretches the blur layer to the dimensions of the layer to which it is applied. 
Otherwise, the blur layer is centered.

Invert Blur Inverts the values of the blur layer. Areas that were previously more blurred will be less 
blurred and vice versa.



Blur and Sharpen effects 

Fast Blur

You can use the Fast Blur effect to specify how much to blur an image. You can specify that the blur
is horizontal, vertical, or both. At Best quality, the Fast Blur effect is a close approximation of a 
Gaussian Blur, but it blurs large areas more quickly.



Blur and Sharpen effects 

Gaussian Blur

The Gaussian Blur effect blurs and softens the image and eliminates noise. You can specify that the
blur is horizontal, vertical, or both. The layer’s quality setting does not affect Gaussian Blur. 



Blur and Sharpen effects 

Motion Blur (directional blur)

The Motion Blur effect performs a directional blur on an image, giving a layer the illusion of motion. 
At Draft quality, the effect is a blur of the image in which each pixel is the unweighted average of its 
adjacent pixels. At Best quality, the effect uses Gaussian weighting, producing a smoother, more 
graduated blur. 

Note: The Motion Blur effect is different from the Motion Blur switch found in the Time Layout window. A blur 
applied to each layer using the Motion Blur switch gives the best approximation of a motion blur. For more 
information on using motion blur on layers, see Using motion blur.

Direction Specifies the direction of the blur. The blur is applied equally around a pixel’s center; 
therefore, a setting of 180 degrees and a setting of 0 degrees look the same.

Blur Length Specifies how much to blur the image. 

A. Original B. Motion Blur C. Radial Blur 



Blur and Sharpen effects 

Radial Blur

The Radial Blur effect creates blurs around a specific point in a layer, simulating the effects of a 
zooming or rotating camera. At Draft quality, the blur appears somewhat grainy. You may prefer the 
draft results for special effects, but be aware that the grain may flicker on interlaced displays.

Amount Specifies the amount of blur, depending on the selection for Type. For a Spin blur, the 
Amount value indicates the degree of rotation. For a Zoom blur, the Amount value specifies the 
degree of radial blurring. 

Center Specifies the position of the center point. 

Type Specifies which type of blur is used. Spin applies blurs in circles around the center point. 
Zoom applies blur that radiates out from the center point. 

Antialiasing (Best Quality Only)    Specifies the level of anti-aliasing applied at Best quality. No 
anti-aliasing is applied at Draft quality. 



Blur and Sharpen effects 

Sharpen

The Sharpen effect increases the contrast where color changes occur. The layer’s quality setting 
does not affect Sharpen.

A. Original image B. Sharpen C. Unsharp Mask 



Blur and Sharpen effects 

Unsharp Mask

The Unsharp Mask effect increases the contrast between colors that define an edge.

Sharpen Amount Specifies the percentage of the effect, from 1 to 100. 

Radius Specifies the depth of pixels that will be affected at an edge. Values can range from 0.1 to 
250. If you specify a high value, more of the pixels surrounding the edge are adjusted for contrast. If
you specify a low value, only pixels at the edge are adjusted.

Threshold Specifies a tolerance to define edges and prevent overall contrast adjustment that might
generate noise or cause unexpected results. Values define the range of contrast allowed between 
adjacent pixels before contrast is adjusted. A lower value produces a more pronounced effect.



Applying Effects 

Channel effects

Use these effects to manipulate, extract, insert, and convert the channels of an image. The 
channels themselves include the component color values (red, green, and blue); calculated color 
values (hue, saturation, and luminance); and transparency values (alpha channel).

See also: 

Arithmetic 

Blend 

Compound Arithmetic 

Invert 

Minimax 

Remove Color Matting 

Set Channels 

Set Matte 

Shift Channels 



Channel effects 

Arithmetic

The Arithmetic effect performs various simple mathematical operations on an image’s red, green, 
and blue channels.

Operator Specifies which mathematical operation to perform between the value you specify for 
each channel and the existing value of that channel for each pixel in the image. And, Or, and Xor 
apply bit-wise logical combinations of the specified value for each channel. Add, Subtract, and 
Difference apply basic math functions using the specified value for each channel. Max sets the 
channel to the specified value at every pixel where the existing color channel value is less than that 
which is specified. Min sets the channel to the specified value at every pixel where the existing color
channel value is greater than that which is specified. Block Above and Block Below set the channel 
off everywhere that it is respectively greater or less than the specified value for each channel. Slice 
sets the channel off where it is below the value specified and sets it on where it is above the value 
specified for each channel.

Clip Result Values Prevents all functions from creating color values that exceed the valid range. If 
this option is not selected, some color values may wrap around from on to off, or vice versa.



Channel effects 

Blend

The Blend effect blends two layers together using one of five modes: Crossfade, Color Only, Tint 
Only, Darken Only, and Lighten Only. A crossfade is a standard transition between two images: the 
original image fades out while the new image fades in. 

Two images blended together to create a textured butterfly.

Note: You can create blends more easily and quickly using layer modes, but you can’t animate layer modes. 
The advantage of using the Blend effect is that you can animate it. For more information on layer modes, see 
Using layer modes.

Blend With Layer Specifies the layer to be blended with the original layer. (The first layer in this 
menu is the layer to which the effect has been applied.) 

Mode Specifies the Blend mode you want to use. Crossfade simply fades between the original 
image and the secondary image. Color Only colorizes each pixel in the original image based on the 
color of each corresponding pixel in the secondary layer. Tint Only is similar to Color Only, but only 
tints pixels in the original image if they are already colored. Darken Only darkens each pixel in the 
original image that is lighter than the corresponding pixel in the secondary image. Lighten Only 
lightens each pixel in the original image that is darker than the corresponding pixel in the secondary
image. 

Blend With Original Specifies the fading level between the blended image and the original image. 
A setting of 0% shows only the secondary layer (or just the layers specified with Blend if you are in 
Crossfade mode). At 100%, only the first layer is visible. Changing this slider linearly over time 
gives you a standard crossfade. To try the other blending modes, set Blend with Original to 0% to 
see the full effect of each mode.

Note: You can create a crossfade without applying an effect by animating the Opacity property of one layer on 
top of another. However, this will not work if the frontmost layer has any transparent portions (which would 
allow the other layer to show through, even when at full opacity). The Crossfade mode creates a proper 
crossfade between two layers, even if both have transparent regions.

If Layer Sizes Differ Specifies how to position the layers. Center positions the second layer in the 
center of the first layer, and crops the second layer if it is larger than the first layer. Stretch to Fit 
stretches the second layer to the size of the first layer. The layer’s quality setting affects Blend only 
if Stretch to Fit is selected and if the layers are of different sizes. Stretching at Best quality will be 
much smoother.

To use the Blend effect:

1    Make sure the two source items to blend have been added to your composition.

2    Apply the Blend to one layer (A) and choose the name of the other layer (B) in the Blend With 
Layer pop-up menu.

3    Hide layer B by clicking the Video switch next to the layer in the Audio/Video Features panel in 
the Time Layout window.



Channel effects 

Compound Arithmetic

The Compound Arithmetic effect mathematically combines the layer to which it is applied with 
another layer. The Compound Arithmetic effect is intended only to provide compatibility with projects
created in earlier versions of After Effects that use the Compound Arithmetic effect. Using layer 
modes is more effective than using the Compound Arithmetic effect in most situations. For more 
information on layer modes, see Using layer modes. 

Source Layer Specifies which layer to use with the current layer in the given operation.

Operator Specifies the operation to perform between the two layers.

Operate on Channels Specifies channels to which the effect is applied.

Overflow Behavior Specifies how pixel values that exceed the allowed range are treated. Clip 
indicates that the values will be limited to the allowed range. Wrap indicates that values exceeding 
the allowed range will wrap around from full on to full off and vice versa. Scale indicates that the 
maximum and minimum values will be calculated and the results will be stretched down from that 
full range to the range of allowable values.

Stretch Second Source to Fit Scales the second layer to match the size (width and height) of the 
current layer. If this option is deselected, the second layer is placed at its source’s current size, 
aligned with the upper left corner of the source layer.



Channel effects 

Invert

The Invert effect inverts the color information of an image.

Channel Specifies which channel or channels to invert. Each group of items operates in a particular
color space, inverting either the entire image in that color space or just a single channel. RGB 
consists of three additive color channels: red, green, and blue. HLS consists of three calculated 
color channels: hue, lightness, and saturation. YIQ is the NTSC luminance and chrominance color 
space, where Y is the luminance signal, and I and Q are the inphase and quadrature chrominance 
signals. Alpha, not a color space, provides a way to invert the alpha channel of the image.

Blend with Original Combines the inverted image with the original. You can apply a fade to the 
inverted image.



Channel effects 

Minimax

The Minimax effect enlarges or reduces a matte for a specific channel or all channels. This effect 
assigns each pixel the minimum or maximum pixel value found within a specified radius. For 
example, a white solid layer with a square mask shrinks one pixel on each side using Minimum and 
a radius of one. The layer’s quality setting does not affect Minimax.

Operation Minimum replaces a pixel with the smallest pixel value within the radius specified. 
Maximum replaces a pixel with the largest pixel value within the radius specified. Minimum Then 
Maximum performs the Minimum operation on the layer followed by the Maximum operation using 
the Radius setting. Maximum Then Minimum does the opposite.

Radius Specifies how many pixels to examine for the Minimum or Maximum operation.

Channel Specifies the channel. Color affects the color channels only. Alpha and Color affects all 
channels. Red, Green, Blue, and Alpha affect only the respective channels.

Direction Specifies the direction of scanning for values. Horizontal & Vertical scans all directions for
the minimum or maximum pixel. Just Horizontal or Just Vertical scans only left and right or up and 
down, respectively.



Channel effects 

Remove Color Matting

The Remove Color Matting effect removes or changes the color of a matte. This effect is useful 
when merging alpha and fill from separate files. If you import footage with a premultiplied alpha 
channel, or if you create alpha channels with After Effects, you may need to remove halos from an 
image. Halos are caused by a large contrast between the image’s color and the background, or 
matte, color. Removing or changing the color of the matte can remove the halos. (Halos can also be
caused by a misinterpretation of an alpha channel’s premultiplied color. See Importing footage 
containing an alpha channel.)

Use Background Color to specify the new background color when you want to change the color of a
matte.



Channel effects 

Set Channels

The Set Channels effect copies channels from other layers into the red, green, blue, and alpha 
channels of the current layer. For example, you can take the luminance of one layer and put it into 
the color channel of the selected layer. All source layers are centered in the current layer. With Best 
quality selected, any stretched layers are anti-aliased.

Use Stretch Layers to Fit to resize all other layers to the size of the layer to which Set Channels is 
being applied.



Channel effects 

Set Matte

The Set Matte effect replaces the alpha channel (matte) of a layer with a channel from another layer
above it for the creation of traveling matte effects. The Set Matte effect is intended only to provide 
compatibility with projects created in earlier versions of After Effects that use the Set Matte effect. 

Note: To create a traveling matte using the Set Matte effect, set up the motion of the matte layer and 
precompose that layer with all properties. Use the resulting composition as the layer from which to take the 
matte. Although you can use Set Matte for a traveling matte, it is easier and faster to create traveling mattes by
using Track Matte. See Creating track mattes and traveling mattes.

Take Matte from Layer Specifies the layer to use as the replacement matte. You can specify any 
layer in the composition.

Use for Matte Specifies the channel of the specified layer to use for the matte.

Invert Matte Inverts the transparency values of the matte.

Stretch Matte to Fit Scales the selected layer to match the size of the current layer. If unselected, 
the layer designated as the matte is centered in the first layer.

Composite Matte with Original Composites the new matte with the current layer, rather than 
replacing it. The resulting matte allows the image to show through only where the current matte and
the new matte both have some opacity.



Channel effects 

Shift Channels

The Shift Channels effect replaces red, green, blue, and alpha channels in the image with other 
channels. In Take (Channel) From, specify which channel to use as a source. 

Note: You can use this effect to display the alpha channel for a layer if you set the RGB channels to Alpha and 
set the alpha channel to Full.



Applying Effects 

Cineon tools 

This category contains the Cineon Converter. 

See also: 

Cineon Converter 



Cineon tools 

Cineon Converter

The Cineon Converter effect provides a high degree of control over 10-bit to 8-bit conversions of 
Cineon frames. The 10 bits of data available in each Cineon channel make it easier to enhance an 
important range of tones while preserving overall tonal balance. By carefully specifying the 8-bit 
range, you can create an 8-bit version of the image that faithfully resembles the original, or even 
improves upon it.

You can set keyframes for the Cineon Converter effect to adjust for changes in tone over time. You 
can also use keyframe interpolation and ease handles to precisely match even the most irregular 
lighting changes. For more information, see Changing effects over time, and Comparing 
interpolation methods.

See also: 

To convert a Cineon file from 10-bit to 8-bit 

To control the tonal balance of a Cineon file 



Cineon Converter 

To convert a Cineon file from 10-bit to 8-bit:

1    Import the Cineon file into After Effects. See Importing Cineon files.

2    Add the Cineon file to a composition. The file appears distorted in the Composition window.

3    Select the Cineon file layer in the Composition or Time Layout window and choose Effect > 
Cineon Tools > Cineon Converter. The Cineon Converter applies the default Kodak conversion 
parameters, which are used for digitally editing motion-picture film. You can refine these choices by 
using the Cineon Converter options in the Effect Controls window.

Conversion Type Specifies how the Cineon file is converted. Choose one of the following:
•      8 Bit Log to Linear converts an 8-bit logarithmic non-Cineon layer that you plan to render as a 
Cineon sequence.
•      8 Bit Linear to Log converts a layer containing an 8-bit linear proxy of a Cineon file into an 8-bit 
logarithmic file so that its display characteristics are consistent with the original Cineon file.
•      Auto Log to Linear automatically detects an 8- or 10-bit logarithmic Cineon file when you plan to 
convert it to an 8-bit linear file for use in After Effects. This is the default setting.
•      Auto Log to Log automatically detects an 8- or 10-bit logarithmic Cineon file when you plan to 
render it as an 8-bit logarithmic proxy.
•      10 Bit Log to Linear converts a 10-bit logarithmic Cineon file into an 8-bit linear file for use in 
After Effects.
•      10 Bit Log to Log renders a 10-bit logarithmic Cineon file as an 8-bit logarithmic proxy. This is 
the preferred way to render a proxy because it maintains consistent color display when you switch 
between the proxy and the original.

10 Bit Black Point/8 Bit Black Point Specifies the black point (minimum density) for converting a 
10-bit or 8-bit logarithmic Cineon layer. 

10 Bit White Point/8 Bit White Point Specifies the white point (maximum density) for converting a 
10-bit or 8-bit logarithmic Cineon layer.

Gamma Specifies the value of midtones. 

Highlight Rolloff Specifies the rolloff value used to correct bright highlights.

See also: 

To control the tonal balance of a Cineon file 



Cineon Converter 

To control the tonal balance of a Cineon file:

1    Choose an option from the Conversion Type menu.

2    Make sure 8 Bit Black Point is set to 0 (zero) and 8 Bit White Point is set to 255. 

3    Do the following to adjust the black point:
•      To darken areas or make areas black, drag the 10 Bit Black Point slider to the right.
•      To lighten black areas and make details in dark areas visible, drag the 10 Bit Black Point slider 
to the left.

4    Do the following to adjust the white point:
•      To whiten gray areas, drag the 10 Bit White Point slider to the left.
•      To darken white areas or make the lightest details visible, drag the 10 Bit White Point slider to 
the right. If adjusting the brightest areas results in the rest of the image appearing too dark, use the 
Highlight Rolloff slider to adjust these areas. See step 6 for details.

5    Adjust midtones by dragging the Gamma slider to the left to darken midtones, or to the right to 
lighten midtones.

6    If highlights appear as white blotches, drag the Highlight Rolloff slider to the right until details are
visible. An image with high contrast may require a high Rolloff value.

7    Adjust the 8-bit version by dragging the 8 Bit Black Point slider to the right to lighten the darkest 
tone, or to the left to darken the lightest tone.

Note: Each computer monitor has unique display characteristics that affect your perception of color on-screen.
For best results when evaluating tonal balance, use the Info palette in After Effects to see the true color values 
of pixels as you move the pointer over them.

See also: 

To convert a Cineon file from 10-bit to 8-bit 



Applying Effects 

Distort effects

Use these effects to geometrically distort an image. 

A. Original B. Mirror C. Polar Coordinates

See also: 

Mirror 

Offset 

Polar Coordinates 

Smear 

Spherize 



Distort effects 

Mirror

The Mirror effect splits the image along a line and reflects one side onto the other. The reflection 
angle determines which side is reflected and where the reflection appears. You can make the line 
and reflection angle change over time. The layer’s quality setting influences the Mirror effect. At 
Best quality, the reflected image is smoother and more accurate.

Reflection Center Specifies the position of the line. 

Reflection Angle Specifies the angle of reflection, and therefore, where the reflection appears on 
the layer. An angle of 0 degrees reflects the left side onto the right. An angle of 180 degrees reflects
the right side onto the left. An angle of 90 degrees reflects the top onto the bottom. An angle of 270 
degrees reflects the bottom onto the top. 



Distort effects 

Offset

The Offset effect pans the image within a layer. Visual information pushed off one side of the image 
appears on the opposite side. At Best quality, the offset is performed with subpixel precision.

Shift Center To Specifies the new position of the original image’s center point. 

Blend With Original Specifies the amount by which the offset image is blended with the original 
image. 



Distort effects 

Polar Coordinates

The Polar Coordinates effect distorts a layer by transposing each pixel in the layer’s x,y coordinate 
system to the corresponding position in the polar coordinate system, or the reverse. This effect 
produces unusual and surprising distortions that can vary greatly depending on the image and the 
controls you select. The standard coordinate system specifies points by measuring the horizontal 
distance (x-axis) and the vertical distance (y-axis) from the origin. Each point is specified as (x,y). 
The polar coordinate system specifies points by measuring the length of a radius from the origin 
and its angle from the x-axis. Each point is specified as (r, q).

Interpolation Specifies the amount of distortion. At 0% there is no distortion.

The following two options are available from the Type of Conversion pop-up menu:

Rect to Polar Moves pixels by using x,y coordinates from each pixel as r, q coordinates. For 
example, an x,y coordinate of 2,3 becomes a polar coordinate with a radius of 2 and a degree of 3. 
Horizontal lines distort into circles and vertical lines into radial lines. 

Polar to Rect Moves pixels by using the r,q coordinates from each pixel as the x,y coordinates. For 
example, a polar coordinate of radius 10 and 45 degrees becomes an x,y coordinate of 10,45.



Distort effects 

Smear

Using Smear, you define an area within an image and then move that area to a new location, 
stretching, or smearing, the surrounding part of the image with it. You create masks to define the 
area you want to distort. 

To use Smear, you first create or import two masks: the source mask and the boundary mask. You 
can create masks on the layer in After Effects or use masks created in Illustrator. To use a mask 
created in Illustrator, copy the mask and paste it into a layer in After Effects. Masks must be closed 
to work with Smear; if a mask is an open trace, After Effects closes it when you select it. Both 
masks must be on the same layer as the footage to which you will apply the Smear effect, although 
you can copy masks from another layer. 

A. Boundary mask B. Mask offset C. Source mask

When you move the source mask within the image, Smear stretches the portion of the image inside 
the boundary mask to follow the edges of the source mask. The boundary mask tries to protect the 
image outside it from being stretched, but some distortion may occur outside the boundary mask, 
especially if the source mask is positioned partially or entirely outside the boundary mask. Both the 
original position of the source mask (set in the Layer window) and the offset position of the source 
mask are displayed in the Composition window. The first position of the source mask is indicated by
a light red outline, and the new position is indicated by a dark outline.

Using keyframes, you can animate the position, size, and rotation of the source mask as it moves to
its offset position. You can also animate the original position of the source mask in the Layer 
window using keyframes. 

A. Original B. Source and Boundary masks set C. Resulting smear

Processing can take up to several minutes with certain settings. Computation time increases as the 
source mask gets closer to the boundary mask. Processing is interrupted when you click a control.

Source Mask Specifies a mask as the source mask. By default, After Effects selects the second 



mask you create for the layer as the source mask. 

Note: You must specify both a boundary mask and a source mask to create a distortion. 

Boundary Mask Specifies a mask as the boundary mask. By default, After Effects selects the first 
mask you create as the boundary mask. 

Mask Offset Specifies a destination position for the source mask. The offset is a position specified 
by x and y coordinates, which are displayed to the right of the Offset button. To set an offset 
location, select the Offset button, move the cursor on the image to the desired location, and click to 
set that position. To set the offset position numerically, type a new value for each axis. When you 
don’t need the precision provided by Mask Offset, you can simply drag the source mask offset in the
Composition window. 

Note: Unwanted undulations may occur if the source mask is close to the boundary mask during animation. 

Mask Rotation Rotates the source mask about its center point, between 0 and 360 degrees. 

Mask Scale Scales the source mask (at its offset position) larger or smaller, in relation to its original
position. 

Percent Specifies what percent of the smear is actually performed. For example, when Percent is 
set to 50%, Smear performs half of the smear you have specified by moving, scaling, and rotating 
the source mask. This value doesn’t affect the location of the original and offset positions of the 
source mask; it affects only the percent of the effect that is performed. 

Elasticity Specifies the elasticity of the Smear effect. The degree of elasticity affects how the image
distorts. Imagine the image on a sheet of rubber; as you move the source mask, the sheet tries to 
stretch. The stiffer the rubber, the less the sheet stretches. The highest setting is Loose, which 
requires the most time to compute but gives the closest fit to the distortion. 

Interpolation Method Specifies a method for the interpolation that Smear performs between 
keyframes. This menu offers two settings, Linear and Smooth. Linear requires two or more 
keyframes and performs a straight line interpolation between the keyframes. Linear produces robot-
like animations in which the distortions change at keyframes. Smooth requires three or more 
keyframes and approximates the distortion using cubic curves, producing distortions with graceful 
motion. If you need further accuracy in the animation between keyframes, add more keyframes. For
example, a distortion representing a 90-degree rotation between two keyframes will appear as a 
folding of the image. To make this distortion more fluid, add a keyframe for every 10 degrees.

See also: 

To use Smear 



Smear 

To use Smear:

1    Double-click the layer in the Composition window to open it in a Layer window. 

2    Create or paste the masks you will use as the boundary mask and the source mask. 

3    Position the boundary mask to specify the area of the layer you do not want Smear to affect. 

4    Scale and position the source mask over the area you want to move. 

5    Make the Composition window active and choose Effects > Distort > Smear. 

6    In the Composition window, move the source mask to its destination position by dragging it or by
using the Mask Offset value. 

7    Use Rotation to rotate the source mask, and use Mask Scale to scale it. 

8    Drag the Percent slider as needed and select the desired setting for Elasticity.



Distort effects 

Spherize

The Spherize effect distorts a layer by wrapping a region of the image onto a spherical shape of 
variable size. The layer’s quality setting influences the Spherize effect. Best quality samples the 
displaced pixels to subpixel accuracy; Draft quality samples to the nearest whole pixel.

Radius Specifies the radius of the sphere in pixels. You can exceed the highest slider value by 
clicking the Radius value and entering a higher number in the dialog box.

Center Of Sphere Specifies the position of the sphere’s center on the layer. 



Applying Effects 

Image Control effects

Use these effects to alter an image’s color values.

See also: 

Change Color 

Color Balance (HLS) 

Equalize 

Gamma/Pedestal/Gain 

Median 

PS Arbitrary Map 

Tint 



Image Control effects 

Change Color

The Change Color effect adjusts the hue, saturation, and lightness of a range of colors. You choose
the range by specifying a base color and similarity values. The similarity can be an RGB similarity, a
hue similarity, or a chroma similarity.

View Specifies what to view in the composition. Corrected Layer shows the results of the Change 
Color effect. Color Correction Mask shows which areas of the layer will be changed. White areas in 
the color correction mask are transformed the most, and dark areas are transformed the least.

Hue Transform Specifies the amount, in degrees, to adjust the hue of the selected colors.

Lightness Transform Specifies the amount to increase or decrease the lightness of the selected 
colors. Positive values brighten the selected regions; negative values darken them.

Saturation Transform Specifies the amount to increase or decrease the saturation of the selected 
colors. Positive values saturate the selected regions (moving toward pure color); negative values 
desaturate the selected regions (moving toward gray).

Color to Change Specifies the color to be changed. Matching Tolerance and Matching Softness 
both use this color as a target for building the color correction mask.

Matching Tolerance Specifies the degree of color matching before the color is affected by the color
correction. With low tolerances, only colors very similar to the change color are added to the color 
correction mask. Larger tolerances add more of the image to the color correction mask.

Matching Softness Specifies the softness of the color correction. This does not always soften the 
color correction mask geometrically, but affects the severity of the color correction for regions 
similar to the base color.

Match Colors Specifies the criterion for determining similarity of two colors. RGB uses the red, 
green, and blue components. Hue matches colors based on hue. For example, bright red, light pink,
and burgundy have similar hue values (a hue of red, but differing values of saturation and 
lightness). Chroma uses the two chromatic components to determine similarity, ignoring brightness. 
Chroma matching would therefore be sensitive to saturation and hue differences, but not to 
lightness differences.

Invert Color Correction Mask Inverts the mask that determines which colors to affect. If selected, 
all colors will be color-corrected, except those selected by using Color to Change and matching 
controls.



Image Control effects 

Color Balance (HLS)

The Color Balance (HLS) effect alters an image’s levels of hue, lightness, and saturation. The Color
Balance (HLS) effect is intended only to provide compatibility with projects created in earlier 
versions of After Effects that use the Color Balance (HLS) effect. For new projects, use the 
Hue/Saturation effect, which operates the same as the Hue/Saturation command in Photoshop. 

Hue Specifies the color scheme of the image.

Note: You can convert a movie to grayscale by setting the Saturation to –100.



Image Control effects 

Equalize

The Equalize effect alters an image’s pixel values to produce a more consistent brightness or color 
component distribution. The effect works similarly to the Equalize command in Photoshop. 
Equalization can be performed using either RGB values or the brightness component. Pixels with 
zero alpha (completely transparent) values are not considered, so masked layers are equalized 
based on the mask area. Layer quality settings do not affect Equalize.

Equalize Specifies which equalization method to use. RGB equalizes the image based on red, 
green, and blue components. Brightness equalizes the image based on the brightness of each 
pixel. Photoshop Style equalizes by redistributing the brightness values of the pixels in an image so 
that they more evenly represent the entire range of brightness levels.

Amount to Equalize Specifies how much to redistribute the brightness values. At 100%, the pixel 
values are spread as evenly as possible, while lower percentages specify less redistribution.



Image Control effects 

Gamma/Pedestal/Gain

The Gamma/Pedestal/Gain effect adjusts the response curve independently for each channel. For 
pedestal and gain, a value of 0.0 is completely off, and a value of 1.0 is completely on. 

Black Stretch    Remaps the low pixel values of all channels. Large Black Stretch values brighten 
dark areas. The effect is the same in all quality settings.

Gamma    Specifies an exponent describing the shape of the intermediate curve. 

Pedestal/Gain    Specify the lowest and highest attainable output value for a channel. 



Image Control effects 

Median

The Median effect replaces each pixel with the median pixel value of neighboring pixels within a 
given radius. At low values, this effect is useful for reducing noise. At higher values, this effect gives 
a layer a painterly effect. This effect is the same at both Draft and Best quality.

Use Radius to specify how many pixels to examine for the Median effect. For instance, when 
Radius is set to 1, the Median will be performed on the eight neighboring pixels that are within one 
pixel of the center pixel.



Image Control effects 

PS Arbitrary Map

The PS Arbitrary Map effect applies a Photoshop arbitrary map file to a layer. An arbitrary map 
adjusts the brightness levels of an image, remapping a specified brightness range to darker or 
brighter tones. In the Curves window in Photoshop, you can create an arbitrary map file for the 
entire image or for individual channels. The PS Arbitrary Map effect is intended only to provide 
compatibility with projects created in earlier versions of After Effects that use the Arbitrary Map 
effect. For new work, use the Curves effect. 

When loaded into After Effects, the specified arbitrary map is applied to the layer or to one or more 
channels of the layer, depending on how it was created. If you do not select an arbitrary map, After 
Effects applies the default map (linear distribution of brightness) to the layer. For more information 
on arbitrary maps, see “Using the Curves command” in Chapter 6 of the Adobe Photoshop 5.0 User
Guide. 

Phase Cycles through the arbitrary map. Increasing the phase shifts the arbitrary map to the right 
(as viewed in the Curves dialog box); decreasing the phase shifts the map to the left.

Apply Phase Map to Alpha Applies the specified map and phase to the layer’s alpha channel. If 
the specified map does not include an alpha channel, After Effects uses the default map (linear 
distribution of brightness) for the alpha channel.

In the Effect Controls window, click Options, and then select an arbitrary map file. Although you 
can’t import .avc files or Photoshop spline files into the After Effects PS Arbitrary Map effect, you 
can convert these files in Photoshop to create files that are compatible with the After Effects Curves
effect. 

To convert .avc and Photoshop spline files:

1    In the Curves dialog box in Photoshop, load the .acv file (Windows) or the Photoshop spline file 
(Mac OS). 

2    Click the pencil tool and then save the file as a .amp file (Windows) or a Photoshop lookup file. 



Image Control effects 

Tint

The Tint effect alters an image’s color information. For each pixel, the luminance value specifies a 
blend between two colors. Map Black To and Map White To specify to which colors dark and bright 
pixels are mapped. Intermediate pixels are assigned intermediate values. Amount To Tint specifies 
the intensity of the effect. The layer’s quality setting does not affect Tint.



Applying Effects 

Keying effects

Use these effects to key out, or make transparent, parts of an image. For more information on using
keying effects, see Creating track mattes and traveling mattes. 

After Effects includes two basic keying effects. For more powerful keying effects, you can use the 
After Effects Production Bundle.

See also: 

Color Key 

Luma Key 



Keying effects 

Color Key

The Color Key effect keys out all pixels in an image that are similar to a specified key color. This 
effect modifies only the alpha channel of a layer. The layer’s quality setting does not affect Color 
Key.

Key Color Specifies the color to be made transparent.

Color Tolerance Specifies how precisely a color is matched to the key color. Higher values mean a
broad range of colors are keyed out; lower values mean only colors very similar to the key color are 
keyed out.

Edge Thin Specifies how much the border of the matte is adjusted. Positive values bring the edge 
in away from the transparent region (thus enlarging the transparent region); negative values move 
the edge out toward the transparent region.

Edge Feather Specifies how much the edges of the keyed region are softened. High values take 
longer to render.



Keying effects 

Luma Key

The Luma Key effect keys out all the regions of a layer with a specified luminance or brightness. 
The layer’s quality setting does not influence the Luma Key effect.

Key Type Removes pixels based on the following criteria: Key Out Brighter removes pixels with 
brightness greater than the Threshold setting. Key Out Darker removes pixels with brightness less 
than the Threshold setting. Key Out Similar removes pixels within the tolerance of the Threshold 
setting. Key Out Dissimilar removes pixels outside of the tolerance of the Threshold setting.

Threshold Specifies the cutoff brightness for Key Out Brighter and Key Out Darker. It also 
determines the average brightness to key for Key Out Similar and Key Out Dissimilar.

Tolerance    Specifies a range of luminance levels for the effect to key out (if Key Type is set to Key 
Out Similar) or leave opaque (if Key Type is set to Key Out Dissimilar). As you move the slider, the 
effect keys out or leaves opaque a wider band of brightness.

Edge Thin Specifies how much to adjust the border of the matte. Setting Edge Thin to a positive 
value shrinks the size of the solid (non-keyed) region by backing away from the border; negative 
values expand the region to include more of the border.

Edge Feather Specifies how much to soften the edge of the keyed region. Higher values take 
longer to render.



Applying Effects 

Perspective effects

Use these effects to adjust an image’s position in an imaginary three-dimensional space, add depth,
or create an adjustable z-axis.

See also: 

Basic 3D 

Bevel Alpha 

Bevel Edges 

Drop Shadow 

Transform 



Perspective effects 

Basic 3D

The Basic 3D effect manipulates a layer in an imaginary three-dimensional space. You can rotate 
your image around horizontal and vertical axes and move it toward or away from you. With Basic 
3D, you can also create a specular highlight to give the effect of light reflecting off a rotated surface.
The light source for the specular highlight is always above, behind, and to the left of the viewer. 
Because the light comes from above, the image must be tilted backwards to see this reflection. This
can enhance the realism of the three-dimensional appearance. The specular highlight can be 
viewed only at Best quality. 

A. Swivel B. Swivel and Tilt C. Swivel, Tilt, and Distance 

The layer’s quality setting affects Basic 3D. Draft quality calculates pixel location to the nearest 
integer value; Best quality calculates pixel location to the subpixel level.

Swivel Controls horizontal rotation (rotation around a vertical axis). You can rotate past 90 degrees 
to see the back side of the image, which is the mirror image of the front.

Tilt Controls vertical rotation (rotation around a horizontal axis).

Distance to Image Specifies the image’s distance from the viewer. As the distance gets larger, the 
rotated image recedes.

Specular Highlight Adds a glint of light that reflects off the surface of the rotated layer, as if an 
overhead light were shining on the surface. In preview mode, the specular highlight is indicated by a
red + if it is not visible on the layer (the center of the highlight does not intersect the layer) and a 
green + if the highlight is visible.

Preview Draws a wireframe outline of the three-dimensional image. Because manipulating an 
image in three-dimensional space can be time-consuming, the wireframe renders quickly so you 
can manipulate the controls to get the rotation you want. Deselect the Preview control when you 
finish manipulating the wireframe image to see your final results. As a safety precaution, the 
preview wireframe is only drawn at Draft quality; when you switch to Best quality, the image content 
is drawn. This way, you won’t accidentally render a Best quality movie in Preview mode.



Perspective effects 

Bevel Alpha

The Bevel Alpha effect gives a chiseled and lighted appearance to the alpha boundaries of an 
image, often giving two-dimensional elements a three-dimensional appearance. (If the layer’s alpha 
channel is completely opaque, the effect is applied to the bounding box of the layer.) The edge 
created in this effect is somewhat softer than that of the Bevel Edges effect. This effect works 
especially well for elements with text in the alpha channel.

A. Bevel Alpha B. Bevel Edges C. Drop Shadow 



Perspective effects 

Bevel Edges

The Bevel Edges effect gives a chiseled and lighted three-dimensional appearance to the edges of 
an image. Edge locations are determined by the alpha channel of the source image. Unlike Bevel 
Alpha, the edges created in this effect are always rectangular, so images with non-rectangular 
alpha channels do not produce the proper appearance. All edges have the same thickness. Best 
quality calculates the thickness of the chiseled area; the edge thickness is interpolated with smooth 
visual results.



Perspective effects 

Drop Shadow

The Drop Shadow effect adds a shadow that appears behind the layer. The shape of the Drop 
Shadow is determined by the layer’s alpha channel. Unlike most other effects, Drop Shadow can 
create a shadow outside the bounds of the layer (the dimensions of the layer’s source). The layer’s 
quality setting affects the subpixel positioning of the shadow and the smoothness of the shadow’s 
soft edges.

Since Drop Shadow uses the alpha channel, it works well with 32-bit footage files from three-
dimensional rendering programs and drawing programs that support the alpha channel.

Because the shadow can be drawn outside the layer’s original dimensions, memory requirements 
for this effect grow as the distance setting increases. If you’re working at decreased resolution, 
switch to full resolution momentarily to be sure that the effect has enough memory to render at the 
given distance value. Increasing the distance also increases the resolution of the layer’s image 
buffer. The layer and buffer size limit is 4000 by 4000 pixels. 

Note: If you want to apply a Drop Shadow to a layer that rotates, rotate the layer using the Transform effect 
and then apply the Drop Shadow effect after the Transform effect. You can also use nesting, precomposing, or 
an adjustment layer to achieve this effect. If you do not use one of these methods, the shadow rotates with the 
layer. See Changing the rendering order. 



Perspective effects 

Transform

The Transform effect applies two-dimensional geometric transformations to the source layer. This 
effect supplements the transform properties available for each layer in the Time Layout window. 
Using the Transform effect, you can skew a layer along any axis. Also, if motion blur is enabled, you
can specify motion blur independent of the composition’s shutter angle. Anchor Point, Position, 
Rotation, and Opacity function the same as the layer transform properties in the Time Layout 
window.

Note: This is relative to the input layer. Therefore, to make a layer rotate around the upper left corner, you 
open the layer window, select Transform in the Layer window menu, and then move the anchor point and the 
position to the upper left corner.    

Scale Height Scales height up or down as a percent of the current layer height.

Scale Width Scales width up or down as a percent of the current layer width.

Skew Specifies skew amount. 

Skew Axis The axis on which the skew is based. Changing the axis has no effect if Skew is 0.

Use Composition’s Shutter Angle If selected, the Transform effect uses the shutter angle of the 
composition when performing motion blur. If not selected, the Transform effect uses the Shutter 
Angle option that follows. 

Shutter Angle Determines the amount of motion blur to apply when motion blurring the layer. 

Note: Motion Blur must be enabled for the layer for Shutter Angle to have any effect.



Applying Effects 

Render effects

Use these effects to create elements in a layer such as ellipses or fills, or to render a visual display 
of an audio file.

See also: 

Audio Spectrum 

Audio Waveform 

Ellipse 

Fill 

Beam 

Ramp 

Stroke 



Render effects 

Audio Spectrum

This effect displays the spectrum of an audio layer. Audio Spectrum displays the magnitude of 
frequencies in the range you define using Start Frequency and End Frequency. This effect can 
display the audio spectrum in a number of different ways, including along a Bezier path of a layer. 
You apply the effect to a layer that contains a solid or an image, and that may contain audio. 

Note: This effect is a visual effect, not an audio effect, and it must be applied to a video layer. 

Audio Layer Specifies the layer that contains the audio that you want to display as a spectrum. 

Note: The audio represents the source footage of the audio layer. The layer’s audio adjustments, such as 
time-remapping, effects, stretch, and levels, will not be present. To graph this information for the audio layer, 
precompose the audio before applying this effect. 

Start Point Specifies the position at which the spectrum starts if Path is set to None.

End Point Specifies the position at which the spectrum ends if Path is set to None.

Path If not set to None, the audio spectrum is displayed along the path of the layer.

Use Polar Path If this is selected, the path will start from a single point and be displayed as radial 
graph.

Start Frequency/End Frequency Specify the first and last frequency, in hertz, in the range of 
frequencies being displayed.

Frequency bands Specifies the number of frequencies displayed.

Maximum Height Specifies the maximum height, in pixels, of a displayed frequency.

Audio Duration Specifies the duration of audio, in milliseconds, used to calculate the spectrum.

Audio Offset Specifies the time offset in milliseconds used to retrieve the audio.

Blend Overlapping Colors When selected, specifies that overlapping spectrums will be blended.

Hue Interpolation If Hue interpolation is not set to zero, the frequencies displayed will rotate 
through the Hue color space.

Dynamic Hue Phase If this is selected and if Hue interpolation is not zero, the Start color will be 
shifted to the maximum frequency in the range of displayed frequencies.    This allows the hue to 
follow the fundamental frequency of the spectrum displayed as it changes.

Color Symmetry If this is selected, the start and end colors will be the same when Hue 
interpolation is not zero. This is to allow color continuity on closed paths.

Display Options Specifies how to display the frequency spectrum, as Digital, Analog Lines, and 
Analog Dots. 

Side Options Specifies whether to display the spectrum above the path (Side A), below the path 
(Side B), or both (Side A and B).

Duration Averaging When selected, specifies that the audio frequencies are averaged together to 
create less randomness.    





Render effects 

Audio Waveform

This effect displays the waveform amplitude of an audio layer. You can display the audio waveform 
in a number of different ways, including along a Bezier path created by an open or closed mask of a
layer. You apply the effect to a layer that contains a solid or an image, and that may contain audio. 

Note: This effect is a visual effect, not an audio effect, and it must be applied to a video layer. 

Audio Layer Specifies the layer that contains the audio that you want to display as a waveform. 

Note: The audio represents the source footage of the audio layer. The layer’s audio adjustments, such as 
time-remapping, effects, stretch, and levels, will not be present. To graph this information for the audio layer, 
precompose the audio before applying this effect. 

Start Point/End Point Specify the position at which the waveform starts and ends, if Path is set to 
None.

Path If set to None, the audio waveform is displayed along the path of the layer.

Displayed Samples Specifies the number of samples to display when graphing the waveform.

Maximum Height Specifies the maximum height, in pixels, of a displayed frequency.

Audio Duration Specifies the duration of audio, in milliseconds, used to calculate the waveform.

Audio Offset Specifies the time offset in milliseconds used to retrieve the audio.

Waveform Options Specifies how to display the audio waveform, as Mono, Left, or Right. Mono 
combines the left and right channels of the audio layer. If the audio source is mono, the Waveform 
Options property has no effect. 

Display Options Specifies how to display the audio waveform, as Digital, Analog Lines, or Analog 
Dots. 
•      Digital displays each sample as a single vertical line connecting the minimum and maximum 
source sample. This option is intended to simulate the display used on digital equipment.
•      Analog Lines displays each sample as a line connecting the previous and next sample from 
either the minimum or maximum audio source sample. This option simulates the retrace seen in the
display of an analog oscilloscope.
•      Analog Dots displays each sample as a dot representing either the minimum or maximum audio 
source sample. 



Render effects 

Ellipse

This effect draws an ellipse based on the dimensions you specify in the Effect Controls window. In 
addition to width and height, you can specify the thickness, softness, and color of the ellipse. 

Width/Height Specify the width and height of the ellipse in pixels. Values range from 0 to 2000 
pixels.

Thickness Specifies the thickness of the arc forming the ellipse. Values range from 0 to 1000 
pixels. 

Softness Specifies the softness or degree of blur of the ellipse’s arc.



Render effects 

Fill

This effect is used to fill a mask with a specified color. The Fill Mask pop-up menu displays the 
available masks. 



Render effects 

Beam

This effect animates the movement of a laser beam. You can make the laser shoot, or you can 
create a wand-like laser with stationery start and end points. This effect uses a three-dimensional 
perspective based on the change in Starting Thickness and Ending Thickness.

To make a shooting laser beam, use keyframes to change the start point, end point, and length over time. 

Note: The beam looks best when motion blur is enabled and the shutter angle is set to 360.

Length Specifies the length of the beam based on a percent of the Time specified. For example, a 
setting of 100% means the visible beam length is at its maximum when the Time option is 50%. 

Time Specifies the time of the beam’s travel from start to end as a percent.

3D Perspective Enables three-dimensional perspective when animating Time.



Render effects 

Ramp

The Ramp effect creates a color gradient, blending it with the original image contents. You can 
create linear or radial ramps and vary the position and colors of the ramp over time.

Start of Ramp Specifies the position of the start of the ramp. 

End of Ramp Specifies the position of the end of the ramp. 

Ramp Shape Specifies whether the ramp shape is linear or radial. 

Ramp Scatter Eliminates banding in the colors of the ramp. This control enables you to scatter the 
colors of the ramp, avoiding a perfectly smooth transition. The graduation of color thus takes on 
more of a textured appearance.

Note: Traditionally, ramps do not broadcast well; serious banding occurs because the broadcast chrominance 
signal does not contain sufficient resolution to reproduce the ramp smoothly. The Ramp Scatter control 
disperses the ramp colors, eliminating the banding apparent to the human eye.



Render effects 

Stroke

This effect creates a stroke or border around a mask or along a Bezier path. You can also specify 
stroke color, opacity, and spacing, as well as brush characteristics. To use a path created in 
Illustrator, copy the path and paste it into a layer in After Effects. 

Brush Hardness Specifies the edge quality of the stroke, between hard and soft. 

Spacing Specifies the spacing between stroke segments. 

Paint On Specifies whether the stroke is applied to the original layer or to a transparent layer.



Applying Effects 

Stylize effects

Use these effects to produce abstract or impressionistic images by altering and displacing pixels 
and manipulating an image’s color scheme.

A. Brushstrokes B. Mosaic C. Motion Tile 

See also: 

Brush Strokes 

Color Emboss 

Emboss 

Find Edges 

Leave Color 

Mosaic 

Motion Tile 

Noise 

Strobe Light 

Texturize 

Write-on 



Stylize effects 

Brush Strokes

The Brush Strokes effect applies a rough painted look to an image. You can also use this effect to 
achieve a pointillist-style look by setting the length of the brush strokes to zero and increasing the 
stroke density. Although you specify the direction of strokes, they are scattered randomly by a small
amount to give a more natural effect. This effect alters the alpha channel, as well as the color 
channels; if you have masked out a portion of the image, the brush strokes “paint” over the edges of
the mask.

Stroke Angle Specifies the direction in which the strokes are made. The image is effectively shifted
in this direction, which may cause some clipping at the layer boundaries. To avoid this, place the 
layer you want to brush into a larger composition, and then apply the Brush Strokes effect to the 
composition.

Stroke Length    Indicates the maximum length of each stroke, in pixels. If Stroke Randomness is 
not zero, the actual length of any given stroke may be slightly less than this maximum length.

Stroke Density Higher densities result in overlapping brush strokes and interesting visual effects.

Paint Surface Specifies where brush strokes are applied. The default setting, Paint on Original 
Image, puts the strokes on top of the unmodified layer. Paint on Transparent causes only the 
strokes themselves to appear, leaving the layer transparent between the strokes. Paint on White 
and Paint on Black enable you to apply your strokes over a white or black background.



Stylize effects 

Color Emboss

The Color Emboss effect works like the Emboss effect, without suppressing the image’s original 
colors.



Stylize effects 

Emboss

The Emboss effect sharpens the edges of objects in the image and suppresses colors. The effect 
also highlights the edges from a specified angle.

The layer’s quality setting influences the Emboss effect by controlling the Relief setting. Relief is 
calculated at the subpixel level in Best quality and rounded off to the pixel level in Draft quality.

Direction Specifies the apparent direction in which the highlight source is shining, in degrees. A 
setting of 45 degrees causes the shadow to be cast in the northeast direction.

Relief Specifies the apparent height of the embossing, in pixels. The Relief setting actually controls 
the maximum width of highlighted edges.

Contrast Specifies the sharpness of the image content’s edges. At lower settings, only distinct 
edges show the effect. As you increase the setting, the highlight becomes more extreme.



Stylize effects 

Find Edges

The Find Edges effect identifies the areas of the image that have significant transitions and 
emphasizes the edges. Edges can appear as dark lines against a white background or colored lines
against a black background. When the Find Edges effect is applied, images often look like sketches
or photographic negatives of the original.

Invert Inverts the image after the edges are found. When Invert is not selected, edges appear as 
dark lines on a white background. When Invert is selected, edges appear as bright lines on a black 
background.



Stylize effects 

Leave Color

The Leave Color effect removes all the colors from a layer except those similar to a given color. For 
example, a movie of a basketball game could be decolored except for the orange of the ball itself. 
The layer’s quality setting does not affect Leave Color.

Amount to Decolor Specifies how much color is removed from the layer. A setting of 100% causes 
the areas of the image dissimilar to the selected color to appear as shades of gray. At 50%, those 
areas lose half of their color saturation.

Color to Leave Specifies the color that is to be left untouched.

Tolerance Specifies how closely the effect matches colors. A value of 0% decolors all areas of the 
image except those that match the Color to Leave exactly. A value of 100% causes no color 
change.

Edge Softness Specifies the sharpness of the color boundaries. High values smooth the transition 
from color to gray.

Match Colors Specifies the color model to use for similarity. RGB uses the RGB color space to 
determine which areas are decolored. Match Colors is a strict matching technique and usually 
decolors more of the image than Hue. Hue uses hue (color) to determine which areas are 
decolored. In other words, choosing light blue as the Color to Leave also leaves dark blue, since 
both colors have the same hue.



Stylize effects 

Mosaic

The Mosaic effect fills a layer with solid color rectangles. It is useful for simulating low resolution 
displays and for obscuring faces. You can also animate it for a transition. At Best quality, the edges 
of the mosaic are anti-aliased.

Horizontal/Vertical Blocks Specify the number of mosaic divisions in each direction.

Sharp Colors Gives each tile the color of the pixel in its center in the unaffected layer. Otherwise, 
the tiles are colored with the average color of the corresponding region in the unaffected layer.



Stylize effects 

Motion Tile

The Motion Tile effect replicates the source image across the output image. It is called Motion Tile 
because, when changing the placement of the tiles, it will use motion blur to accentuate the 
movement if motion blur is enabled. Tile Center controls the position of the main tile. 

Tile Width/Height Specify the size of the tiles as a percentage of the input.

Output Width/Height Specify the size of the output image, or modified layer, as a percentage of 
the input.

Mirror Edges When Phase is set to 0, selecting this causes the edges of the layer to be mirrored 
with the surrounding tiles.

Phase Controls the horizontal or vertical shift of the tiles that are adjacent to the main tile.

Horizontal Phase Shift Applies horizontal shifting to the tiles instead of vertical shifting.



Stylize effects 

Noise

The Noise effect randomly changes pixel values throughout the image. The layer’s quality setting 
does not affect Noise.

Amount of Noise Specifies the amount of noise, and therefore the amount of distortion, through 
random displacement of the pixels. The range is 0% (no effect) to 100% (the image may not be 
recognizable).

Noise Type Randomly changes the red, green, and blue values of the image’s pixels individually 
when Use Color Noise is selected. Otherwise, the same value is added to all channels.

Clipping Determines whether the noise causes pixel colors to wrap around. When the color of a 
pixel gets as large as it can, clipping makes it stay at that value. With unclipped noise, the color 
value wraps around or starts again at low values. When Clipping is selected, even 100% noise 
leaves a recognizable image. If you want a completely randomized image, turn off Clipping and turn
on Color Noise.



Stylize effects 

Strobe Light

The Strobe Light effect performs an arithmetic operation on a layer at periodic or random intervals. 
For example, every five seconds the layer could appear completely white for one-tenth of a second,
or a layer’s colors could invert at random intervals. The layer’s quality setting does not affect Strobe
Light.

Strobe Duration Specifies in seconds how long a strobe effect lasts.

Strobe Period Specifies in seconds the duration between the start of subsequent strobes. For 
example, if the Strobe Duration is set to 0.1 second and the Strobe Period is set to 1.0 seconds, 
then the layer will have the effect for 0.1 second and then be without the effect for 0.9 second. If this
value is set lower than the Strobe Duration, the strobe effect is constant.

Random Strobe Probability Specifies the probability that any given frame of the layer will have the
strobe effect, giving the appearance of a random effect.

Strobe Specifies how the effect is applied. Operates On Color Only performs the strobe operation 
on all color channels. Make Layer Transparent makes the layer transparent when a strobe effect 
occurs.

Strobe Operator Specifies the arithmetic operator to use when Operates On Color Only is selected
from the Strobe pop-up menu. The default setting is Copy.



Stylize effects 

Texturize

The Texturize effect gives a layer the appearance of having the texture of another layer. For 
example, you could make the image of a tree appear as if it had the texture of bricks, and control 
the depth of the texture and the apparent light source. At Best quality, the texture layer is positioned
and scaled with subpixel accuracy.

Texture Placement Specifies how the effect is applied. Tile Texture applies the texture repeatedly 
over the layer. Center Texture positions the texture in the middle of the layer. Stretch Texture to Fit 
stretches the texture to the dimensions of the selected layer.



Stylize effects 

Write-on 

The Write-on effect animates strokes on a layer. For example, you can simulate the writing of 
cursive text or create snakelike movement for a stroke. Using the Write-on effect, you can animate 
the brush size, color, hardness, and opacity of a stroke. If you have the After Effects Production 
Bundle, you can use the Write-on effect with the Motion Sketch and Motion Math palettes to 
animate a stroke that follows a path you draw.

At each keyframe, you can apply a new property value to the current segment of the stroke, or you 
can apply the value to the entire stroke. For example, you can make a stroke become gradually 
thicker as it is drawn by increasing the stroke’s brush size at each keyframe. You control whether a 
property is applied to stroke segments or to the entire stroke using the Paint Time and Brush Time 
pop-up menus.

In addition, you can apply a stroke to the original layer or to a transparent layer. Applying a stroke 
on a transparent layer is useful when you want to use the brush stroke as a track matte or when 
you want to combine it with other layers using blending modes. With this effect, you can use an 
open path to create the stroke. 

Stroke Length Specifies the length, in seconds, of the stroke at any moment. If this value is 0, the 
stroke has unlimited length. Use a single stroke length (not zero) for all keyframes to create a 
snakelike movement of the stroke across the layer. Change the stroke length at keyframes to make 
the length of the stroke expand and contract as it is drawn.

Brush Spacing Specifies the time interval, in seconds, between dabs of color as the stroke is 
drawn. Smaller values produce smoother paint strokes, but take more time to render.

Paint Time Properties Specifies whether paint properties (color and opacity) are applied to each 
stroke segment or to the entire stroke, using the following: 
•      None applies color and opacity specified at each keyframe to the entire stroke.
•      Color applies the color specified at a keyframe to the stroke starting at that keyframe until it is 
changed at a later keyframe. The opacity specified at each keyframe is applied to the entire stroke.
•      Opacity applies the opacity specified at a keyframe to the stroke starting at that keyframe until it 
is changed at a later keyframe. The color specified at each keyframe is applied to the entire stroke.

Brush Time Properties Specifies whether brush properties (size and hardness) are applied to 
each stroke segment or to the entire stroke, using the following:
•      None applies the brush size and hardness specified at each keyframe to the entire stroke.
•      Size applies the brush size specified at a keyframe to the stroke starting at that keyframe until it 
is changed at a later keyframe. The hardness specified at each keyframe is applied to the entire 
stroke.
•      Hardness applies the hardness specified at a keyframe to the stroke starting at that keyframe 
until it is changed at a later keyframe. The size specified at each keyframe is applied to the entire 
stroke.
•      Size & Hardness applies both the brush size and hardness specified at a keyframe to the stroke
starting at that keyframe until they are changed at a later keyframe.

Paint On Specifies whether the stroke is applied to the original layer or to a transparent layer. 



See also: 

To animate a stroke using Motion Sketch and Motion Math (Production Bundle only) 



Write-on 

To animate a stroke using Motion Sketch and Motion Math (Production 
Bundle only):

1    Activate the Composition window that contains the layer on which you want to animate a stroke, 
then choose Layer > New Solid to create a new layer in the composition.

2    With the new layer selected, choose Window > Plug-in Palettes > Motion Sketch. Select the 
Don’t Erase Contents of Window option, and then draw a path across the second layer.

3    Select the second layer, and then choose Effect > Stylize > Write-on. 

4    Choose Window > Plug-in Palettes > Motion Math and load the Apply to Effect Point script. 
Apply the position property of the layer you used for sketching (Layer 2 in Motion Math) to the point 
control of the brush position in the second layer (Layer 1 in Motion Math). 



Applying Effects 

Text effects

Use these effects to create text and numbers for overlays, credit scrolls, titles, and other text.

See also: 

Basic Text 

Numbers 

Path Text 



Text effects 

Basic Text

Using the Basic Text effect, you can create text and text animation. You can specify font, style, and 
alignment of text, as well as select horizontal or vertical text orientation. Animation is created by 
changing the Position point over time. Basic Text also gives you the choice of either compositing the
text over the layer image or using the text by itself. Best quality creates anti-aliased text that 
animates smoothly.

The Basic Text effect places text on an existing layer (unlike imported text created in Photoshop or 
Illustrator, which becomes its own layer). This effect can be used for basic title text; for more 
flexibility in working with text, import text created in an illustration or imaging program. The font you 
select when creating text must be available on the system you use to render the composition. If the 
font is not available, an available font is substituted. After Effects creates an alpha channel for text it
creates. You can use a text effect’s alpha channel with features such as track matte. 

Note: The width and height of text are not constrained by the dimensions of the layer; the layer dimensions 
merely define the visible region of the text. This feature makes it simple to scroll text over a layer.

These options and values are available in the Basic Text dialog box: Font, Style, Direction, 
Alignment, and Show Font. These options and values are in the Effect Controls window after the 
Basic Text dialog box has been closed: Size, Tracking, Line Spacing, Position, Text Color, and 
Composite on Original.

To create text using the Basic Text effect:

1    Choose Effects > Text > Basic Text.

2    Select a font, style, direction, and alignment for the text.

3    Type text in the text box.

4    Click OK.

5    In the Effect Controls window, adjust controls for size, tracking, line spacing, position, and color. 

Note: The behavior of the Position point is affected by the Alignment setting in the Basic Text Options dialog 
box. The point always positions the vertical center of the text relative to the layer. However, if the text is left-
aligned, the point positions the left edge. If the text is center-aligned, the point positions the center; and if the 
text is right-aligned, the point positions the right edge.



Text effects 

Numbers

The Numbers effect generates random and sequential numbers in different formats. You can use it 
to display random times and dates or timecodes, or to print the current date and time on a layer 
whenever it’s rendered. 

These options and values are available in the Font Style dialog box: Font, Style, Direction, and 
Alignment. These options and values are in the Effect Controls window after the Font Style dialog 
box has been closed:

Type Specifies the type of numeric string used, such as time, timecode, date, or hexadecimal:
•      Number specifies a decimal number. If Random is selected, the number is bounded by zero and
the slider value.
•      Number — Leading Zeros specifies a decimal number with 5 digits to the left of the decimal 
place at all times. 
•      Timecode — 30, Timecode — 25, and Timecode — 24 are standard timecode formats 
(XX:XX:XX:XX) using the stated frame rate. The timecode types use the layer’s current time. 
•      Time is the number of minutes since midnight. If Current Time/Date is selected, 
Value/Offset/Random Max is ignored. If Random is selected, the time is bounded by 0 (12:00 AM) 
and the slider value. 
•      Date is determined by other Number settings. If Current Time/Date is not selected, the 
Value/Offset/Random Max is the number of days since January 1, 1995 (zero on the slider 
corresponds to January 1, 1995). If Current Time/Date is selected, Value/Offset/Random Max is the 
number of days since the current date (zero on the slider corresponds to the current date). If 
Random is checked, the date is bounded by zero (either the current date or January 1, 1995) and 
the slider value.

Note: If you use more than one system to render a composition that uses the date or time types, you must 
make sure the format specified in the Date & Time system control is the same on all systems.
•      Hexadecimal is a base-16 value (digits from 0 to F). Hexadecimal corresponds to the 
Value/Offset/Random Max value displayed. It will increment by 0x1 for every 0.0000125 that the 
slider increases, and it will increment by 0x10000 for every 1.0 that the slider increases. If Random 
is selected, the number is bounded by 0 and the slider value.

Options    Opens the Font Style dialog box, which you use to change font, style, or alignment.

Random Values When selected, generates random values limited by the Value/Offset/Random 
Max setting. If Value/Offset/Random Max is zero, values are random across their maximum 
possible range. 

Value/Offset/Random Max Varies based on the chosen type and whether or not Random Values is
selected.

Decimal Places Specifies the number of places to the right of the decimal point. 

Current Time/Date Specifies whether you will enter a specific time and date (not selected) or After 
Effects will enter the current time and date (selected). 

Proportional Spacing Specifies that numbers use proportional spacing instead of mono spacing.

See also: 

To create numbers using the Numbers effect 



Numbers 

To create numbers using the Numbers effect:

1    Choose Effect > Text > Numbers.

2    Select a font, style, direction, and alignment for the numbers.

Note: Several Type controls, including Time, Numerical Date, Short Date, and Long Date, use the formats 
specified in the Regional Settings Properties dialog box (Windows) or the Date & Time system control (Mac 
OS). 

3    Click OK.

4    Choose a numbers type from the Type pop-up menu. (Note that the meaning of the Random 
Values, Value/Offset/Random Max, and Decimal Places controls vary based on the type of number 
chosen.)

5    Set other controls as needed. 

Note: Leap years are taken into consideration. Note that on some Mac OS systems, the clock starts on 
January 1, 1904 and does not go beyond February 6, 2040.



Text effects 

Path Text

The Path Text effect simplifies the process of animating text along a path. Using this effect, you can 
animate words or groups of characters on a single layer instead of having to animate each 
character on a separate layer. You can define a path as a straight line, a circle of any diameter, or a 
Bezier curve. You can also import a path created in another application, such as Photoshop or 
Illustrator. The Path Text effect provides a variety of controls for animating the text, such as 
character rotation, tracking, baseline shift, and the number of visible characters. You can also add 
randomness to a number of controls to make text jump or dance.

You can animate text on an existing layer; or, for additional control over placement of text, you can 
create a solid and animate the text on it. The layer on which you animate text is transparent, unless 
you specify compositing. To modify and animate text, you type the text using a specified font, define
the path, and then create keyframes for the text properties you want to change over time. To move 
text along a path, you need to create keyframes for the left margin or right margin.

Path Text applied to a motion path

When changing the shape of a Bezier path over time, make sure to create initial keyframes for all 
four path control points; otherwise, moving a control point without an initial keyframe does not move
it over time. You may find it easier to animate a path by modifying the motion paths of individual 
control points in the Layer window.

Note: Handles appear in the Composition window only if the effect is selected in the Effect Controls window 
and if you are not animating text along a mask or path. 

If you want to move a Bezier path across the composition, but you don’t want to change its shape, 
animate the layer rather than the path. If you want to stretch, shrink, or “wag” one side of the Bezier 
path while keeping the other half in the same position, you need to move a tangent-vertex pair 
together. To do this, create keyframes for both by dragging the outer circle of the appropriate vertex.

Note: When animating the control points of a Bezier path, don’t confuse the Bezier path shape with the Bezier 
spatial interpolation of the keyframes. Like keyframes for other position controls, those for the vertex or tangent
of a Bezier path can be set to either linear or Bezier. The default spatial interpolation is specified in General 
Preferences. Spatial interpolation can be selected for individual keyframes by choosing Layer > Keyframe 
Interpolation.

You can apply motion blur to motion that you create with the Path Text effect. Blurring occurs on 
each character. Like motion blur for layers, blurring for characters is more visible when movement is
quick. For example, blurring is quite pronounced when you choose negative jitter values, which 
produce jumpy motion. For more information about motion blur, see About motion blur. 

The Path Text effect works with non-square pixels, adjusting both character shape and path shape 
accordingly. 

If you are using Adobe Type Manager (ATM) and large text looks blocky or does not otherwise 
render properly, increase the Character Cache Size in the ATM control panel. For more information, 
see the ATM User Guide.

See also: 

To enter text 



To animate path text 

To specify the location of the vertices and tangents 

To specify kerning in path text 



Path Text 

To enter text: 

1    In the Time Layout window, select the layer on which you want to animate text, or create a new 
layer by choosing Layer > New Solid. 

2    Choose Effect > Text > Path Text. 

3    In the dialog box that appears, choose the font and style for your text, and then type the text. 
You can display the text in the font you’ve chosen by selecting Show Font. 

4    Click OK. The text appears on the layer in the default color of red; by default, the layer itself is 
transparent. To display the layer, select Composite on Original in the Effect Controls window. 

5    If you need to change the text or font, click the Options button in the Effect Controls window. 

Path text is animated primarily on the location of the path control points. Text will move with the 
position of these points or on a closed path that can be selected from the Path Control Points 
option. You can also animate text by creating keyframes for margin, kerning, tracking and size.

See also: 

To animate path text 

To specify the location of the vertices and tangents 

To specify kerning in path text 



Path Text 

To animate path text:

1    In the Time Layout window, select the layer that has the Path Text effect applied. Display the 
properties for Path Text and expand the controls under Path Control Points.

2    Move the current-time marker to a point where you want to add a keyframe.

3    Adjust the path control points so that the text is displayed as desired. 

4    Click the stopwatch next to the path control points or other properties for which you will be 
creating keyframes. See Setting keyframes.

5    Repeat steps 2 and 3 until you have created the keyframes needed to animate the text.

Shape Type    Defines the shape of the path. The Path Text effect name must be selected in the 
Effect Controls window in order to make the path visible in the Composition window. Select one of 
the following shapes:
•      Select Bezier to shape text along a Bezier curve, defined by four control points (Vertex 1/Circle 
Center, Tangent 1/Circle Point, Tangent 2, Vertex 2). Characters that don’t fit on the path are placed 
off the end in a straight line.
•      Select Circle to shape text around the circumference of a circle, defined by two control points 
(Tangent 1/Circle Point, Vertex 1/Circle Center). If the text is longer than the circumference of the 
circle, the text overlaps itself. If an arbitrary path is chosen and if the path is closed, this property 
forms the text around the path, as opposed to looping it. 
•      Select Loop to shape text around the circumference of the circle, defined by two control points 
(Vertex 1/Circle Center, Tangent 1/Circle Point). If text is longer than the circumference of the circle,
it flows off the Tangent 1 point in a straight line. You can also use margin controls to make text enter
or exit a circle in a straight line.
•      Select Line to shape text in a straight line, defined by two control points (Vertex 1/Circle Center, 
Vertex 2). Note that, like the Bezier path, the distance between the two control points does not 
affect the spacing of the text, unless alignment is set to Force (see Alignment below).

Information    Displays the current font name, text length, and path length. Knowing lengths can be 
useful if you need to match other instances of text.

See also: 

To enter text 

To specify the location of the vertices and tangents 

To specify kerning in path text 



Path Text 

To specify the location of the vertices and tangents: 

Do one of the following:
•      Drag the points in the Composition or Layer window. Dragging the outer circle of a point 
dynamically updates the shape of the curve in the Composition window. To constrain the point to its 
current vertical or horizontal coordinate, press Shift while dragging its cross hair.
•      Click the cross hair for the point in the Effect Controls window, and then click in the Composition
window.
•      Click the coordinates for the point in the Effect Controls window, and then specify new 
coordinates.

Note: If you have animated the position of one or more points over time, you can modify their individual motion
paths in the Layer window when you select Path Text in the Layer window menu.

Tangent 1/Circle Point    Specifies the following points: starting tangent for a Bezier curve; 
diameter of a circle and starting or ending point of text (depending on specified alignment); and 
diameter of a loop and the point where text enters. You can automatically snap the Tangent 1/Circle 
Point on top of the Vertex 1/ Circle Center. To do this on a Mac OS, press Command and click the 
outer circle (not the cross hair) of Tangent 1. On a Windows system, select the pen tool, and then 
click the outer circle of Tangent 1. To snap the Tangent 1/Circle Point to increments of 45 degrees 
from the Vertex 1/Circle Center, hold down Shift while dragging the outer circle of Tangent 1.

Vertex 1/Circle Center    Specifies the following points: starting vertex for a Bezier curve; center of 
a circle or loop; and starting or ending point for text on a line (depending on specified alignment). To
move both the Vertex 1/Circle Center and the Tangent 1/Circle Point together, drag the outer circle 
of the Vertex 1/Circle Center. To move only the Vertex 1/Circle Center, drag its cross hair.

Tangent 2    Specifies the ending tangent of the Bezier curve. The line between Tangent 2 and 
Vertex 2 specifies the slope of the curve at its ending point. For circles or loops, Tangent 2 is 
ignored.

Vertex 2    Specifies the ending vertex of a Bezier curve and the angle of a line. To move both 
Vertex 2 and Tangent 2 together, drag the outer circle of Vertex 2. To move only Vertex 2, drag its 
cross hair. For circles or loops, Vertex 2 is ignored.

Path    Specifies an arbitrary path. You can use a mask created in the Layer window or in Illustrator. 

Left Margin and Right Margin    Left Margin specifies the position of the first character in pixels, 
relative to the starting point; Right Margin specifies the position of the last character, relative to the 
ending point. In path shapes, the starting point for Bezier curves and lines is Vertex 1, and the 
starting point for circles and loops is Tangent 1. The ending point for Bezier curves and lines is 
Vertex 2, and the ending point for circles and loops is Tangent 1. To move text across the path 
shape that you’ve defined, create keyframes for the Left or Right margins (depending on the 
specified alignment). Positive values move the text to the right; negative values move it to the left.

Alignment    Specifies the horizontal alignment of the text on the specified path:
•      Select Left to place the first character at the position specified by Left Margin; all other 
characters are drawn relative to it. Right Margin is ignored.
•      Select Right to place the last character at the position specified by Right Margin; all other 
characters are drawn relative to it. Left Margin is ignored.
•      Select Center to center the text between Left Margin and Right Margin.
•      Select Force to place the first character at the position specified by Left Margin and the last 
character at the position specified by Right Margin, and to space all other characters evenly 
between. Tracking is ignored.

Kerning    Controls the horizontal distance between two characters. If you change the text, specified



kerning is preserved for all unchanged character pairs. Kerning controls have two restrictions: you 
cannot use the Undo command to undo kerning changes, and you cannot change Kerning over 
time by using keyframes. To change horizontal spacing between characters over time, use Kerning 
jitter or create keyframes for Tracking. See To specify kerning in path text:.

Baseline Shift    Specifies the distance in pixels between the path and the bottom of the characters.
Depending on the path shape, text may appear to be better spaced when the path passes through 
the centers of the characters. To do this, set Baseline Shift to a negative value so that the centers of
characters lie on the path.

Character Rotation    Specifies the rotation of all characters. Each character is rotated by the 
specified number of degrees from its current angle. The center of rotation is on the point where the 
character intersects the path. To rotate the characters around their centers, set Baseline Shift so 
that the path goes through the centers of the characters, as explained above. Note that 
Perpendicular To Path changes the initial angle of the characters.

Perpendicular To Path    Rotates each character so that it is perpendicular to the path. If not 
selected, characters always remain upright (unless rotated by Character Rotation).

Vert. Glyphs (Double-Byte Chars Only)    Substitutes certain double-byte characters with their 
vertical counter-parts. Select only when using double-byte characters (such as Japanese) on a 
vertical path.

Horizontal Shear    Slants characters left or right, similar to italics. The slant is based on the point 
where the character intersects the path. To slant characters from their centers, set Baseline Shift to 
make the path go through the centers of the characters.

Horizontal Scale and Vertical Scale    Scales the characters by the specified percentage in the 
horizontal and vertical directions. Text is scaled from the initial rasterization size, specified for Size. 
Setting the scaling percentage greater than 100 may result in blurred edges.

For best results, set Size to a point size that does not require scaling beyond 100% to achieve the 
largest desired text size. For example, to increase the size text from 48 to 88 points, set Size at 88 
and specify a starting value for both Vertical and Horizontal Scale at 55%, then increase both scale 
values to 100% when you want the text displayed at 88 points.

Visible Characters    Specifies the number of characters that appear at the current time. By 
creating keyframes, you can use the Visible Characters property to display one or more characters 
at a time to create a “type-on” effect. Positive values specify the number of visible characters from 
the beginning of the text to the end. Negative values specify the number of visible characters from 
the end of the text to the beginning. Remember that spaces are characters, too.

You can also use this property with Fade Time to fade in characters. When Fade Time is zero, the 
next character appears when the value of Visible Characters is halfway to the next whole number. 
For example, the second character appears when the value of Visible Characters is 1.5; the third 
character appears when the value is 2.5, and so on. A Fade Time value of zero produces a “typed-
on” effect. For other Fade Time values, see Fade Time below.

Note: Visible Characters does not alter the positions of characters defined by the path and other controls.

Fade Time    Specifies a range of time over which a particular character is partially visible. Fade 
Time works in conjunction with Visible Characters. When Fade Time is zero, each letter appears 
fully opaque at the appropriate Visible Characters value (see description above). When Fade Time 
is 100%, a particular character is displayed with greater and greater opacity as the value of Visible 
Characters increases between whole numbers. The exact opacity of the character is equal to the 
fractional part of the Visible Characters value. For example, the eighth character is displayed at 
10% opacity when the value of Visible Characters is 7.10 and Fade Time is 100%; the same 
character is displayed at 60% opacity when the value of Visible Characters is 7.60, and so on.

For Fade Time values between 0 and 100%, the opacity of the character is defined as a range 
across the halfway point between whole number values of Visible Characters. For example, when 
Fade Time is 20%, the eighth character will begin to appear at a Visible Character value of 7.4 and 



will be fully opaque at 7.6. If Fade Time is set to 60%, the same character would begin to appear at 
a value of 7.2 and be fully opaque at 7.8.

Mode    Specifies the transfer mode used when characters overlap each other. The specified mode 
is applied only to the parts of characters that overlap. When Mode is set to Difference, overlapping 
parts of characters appear in black. When Mode is set to normal, overlapping parts appear in the 
specified Text color.

Jitter Settings    Specify maximum amount of deviation added randomly to baseline, kerning, 
rotation, or scale. Higher values produce greater deviations. Positive values produce smooth 
motion; negative values produce jumpy motion. Movement is created without keyframes, although 
you can use keyframes to change the maximum values.

You can specify the following types of jitter:
•      Specify Baseline Jitter Max to set a maximum distance, in pixels, that characters are randomly 
moved above or below the path after Baseline Shift is applied.
•      Specify Kerning Jitter Max to set a maximum distance, in pixels, that characters are randomly 
moved apart from one another along the horizontal after kerning and tracking are applied.
•      Specify Rotation Jitter Max to set a maximum amount, in degrees, that characters are randomly 
rotated after Character Rotation is applied.
•      Specify Scale Jitter Max to set a maximum amount, as a percentage, that characters are 
randomly scaled after Horizontal and Vertical Scale are applied. For best results, characters should 
not scale greater than 100%.

A specific jitter value will generate the same seemingly random motion for identical text and 
settings. If your composition contains duplicate animated text, you can generate different motion for 
each instance of the text by changing a setting but making the change invisible. For example, you 
could add a space to a second instance of text, and then adjust the kerning so that the space is not 
visible. This creates an invisible change that will generate different motion.

See also: 

To enter text 

To animate path text 

To specify kerning in path text 



Path Text 

To specify kerning in path text: 

1    In the Effect Controls window, click the triangle next to Kerning to display the kerning controls.

2    To change kerning between two characters, click the triangles on either side of the character 
display until the character pair is displayed. (Remember that spaces are characters, too.) To move 
quickly across the character pairs, hold down either triangle. To toggle between the first and last 
pair of characters, click the character display.

3    With the character pair displayed, click the second set of triangles to adjust the kerning amount. 
Hold down the Shift key when clicking to increase kerning increments by ten. You can also hold 
down either triangle to scan quickly to a higher or lower kerning amount.

4    To reset kerning for the selected pair to zero, click the Clear button. To reset kerning for all pairs 
to the default values, click Reset All. To reset kerning for all pairs to zero, hold the Alt key 
(Windows) or the Option key (Mac OS) and click Reset All.

See also: 

To enter text 

To animate path text 

To specify the location of the vertices and tangents 



Applying Effects 

Time effects

Use these effects to manipulate the timing of a layer. These effects use the source of a layer as the 
basis of time, so all effects previously applied to a layer are ignored when Time effects are applied.

See also: 

Echo 

Posterize Time 



Time effects 

Echo 

The Echo effect combines frames from many different times in a layer. It has a variety of uses, from 
a simple visual echo to streaking and smearing effects. This effect must be applied and is visible 
only in the Composition window, not the Layer window, and it is visible only when there is motion in 
the layer. By default, a layer’s mask and any previously applied effects are ignored when you apply 
the Echo effect. If you do not want them ignored, precompose the layer with other effects before 
applying the Echo effect. This creates a new composition with the mask already applied. Whenever 
Echo needs to retrieve a frame, it can do so from that composition.

The Echo effect is based on the positions of the previous or subsequent frames.

Echo Time Specifies the time, in seconds, between echoes. Negative values seek backward in 
time; positive values echo forward in time. 

Number Of Echoes Specifies the number of frames to combine for the Echo effect. For example, if 
two echoes are specified, Echo will make a new image out of (current time), (current time + Echo 
Time), and (current time + 2 * Echo Time). 

Starting Intensity Specifies the intensity of the starting frame in the echo sequence. For example, 
if this is set to 1, the first frame is combined at its full intensity. If this is set to 0.5, the first frame is 
combined at half intensity. 

Decay Specifies the ratio of intensities of subsequent echoes. For example, if the decay is set to 
0.5, the first echo will be half the strength of the Starting Intensity. The second echo will then be half
that, or 0.25 times the Starting Intensity.

Echo Operator Specifies the operations to be performed between the echoes. Add combines the 
echoes by adding their pixel values. If the starting intensity is too high, this mode can quickly 
overload and produce streaks of white. Set the Starting Intensity to 1.0 per number of echoes and 
the Decay to 1.0 to blend the echoes equally. Maximum combines the echoes by taking the 
maximum pixel value from all the echoes. Minimum combines the echoes by taking the minimum 
pixel value from all the echoes. Screen emulates combining the echoes by sandwiching them 
optically. This is similar to Add, but it will not overload as quickly. Composite in Back uses the 
echoes’ alpha channels to composite them back to front. Composite in Front uses the echoes’ alpha
channels to composite them front to back. 

See also: 

To incorporate a layer’s motion into the Echo effect 

To create an image trail using the Echo effect 



Echo 

To incorporate a layer’s motion into the Echo effect:

1    Set up your motion before applying the Echo effect.

2    Precompose the layer with any additional effects. This creates a new composition containing 
only that layer and its motion keyframes.

3    Choose Effects > Time > Echo.

Note: Use a large Number of Echoes and a short Echo Time to get smooth streaking and smooth trail effects.

4    Set controls as needed. 

See also: 

To create an image trail using the Echo effect 



Echo 

To create an image trail using the Echo effect:

1    Choose File > Import > Footage File, select the source footage file, and then click OK.

2    Drag the source footage from the Project window into the Composition window.

3    Highlight the source footage layer in the Time Layout window and create a motion path using 
position keyframes. For instructions on creating a motion path, see Setting and animating position.

4    Highlight the source footage layer in the Time Layout window and choose Layer > Pre-compose.

5    Type a name for the precomposed composition in the Pre-compose dialog box, select Move All 
Attributes Into The New Composition, and then click OK.

6    Select the name of the precomposed composition in the Time Layout window.

7    Choose Effect > Time > Echo. 

8    Change the effect controls to these values:
•      Echo Time: –0.10
•      Number of Echoes: 10
•      Starting intensity: 1.00
•      Decay: 0.68
•      Echo Operator: Composite In Front

9    Press the spacebar to preview the trail effect; use RAM Preview for a quicker preview; or render 
the composition to view the effect in real time.

See also: 

To incorporate a layer’s motion into the Echo effect 



Time effects 

Posterize Time

The Posterize Time effect locks a layer to a specific frame rate. Posterize Time is useful on its own 
as a special effect, but it also has more subtle uses. For example, 60-field video footage can be 
locked to 24 frames per second (and then field rendered at 60 fields per second) to give a film-like 
look. Also, nested compositions can be locked to a given frame rate. This effect is sometimes called
Strobe in hardware devices.

A layer’s mask and any previously applied effects are ignored when the Posterize Time effect is 
applied. To posterize the time of a masked layer, create the mask in another composition or 
precompose the layer with other effects before applying the Posterize Time effect.

Animating the value of the Frame Rate slider can give unpredictable results. For this reason, the 
only interpolation of the frame rate allowed is Hold.



Applying Effects 

Transitions effects

Use these effects as transitions between one layer and another, or between several layers. Place 
the transition layer in front of other layers you want to transition into. Apply the effect to the 
transition layer. Set keyframe values for the Transition Completion slider to animate the change 
from the transition layer to the layers beneath.

See also: 

Block Dissolve 

Gradient Wipe 

Iris Wipe 

Linear Wipe 

Radial Wipe 

Venetian Blinds 



Transitions effects 

Block Dissolve

The Block Dissolve effect makes a layer disappear in random blocks. The width and height of the 
blocks, in pixels, can be set independently. At Draft quality, the blocks are placed with pixel 
accuracy and have sharply defined edges; at Best quality, the blocks can be positioned with 
subpixel accuracy and have soft edges.

A. Draft quality B. Best quality C. Best quality with different block dimensions



Transitions effects 

Gradient Wipe

The Gradient Wipe effect creates transitions based on the luminance values of a second layer, 
called the gradient layer. The luminance of a pixel in the gradient determines the time at which the 
corresponding pixel in the first layer will become transparent. Dark areas of the gradient layer 
represent those areas which will become transparent first, followed by lighter areas.

A. Grayscale gradient image B. Gradient Wipe near beginning C. Gradient Wipe near end

For example, a simple grayscale gradient from left to right will produce a left-to-right wipe. The 
gradient layer need not be a still image; you can use any layer in After Effects as a gradient for 
unusual wipe effects. More interesting wipes can be created in a variety of ways. The Ramp effect 
is a good starting point because it can generate a variety of grayscale gradients. For completely 
custom gradients, you can paint them in a program such as Photoshop or draw them in a program 
such as Illustrator.

Transition Softness Specifies the amount of softness applied to the transition’s edge.

Gradient Layer Specifies the layer used as the gradient. All available layers are listed in the menu. 
The gradient layer must be in the same composition as the layer to which you apply Gradient Wipe.

Gradient Placement Specifies how the gradient is positioned and sized in the layer. Tile Gradient 
creates multiple tiled copies of the gradient. Center Gradient places a single gradient in the center 
of the layer. Stretch Gradient To Fit resizes the gradient layer horizontally and vertically to fit the 
entire area of the layer. 

Invert Gradient When selected, inverts the position of the gradient layer and the layer affected by 
the gradient transition. 



Transitions effects 

Iris Wipe

The Iris Wipe effect creates a radial transition that reveals an underlying layer. With this effect you 
can specify the number of points used to create the iris, and whether an inner diameter is used.

Iris Wipe creates a transition from one layer to another using an iris with seven points.

Iris Points Specifies the number of points used to create the iris, with a range of 6 to 32 points. 

Outer Radius Specifies the outer radius of the iris. 

Use Inner Radius When selected, both the inner and outer radii can be specified. When selected, 
the iris is not visible when Outer Radius, Inner Radius, or both are set to 0. 

Inner Radius Specifies the inner radius. The inner radius is used only if Use Inner Radius is 
selected. The iris is roundest when both Outer Radius and Inner Radius are set to the same value. 



Transitions effects 

Linear Wipe

The Linear Wipe effect performs a simple linear wipe of a layer in a specified direction. At Draft 
quality, the edge of the wipe is not anti-aliased; at Best quality, the edge of the wipe is anti-aliased 
and the feather is smooth.

Wipe Angle Specifies the direction that the wipe travels. For example, at 90 degrees the wipe 
travels from left to right.



Transitions effects 

Radial Wipe

The Radial Wipe effect reveals an underlying layer using a wipe that circles around a specified 
point. At Best quality, the edges of the wipe are anti-aliased.

Start Angle Specifies the position or angle at which the transition starts. With a start angle of 0 
degrees, the transition starts at the top of the layer. 

Wipe Specifies whether the transition moves clockwise, counterclockwise, or alternates between 
the two. 



Transitions effects 

Venetian Blinds

The Venetian Blinds effect reveals an underlying layer using strips of specified direction and width. 
At Draft quality, the strips are animated with pixel accuracy; at Best quality the strips are animated 
with subpixel accuracy.

Venetian Blinds creates a striped transition from one layer to another.



Applying Effects 

Video effects

Use these effects to prepare your movie for video.

See also: 

Broadcast Colors 

Reduce Interlace Flicker 

Timecode 



Video effects 

Broadcast Colors

The Broadcast Colors effect alters pixel color values so that the layer can be accurately 
represented in a television broadcast. Computers represent colors as combinations of red, green, 
and blue. Consumer video equipment represents colors using different composite signals. Home 
video equipment cannot reproduce signals above a certain amplitude, and computer-generated 
colors can easily exceed this limit. (Signal amplitude is measured in IRE units; 120 IRE units is the 
maximum possible transmission amplitude.) Use the Broadcast Colors effect to reduce luminance 
or saturation to a safe level. The layer’s quality setting does not affect the Broadcast Colors effect.

Reducing saturation requires greater amplitude modification than reducing luminance to achieve the
same IRE unit level, which alters the appearance of your image more. Key Out Unsafe and Key Out
Safe are intended to make it easy for you to determine which portions of the layer will be affected 
by the Broadcast Colors effect at the current settings. If you make your background a contrasting 
color and temporarily select Key Out Unsafe or Key Out Safe, the background will be visible 
through affected or unaffected areas of the layer, respectively.

An unsafe level merely means that if some portions of your movie exceed the safe level, they will 
not look as you intended when viewed on a television monitor. Here are some guidelines for using 
color in movies intended for broadcast:
•      Avoid using highly saturated colors. For example, a red value of 255 used with green and blue 
values of 0 will cause red to smear on an NTSC monitor. 
•      Render a test of your movie and play it back on an NTSC monitor to ensure that colors are 
represented accurately. 
•      Avoid pure black and white values. Commonly used values for black and white are 235 and 16, 
respectively.

Note: The output you are creating should determine whether you use this effect. Many video systems alter 
colors for broadcast during the encoding process.

Broadcast Locale Specifies the type of broadcast standard you intend to use. NTSC (National 
Television Systems Committee) is the North American standard. It is also used in Japan. PAL 
(Phase Alternating Line) is used in most of Western Europe and South America.

How to Make Color Safe Specifies the method of reducing the signal amplitude. Reduce 
Luminance reduces a pixel’s brightness by moving it towards black. This is the default setting. 
Reduce Saturation moves the pixel toward a gray of similar brightness, making it less colorful. Key 
Out Unsafe makes unsafe pixels transparent. Key Out Safe makes safe pixels transparent.

Maximum Signal Specifies the IRE unit level above which your layer’s pixels are altered. The 
range is Amplitude (IRE) from 100 to 120 IRE. A level of 100 can affect a layer noticeably; a level of 
120 is the maximum possible IRE and is risky. The default, 110 IRE units, is conservative.



Video effects 

Reduce Interlace Flicker

The Reduce Interlace Flicker effect reduces high vertical frequencies to make images more suitable
for use in an interlaced medium (such as NTSC video). For example, images with very thin 
horizontal lines can flicker annoyingly when broadcast. Reduce Interlace Flicker softens horizontal 
edges to reduce the flickering.

Note: Flicker may result from fields that have not been separated. For information on separating fields, see 
Using interlaced video in After Effects.



Video effects 

Timecode

The Timecode effect displays timecode or frame number information within a layer. It can also 
encode the timecode information into the layer for later display within After Effects. This effect 
cannot modify timecode embedded from external sources, such as QuickTime movies rendered 
with or assigned a timecode track. Although you can’t render movies containing embedded 
timecode information, you can render movies containing visible timecode. 

Mode Specifies whether timecode is visible or encoded (invisible). To ensure that After Effects can 
read encoded timecode, follow these guidelines:
•      Use a lossless compressor or no compressor when rendering.
•      Do not rotate or scale an encoded-timecode layer. 
•      Do not crop the lower edge of an encoded-timecode layer or cover it with another layer in the 
Composition window. 

Display Format Specifies whether timecode is displayed in the SMPTE format of HH:MM:SS:FF or 
in frame numbers only. 

Time Units Use to mark each frame of a layer for variable composition frame rates. The Time Units 
control determines the frame rate in frames per second (fps) for a specific layer in the composition. 
For example, a value of 60 changes the timecode for a specific layer to match the composition’s 60 
fps rate. This control affects how After Effects counts the layer’s frames, not how the footage plays. 

Starting Frame Specifies the timecode count at the beginning of the layer. You can set the Starting 
Frame slider to correspond to the layer’s In point; or, if you combine a layer with another 
composition and need to match the timecode at a frame other than the In point, you can set the 
Starting Frame accordingly. 



Managing Projects Effectively

As you create large or intricate projects with After Effects, you may find that using a large number of
layers in one composition can be difficult to manage and may require more time to preview. After 
Effects provides tools for organizing projects, speeding up previews, and working more efficiently.

You can organize a project into multiple compositions and arrange them within a main composition 
from which you render the final movie. This is similar to grouping objects in a drawing program. 
When you use one composition inside another, that composition becomes a layer in the 
composition containing it. This process is called nesting. To speed up previewing and final 
rendering, you can prerender compositions into movies. 

See also: 

Understanding default rendering order 

Organizing a project using nesting 

Creating animations by nesting compositions 

Synchronizing time displays of nested compositions 

Maintaining image quality of nested compositions 

Saving time by prerendering nested compositions 

Understanding precomposing 

Techniques for working efficiently 

Using RAM effectively 

Running After Effects on multiprocessors 

Running After Effects with Intel’s MMX 



Managing Projects Effectively 

Understanding default rendering order

The order in which After Effects renders the various parts of a composition can affect the look of 
some visual effects in a rendered movie. An understanding of how After Effects renders a 
composition will help you get the effect you want every time.

Note: Transform was called Geometrics in After Effects 3.1 and earlier versions. Likewise, the Collapse 
Transformations switch was called Collapse Geometrics.

In rendering a composition, After Effects processes layers in the order in which they are listed in the
Time Layout window, starting at the bottom of the list. In processing each layer, After Effects 
processes the mask, effects, and transform changes in the order that these three categories appear
in the Time Layout window, starting at the top, followed by transfer modes and track mattes.

First, After Effects processes any masks you have applied, making the footage transparent in areas 
that you masked out. Next, After Effects processes the effects you have applied, in the order in 
which the effects are listed in the Effect Controls window and the Time Layout window. Finally, After 
Effects places the resulting image in your composition according to the transform properties you 
have specified, which include position, scale, rotation, and opacity. When that layer has been 
processed, After Effects then blends it with the layers behind it.

A. Original layer at start of rendering B. A mask applied at the mask stage C. The Wave effect applied at the 
effect stage D. Scale applied at the transform stage

See also: 

Changing the rendering order 



Understanding default rendering order 

Changing the rendering order

Sometimes, you may require a visual effect that cannot be achieved using the default rendering 
order. For example, you may be constructing an animation in which you want a rotated object to 
have a drop shadow effect. By default, After Effects renders an effect before rotation, which would 
not create a properly oriented shadow. Therefore, you need to apply rotation before you apply the 
drop shadow effect. 

A. Original layer B. Drop shadow applied at effect stage C. Rotation applied at transform stage results in the 
shadow rotating with the layer. 

A. Original layer B. Rotation applied using the Transform effect C. Drop shadow applied at the effect stage 
results in a properly oriented shadow

Although you can’t instruct After Effects to change the order of processing within a layer, there are 
three ways to get the rendering order you want. You can change the rendering order in a layer by 
applying the Transform effect, by including an adjustment layer above the layer, or by using nesting 
or precomposing. 

Transform effect Apply the Transform effect when you simply want After Effects to render a 
transform property before an effect. Using the Transform effect is the easiest way to change the 
rendering order. The Transform effect lets you apply changes to transform properties at the effects 
stage in a layer (see Transform). This means that these transform changes will be rendered before 
subsequent effects. For example, if you rotate the layer at the effects stage using the Transform 
effect, and apply a shadow effect to that layer, After Effects will render the rotation first, then render 
the shadow effect to the rotated layer. Other transform properties set in the Time Layout window will
be rendered last. 

Adjustment layer Use an adjustment layer in your composition when you want to change 
rendering order and apply transform properties or effects to more than one layer at a time. See 
Creating an adjustment layer. For example, a layer with a rotation applied will be rendered prior to 
the adjustment layer effect. 

When you apply an effect to an adjustment layer, After Effects renders the effect after rendering the 
transform properties in the other layers. To apply an adjustment layer to some, but not all, of the 
layers below it, you must either nest or precompose the adjustment layer with those layers.



Nesting or precomposing Use either nesting or precomposing to change the rendering order 
while also applying an effect to continuously rasterized or collapsed layers. Precomposing is simply 
another form of nesting, and both change the rendering order in the same way. To make an effect 
render after a transform property using nesting or precomposing, apply the effect to the nested 
composition instead of to the layer inside that composition. See Organizing a project using nesting 
and Understanding precomposing. 



Managing Projects Effectively 

Organizing a project using nesting 

When you nest compositions, you organize your project into a hierarchy. In its simplest form, 
nesting means you combine two or more compositions into one main composition from which you 
render the final movie. When you nest a composition inside another composition, it becomes a layer
within that composition.

A. Footage items B. Layers in a composition C. Intermediate compositions D. Compositions nested with 
another footage item (the head at right) in a composition E. Final composition 

In a large project, a diagram of the project may reveal a deep hierarchy with many levels. 

You can use composition nesting to save time working and rendering. With composition nesting, 
you can do the following:
•      Apply complex changes uniformly to several objects. For example, if you want to animate ten 
still images as a group along the same motion path during the same period of time, you do not have
to build keyframes and a motion path for each still image individually. You can create one 
composition containing all the still images, nest the composition in another one, and simply animate
the composition containing the still images.
•      Reuse anything you build. For example, if you create a six-layer animation and you want to use 
it ten times in a project, you only have to build the animation once. Build it in its own composition, 
and then drag it into any other composition as many times as you want.
•      Update many composition copies in one step. For example, if you animated a logo and nested 
the resulting composition in ten different compositions, you can update the animated logo 
composition in all ten compositions just by editing the original animated-logo composition; every 
time you reuse the composition, After Effects locates and uses the original.



•      Alter the default rendering order of a layer, for example, to render a transform change (such as 
rotation) before rendering effects.
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Creating animations by nesting compositions

Nesting is useful whenever you want to apply a single transform property to a layer in more than 
one way. For example, you could use nesting to rotate a head and then revolve it around a circle. 
Nesting adds another opportunity to apply masks, effects, or a transform change. By nesting, you 
can apply rotation to the head in one composition and then move that composition into another 
composition containing the background. The head composition becomes a new layer in the 
composition containing the background. You can then apply rotation to this new layer to make it 
revolve around the circle.

To revolve a head that rotates, nest one composition in another.

To nest a composition:

Drag a composition icon from the Project window and drop it in one of three places:
•      Into the Composition window of another composition.
•      Into the Time Layout window of another composition.
•      Onto the icon of another composition in the Project window.



Managing Projects Effectively 

Synchronizing time displays of nested compositions

When you open windows associated with a composition, for example, the Time Layout, the Layer, 
and the Effect Controls windows, changing the current time in one window updates the other 
windows associated with that composition. However, changing the current time in one composition 
does not change the current time in windows belonging to other compositions, unless you are 
working with nested compositions.

When you work with nested compositions, you can tell After Effects to synchronize the current-time 
markers in open windows belonging to a nested composition. After Effects provides a preference 
that updates all windows of nested compositions when you move the current-time marker in any 
nested composition.

To synchronize time displays in windows of nested compositions:

Choose File > Preferences > Display, click the Synchronize Time of All Related Items option, and 
then click OK.
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Maintaining image quality of nested compositions

There are two methods of calculating changes to transform properties (such as rotation or scaling) 
during rendering of a nested composition. The default method applies transform properties and 
rasterizes at every level of nested compositions. The alternative method, Collapsing 
transformations, postpones the calculation of transform properties and rasterization of nested 
compositions until the rendering process reaches a layer you select. (You cannot collapse a layer’s 
transform properties if a mask or effect is applied to it.) You can increase image quality and 
significantly reduce rendering time by collapsing transformations. 

Collapsing transformations can preserve resolution when a nested composition is scaled down and 
then scaled back up in successive compositions. Without collapsed transformations, a nested 
composition that is scaled down loses the resolution of its original larger size. When you collapse 
transformations, the original resolution of a nested composition is preserved; its final resolution is 
determined by its size within the composition that uses collapsed transformations.

Default method When a nested composition is scaled down and then up again in successive compositions, it 
retains the lower resolution of the scaled-down version. 

Collapsed transformation When a nested composition is scaled down and then up again in successive 
compositions, it retains the resolution of the original layer.

When you collapse the transform properties of a layer, all of the compositions nested inside it 
combine their opacity setting with the opacity setting of the layer that uses collapsed transform 
properties.

Because you can collapse transformations but not mask or effect properties, After Effects 
automatically disables all composition and layer switches related to masks or effects when you 
collapse transformations. If you click a disabled layer switch, After Effects prompts you to turn off 
Collapse Transformations. You cannot turn on the Effect, Mask, Mask Feather, or Motion Blur layer 
properties or apply transfer controls to a layer in which you collapsed transform properties. You can 
still apply these properties to a composition nested within the composition with transform properties 
collapsed, as long as the Collapse Transformations switch is not turned on for that composition.



Some layer switches are not available when you collapse transformations.

When a layer contains an Adobe Illustrator file instead of a nested composition, the Collapse 
Transformations switch for that layer becomes the Continuously Rasterize switch, which you can 
use to improve the image quality of footage. See Importing an Adobe Illustrator or EPS file and 
Collapsing the transformation properties or continuously rasterizing a layer.

See also: 

Collapsing Transformations 



Maintaining image quality of nested compositions 

Collapsing Transformations 

To reduce rendering time and increase image quality, use the Collapse Transformations switch with 
nested compositions. 

To collapse transformations of a nested composition:

In the Layer Feature panel of the Time Layout window, click the Collapse Transformations switch 
icon next to the layer containing the nested composition.
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Saving time by prerendering nested compositions

A complex nested composition can take a long time to preview and render. If you have a nested 
composition that you do not expect to work on any further, render the nested composition into a 
movie and use it as a proxy for the actual nested composition. As a rendered movie, it will require 
less calculation and time to display and render in the larger project. You can still make changes to 
the prerendered composition, because the original nested composition remains in the project list. If 
you make a change to the original nested composition, simply render it again. Prerendering a 
nested composition is particularly beneficial when you use a nested composition multiple times in a 
project.

A. Footage items    B. Layers in a composition C. Rendered movie D. Movies and another footage item in a 
composition E. Final composition 

Using a prerendered movie in place of a nested composition also saves time and memory when 
you render the final version of the main composition. Just be sure to apply your final output settings 
when you prerender the nested composition. For more information about rendering options, see 
Rendering a Movie.

See also: 

To prerender a composition 

To edit a prerendered composition 



Saving time by prerendering nested compositions 

To prerender a composition:

1    Create a composition. See Creating a composition.

2    Render the composition you created. See Rendering a Movie.

3    Create a proxy using the rendered composition. See Substituting a low-resolution proxy for 
footage.

See also: 

To edit a prerendered composition 



Saving time by prerendering nested compositions 

To edit a prerendered composition:

1    In the Project window, click the proxy indicator for the prerendered composition until it displays 
an empty box. This turns off the proxy so that After Effects uses the actual composition in the 
project.

2    In the Project window, double-click the composition from which the proxy movie was rendered.

3    Edit the composition.

4    Save the project.

5    Render the composition into a movie again, using the same filename as the previous version of 
the movie.

6    After rendering is complete, set up the movie as a proxy for the composition. The next time you 
view the composition containing the movie, the new movie will be displayed.

See also: 

To prerender a composition 
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Understanding precomposing

Sometimes you realize that it’s necessary to nest compositions after you have already created a 
complex project hierarchy. In many cases it’s tedious or difficult to use nesting in an existing 
composition. Precomposing is a method of nesting layers within an existing composition. 
Precomposing moves the layers to a new composition, as shown in the illustration that follows. 
When you want to change the order in which layer components are rendered (see Understanding 
default rendering order), precomposing is a quick way to create intermediate levels of nesting in an 
existing hierarchy.

Precomposing makes it easier to add an additional rendering stage before rendering the entire 
composition. When you precompose, one or more layers that you select are moved into a new 
composition. This new composition takes the place of the selected layers, which does not occur in 
nesting. Precomposing also places the new composition in the Project window, available for use in 
any composition.

A. Using these footage items as layers in a composition results in only one eye B. Precomposing the footage 
items that make up the eye creates a composition, which replaces the item's layers in the original composition.

Note: The Precompose command was called the Compify command in After Effects 1.0–2.02.

When you precompose only one layer, you can transfer the keyframes and the mask, effects, and 
transform properties from the original layer to the new layer. You can also choose to keep the 
keyframes and properties with the original layer while it moves one rendering step further from the 
main composition. When you precompose more than one layer, the keyframes and properties stay 
with the original layers.

After Effects offers two options for working with layer properties and keyframes during 
precomposing:

Leave All Attributes In (selected composition) Leaves the selected layer’s properties and 



keyframes in the original composition. The frame size of the new composition is the same as that of
the selected layer. Select this option when you do not need to change the rendering order. For 
example, you would use this option when you precompose layers only to simplify or reuse a 
composition, not to change the rendering order of layer properties. This option is not available when
you select more than one layer.

Note: After you precompose using the Leave All Attributes In option, changes you applied to the properties of 
the original layer are still applied to that layer in the original composition. 

Move All Attributes Into The New Composition Moves the properties and keyframes of one or 
more selected layers one level further from the main composition in the composition hierarchy. The 
frame size of the new composition is the same as that of the original composition. Choose this 
option when you want to change the rendering order in the selected layers. For example, you would
use this option when you want to rotate a layer but not its drop shadow. This situation is described 
in Creating animations by nesting compositions. You can also select this option to organize selected
layers into their own composition.

See also: 

To precompose one or more layers 
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To precompose one or more layers:

1    In the Time Layout window containing the layer you want to precompose, select the layer.

2    Choose Layer > Pre-compose.

3    Select an option to specify how to handle layer properties and keyframes:
•      To apply changes to layer properties that you want rendered before the original set of property 
changes, select Leave All Attributes In. 
•      To apply changes to layer properties that you want rendered after the properties are applied to 
the selected layers, select Move All Attributes into the New Composition.

4    Click OK.
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Techniques for working efficiently

Projects you create using high resolution or many layers can take longer to work with because of 
long previewing times or difficult navigation. After Effects provides many options and techniques for 
working faster and more efficiently.

In many cases you can work more quickly by displaying an appropriate level of detail for the layers 
you are working on. For example, imagine you are animating a frame containing a small moving 
layer in front of a larger layer. If you’re adjusting the motion of the small layer in relation to the large 
layer, you may need to see both layers. If you’re adjusting only the effect applied to the smaller 
layer, you can speed previewing by preventing a detailed display of the larger layer; by displaying 
the layer at a lower resolution or as a wireframe; or by turning off the display of the layer. As you 
work on other parts of the project, use the following techniques to speed screen updates on the 
area in which you are currently working.

Lower the composition’s resolution Displaying a composition at a lower resolution than is set in 
its Composition Settings dialog box speeds previewing, especially when you adjust the window size
accordingly. See Setting resolution. 

Use folders in the Project window To make it easier to locate and move items, you can organize 
items by creating and using folders in the Project window. See Project window.

Close unneeded windows and tabs Keep open only those windows and tabs that you need to see
as you work. After Effects must spend time updating all Layer or Composition windows that are 
open, which takes time from the one or two windows that are most important. Tabs consume 
memory, which could otherwise be used to speed up other operations. 

Substitute a proxy for a source item When working at resolutions such as NTSC, PAL, or higher, 
substitute a low-resolution or still-image proxy for a layer to speed previewing and working. See 
Substituting a low-resolution proxy for footage.

Lower a layer’s display quality Selecting Draft for a layer while working with it is often a good 
compromise in quality that will speed previewing. See Changing a layer’s image quality.

Hide layers When you don’t need to see one or more layers in the Time Layout window, you can 
hide them or mark them as shy, which speeds previewing. See Using Layer Switches.

Lock layers To avoid wasting time undoing accidental modifications, lock a layer when you want to 
see it but do not want to modify it. See Using Layer Switches.

Prerender nested compositions Render a completed composition as a movie so that After Effects
doesn’t use the time and memory required to calculate its changes every time it displays. See 
Saving time by prerendering nested compositions.

Collapse transformations of nested compositions In some cases, you can improve preview 
speed, rendering speed, and image quality by collapsing transformations of a layer containing 
nested compositions. See Collapsing Transformations.

Deselect Continuously Rasterize for Illustrator files Deselect the Continuously Rasterize switch 
for an Adobe Illustrator file until you need to view or render it in detail. This prevents After Effects 
from rasterizing the entire file after each change, saving you time. See Importing an Adobe 
Illustrator or EPS file, and Collapsing the transformation properties or continuously rasterizing a 
layer.

Stop window updates Press the Caps Lock key to prevent After Effects from updating Footage, 
Layer, or Composition windows. This is useful for a Layer or Composition window that takes a long 
time to update. When Caps Lock is active, all open Footage, Layer, or Composition windows 
display the last update you made before pressing Caps Lock, regardless of the changes you make. 
As soon as you make a change that would appear in a window, After Effects adds a red outline to 



any affected windows, and the windows are not updated. After Effects continues to update window 
controls such as motion paths, anchor points, and mask outlines as you move them. To resume 
window updates and display all changes made while Caps Lock was active, press Caps Lock again 
to deactivate it.

Use rectangular masks When possible, use a rectangular mask, which renders faster than an oval
or Bezier mask. The difference in speed is greatest when you set the layer display quality to Best, 
or when you feather the edge of the mask. For more information on creating and masks, see 
Changing the shape of a mask.

Allocate more memory (Mac OS only) Rendering performance on a Mac OS system is 
significantly affected by the amount of RAM you allocate to After Effects. The more RAM you 
allocate, the faster it can render. See Using RAM effectively. To avoid unnecessary rendering, After 
Effects stores and reuses rendered layer components in RAM. However, it can do this only if there 
is enough memory available to store the rendered components. 

In general, you should assign as much memory to After Effects as you can, up to 90% of the largest
unused block. Leave the remaining 10% unused so that the system software has room to expand 
when additional system components are loaded.

See also: 

To allocate more memory to After Effects 
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To allocate more memory to After Effects:

1    Quit After Effects and all other applications.

2    In the Finder, choose About This Macintosh (System 7.x) or About This Computer (Mac OS 8.0) 
in the Apple menu.

3    Note the Largest Unused Block value, and then close the dialog box.

4    Click the After Effects application icon (not an alias), and then choose File > Get Info.

5    In the After Effects Info dialog box, increase the Preferred Size value, but don’t exceed 90% of 
the Largest Unused Block value noted previously. Do not change the Minimum Size value.

6    Close the After Effects Info dialog box.
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Using RAM effectively

Occasionally, After Effects may display an alert message indicating that it requires more memory to 
display or render a composition. To render more efficiently, it’s helpful to understand how After 
Effects uses memory and what parts of a composition may be increasing the memory load. Many 
variables, such as memory management controlled by QuickTime or other system software, make it
impossible to predict the exact amount of memory required for displaying or rendering a particular 
layer. However, you can usually identify memory-intensive layers with enough certainty to get a 
composition to render.

When rendering a composition, the following factors determine memory requirements:
•      The resolution of the composition frame. A higher resolution frame requires more memory.
•      The memory requirement of the most memory-intensive layer in the composition.
•      The size of the project file.

If you have no problems displaying every frame of a full-resolution, best-quality preview of a 
composition, then you have enough memory to render the composition. Rendering a composition 
into a movie takes somewhat less memory than displaying it on-screen.

See also: 

Identifying memory-intensive layers in a composition 

Reducing a composition’s memory requirements 
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Identifying memory-intensive layers in a composition

After Effects renders each frame of a composition one layer at a time. This means that the memory 
requirement of each individual layer is more important than the duration of the composition or 
number of layers in the composition. The memory requirement for a composition is equivalent to the
memory requirement for the most memory-intensive single layer in the composition. For example, it 
generally takes less memory to render 30 layers at NTSC resolution than 2 layers at motion-picture 
film resolution.

The memory requirements of a layer increase in the following situations:
•      When you use larger image sizes.
•      When you add a mask in After Effects.
•      When the source of a layer is a composition. When a layer contains a composition, everything 
in that composition must be rendered before the next layer, so you also have to look for memory-
intensive layers within that composition.
•      When you apply certain plug-in effects or transfer options, especially those that combine the 
layer with other layers. For example, After Effects must set aside an additional memory buffer for 
the Set Channels effect.
•      When you apply certain output options, such as 3:2 pulldown, cropping, and stretching.

To help you calculate the memory required to render a composition, a table is included in PDF 
format on the After Effects CD-ROM. 
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Reducing a composition’s memory requirements

Once you identify the layers that use memory-intensive features, you can employ several strategies
to reduce the memory load:
•      Collapse transformations of nested compositions where possible. Collapsing transformations 
calculates the transform property changes once for all nested compositions instead of calculating at
every level in the composition hierarchy. This saves memory and improves performance. This 
technique cannot be used if the nested composition uses a mask or effect. See Techniques for 
working efficiently.
•      Prerender nested compositions. When you render nested compositions into movies, After 
Effects saves the time and memory required to calculate the changes in them. See Saving time by 
prerendering nested compositions.
•      Render compositions in draft mode. Although draft quality is not sufficient for final output, it does
produce a movie that is good enough for previewing your project. 
•      Reduce the number of changes you can undo with the Undo command by choosing File > 
Preferences > General and entering a lower number for Undo-able Actions. 
•      Free up RAM currently used to cache images by choosing Edit > Purge > Image Caches. You 
can also free up RAM currently used to store undo changes by choosing Edit > Purge > Undo. 

If insufficient-memory problems persist, try the following:
•      On Mac OS systems, disable unnecessary system extensions. This will also improve rendering 
performance.
•      On Mac OS systems, make sure you have allocated the maximum amount of available RAM to 
After Effects.
•      Estimate the amount of RAM required for the composition, and add additional RAM to your 
computer. See the table for calculating memory requirements for rendering, which is included in 
PDF format on the After Effects CD-ROM.
•      When a memory error message is displayed, temporarily remove effects from the project in 
order to finish rendering. 

Note: Although After Effects can run with RAM-extending utilities, such as RAM Doubler, use of such utilities 
will significantly slow the application and is not recommended. The use of virtual memory on Mac OS systems 
is also not recommended for the same reason. 
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Running After Effects on multiprocessors

When running on a Windows NT or Mac OS multiprocessor system, After Effects employs an MP 
plug-in to make use of the added processing power available. With this plug-in, a multiprocessing 
system previews and renders certain operations much faster than single processor systems. The 
MP plug-in accelerates movement, rotation, motion blur, blending modes, and other computer-
intensive operations, including plug-in effects such as Compound Arithmetic and Bevel Alpha. 

The degree to which the MP plug-in improves performance depends on the type of operation being 
performed. Hard disk-intensive operations are accelerated significantly. Memory-intensive 
operations are accelerated only minimally. Performance improvement is also dependent on system 
variables, such as the operating system, the type and number of processors, hard drive type, and 
compression. To determine the impact on rendering speed, render a project using the plug-in, move
the plug-in out of the Plug-ins folder, render the project again, and compare the rendering times. 

For a list of operations and effects that are accelerated by the MP plug-ins, see the Accelerated 
Functions file in PDF format on the After Effects CD-ROM. 

Separate versions of the MP plug-in are available for Windows NT systems and Mac OS systems. 

See also: 

Using the Windows MP plug-in (Windows NT only) 

Using the Mac OS MP plug-in 
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Using the Windows MP plug-in (Windows NT only)

The MThread.aex plug-in enhances After Effects performance on multiprocessor systems under 
Windows NT. The Adobe MP Accelerator plug-in is installed automatically during the After Effects 
installation process. 



Running After Effects on multiprocessors 

Using the Mac OS MP plug-in

The Adobe MP Accelerator plug-in enhances After Effects performance on Mac OS multiprocessor 
systems such as UMAX or Apple 9500. The Adobe MP Accelerator plug-in is installed automatically 
during the After Effects installation process.
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Running After Effects with Intel’s MMX

When running After Effects on a Windows system that supports Intel’s MMX technology, you can 
use the Mmxsup.aex plug-in to accelerate certain operations. On MMX-enhanced computers, this 
plug-in significantly accelerates most compositing operations. After Effects automatically uses this 
plug-in if it is in the After Effects\Plug-ins\Standard\Extensns folder and if the system supports MMX
technology. 



Rendering a Movie

When you have finished assembling and animating an After Effects composition, you can create 
many types of output from a single composition, including a compressed movie ready for videotape 
or an image sequence of the composition frames.

When you create output, the layers of a composition and each layer’s masks, effects, and 
properties are rendered frame by frame into one or more output files or, in the case of a sequence, 
into a series of consecutive files. The quality of output and the amount of time required to render 
depend on several factors that you control in the Render Queue window.

A movie is not always the last step in creating a project. You may decide to render a composition 
within a project to simplify structure and speed up previewing and final rendering. See Saving time 
by prerendering nested compositions. You may also want to render a movie before you finish 
building a composition in order to preview motion, although when sufficient RAM is available, using 
RAM Preview is easier. You can also preview motion using wireframe preview. For more information
on previewing motion using wireframes, see Setting preview options.

For faster rendering, create test movies with draft quality and low resolution. When you are ready to
create your final movie, change the resolution and quality to their best settings. You can also use 
proxies to speed up test rendering.

Movies created in After Effects can be rendered in QuickTime, Video for Windows (Windows only), 
PICT, BMP (Windows only), Adobe Photoshop, and ElectricImage formats, as well as any formats 
added by using a plug-in. 

You can render movies to use in a wide variety of ways, including the following:
•      To play on systems that have a movie player application (such as Apple MoviePlayer).
•      To record on videotape for playback on NTSC and PAL broadcast television equipment.
•      To record to 35-mm film for editing into a cinema release.
•      To play from CD-ROM.
•      To play on the World Wide Web.
•      To play as digital video.
•      To import into non-linear editing systems, such as Avid or Media 100, for final output.
•      To broadcast on HDTV.

Of course, to render to film or video, you must have the proper hardware for film or video transfer, 
or have access to a service bureau that can provide transfer services.

After Effects includes a render queue, in which you can specify items to be rendered, each with its 
own rendering settings. The render queue makes it possible to render a number of compositions 
unattended and in any order. You can render each composition into multiple output formats.

Before making your movie, keep in mind that an output file can take up many megabytes of disk 
space, and its size may be greater than the sum of its component layers. Be sure you have 
adequate space on your hard disk. For more information on assigning alternate storage locations, 
see Working with overflow volumes.

See also: 

Understanding rendering and compression 

Compressors and file formats 

Making a movie 

Using the Render Queue window 

Changing render settings 



Creating and using render settings templates 

Changing output module settings 

Creating and using output module templates 

Outputting to a DDR 

Rendering an item to multiple formats 

Choosing compression options 

Rendering checklist 

Exporting a single frame of a composition 

Creating a filmstrip file for editing in Photoshop 

Rendering frames as a sequence of still images 

Rendering cross-platform movies and stills 

Rendering single-frame sequences on multiple systems 

Working with overflow volumes 

Rendering movies at different sizes 

Creating low-resolution movies for testing motion 

Testing the field rendering order 
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Understanding rendering and compression

Rendering is a series of operations performed on your composition. First, each layer or nested 
composition is rendered with its masks, effects, and layer properties. Next, transfer modes are 
applied. Finally, the composited frame is sent to each output module to create the final movie. 

The output module specifies the compression scheme to be used in rendering the movie. The 
quality of the audio for a movie is determined by the settings in the output modules. 



Rendering a Movie 

Compressors and file formats

The codecs and file formats listed here are dependent on the computer you are using to run After 
Effects and on the hardware in your computer, such as video capture boards. These lists are 
accurate as of the release of After Effects 4.0. Note that new codecs and file formats are released 
frequently. 

See also: 

Compressors 

Video formats (supported by third-party extensions) 

Audio formats 

Audio formats (supported by third-party extensions) 

Digital file formats (video) 

Digital file formats (audio) 

Digital file formats (still image) 

Digital file formats (animation) 

Digital video compression 

Data compression schemes 



Compressors and file formats 

Compressors

•      Animation
•      Apple Graphics
•      Apple Video
•      ARGB
•      AVR (Avid Video Resolution)
•      CCIR 601
•      Cinepak
•      DV (NTSC and PAL)
•      GIF
•      H.263
•      JPEG (Photo)
•      MPEG
•      MJPEG (A and B)
•      Open DML Motion
•      Photoshop
•      Vector Animation
•      Windows RLE
•      YUV (4:1:1 and 4:2:2)
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Video formats (supported by third-party extensions)

•      ClearVideo
•      H.261
•      Indeo 3.2
•      Indeo Video 4.4
•      Interactive
•      TrueMotion
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Audio formats

•      DV
•      IEEE Floating Point (32-bit and 64-bit)
•      IMA 4:1 (ADPCM)
•      MACE 6:1
•      MAXI 3:1
•      PCM
•      uLaw 2:1
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Audio formats (supported by third-party extensions)

•      G.723
•      G.728
•      GSM 6.10 (Windows only)
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Digital file formats (video)

•      AVI
•      DV
•      MPEG
•      OMF
•      Open DML
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Digital file formats (audio)

•      AIFF/AIFC
•      AU
•      MPEG Layer 2
•      SoundDesigner II
•      Wave
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Digital file formats (still image)

•      BMP
•      GIF
•      JPEG/JFIF
•      MacPaint
•      Photoshop
•      PNG
•      QuickDraw Picture
•      QuickTime Image File
•      SGI
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Digital file formats (animation)

•      FLC/FLI
•      General MIDI
•      Karaoke MIDI
•      MIDI
•      PICS
•      3DMF
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Digital video compression

Compression is the process of removing or restructuring data to decrease file size. Digital video 
files are very large, requiring high data-transfer rates for playback. As you render an After Effects 
file, you can compress the data to reduce file size and facilitate movie playback. Data 
decompression takes place as the movie plays back. Compression and decompression are critical if
the movie is to be played on a CD-ROM drive. For more information on specifying compression 
settings, see Choosing compression options.

Many compression/decompression algorithms, called compressors or codecs, are available for 
compressing movies. Compressors can be software-based or hardware-based. Hardware 
compression is significantly faster and more effective than software compression. The compressors 
you choose may affect the visual quality of the movie and the facility with which it plays on a 
monitor or screen. Video for CD-ROM is normally compressed using software because it allows 
anyone with a CD-ROM drive to view movies without specialized hardware.

If your video board provides hardware compression, refer to the documentation that came with your
board for recommendations about which compressors to choose.
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Data compression schemes

Compressors use several schemes for removing or restructuring data to decrease the size of a file. 
Lossless compression schemes preserve the original data, ensuring that the image is the same 
after compression and decompression. Most lossless schemes use run-length encoding, a process 
that summarizes continuous regions of identical colors. This technique works well for electronically 
generated images whose colored areas are often composed of solid colors. In general, however, 
lossless compression is not very effective with digitized video and scanned images because these 
images usually contain few large areas of unchanging color.

Lossy compression schemes attempt to remove picture information that viewers are not likely to 
notice. Lossy compressors do not preserve original data; image information is lost and cannot be 
recovered. The amount of data lost depends on the degree of compression. Natural images, such 
as images of forests or of nature scenes, compress well with lossy compression schemes.

Note: Most video capture/playback hardware ships with custom compressors. If you use one of these systems,
use the hardware codec included for best playback performance. Be aware, however, that hardware 
compressors such as MJPEG use lossy compression. These compressors may cause artifacts such as 
blockiness or dithering effects, especially if high quality is not maintained during rendering. To achieve the best
quality when using hardware compressors, use a high data rate; ideally, you should use the same data rate (or
higher) and compression settings used when the footage was digitized. 
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Making a movie

Making a movie from your final composition can take a few minutes or many hours, depending on 
the composition’s frame size, quality, complexity, and compression method. When you place your 
composition into the render queue, it becomes a render item that uses the render settings assigned 
to it. An audio alert indicates that rendering is complete. You will not be able to work in After Effects 
while making a movie. 

To make a movie from a composition:

1    Save the project.

2    Review the Rendering checklist.

3    Drag the composition you want to render from the Project window to the Render Queue window.
Default render settings and output module templates are assigned automatically.

4    Click the underlined setting to the right of Render Settings to change the default render settings 
template, or choose a render settings template from the pop-up menu. See Changing render 
settings.

5    Choose a Log type from the Log menu.

6    Click the triangle to the left of the Output Module heading to change the default output module 
settings template, or choose a template from the Output Module pop-up menu. See Changing 
output module settings.

7    Click the underlined text after Output To to specify the name and location of the output file.

8    Select the Render option under the Render column heading. The status of the item changes to 
Queued.

9    Click the Render button.

Note: To view more information about the composition as it renders, click the triangle to the left of Show 
Details. To view details of a completed rendering, review the log file.

See also: 

Monitoring the rendering process 
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Monitoring the rendering process 

The Render Queue window displays both elapsed time and estimated time remaining for the 
composition being rendered. In addition, the Render Queue window displays the following 
information for all queued items:

Message Contains a status message. 

RAM Shows the memory available for the rendering process. 

Renders Started Lists which items in the queue have started rendering.

Total Time Elapsed Shows the time elapsed for all items that have been rendered or are currently 
being rendered. 

Log File Shows the name and location of the file to which rendering status messages are written. 
After Effects creates a log file, AE Log (date/time).txt. The path of the log file is displayed in the 
Render Queue window during rendering. Using the Log menu in the Render Queue window, you 
can select which information is written to the log file. 
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Using the Render Queue window

Use the Render Queue window to render all compositions, apply rendering and output module 
options, and obtain information on the rendering process. You can queue items to be rendered in 
any order.

All the settings for rendering a movie or sequence are included in the Render Queue window. When
you drag or place a composition into the Render Queue window, it becomes a render item. You can 
then queue, or line up, a number of items for rendering, so that After Effects can render multiple 
items unattended. The settings you change in the Render Queue window affect only rendering and 
do not change the original compositions.

There are two sections to the Render Queue window. The top section monitors an item that After 
Effects is rendering. In the bottom section, you can arrange a queue of items to be rendered and 
specify render settings and output modules for each one.

The Render Queue window A. Information on an item that is rendering B. Information on items queued for 
rendering, including settings you can change 

See also: 

Working in the Render Queue window 

Checking rendering status 
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Working in the Render Queue window

You can place multiple items in the render queue. When rendering is complete, each item remains 
in the queue with its status changed to Done until you remove it. You cannot render a completed 
item again, but you can duplicate it to create a new item in the queue with the same settings or with 
new settings you specify.

See also: 

To add compositions to the queue 

To remove render items from the render queue 

To rearrange render items in the render queue 

To pause rendering 

To stop rendering 

To rerender a render item with the same or different settings 



Working in the Render Queue window 

To add compositions to the queue:

Drag the composition from the Project window into the Render Queue window; or, when the 
composition is selected, choose Composition > Make Movie or press Control + Shift + / (Windows) 
or Command + Shift + / (Mac OS).

See also: 

To remove render items from the render queue 

To rearrange render items in the render queue 

To pause rendering 

To stop rendering 

To rerender a render item with the same or different settings 
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To remove render items from the render queue:

Select the composition in the Render Queue window and press Delete or choose Edit > Clear.

See also: 

To add compositions to the queue 

To rearrange render items in the render queue 

To pause rendering 

To stop rendering 

To rerender a render item with the same or different settings 



Working in the Render Queue window 

To rearrange render items in the render queue:

Drag the composition up or down the queue. A heavy black line appears between compositions, 
indicating where the composition will be placed.

See also: 

To add compositions to the queue 

To remove render items from the render queue 

To pause rendering 

To stop rendering 

To rerender a render item with the same or different settings 
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To pause rendering:

Click the Pause button.

Note: While the rendering process is paused, you will not be able to change settings or use After Effects in any
other way, but you can use other applications. 

See also: 

To add compositions to the queue 

To remove render items from the render queue 

To rearrange render items in the render queue 

To stop rendering 

To rerender a render item with the same or different settings 
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To stop rendering:

Click the Stop button.

Note: If you stop the rendering process, the item you stopped is assigned the status User Stopped, and a new 
item with the status of Needs Output is added to the render queue and set to resume rendering at the first 
unrendered frame.

See also: 

To add compositions to the queue 

To remove render items from the render queue 

To rearrange render items in the render queue 

To pause rendering 

To rerender a render item with the same or different settings 
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To rerender a render item with the same or different settings:

1    In the Render Queue window, select the render item.

2    Do one of the following:
•      To render with the same filename, choose Edit > Duplicate With Filename.
•      To render with a new filename, choose Edit > Duplicate, click the underlined Output To filename,
type a new filename, and then click Save.

3    Click Render.
 Close the 

Composition window to increase rendering speed. 

See also: 

To add compositions to the queue 

To remove render items from the render queue 

To rearrange render items in the render queue 

To pause rendering 

To stop rendering 



Using the Render Queue window 

Checking rendering status

The status line in the Render Queue window provides important information on the rendering 
process.

Render queue status options include the following:

Unqueued Indicates that the render item is listed in the Render Queue window but is not ready to 
render. Confirm that you have selected the desired render and output module settings and then 
select the Render option to queue the composition.

Queued Indicates that the composition is ready to render.

Needs Output Indicates that an output filename has not been specified for one of the output 
modules.

Failed Indicates that After Effects was unsuccessful in rendering the movie. Use a text editor to 
view the log file for specific information on why the rendering was unsuccessful.

User Stopped Indicates that the rendering process was stopped.

Done Indicates that the rendering process for the item is complete.
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Changing render settings

The Render Queue window displays the current render settings—either default settings or settings 
you made when you created the composition. You can change these settings or override the 
settings for all layers or compositions.

When you set the quality and resolution of a composition while editing, it does not necessarily 
change the quality or resolution of compositions nested within it. When rendering, you can have 
After Effects automatically adjust the settings of all layers and compositions in your final rendered 
item.

You can change render settings in the Render Queue window by clicking the underlined render 
settings template name or by selecting a render settings template from the Render Settings pop-up 
menu. Several basic templates are provided. You can use the Draft Settings template for reviewing 
motion or for testing. The Best Settings template works well for final rendering. To use the 
composition’s current settings, use the Current Settings template.

To change render settings, click the underlined settings name. These settings affect the composition
and all nested compositions. The Render Settings dialog box has the following options:

Quality    Determines the quality setting for all layers.

Resolution    Determines the size and clarity of the rendered composition, relative to the original 
composition dimensions.

Note: When rendering at reduced resolution, you should set the Quality option to Draft. Rendering at Best 
quality while reducing resolution does not produce a clear image and takes longer to render than rendering at 
draft quality.

Proxy Use    Determines whether proxies will be used when rendering. Current Settings uses the 
settings for each item.

Effects    Determines which effects are enabled for the rendered composition. You can choose to 
use current settings or to turn all effects on or off. If you select All On, all applied effects are used in 
a composition or a layer. If you select All Off, all effects for the composition are disabled. 

Frame Blending    Determines the frame blending settings for all layers. Use On for Checked 
Layers to render frame blending only for layers with frame blending enabled in the Switches panel 
in the Time Layout window, regardless of the composition’s Enable Frame Blending setting. See 
Using frame blending.

Field Render    Determines the field rendering technique used for the rendered composition. 
Choose Off if you are rendering for film or for display on a computer screen. For information on 
determining field order, see Field rendering considerations and Testing the field rendering order. For
general information on fields, see Interlaced and non-interlaced footage and Using interlaced video 
in After Effects.

3:2 Pulldown    Determines the phase of 3:2 pulldown introduction. See Introducing 3:2 pulldown.

Motion Blur    Determines when motion blur is applied. Use On for Checked Layers to render 
motion blur only for layers with motion blur enabled in the Switches panel in the Time Layout 
window, regardless of the composition’s Enable Motion Blur setting. See Using motion blur. Shutter 
angle affects the amount of Motion Blur. Select Use Pref Shutter Angle if you want After Effects to 
use the shutter angle selected in the General Preferences dialog box. Select Use This Shutter 
Angle to enter a different shutter angle. For more information on how shutter angle affects motion 
blur, see Adjusting the shutter angle for motion blur.

Use Storage Overflow    Determines whether rendering continues when the first assigned storage 
volume overflows. If not selected, rendering stops when the first assigned volume reaches capacity.
See Working with overflow volumes.



Time Span    Indicates how much of the composition is being rendered. To render the entire 
composition, choose Length Of Comp. To render only the part of your composition indicated by the 
work-area markers, choose Work Area Only. If you want to render a custom time span, choose 
Custom or simply click Set, type timecodes in Start, End, and Duration, and then click OK.

Frame Rate    Determines the sampling frame rate used to render the composition. Select Use 
Comp’s Frame Rate to use the frame rate specified in the Composition Settings dialog box, or 
select Use This Frame Rate to type in a different frame rate. The actual frame rate of the 
composition is unchanged.

Skip Existing Files    When this option is selected, you can rerender part of a sequence of files 
without wasting time on previously rendered frames. When rendering a sequence of files, After 
Effects locates files that are part of the current sequence, identifies the missing frames, and then 
renders only those frames, inserting them where they belong in the sequence. You can also use this
option to render single-frame sequences on multiple systems. 

Note: The current sequence must have the same name as the existing sequence, and the starting frame 
number, frame rate, and time span must be the same.

See also: 

Field rendering considerations 
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Field rendering considerations

When working with video footage, the two fields of a video frame should be separated so rendering 
can occur separately. This is necessary if there is any vertical scaling, translation, rotation, or 
effects applied to the image. If the field settings in the Interpret Footage are correct for the input 
footage and the field settings in the Render Settings dialog box are correct for the output device, 
you can mix footage items of different field orders in a composition. If either of these settings is 
incorrect, however, the frames will be in the correct order, but the field order may be reversed, 
resulting in jerky, unacceptable images. The Upper Field First option corresponds to Even Field 
First in an ElectricImage file. For more information, see Testing the field rendering order. For 
general information on fields, see Interlaced and non-interlaced footage and Using interlaced video 
in After Effects.
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Creating and using render settings templates

You can create templates that save commonly used render settings. These templates appear in the 
Render Settings pop-up menu in the Render Queue window. You can specify a default render 
settings template for movie rendering as well as a default template for creating a single frame. You 
can also save all render settings templates to a file to use on another computer.

See also: 

To set the default render settings templates 

To create a new render settings template 

To edit an existing render settings template 

To save all currently loaded templates to a file 

To load a saved template file 
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To set the default render settings templates:

1    Choose File > Templates > Render Settings.

2    To select a default template to be used when rendering movies, select a template from the 
Movie Default pop-up menu. To select a default template to be used when rendering a single frame,
select a template from the Frame Default pop-up menu.

See also: 

To create a new render settings template 

To edit an existing render settings template 

To save all currently loaded templates to a file 

To load a saved template file 
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To create a new render settings template:

1    Choose File > Templates > Render Settings.

2    Click New.

3    Enter the render settings you want, and then click OK.

4    Type a name for the new template and click OK.

See also: 

To set the default render settings templates 

To edit an existing render settings template 

To save all currently loaded templates to a file 

To load a saved template file 
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To edit an existing render settings template:

1    Choose File > Templates > Render Settings.

2    Select a template from the Settings Name pop-up menu.

3    Click Edit.

4    Change the settings you want, and then click OK.

5    Click OK to close the Render Settings Templates dialog box.

Note: Changes to an existing template do not affect render items that are already in the render queue.

See also: 

To set the default render settings templates 

To create a new render settings template 

To save all currently loaded templates to a file 

To load a saved template file 
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To save all currently loaded templates to a file:

1    Choose File > Templates > Render Settings.

2    Click Save.

3    Select a location for the file, type a filename, and then click OK.

4    Click OK to close the Render Settings Templates dialog box.

See also: 

To set the default render settings templates 

To create a new render settings template 

To edit an existing render settings template 

To load a saved template file 
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To load a saved template file:

1    Choose File > Templates > Render Settings.

2    Click Load.

3    Select the template file, and then click Open.

4    Click OK to close the Render Settings Templates dialog box.

See also: 

To set the default render settings templates 

To create a new render settings template 

To edit an existing render settings template 

To save all currently loaded templates to a file 
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Changing output module settings

An output module includes options for the specific video and audio output format to which you are 
rendering the movie, as well as video compression options. The Render Queue window shows the 
current settings for an output module.

You can change output module settings from the Render Queue window by clicking the underlined 
output module template name or by selecting a template from the Output Module pop-up menu. 
Several templates are provided, including the Lossless template for creating movies for transfer to 
video or film and the Millions+PICT template for creating PICT sequences with an alpha channel.

Note: Before rendering, it is important to check the Audio Output settings in the Output Module Settings dialog 
box to ensure that they are correct. If your project includes audio, be sure that Audio Output is selected. If your 
project does not include audio, Audio Output should not be selected; this ensures that the size of the rendered 
file is not increased needlessly. 

You can specify the following settings in the Output Module Settings dialog box:

Format    Specifies the format for the output file or sequence of files. File formats include 
QuickTime, Video for Windows, PICT Sequence, ElectricImage, Photoshop, and file types available 
from plug-in file format modules.

Import Into Project When Done    When selected, imports the rendered movie into the project. Use
this option to import prerendered compositions back into a project. 

Format Options    Opens a dialog box with format-specific information. For example, if QuickTime 
is your format, Format Options opens a QuickTime Compression dialog box. For information on 
compression settings, see Choosing compression options.

Channels    Specifies the output channels contained in the rendered movie. After Effects creates a 
movie with an alpha channel if you choose RGB+Alpha, implying a depth of Millions of Colors+.

Note: All files created with a color depth of Millions of Colors+ have labeled alpha channels; information 
describing the alpha channel is stored in the file. Therefore, you do not have to specify an alpha interpretation 
each time you import an item created in After Effects.

Depth    Specifies the color depth of the rendered movie. You can choose from color or grayscale 
options. Note that certain formats may limit depth and color settings.

Color    Specifies how colors are created with the alpha channel. Choose from either Premultiplied 
(With Black) or Straight (Unmatted). For information on alpha channels, see Importing footage 
containing an alpha channel.

Stretch    Specifies the size of your rendered movie. Select Lock Aspect To if you want to retain the 
existing frame aspect ratio when stretching the frame size. Select Low Stretch Quality when 
rendering tests, and select High Stretch Quality when rendering a final movie. 

Crop    Used to trim or add pixels to the edges of the rendered movie. You can specify the number 
of pixels to be added or subtracted from the top, left, bottom, and right sides of the movie. Enter 
positive values to crop, and enter negative values to add pixels.



Note: By adding one pixel to the top of a rendered movie with field rendering, you can change the field 
rendering order. See Making a movie smaller than the rendered composition.

Audio Output    Specifies the sample rate (from 5.564 to 96.000 KHz), sample depth (8 Bit or 16 
Bit), and playback format (Mono or Stereo). Choose a sample rate that corresponds to the 
capability of the output format. A sampling rate of 22.050 KHz is a standard for movies on most 
computers; 44.100 KHz is standard for compact disc audio; and 48 KHz is standard for digital audio
tape (DAT). Choose 8- or 16-bit sample depth, depending on the expected output format of the 
movie. Choose an 8-bit sample depth for playback on the computer, and a 16-bit sample depth for 
compact disc and digital audio playback or for hardware that supports 16-bit playback.

See also: 

Introducing 3:2 pulldown 
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Introducing 3:2 pulldown

If you are creating output for motion-picture film or if you want to simulate a film look for animation, 
use 3:2 pulldown. Footage items that were originally film transferred to video and had 3:2 pulldown 
removed when imported into After Effects can be rendered back to video with 3:2 pulldown 
reintroduced. You can set the introduction of 3:2 pulldown using any of five different phases. For 
more information on 3:2 pulldown, see Removing 3:2 pulldown from video transferred from film.

Note: It is important to match the phase of a segment that had 3:2 pulldown removed if it will be edited back 
into the video footage it came from.

To introduce 3:2 pulldown:

1    In the Render Queue window, select the render item and then click the underlined Render 
Settings name.

2    For Field Render, choose a field order.

3    For 3:2 Pulldown, select a phase.

4    Select other settings as appropriate, and then render.
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Creating and using output module templates

You can create templates that save commonly used output module settings. These templates 
appear in the Output Module pop-up menu in the Render Queue window. You can specify a default 
output module template for movie rendering and another for creating a single frame. You can also 
save all output module settings templates to a single file to use on another computer.

See also: 

To set the default output module template 

To create a new output module template 

To edit an existing output module template 

To save all currently loaded output module templates to a file 

To load a saved output module template file 
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To set the default output module template:

1    Choose File > Templates > Output Module.

2    To select a default template to be used when creating movies, select a template for Movie 
Default. To select a default template to be used when creating a single frame, select a template for 
Frame Default.

See also: 

To create a new output module template 

To edit an existing output module template 

To save all currently loaded output module templates to a file 

To load a saved output module template file 
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To create a new output module template:

1    Choose File > Templates > Output Module.

2    Click New.

3    Enter the output module settings you want, and then click OK.

4    Type a name for the new template, and then click OK.

See also: 

To set the default output module template 

To edit an existing output module template 

To save all currently loaded output module templates to a file 

To load a saved output module template file 
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To edit an existing output module template:

1    Choose File > Templates > Output Module.

2    Select a template from the Settings Name menu.

3    Click Edit.

4    Change the settings you want, and then click OK.

5    Click OK to close the Output Module Templates dialog box.

Note: Changes to an existing template do not affect render items that are already in the render queue.

See also: 

To set the default output module template 

To create a new output module template 

To save all currently loaded output module templates to a file 

To load a saved output module template file 
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To save all currently loaded output module templates to a file:

1    Choose File > Templates > Output Module.

2    Click Save.

3    Select a location for the file, type a filename, and then click OK.

4    Click OK to close the Output Module Templates dialog box.

See also: 

To set the default output module template 

To create a new output module template 

To edit an existing output module template 

To load a saved output module template file 



Creating and using output module templates 

To load a saved output module template file:

1    Choose File > Templates > Output Module.

2    Click Load.

3    Select the template file, and then click Open.

4    Click OK to close the Output Module Templates dialog box.

See also: 

To set the default output module template 

To create a new output module template 

To edit an existing output module template 

To save all currently loaded output module templates to a file 
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Outputting to a DDR

Digital disk recorders (DDRs) can be integrated into the Adobe After Effects production environment
by using third-party plug-in modules. 

See also: 

About DDRs 

The Àccom DDR plug-in (Windows only) 

Transferring DDR footage to a hard disk 

Rendering a composition to a DDR 
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About DDRs

Video images and sequences on DDRs can be saved on a hard disk for use in After Effects. 
Similarly, After Effects compositions can be rendered directly to DDRs. Device control plug-ins to 
support capturing from DDRs and rendering to DDRs are available from a variety of manufacturers. 



Outputting to a DDR 

The Àccom DDR plug-in (Windows only)

The Àccom DDR device control plug-in, for use with Windows 98 and Windows NT systems, is 
included on the After Effects CD-ROM. For instructions on using this DDR plug-in, see the Àccom 
DDR document in PDF format in the Àccom DDR folder on the CD-ROM.

A working Ethernet connection between the computer and the DDR is required for controlling your 
DDR via Ethernet. Adobe does not provide technical support for general network configuration; 
consult a local network administrator and the computer or DDR provider. 

SCSI control of the DDR usually requires no additional configuration. Ensure that the SCSI is 
properly terminated. After Effects will automatically detect all properly configured, cabled, and 
terminated DDRs on the SCSI bus when SCSI control is selected. Make sure that the SCSI ID 
number of the DDR is set properly; no other device on your SCSI chain can share the same ID 
number as the DDR. 
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Transferring DDR footage to a hard disk

As an alternative to working with DDR-based footage while connected to the DDR, you can transfer 
the desired frames from the DDR and save them to your hard disk. Once saved to the hard disk, the
footage items can be used as any other file.

The method for transferring frames from the DDR to the hard disk is essentially the same as 
rendering a composition to the hard disk. In this case, the composition is a single footage item that 
has been placed in the Composition window from the Project window.

To save a sequence of frames from the DDR:

1    Import the desired DDR footage into the Project window. 

2    Select the footage item in the Project window.

3    Perform any desired Interpret Footage modifications, such as separating fields or applying 3:2 
pulldown. Be sure that all frame rate settings are to your specifications. For most operations, set 
frame rate to 29.97 fps for NTSC and 25 fps for PAL.

4    Place the footage in the Composition window.

5    Render the composition to your hard disk. 
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Rendering a composition to a DDR

Rendering an After Effects composition to a DDR is virtually the same as rendering a composition to
your hard disk. The principal difference is that, instead of selecting an output destination as a file 
destination on your hard disk, you select the timecode location of the DDR where you want the 
output footage to begin. For information on using your DDR with After Effects, refer to your DDR 
plug-in documentation.
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Rendering an item to multiple formats

You can apply more than one output module to each render item in the queue. This is useful when 
you want to make more than one version of a movie. For example, you can automate the creation 
of a movie and its alpha matte, or you can create high-resolution and low-resolution versions of a 
movie.

When you apply more than one output module to a render item, After Effects renders to the various 
output formats simultaneously, saving you time. 

To apply an additional output module:

1    In the Render Queue window, select an item.

2    Choose Composition > Add Output Module.
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Choosing compression options

Compression is an essential operation to reduce the data size of movies that would otherwise be so
large as to prohibit effective playback. When compressing a movie file, you can fine-tune it for the 
best-quality playback on a computer, on a video playback device, or from a CD-ROM drive.

QuickTime and Video for Windows have several built-in software-based compression algorithms. 
The QuickTime compressors listed here are compatible on both Windows and Mac OS systems. 

See also: 

QuickTime compressors 

Setting QuickTime compression options 

To specify QuickTime compression settings 

Video for Windows compression 

To specify Video for Windows compression settings 
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QuickTime compressors

The same types of compressors are available for QuickTime regardless of whether you are running 
After Effects on a Windows system or a Mac OS system. Compressors available for QuickTime are 
Animation, BMP, Cinepak, Component Video, DV, Graphics, H.263, Intel Indeo, Microsoft Video, 
Motion JPEG A/B, Photo JPEG, Planar RGB, and Sorenson Video. Choose one of these 
compressors based on the type of original footage you have and what you are using it for:

Animation compressor    Use for any output, regardless of source, that will not be played back on 
a computer. The Animation compressor is a lossless compressor that employs a compression 
algorithm developed by Apple based on run-length encoding techniques. It is the best compressor 
to use for highest quality output. The Animation compressor supports both spatial and temporal 
compression. This compressor allows a depth setting of Millions of Colors+, which allows you to 
output an alpha channel with your movie.

Cinepak compressor    Use when compressing 16-bit and 24-bit video for Web-based movies, 
playback from CD-ROM, or for desktop presentations. For best results, use the Cinepak 
compressor on raw source data that has not been previously compressed with a highly lossy 
compressor. Note that this is a slow compression method. With Cinepak, decompression is much 
faster than compression, and the data rate for playback can be defined by the user. However, you 
cannot save an alpha channel using the Cinepak compressor. 

To create smaller file sizes, select other compressors, such as MJPEG and Sorenson Video. Other 
compressors tend to give results that are less than highest quality, although they do produce 
smaller file sizes. You should experiment before using them for a final project.

MJPEG-A, MJPEG-B Use when compressing movies that will be edited on a non-linear editing 
system. Although MJPEG is a lossy codec, image quality is good when the Best quality setting is 
used for rendering. Unlike JPEG, the MJPEG codecs provide only spatial compression. For best 
results, use the MJPEG compressors at moderate data rates. MJPEG can produce better results 
than Cinepak at typical World Wide Web data rates (usually 5 to 20KBps). You should use MJPEG 
for playback from CD or at higher data rates only with assistance from a capture card. Both MJPEG
codecs include built-in support for capture cards. 

Sorenson Video Use for producing movies played back from CD or the World Wide Web at high 
quality. Sorenson can provide higher image quality than Cinepak, at significantly lower data rates, 
producing smaller files. Using Sorenson, you can store up to four times as much data on a disc as 
you can with Cinepak. For best results, keep data rates lower than you would with Cinepak. For 
playback from CD, a data rate of 50 to 100 KBps is reasonable. For smooth playback of movies 
larger than 320-by-240 or at data rates greater than 100KBps, high performance computers are 
necessary. In general, playback from CD requires faster computers than playback using Cinepak. 

None    Use for a depth setting of Millions of Colors+ when an alpha channel is required. 
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Setting QuickTime compression options

Choices you make in the Compression Settings dialog box require trade-offs between file size and 
movie quality. The higher the visual quality of your movie, the larger the file size.

Quality The Quality control specifies the spatial compression of the movie, which compresses the 
data in each frame of a composition. Higher quality produces better image quality, but results in a 
bigger movie file. Lower quality results in a blocky and slightly blurred image (although it is still 
recognizable) and a smaller, more compressed movie file. Note that this quality is unrelated to each
layer’s quality setting in After Effects.

Key Frame Every In QuickTime terminology, the term key frames is different from the change-over-
time keyframes placed in the After Effects Time Layout window. In QuickTime, key frames are 
frames that occur at regular intervals in the movie. During compression they are stored as complete
frames. Each intermediate frame that separates them is compared to the previous frame, and only 
changed data is stored. This greatly reduces movie size. Shorter intervals between key frames 
enables faster seeking and reverse playback, but can significantly increase the size of the file.
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To specify QuickTime compression settings:

1    In the Render Queue window, click the underlined name of the output module.

2    For Format, choose QuickTime.

3    Click Format Options in the Video Output section.

4    In the Compression Settings dialog box, choose a compressor from the first menu in the 
Compressor section.

Note: Set the color depth in the Compression Settings dialog box instead of in the Output Module Settings 
dialog box. This ensures that Non-Adobe plug-ins receive color depth information from After Effects. See step 
8. 

5    Select a Quality level from Least to Best.

Note (Mac OS Only): If you intend to use key frames in the movie, hold down Option and adjust the Quality 
slider to control the temporal compression of the movie. Temporal compression compresses a movie by 
comparing successive frames and keeping only changed data. High temporal quality maintains a smoothness 
of motion. Low temporal quality tends to produce a jerkiness of motion because a pixel doesn’t change unless 
the difference between frames is great.

6    If you want the smallest possible files, and your compressor choice allows for a key frame rate, 
select the box and enter a number in the Key Frame Every box. Generally, you should enter a 
number equal to the frame rate. For example, if you set a frame rate of 30 fps, type 30 in the Key 
Frame box. This sets one key frame every 30 frames of your movie.

Note: If you are going to use the resulting movie in another After Effects composition, type a small value 
(under 5) in the Key Frame Every box or deselect the Key Frame Every option. The presence of key frames 
greatly increases the memory required to edit and render a movie.

7    Click OK.

8    If your compressor choice supports different image color depths, choose the appropriate color 
depth in the Output Module Settings dialog box:
•      Choose Millions of Colors+ if you want 24-bit color quality and you want your composition 
background to be transparent (to include an alpha channel). The composition’s background color is 
disregarded. Only Animation and None can support the Millions of Colors+ color depth.
•      Choose Millions of Colors if you want 24-bit color quality, but want to include your composition 
background color (no alpha channel).

Note: Color depth settings of Thousands Of Colors or lower may cause banding and dithered images. 

9    Choose other options in the Output Module Settings dialog box, as described in Changing 
output module settings. Then click OK.

See also: 

QuickTime compressors 

Setting QuickTime compression options 

Video for Windows compression 

To specify Video for Windows compression settings 
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Video for Windows compression

Compressors available for Video for Windows are Microsoft Video 1, Cinepak, Microsoft RLE, and 
Intel Video. Choose one of these compressors based on the type of original images you have and 
the purpose of the rendered movie:

Cinepak Use when compressing 16-bit and 24-bit video for playback from CD or for desktop 
presentations. For best results, use the Cinepak compressor on raw source data that has not been 
previously compressed with a highly lossy compressor. Note that this is a slow compression 
method. With Cinepak, decompression is much faster than compression, and the data rate for 
playback can be defined by the user. However, you cannot save an alpha channel using the 
Cinepak compressor. 

Microsoft RLE Use for lossless compression limited to 256 colors.

Intel Indeo/Microsoft Video Use when compressing video for playback from CD.

Full Frames (Uncompressed) Use for a depth setting of Millions of Colors+ when an alpha 
channel is required. 
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To specify Video for Windows compression settings:

1    In the Render Queue window, click the underlined name of the output module.

2    Choose Video for Windows from the Format menu.

3    Click Format Options in the Video Output section.

4    In the Video Compression dialog box, choose a compressor from the first menu in the 
Compressor section.

5    Select a Compression Quality level.

6    If you selected either Cinepak or Microsoft Video in step 4, click the Configure button to set other
options:
•      For Cinepak, choose whether the movie is compressed to color or to black and white.
•      For Microsoft Video, choose a level for the temporal compression quality of the movie. Temporal
compression compresses a movie by comparing successive frames and keeping only changed 
data. High temporal quality maintains a smoothness of motion. Lower temporal quality tends to 
produce a jerkiness of motion because a pixel doesn’t change unless the difference between 
frames is great.

7    If you want the smallest possible files, and your compressor choice allows for a key frame rate, 
select the Key Frame Every option and enter a number of frames. Generally, you should enter a 
number equal to the frame rate. For example, if you set a frame rate of 30 fps, type 30 in the Key 
Frame box. This sets one key frame every 30 frames of your movie.

Note: If you are going to use the resulting movie in another After Effects composition, type a small value 
(under 5) in the Key Frame Every field or deselect the Key Frame Every option. The presence of key frames 
greatly increases the memory required to edit and render a movie.

8    Click OK.

9    If your compressor choice supports different image color depths, choose the appropriate color 
depth in Output Module Settings dialog box. See Setting QuickTime compression options.

10    Choose other options in the Output Module Settings dialog box, as described in Changing 
output module settings. Then click OK.

See also: 

QuickTime compressors 

Setting QuickTime compression options 

To specify QuickTime compression settings 

Video for Windows compression 



Rendering a Movie 

Rendering checklist

Rendering a high-quality movie can take many hours, so it’s a good idea to minimize the number of 
times you have to render a movie. You can prevent potential complications and mistakes by making
sure your project and your hardware are appropriate for the final movie.

See also: 

Workflow checklist 

Composition checklist 
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Workflow checklist

Use this checklist before you render to ensure that you have satisfied all rendering requirements. 

q Save your project Always save your project before rendering.

q Disk space Have enough disk space available for the final movie. Movies can be many 
megabytes in size, depending on the project and the compression method. After Effects warns you 
during the rendering if too little space is available. You can pause rendering to create more space, 
and you can have After Effects store your movie across several drives or partitions. At the time of 
publication, QuickTime files are limited to 2 MB, and Video for Windows files are limited to 1 MB. 
For more information on storage overflow, see Working with overflow volumes.

q Source footage Be sure you have all source footage items available. After Effects depends on 
locating the original footage files somewhere on your hard disk. The files don’t have to be in their 
original folder locations, but if they have been removed, After Effects warns you that it cannot 
complete the rendering process. This will occur, for example, if you use proxy items for creating a 
composition and you remove the original items before rendering.

q Output requirements Know your final output requirements. If you are creating a movie that will 
be transferred to videotape, determine the field rendering order used by the videotape equipment: 
Upper Field First or Lower Field First. After Effects can render the movie using either method, but if 
you use the wrong method, your movie will look distorted. For a simple test to determine field 
rendering order, see Testing the field rendering order.

Note: You do not have to be concerned about the field order if your movie is meant for film or desktop 
computer presentations, or if you are rendering a test movie.
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Composition checklist

Use this checklist to ensure that you have the information about your composition that you need to 
set up the rendering process. 

q Quality settings Be sure you know which quality settings are used in the composition. In 
general, use the best quality settings for each layer when creating your final movie. If you want to 
retain the different layer quality settings in the final movie, review these settings in the Time Layout 
window. After Effects gives you the choice of retaining these quality settings in the final movie or 
replacing them with a single quality setting.

q Resolution settings Know the correct resolution setting. You can set one overall resolution for 
your final movie so you do not have to go to each nested composition and change its resolution 
setting. Resolution affects the dimensions of the image sent to each output module.

q Effects on/off Look over your composition’s Time Layout window. If the Effect switch is disabled 
for a layer, any effects applied to the layer will not appear in the final movie, unless you choose to 
enable all effects in the Render Settings dialog box. If you want to choose which layers keep their 
effects in the final movie, select the appropriate switches. Also review the switches in any nested 
compositions. See Applying and controlling effects. Review the Effects options in the Render 
Settings dialog box. See Changing render settings.

q Composition background color Decide whether you want to use the composition background 
color in the final movie. If you do, make sure the color is correct. If you choose a color depth other 
than Millions of Colors+ from the options in the Output Module Settings dialog box, the background 
is included with the movie as a solid area, and the background color appears in the movie as it does
in the composition. If you use a color depth of Millions of Colors+, After Effects renders the 
background transparent. See Creating a new solid layer.

q Work area Set work-area markers to the correct time span. If you plan to render the composition 
time span between the work-area markers, review that time span. You can save disk space and 
time by rendering only a portion of a composition. You can also specify a custom time span in the 
Render Settings dialog box.
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Exporting a single frame of a composition

You can save a single frame from a composition to any output format or as an Adobe Photoshop file
with layers intact. One frame of the composition is rendered at the current time as set in the 
Composition window. This is useful for editing files in Photoshop or creating a proxy. 

You can preserve the individual layers of a composition and save a frame of the composition as an 
Adobe Photoshop file. This makes it possible to use footage imported into After Effects as images in
Adobe Photoshop. Preserving layers is also useful if you want to use a composition frame as a 
source for both print and dynamic media.

To export one frame of a composition:

1    In the Composition window, display the frame you want to export.

2    Choose Composition > Save Frame As > File.

3    Type a filename and click OK.

4    The Render Queue window is displayed. Adjust settings if necessary, and then click Render.

To export a single composition frame as an Adobe Photoshop file with layers:

1    In the Composition window, display the frame you want to export.

2    Choose Composition > Save Frame As > Photoshop Layers.

3    Type a filename and click OK.
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Creating a filmstrip file for editing in Photoshop

If you need to edit footage in Photoshop, you can use the Filmstrip format, which was created for 
this purpose. This format is useful when you want to paint directly on video frames, a process 
known as rotoscoping. You can render part or all of a composition as a filmstrip. A filmstrip is a 
single file that contains all the frames of a composition or portion of a composition. Because video 
compression is not used in creating a filmstrip file, these files can be large. If your computer doesn’t
have enough memory to enable Photoshop to load your filmstrip file, you can break it into any 
number of smaller files by setting the work area to a different portion of the composition before 
rendering each portion. 

A filmstrip opens in Photoshop as a series of frames in a column, with each frame labeled by 
number, reel name, and timecode. If the column created by the filmstrip frames is more than 30,000
pixels tall, the frames continue in a second column. 30,000 pixels is the maximum image height 
Photoshop can handle. The number of frames displayed depends on the duration of the footage 
and the frame rate selected when you render the filmstrip. 

When editing a filmstrip in Photoshop, use the following guidelines for best results:
•      You can paint on the gray lines dividing the frames of the filmstrip without damaging the file. 
After Effects will display only the part of each frame that lies within the frame border. 
•      You can edit the red, green, blue, and alpha channels in the filmstrip file. Use only channel #4 
as the alpha channel; a filmstrip file requires this convention. 
•      Do not resize or crop the filmstrip. 
•      Flatten any layers you add in Photoshop.

Note: If you simply want to export a single frame, you don’t need to use the Filmstrip format. See Exporting a 
single frame of a composition.

To render a composition as a filmstrip:

1    Be sure the composition you want to render is active. If you want to render only part of the 
composition, set the work-area markers to define the part you want to render. 

2    Choose Composition > Make Movie.

3    Type a filename.

4    In the Render Queue window, click the underlined Output Module template name.

5    Choose Filmstrip from the Format pop-up menu. Specify the rest of the settings you want and 
click OK.

6    In the Render Queue window, click Render.
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Rendering frames as a sequence of still images

Movies are the type of output most useful for easy previewing. However, a sequence of still images 
from a composition can be used for movie-making and desktop presentations. You can use a 
sequence of stills in the following ways:
•      Transfer frames to film using a film recorder.
•      Create still images for high-end video systems.
•      Create still images and use them in a presentation.
•      Select images for publishing or creating story boards.
•      Export source images for a graphics program in which the images can be edited or retouched 
and imported back into After Effects as footage items.

To export a range of frames as a sequence of stills:

1    Choose Composition > Make Movie.

2    Type a filename.

Note: When rendering frames on a Mac OS system for use on a Windows system, the filename must be in this
format: filename[###].tga. As each frame is rendered and a filename created for it, After Effects replaces the 
[###] portion of the name with a number indicating the order of the frame in the sequence. 

3    In the Render Queue window, click the underlined Output Module template name.

4    Choose one of the sequence formats from the Format pop-up menu. Specify the rest of the 
settings you want and click OK.

5    In the Render Queue window, click Render.
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Rendering cross-platform movies and stills

Because the Windows and UNIX platforms play only flattened movies (sometimes called single-fork
movies), files created in After Effects for Mac OS systems and intended for use across platforms 
must be rendered as flattened files. Earlier versions of After Effects included a plug-in for flattening 
movies. After Effects 4.0 creates flattened movies automatically, and the Cross Platform plug-in 
available for earlier versions is no longer needed. 

Files intended for use across platforms should have a filename of eight characters or less with a file
extension of three characters or less. For more information on project hierarchy, file naming, and 
other related topics, see Considerations for cross-platform projects.

Note: Make sure the codec you use to render a QuickTime movie is available on the platforms you want to 
support; otherwise the movie will not play. 
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Rendering single-frame sequences on multiple systems

To significantly decrease the time required for rendering a single-frame sequence, you can use 
multiple systems and multiple copies of After Effects to render a project across a network. 
Rendering in each copy of After Effects starts at approximately the same time. By specifying that 
each copy skip existing frames or frames in progress, multiple systems can render the project 
simultaneously, writing the single-frame sequence to a single folder.

You can use multiple systems to render only single-frame sequences; you cannot use multiple 
systems to render movies or render projects to DDRs. You can use any combination of Windows or 
Mac OS systems. 

Note: If you are rendering a project using Production Bundle effects on multiple systems, each system must be
running the Production Bundle version of After Effects. 

See also: 

To render a single-frame sequence with multiple systems 

Network performance 

Tracking discrepancies and load-sharing (Mac OS only) 
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To render a single-frame sequence with multiple systems:

1    Install After Effects on each system that will be rendering the project. Make sure that you set the 
same After Effects preferences on each system. Also make sure that the same fonts are installed 
on each system.

Note: Do not share plug-ins across a network. Make sure that you have a copy of the plug-ins folder on each 
system that is running After Effects. When using third-party plug-ins, also be sure that the same plug-ins are 
available on all systems and that you have sufficient licenses for the plug-ins. 

2    Open the project on one system, and then choose Composition > Add to Render Queue. 

3    In the Render Queue window, specify the Skip Existing Files option in the Render Settings 
section. You may need to first deselect the Use Storage Overflow option. The Skip Existing Files 
option ensures that multiple systems do not render the same frames.

4    In the Render Queue window, specify a single-frame sequence in the Output Module section 
and specify a folder in the Output To section. This folder must be available for all the systems that 
are rendering.

5    Save the project on the system where you opened it in step 2.

6    On each system that will be rendering, open and save the project. This ensures that After Effects
records the new relative paths to each system in the following step.

7    Unless the network can handle large file transfers rapidly, copy the project file and all its source 
footage onto each system that will be rendering.

8    Open the Render Queue window on each system and click Render. You do not need to start 
rendering on each system simultaneously, but to ensure equal workloads, you should start them at 
approximately the same time. As each system finishes rendering a frame, After Effects searches the
Output folder for the next unrendered frame and starts rendering again.

9    You can stop and start any system at any time. However, if you stop a system without starting it 
again, the frame that it was rendering may not be finished. If one or more systems stop during 
rendering, starting any one system will ensure that all frames in the sequence get rendered.

See also: 

Network performance 

Tracking discrepancies and load-sharing (Mac OS only) 
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Network performance

There is no limit to the number of systems you can use for rendering; in general, the more systems, 
the faster the rendering. However, if too many systems are used across a busy network, network 
traffic may be significant enough to slow down the entire process. You can detect network 
slowdown by observing the time spent in the Compressing & Writing stage in the Show Details 
section of the Render Queue window.

You should use multiple-system rendering with an Ethernet or faster network. With Mac OS 
systems, the LocalTalk network is not recommended. If you are using Apple File Sharing to serve a 
network volume, you should not use that system to render. Rendering on the server slows down 
client access and can significantly reduce performance.
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Tracking discrepancies and load-sharing (Mac OS only)

With After Effects for Mac OS, you can use Finder labels to track discrepancies and load-sharing 
when rendering with multiple systems. When the After Effects application is given a Finder label, it 
renders each frame with the same label. If you give each copy of After Effects a different label, you 
can track single frames to a particular copy of the application.

For example, if you discover a discrepancy in a certain frame created with network rendering, you 
can adjust options in the copy of After Effects that rendered the frame. You can also view the 
difference in rendering speed between the networked systems by counting the number of frames for
each label, and then make any necessary adjustments to balance the workload. 

To give the After Effects program a Finder label:

1    Quit After Effects.

2    Select the After Effects icon, and then choose a label from the Finder’s Label menu.
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Working with overflow volumes

A situation in which After Effects reaches a disk space limit while rendering a composition is called 
an overflow. You specify this limit for Minimum Diskspace Before Overflowing in the Output 
Preferences dialog box. When After Effects overflows a volume, the resulting files go into a folder 
on the root of the next volume in the After Effects Overflows list. Overflow volumes let you specify 
multiple volumes to which rendered compositions can be directed.

Overflow behavior occurs in the following instances:
•      A drive fills up. In this case, After Effects tries the next drive on the Preferences list. 
•      You have more than a specified number of sequence files in a folder. In this case, After Effects 
makes a new folder next to the current one and continues rendering images to the new folder.
•      A single movie file is larger than a specified size. In this case, After Effects starts a new file next 
to the current one.

Note: It is important to look at the log file after rendering; the log file reports when a render overflows.

To enter overflow settings:

1    Choose File > Preferences > Output.

2    To set overflow volumes, choose the volumes you want from the Volume menus under Make 
Movie Contingencies.

3    To set a maximum number of files, select the Segment Sequences At option and type a 
maximum number of files.

4    To set a maximum movie file size before creating an overflow, select the Segment Movie Files At
option and enter a maximum file size. Then click OK.
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Rendering movies at different sizes

You can create output in sizes other than the size of your rendered composition. For example, you 
can create a full-sized movie for recording onto videotape and a smaller movie for use on CD-ROM 
or in an on-screen presentation.

See also: 

Making a movie smaller than the rendered composition 

Making a movie larger than the rendered composition 
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Making a movie smaller than the rendered composition

Several methods exist for producing a reduced-size movie, each with trade-offs between speed and
quality.

You can create a movie smaller than the rendered composition by using these methods:
•      Create a new composition at the smaller dimensions, and nest the large composition inside it. 
This method renders faster than stretching in the Output Module Settings and offers good image 
quality. For example, if you create a 640-by-480 composition, you can place it in a 320-by-240 
composition. You can then scale the composition to fit the new smaller composition size, and then 
collapse transformations by choosing Layer > Switches > Collapse. The resulting composition 
rendered at full resolution and best quality will have excellent image quality, better than if you had 
rendered using a reduced resolution.
•      Stretch the movie. This method produces the highest quality reduced-size movie but is slower 
than nesting a composition. For example, if you create a 640-by-480 composition and render it at 
full resolution, you can set the stretch value in your Output Module Settings to 50% to create a 320-
by-240 movie. For a composition rendered at full resolution, the image quality is excellent when the 
Stretch Quality is set to High.

Note: Do not use stretching to change the vertical dimensions of a movie when field rendering is on. Stretching
vertically mixes the field order, which distorts motion. Use either cropping or composition nesting if you need to
vertically resize a field-rendered movie.
•      Crop the movie. This method is ideal for reducing the size of a movie by a few pixels. To reduce 
a movie by cropping, use the Crop options in the Output Module Settings dialog box. Remember 
that cropping cuts off part of the movie so that objects centered in the composition may not appear 
centered unless the movie is cropped evenly on opposite edges.

Note: Cropping an odd number of pixels from the top of a field-rendered movie reverses the field order. For 
example, if you crop one row of pixels from the top of a movie with Upper Field First field rendering, the field 
rendering order then becomes Lower Field First. Remember that if you crop pixels from the top of the movie, 
you need to add to the bottom row of the movie to maintain the original size. If you are willing to lose one scan 
line, this gives you a way to output two movies from one render, each with a different field order. See Using 
interlaced video in After Effects and Field rendering considerations.
•      Render the movie at a reduced resolution. This method is the fastest way to created reduced-
size movies. For example, if you create a 640-by-480 composition, you can set the composition 
resolution to one half, reducing the size of the rendered composition to 320-by-240. You can then 
create movies or images at this size. Note that the reduced resolution reduces the sharpness of the 
image and is best used for creating preview or draft movies.

Note: When rendering at reduced resolution, you should set the quality of the composition to Draft. Rendering 
at Best quality while reducing resolution does not produce a clean image and takes longer to render than 
rendering at Draft quality.
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Making a movie larger than the rendered composition

Increasing the size of the output from a rendered composition reduces the image quality of a movie 
and is not recommended. If you must enlarge a movie, to maintain highest image quality, always 
enlarge a composition that was rendered at full resolution and highest quality.

You can create a movie larger than the rendered composition by using these methods:
•      Create a new composition at the larger dimensions and nest the smaller composition inside it. 
For example, if you create a 320-by-240 composition, you can place it in a 640-by-480 composition.
You can stretch the composition to fit the new larger composition size, and then collapse 
transformations by choosing Layers > Switches > Collapse. The resulting composition rendered at 
full resolution and best quality will have better image quality than if you had stretched the movie. 
However, this method also renders slower than creating a composition and stretching it.

Note: To create a draft movie with specific dimensions, use both the Stretch option and reduced resolution in 
the rendered composition.
•      Stretch the movie. For example, if you create a 320-by-240 composition and render it at full 
resolution, you can set the stretch value in the Output Module Settings dialog box to 200% to create
a 640-by-480 movie. For a composition rendered at full resolution, the image quality will usually be 
acceptable.

Note: Do not use stretching to change the vertical dimensions of a movie with field rendering. Stretching 
vertically mixes the field order, which distorts any motion. Use either cropping or composition nesting if you 
need to vertically resize a field-rendered movie.
•      Crop the movie. To enlarge a movie by a few pixels, you can increase the size of a movie by 
using negative values for the Crop options in the Output Module Settings dialog box. For example, 
to increase the size of a movie by two pixels, enter –2 in the Cropping section of the Output Module 
Settings dialog box. Remember that negative cropping adds to one side of a movie, so objects 
originally centered in the composition may not appear centered when the movie is cropped.

Note: Adding an odd number of pixels to the top of a field-rendered movie reverses the field order. For 
example, if you add one row of pixels to the top of a movie with Upper Field First field rendering, the field 
rendering order then becomes Lower Field First. Remember that if you add pixels to the top of the movie, you 
need to crop from the bottom row of the movie to maintain the original size. See Using interlaced video in After 
Effects and Field rendering considerations.



Rendering a Movie 

Creating low-resolution movies for testing motion

You can test the motion of a high-quality composition by quickly creating a low-resolution, or 
thumbnail, movie. You accomplish this by making a movie at a resolution less than full (using the 
Resolution pop-up menu in the Render Settings dialog box). After Effects creates a movie with 
dimensions proportional to the resolution. 

For example, if your composition is 640-by-480 pixels and you make a movie at quarter resolution, 
the resulting movie will be 160-by-120 pixels (one sixteenth the size of the composition). This 
thumbnail renders almost 16 times faster than at full resolution. You can then play the thumbnail on 
your system to get a good idea of what motion will be like in your final, full-sized movie. You can 
also enlarge the thumbnail in a movie-playing application to see playback at full size.



Rendering a Movie 

Testing the field rendering order

You can run a simple test to determine the order in which your videotape equipment requires fields. 
When you make a movie, the rendering order (Upper Field First or Lower Field First) should be in 
sync with the method used by your equipment, or your movie will appear distorted.

Note: The field order with which you record to video equipment can be altered by changes in the hardware or 
software of your production setup. For example, changing your video board, device control software, or VCR 
after setting the field order can reverse your fields. Therefore, any time you make a change to your setup, you 
should run this test for field rendering order.

The test takes about 15 to 20 minutes and involves creating two movie versions of the same 
composition (one rendered with Upper Field First and one with Lower Field First) and then taping 
and playing the movies to see which choice looks right.

To test field rendering order:

1    Create a simple composition with the correct frame size and frame rate. Choose an NTSC or 
PAL size from the Frame Size menu in the Composition dialog box, and make the composition at 
least 3 seconds long.

2    Within the composition, make a layer that is a small rectangular solid. The layer can be any color
as long as it contrasts sharply with the composition background. You may wish to add a title such 
as “Upper Field First” to the solid, to make identification of the movie easier.

3    Apply some fast movement to the solid using keyframes in its Position property. Set keyframes 
from the upper left of the Composition window to the lower right, for 1 second.

4    Save the project, and then drag the composition to the Render Queue window.

5    Click the underlined Render Settings name, and then choose Upper Field First.

6    Click OK, and then click Render to make the movie. 

7    In the composition, change the color of the solid in the Composition window, and add a new title 
such as “Lower Field First” to identify it.

8    Render the composition again, choosing Lower Field First.

9    Record both movies to videotape with the same device.

10    Play both movies.

One movie will look distorted and have jumpy horizontal motion or shape distortion during vertical 
motion. The other movie will play correctly, with sharply defined edges. The Field Render choice 
used for the correctly played movie is the choice you should use whenever you intend to record a 
movie with the setup you used in this test.



Layer Blending Modes

Original Normal



Layer Blending Modes

Original Normal, 70% opacity



Layer Blending Modes

Original Dissolve



Layer Blending Modes

Original Multiply



Layer Blending Modes

Original Screen



Layer Blending Modes

Original Overlay



Layer Blending Modes

Original Overlay 50%



Layer Blending Modes

Original Soft Light



Layer Blending Modes

Original Hard Light



Layer Blending Modes

Original Color Dodge



Layer Blending Modes

Original Color Burn



Layer Blending Modes

Original Darken



Layer Blending Modes

Original Lighten



Layer Blending Modes

Original Difference



Layer Blending Modes

Original Exclusion



Layer Blending Modes

Original Hue



Layer Blending Modes

Original Saturation



Layer Blending Modes

Original Color



Layer Blending Modes

Original Luminosity




